Welcome to 오즈 리포트 뷰어

최상의 보고서 서비스 환경을 지원하는 오즈 리포트 뷰어를 사용하게 되신 것을 환영합니다.

오즈 리포트 뷰어는 오즈 리포트 디자이너로 개발한 보고서를 미리보기, 파일 저장, 메일 전송, 프린터 출력 등을 실행하는 오즈 리포트 전용 뷰어입니다.

오즈 리포트 뷰어는 운영체제 및 브라우저 환경에 제약없이 여러 환경에서 보고서를 볼 수 있도록 ActiveX, Applet, Flash, WPF, HTML5, Android, iOS, WinRT 등 다양한 뷰어를 제공하여, 고객의 비즈니스 환경에 최적화된 리포팅 환경을 제공합니다.

본 도움말은 웹 브라우저, 다른 응용 프로그램, 모바일 앱 등에서 오즈 뷰어를 실행할 수 있도록 뷰어 설치와 실행 방법에 대해 설명하고 오즈 리포트 뷰어에서 제공하는 패러미터, 함수, 이벤트, 다이얼로그, 제약 사항 등에 대해 설명합니다.

사전 지식

본 도움말은 개발자용 도움말로, 뷰어 개발을 위해서는 아래와 같은 사전 지식이 필요하며, 해당 지식을 가진 개발자 기준으로 작성되었습니다.

[ActiveX 뷰어]

·WAS(Web Application Server)에 대한 기본 지식

·HTML, JSP, ASP 등 웹 페이지 작성에 대한 중급 이상 지식

·다른 응용 프로그램과 연동할 경우 해당 프로그래밍 언어 중급 이상 지식

[Applet 뷰어]

·WAS(Web Application Server)에 대한 기본 지식

·HTML, JSP, ASP 등 웹 페이지 작성에 대한 중급 이상 지식

·자바 개발 환경에 대한 기본 지식

·다른 응용 프로그램과 연동할 경우 해당 프로그래밍 언어 중급 이상 지식

[Flash 뷰어]

·WAS(Web Application Server)에 대한 기본 지식

·HTML, JSP, ASP 등 웹 페이지 작성에 대한 중급 이상 지식

·Adobe Flash Player 개발 환경에 대한 기본 지식

[WPF 뷰어]

·WAS(Web Application Server)에 대한 기본 지식

·.NET 프로그래밍 언어 중급 이상 지식

[HTML5 뷰어]

·WAS(Web Application Server)에 대한 기본 지식

·HTML, JSP, ASP 등 웹 페이지 작성에 대한 중급 이상 지식

[Android 뷰어]

·WAS(Web Application Server)에 대한 기본 지식

·Eclipse 중급 이상 지식

[iOS 뷰어]

·WAS(Web Application Server)에 대한 기본 지식

·Xcode 중급 이상 지식

[WinRT 뷰어]

·WAS(Web Application Server)에 대한 기본 지식

·C# 혹은 C++/CX 중급 이상 지식


뷰어 설치와 실행

본 장에서는 오즈 뷰어를 설치하고 실행하는 방법에 대해 설명합니다.


ActiveX 뷰어

ActiveX 뷰어 설치 및 버전 업데이트 관리는 ZTransferX Control이 담당합니다.

기능 추가, 버그 패치 등으로 인해 사용자 PC에 설치된 뷰어를 업데이트하려면 웹 서버의 특정 폴더에 뷰어 설치 파일을 복사한 후 뷰어 설치 뿐만 아니라 ZTransferX Control을 설치하는 패러미터가 추가된 웹 페이지를 사용자가 다시 실행할 수 있도록 웹 페이지를 디자인하시기 바랍니다.


시스템 요구 사항

시스템 요구 사항 - ActiveX 뷰어

·Windows XP 이상에 설치된 ActiveX Control을 지원하는 Internet Explorer 8.0 이상


뷰어 설치

뷰어 설치 - ActiveX 뷰어

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사한 후 ZTransferX와 뷰어를 설치하는 뷰어 패러미터를 웹 페이지에 추가합니다.

웹 서버의 특정 폴더에 뷰어 설치 파일 복사

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사합니다.

웹 페이지에 뷰어 설치 패러미터 추가

ZTransferX를 설치한 후 오즈 뷰어를 설치하는 뷰어 패러미터를 웹 페이지에 추가합니다.

ZTransferX는 오즈 뷰어를 설치하고 버전을 관리하는 모듈입니다.

본 장에서는 웹 브라우저가 Internet Explorer인 경우를 예로 들어 설명합니다. 그 외 경우는 뷰어 패치 파일에 함께 배포되는 rv_install_bind.html 파일과 ztransferx_browers.js 파일을 참고하시기 바랍니다.

ZTransferX를 설치하는 패러미터를 아래와 같이 추가합니다.

...

<object id = "ZTransferX" classid = "CLSID:C7C7225A-9476-47AC-B0B0-FF3B79D55E67" width = "0" height = "0" codebase = "http://127.0.0.1:8080/ozrviewer/ZTransferX_2,2,5,1.cab#version=2,2,5,1">

... 뷰어 설치 패러미터 추가 ...

</object>

...

id는 ZTransferX의 오브젝트 ID이고, classid는 ZTransferX의 클래스 ID입니다. ZTransferX는 화면에 표시할 필요가 없으므로 width와 height를 0으로 설정하고, codebase에 ZTransferX를 다운받을 URL을 설정하고 version에 ZTransferX 버전을 설정합니다.

뷰어를 설치하는 패러미터를 아래와 같이 추가합니다.

...

   <param name = "download.server" value = "http://127.0.0.1/ozrviewer/">

   <param name = "download.port" value = "8080">

   <param name = "download.instruction" value = "ozrviewer.idf">

   <param name = "install.base" value = "<PROGRAMS>/Forcs">

   <param name = "install.namespace" value = "custom_namespace">

...

download.server에 뷰어 설치 파일 경로를, download.port에 웹 서버 포트 번호를, download.instruction에 뷰어 설치 정보 파일 이름을, install.base에 클라이언트 PC에 뷰어를 설치할 기본 경로를, install.namespace에 네임스페이스를 설정합니다.


뷰어 설치 정보 파일

뷰어 설치 정보 파일 - ActiveX 뷰어

뷰어 설치 정보 파일이란, 오즈 뷰어 설치 파일과 함께 제공되는 파일로 오즈 뷰어의 설치 정보 즉, 뷰어 버전, 설치할 DLL 파일, OCX 파일 등을 정의해 놓은 파일로, 통상적으로 파일 포맷을 IDF(Install Direction File)로 정의합니다.

뷰어 설치 정보 파일은 오즈 뷰어 설치 파일과 함께 제공되며 파일명은 "ozrviewer.idf"입니다.

뷰어 설치 정보 파일 구조

뷰어 설치 정보 파일은 ActiveX 뷰어의 각 모듈 및 라이브러리 파일을 그룹핑하여 고유한 섹션으로 구분하고, 각 섹션에서 파일 버전, 파일명, 설치 경로, 특정 명령 등을 정의합니다.

뷰어 설치 정보 파일에서 세미콜론(;)으로 시작하는 줄은 주석으로 간주됩니다.

Header 패러미터

Header에서는 뷰어 설치 정보 파일의 RootVersion, 버전 체크 여부, 업데이트 옵션, 설치 중지 옵션, 에러 메시지 등을 설정하는 부분으로 다음과 같은 패러미터로 구성됩니다.

version

뷰어 설치 정보 파일이 갱신된 버전으로 뷰어 설치 정보 파일의 RootVersion을 의미합니다.

formatversion

뷰어 설치 정보 파일의 포맷 버전으로 설치 시 배포된 파일의 내용대로 사용합니다. 사용자 임의로 변경할 필요가 없으며 뷰어 설치 정보 파일의 포맷이 바뀔 경우 버전이 변경되어 설치됩니다.

checkrootversion

RootVersion 체크 여부를 설정합니다.

true로 설정할 경우 RootVersion을 비교하여 웹 서버에 있는 뷰어 설치 정보 파일의 RootVersion이 사용자 PC에 설치된 뷰어 설치 정보 파일의 RootVersion 버전보다 상위 버전인 경우에만 뷰어 파일을 업데이트합니다.

false로 설정할 경우 RootVersion은 비교하지 않고, 각각의 섹션에 명시된 entryversion을 비교하여 웹 서버에 있는 뷰어 설치 정보 파일의 entryversion 버전이 사용자 PC에 설치된 뷰어 설치 정보 파일의 entryversion 버전보다 상위 버전인 경우에만 뷰어 파일을 업데이트합니다.

stoponerror

뷰어 설치 중에 에러가 발생한 경우 설치 작업을 중단할지 여부를 설정합니다.

true로 설정할 경우 에러가 발생하면 이후 설치 작업을 중단하고, false로 설정할 경우 에러가 발생한 파일은 무시하고 다음 파일 설치 작업을 진행합니다.

msgonerror

뷰어 설치 중에 에러가 발생한 경우 에러 메시지를 표시할지 여부를 설정합니다.

true로 설정할 경우 에러 메시지를 표시하고, false로 설정할 경우 에러 메시지를 표시하지 않습니다.

assureall

뷰어 파일을 업데이트할 때 모든 파일을 업데이트할지 여부를 설정합니다.

true로 설정할 경우 모든 파일을 업데이트하고, false로 설정할 경우 업데이트를 실패했을 때 다음 업데이트 시점에 업데이트하지 못한 파일만 업데이트합니다.

messagefile

각 섹션에 대한 설명을 담고 있는 메시지 파일 이름을 설정합니다.

메시지 파일은 사용자 PC에 각 섹션의 파일이 설치될 때 프로그레스바 위에 표시할 메시지가 입력된 파일입니다.

뷰어가 설치될 때 messagefile 패러미터에서 설정한 파일 이름에 언어명_국가명을 적용하여 메시지 파일을 찾습니다. 예를 들어, messagefile 패러미터 값을 ozrviewer.message로 설정한 경우 사용자 PC가 한국어_한국인 경우 ozrviewer_ko_kr.message 파일을 찾고, 영어_미국인 경우 ozrviewer_en_us.message 파일을 찾아 메시지를 표시합니다.

*.message 파일은 "섹션 이름=메시지" 형태로 섹션별로 줄바꿈하여 만들어야하며, 작성 예는 뷰어 설치 파일에 함께 배포되는 *.message 파일을 참고하시기 바랍니다.

Body 패러미터

Body에서는 zip 파일 단위별로 섹션을 정의하고, entryversion, 섹션 파일 이름, 설치 경로, 설치 언어, 레지스트리 등록 등을 설정하는 부분으로 다음과 같은 패러미터로 구성됩니다.

[섹션 이름]

뷰어 설치 파일을 구분하는 이름을 설정합니다.

일반적으로 zip 파일 단위별로 섹션을 정의합니다.

이름은 고유한 값으로 설정하시기 바라며, 만일 중복된 이름이 있을 경우 맨 마지막에 설정한 값으로 적용됩니다.

entryversion

섹션의 버전을 설정합니다.

file

섹션의 파일 이름을 설정합니다.

compress

섹션 파일이 압축된 경우 압축 포맷을 설정합니다. 압축 포맷은 zip 형태만 지원합니다.

destdir

사용자 PC에 설치될 경로를 설정합니다.

하나의 섹션을 여러 경로로 설정할 경우 콤마(",")를 구분자로 하여 나열할 수 있습니다.

경로 설정 시 아래와 같은 예약어를 사용할 수 있습니다.

·<THIS> : install.base, install.namespace 패러미터로 설정된 뷰어 설치 기본 경로

·<PROGRAMS> : 윈도우 Program Files 경로

·<SYSTEM> : 윈도우 시스템 경로

·<FONTS> : 윈도우 폰트 경로

·<IE> : Internet Explorer가 설치된 경로

AutoRunEnable

연결 프로그램 등록 기능 사용 여부를 설정합니다.

true로 설정할 경우 AutoRunExtension와 AutoRunFileName에서 설정한 값으로 연결 프로그램을 등록하고, false로 설정할 경우 연결 프로그램을 등록하지 않습니다.

AutoRunExtension

연결 프로그램에 등록할 파일 확장자를 설정합니다.

AutoRunFileName

연결 프로그램 파일 이름을 설정합니다.

entry

섹션에 있는 파일 중 레지스트리에 등록하거나 자동 실행 또는 삭제할 파일 이름을 설정합니다.

command

entry에서 설정한 파일에 대해 실행할 명령어를 설정합니다.

설정 가능한 명령어는 아래와 같습니다.

·RegisterServer : 레지스트리에 등록

·UnRegisterServer : 레지스트리에서 삭제

·Execute : 뷰어 설치 후 자동 실행

·ExecuteAtDownload : 파일이 업데이트된 경우에만 뷰어 설치 후 자동 실행

·Delete : 파일 삭제

clsid

entry에서 설정한 파일을 레지스트리에 등록할 경우 클래스 ID를 설정합니다.

param

command에서 설정한 명령어 실행 시 전달할 패러미터를 설정합니다.

SleepAfterExecute

command가 Execute 또는 ExecuteAtDownload일 때 entry에서 설정한 파일이 실행된 후 일정 시간 동안 뷰어 설치를 대기하도록 대기 시간을 설정합니다.

0으로 설정하면 대기하지 않고, 1로 설정하면 파일 실행이 종료될 때까지 대기하고, 그 외 값으로 설정한 경우 지정한 시간(단위:ms)만큼 대기합니다.

comparefile

사용자 PC에 이미 설치된 파일인지 비교할 파일 이름을 설정합니다.

compareoption

comparefile에서 설정한 파일이 사용자 PC에 이미 설치된 경우 복사 옵션을 설정합니다.

exist로 설정할 경우 파일이 이미 설치된 경우 복사하지 않고, 그 외 값으로 설정한 경우 무조건 복사합니다.

destOS

뷰어 설치 시 사용자 PC의 OS 종류에 따라 설치 여부를 설정합니다.

"-"를 이용하여 하위 버전, 상위 버전으로도 설정할 수 있습니다. 예를 들어, 윈도우 7을 포함한 하위 버전에서만 설치하려면 "-6.1"로, 윈도우 7을 포함한 상위 버전에서만 설치하려면 "6.1-"로 설정하시기 바랍니다.

OS 버전 번호는 아래 URL을 참고하시기 바랍니다.

https://msdn.microsoft.com/ko-kr/library/windows/desktop/ms724832(v=vs.85).aspx

shortcutfilename

바탕 화면 또는 시작 메뉴의 프로그램에 바로가기로 등록할 파일 이름을 설정합니다.

shortcutdisplayname

바탕 화면에 바로가기를 등록하고 바로가기 이름을 설정합니다.

startprogramname

시작 메뉴의 프로그램에 바로가기를 등록하고 바로가기 이름을 설정합니다.

shortcuticonname

바로가기 아이콘 파일 이름을 설정합니다.


뷰어 설치 패러미터

뷰어 설치 패러미터 - ActiveX 뷰어

ZTransferX를 이용하여 오즈 뷰어를 설치할 때 뷰어 설치 파일 다운로드 경로, 사용자 PC에 설치될 경로, 기타 설치 옵션 등을 뷰어 설치 패러미터를 이용하여 설정합니다.

오즈 뷰어를 설치하려면 뷰어 설치 파일 다운로드 경로와 사용자 PC에 설치될 경로를 나타내는 패러미터 값을 반드시 설정하여야 합니다.

뷰어 설치 파일 다운로드 경로를 설정하는 패러미터는 download.server, download.port, download.instruction이고, 사용자 PC에 설치될 경로를 설정하는 패러미터는 install.base, install.namespace입니다.

download.server

오즈 뷰어 설치 파일이 위치한 웹 서버 경로를 설정합니다.

예를 들어, 웹 서버 IP가 "127.0.0.1", 오즈 뷰어 설치 파일 경로가 웹 서버 루트/ozrviewer인 경우 아래와 같이 설정합니다.

<param name = "download.server" value = "http://127.0.0.1/ozrviewer/">

download.port

오즈 뷰어 설치 파일이 위치한 웹 서버의 포트 번호를 설정합니다.

예를 들어, 포트 번호가 8080인 경우 아래와 같이 설정합니다.

<param name = "download.port" value = "8080">

download.instruction

오즈 뷰어 설치 정보 파일의 경로 중 파일 이름만 설정합니다.

파일 이름 외에 다른 경로는 download.server, download.port에서 설정한 경로로 적용됩니다.

예를 들어, 파일 이름이 ozrviewer.idf인 경우 아래와 같이 설정합니다.

<param name = "download.instruction" value = "ozrviewer.idf">

download.instructionURL

오즈 뷰어 설치 정보 파일의 전체 경로를 설정합니다.

download.instructionURL 패러미터는 오즈 뷰어 설치 정보 파일의 위치가 오즈 뷰어 설치 파일의 위치와 다른 경우에 설정하시기 바랍니다.

예를 들어, 웹 서버 IP가 "127.0.0.1", 오즈 뷰어 설치 파일 경로가 웹 서버 루트/ozrviewer, 웹 서버 포트 번호가 8080, 오즈 뷰어 설치 정보 파일 이름이 ozrviewer.idf인 경우 아래와 같이 설정합니다.

<param name = "download.instructionURL" value = "http://127.0.0.1:8080/ozrviewer/ozrviewer.idf">

Additional Information: 일반적인 경우 오즈 뷰어 설치 정보 파일은 오즈 뷰어 설치 파일과 같은 경로에 위치합니다. 그러므로 download.instruction을 이용하여 파일 이름만 설정하시기 바랍니다. 만일 오즈 뷰어 설치 정보 파일의 경로와 오즈 뷰어 설치 파일의 경로가 다른 경우에는 download.instructionURL을 이용하여 전체 경로로 설정하시기 바랍니다. download.instruction과 download.instructionURL 값을 모두 설정한 경우에는 오즈 뷰어 설치 정보 파일 경로가 download.instructionURL에서 설정한 값으로 적용됩니다.

download.quiet

뷰어 설치 중 에러 발생 시 에러 메시지를 표시하지 않도록 설정합니다.

패러미터 값을 설정하지 않으면 "false"로 적용되어 에러 발생 시 에러 메시지를 표시합니다.

<param name = "download.quiet" value = "true">

install.base

사용자 PC에 설치할 기본 경로 설정합니다.

기본 경로는 전체 경로로 설정하거나 시스템 경로를 나타내는 예약어를 사용할 수 있습니다. 사용 가능한 시스템 예약어는 윈도우의 Program Files 경로를 나타내는 <PROGRAMS>, 윈도우 시스템 경로를 나타내는 <SYSTEM>, 윈도우 폰트 경로를 나타내는 <FONTS>가 있습니다.

<param name = "install.base" value = "<PROGRAMS>/Forcs">

install.namespace

설치할 오즈 뷰어의 네임스페이스를 설정합니다.

네임스페이스는 사용자 PC에 여러 버전의 오즈 뷰어가 설치될 때 해당 프로젝트의 보고서를 표시할 뷰어를 지정하는 고유 이름입니다. 네임스페이스는 다른 사이트와 중복되지 않게 해당 프로젝트의 특징을 나타낼 수 있는 고유한 이름으로 설정하시기 바랍니다.

<param name = "install.namespace" value = "custom_namespace">

install.registernamespace

네임스페이스를 레지스트리에 등록할지 여부를 설정합니다.

패러미터 값을 설정하지 않으면 "true"로 적용되어 네임스페이스를 레지스트리에 등록합니다.

<param name = "install.registernamespace" value = "false">

install.registonly

이미 설치된 뷰어 파일을 사용자 PC에 업데이트하지 않고, 레지스트리에 등록하는 작업만 수행합니다.

패러미터 값을 "true"로 설정한 경우 오즈 뷰어 설치 정보 파일(ozrviewer.idf)의 내용을 읽어 command 옵션 값이 RegistServer이고, entryversion, clsid, destdir이 모두 설정된 파일을 레지스트리에 등록합니다.

<param name = "install.registonly" value = "true">

install.useuac

비스타 이상 윈도우에서 UAC 기능을 사용할지 여부를 설정합니다.

패러미터 값을 설정하지 않으면 "true"로 적용되어 비스타 이상 윈도우에서 일반 사용자는 권한 상승을 통해 특정 폴더 및 레지스트리 접근이 가능합니다. 패러미터 값을 "false"로 설정한 경우 권한 상승을 하지 않으므로, 비스타 이상 윈도우에서 특정 폴더 및 레지스트리 접근이 허용되지 않습니다.

<param name = "install.useuac" value = "false">

useprogress

뷰어 설치 창을 화면에 표시합니다.

패러미터 값을 설정하지 않으면 "true"로 적용되어 뷰어 설치 창을 화면에 표시합니다.

<param name = "useprogress" value = "false">

imageurl

뷰어 설치 창에 표시할 이미지의 파일 경로를 설정합니다.

이미지 파일 경로를 설정하지 않을 경우 기본 이미지가 표시됩니다.

<param name = "imageurl" value = "http://127.0.0.1:8080/images/install.gif">

messagetitle

뷰어 설치 창의 타이틀 제목을 설정합니다.

패러미터 값을 설정하지 않으면 install.namespace 패러미터 값 + " 뷰어 설치" 형태로 표시됩니다.

<param name = "messagetitle" value = "매출 현황 시스템 전용 뷰어 설치 중...">

installendcommand

ZTInstallEndCommand 이벤트 사용 여부를 설정합니다.

패러미터 값을 설정하지 않으면 "true"로 적용되어 ZTInstallEndCommand 이벤트가 호출됩니다.

<param name = "installendcommand" value = "false">

Additional Information: ZTInstallEndCommand(string arg1, string arg2) 이벤트는 아래 경우에 발생합니다.

·뷰어 파일을 설치한 경우

·뷰어 파일은 설치하지 않았으나 IDF 파일만 비교한 경우

·파일 설치없이, 레지스트리 등록만 실행한 경우(install.registonly=true)

·뷰어 파일 설치 중 에러가 발생한 경우

maxconnect

오즈 서버에 동시 접속할 수 있는 최대 접속자 수를 설정합니다.

설정한 값은 레지스트리에 등록됩니다. 단, maxconnect 패러미터 값이 사용자 PC의 레지스트리에 등록된 값보다 크고, install.registonly 패러미터 값이 false일 경우에만 등록됩니다.

윈도우 비스타 이상의 PC에서 로그인한 사용자가 관리자 권한 상승이 안되는 경우 해당 기능을 사용할 수 없습니다.

<param name = "maxconnect" value = "100">

minconnecttimeout

Internet Explorer에서 웹 서버에 접속할 때 적용할 타임아웃의 최솟값을 설정합니다.

설정한 값은 레지스트리에 등록됩니다. 단, minconnecttimeout 패러미터 값이 사용자 PC의 레지스트리에 등록된 값보다 크고, install.registonly 패러미터 값이 false일 경우에만 등록됩니다.

타임아웃이 변경되면 Internet Explorer를 재시작하여야 변경된 타임아웃으로 적용됩니다.

윈도우 비스타 이상의 PC에서 로그인한 사용자가 관리자 권한 상승이 안되는 경우 해당 기능을 사용할 수 없습니다.

<param name = "minconnecttimeout" value = "60">

minsendtimeout

Internet Explorer에서 웹 서버에 요청할 때 적용할 타임아웃의 최솟값을 설정합니다.

설정한 값은 레지스트리에 등록됩니다. 단, minsendtimeout 패러미터 값이 사용자 PC의 레지스트리에 등록된 값보다 크고, install.registonly 패러미터 값이 false일 경우에만 등록됩니다.

타임아웃이 변경되면 Internet Explorer를 재시작하여야 변경된 타임아웃으로 적용됩니다.

윈도우 비스타 이상의 PC에서 로그인한 사용자가 관리자 권한 상승이 안되는 경우 해당 기능을 사용할 수 없습니다.

<param name = "minsendtimeout" value = "60">

minreceivetimeout

Internet Explorer에서 웹 서버로부터 응답을 받을 때 적용할 타임아웃의 최솟값을 설정합니다.

설정한 값은 레지스트리에 등록됩니다. 단, minreceivetimeout 패러미터 값이 사용자 PC의 레지스트리에 등록된 값보다 크고, install.registonly 패러미터 값이 false일 경우에만 등록됩니다.

타임아웃이 변경되면 Internet Explorer를 재시작하여야 변경된 타임아웃으로 적용됩니다.

윈도우 비스타 이상의 PC에서 로그인한 사용자가 관리자 권한 상승이 안되는 경우 해당 기능을 사용할 수 없습니다.

<param name = "minreceivetimeout" value = "60">


뷰어 실행

뷰어 실행 - ActiveX 뷰어

오즈 서버 정보와 보고서 파일 이름을 설정하는 뷰어 패러미터를 웹 페이지에 추가합니다.

웹 페이지에 보고서 바인딩 패러미터 추가

보고서 파일이 있는 오즈 서버 정보, 보고서 파일 이름, 뷰어 네임스페이스 등 뷰어를 실행하고 바인딩할 보고서 정보를 설정하는 뷰어 패러미터를 웹 페이지에 추가합니다.

본 장에서는 웹 브라우저가 Internet Explorer인 경우를 예로 들어 설명합니다. 그 외 경우는 뷰어 패치 파일에 함께 배포되는 rv_install_bind.html 파일과 ozviewer_browers.js 파일을 참고하시기 바랍니다.

뷰어를 실행하고 보고서를 바인딩하는 패러미터를 아래와 같이 추가합니다.

...

   <object id = "OZViewer" classid = "CLSID:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width = "100%" height = "100%">

   <param name = "connection.servlet" value = "http://127.0.0.1:8080/oz/server">

   <param name = "connection.reportname" value = "category_path/sample.ozr">

   <param name = "viewer.isframe" value = "false">

   <param name = "viewer.namespace" value = "custom_namespace\\ozviewer">

...

id에 뷰어 오브젝트 ID를, classid에 뷰어의 클래스 ID를, width/height에 뷰어를 웹 브라우저에 임베디드된 형태로 실행할 때 뷰어를 표시할 영역의 너비/높이를 설정합니다.

connection.servlet에 오즈 서버 경로를, connection.reportname에 바인딩할 보고서 경로와 이름을, viewer.isframe에 뷰어 창 표시 형태를, viewer.namespace에 클라이언트 PC에 설치된 뷰어 중 해당 보고서를 바인딩할 뷰어를 설정합니다.

뷰어 실행

뷰어를 실행하고 보고서를 바인딩하는 웹 페이지를 웹 브라우저에서 실행한 후 보고서가 바인딩되는지 확인합니다.


다른 응용 프로그램과 뷰어 연동

다른 응용 프로그램과 뷰어 연동 - ActiveX 뷰어

오즈 리포트 ActiveX 뷰어는 ActiveX Control을 지원하는 다른 응용 프로그램과 연동하여 실행할 수 있습니다.

본 도움말에서는 Visual Basic .NET, C# .NET과 연동하는 방법에 대해 설명합니다.


Visual Basic .NET 연동

Visual Basic .NET 연동 - ActiveX 뷰어

오즈 뷰어 ocx 파일을 Visual Basic의 COM 구성 요소에 추가하고 폼에 오즈 뷰어를 추가한 후 CreateReport 함수를 호출하여 오즈 뷰어를 실행합니다.

COM 구성 요소에 추가

Visual Basic .NET의 [프로젝트] > [참조 추가] 메뉴를 클릭합니다.

참조 추가 다이얼로그의 [COM] 탭에서 "OZRViewer ActiveX Control module"을 선택하고 [선택] 버튼을 클릭한 후 [확인] 버튼을 클릭합니다.

도구 상자 창의 구성 요소 항목에서 마우스 오른쪽 버튼을 클릭하여 나타나는 팝업 메뉴에서 [항목 추가/제거] 메뉴를 클릭합니다.

도구 상자 사용자 지정 다이얼로그에서 [COM 구성 요소] 탭을 선택한 후 "EXOZViewer50 Control"을 체크하고 [확인] 버튼을 클릭하면

오즈 뷰어 컨트롤이 구성 요소에 추가됩니다.

폼에 오즈 뷰어 추가

폼에 "EXOZViewer50 Control"을 추가합니다.

스크립트 입력

디자인한 폼을 더블클릭하여 나타나는 스크립트 창에서 "Form1 Events"의 "Load" 이벤트에 아래와 같이 스크립트를 입력합니다.

AxEXOZViewer301.CreateReport("connection.servelet=http://127.0.0.1:8080/oz/server" + Chr(10) + "connection.reportname=sample.ozr");

Additional Information: AxEXOZViewer301은 폼에 추가된 EXOZViewer50 Control 이름입니다.

뷰어 실행

[디버그] > [시작] 메뉴를 클릭하여 프로젝트를 실행합니다.


C# .NET 연동

C# .NET 연동 - ActiveX 뷰어

오즈 뷰어 ocx 파일을 C# .NET의 COM 구성 요소에 추가하고 폼에 오즈 뷰어를 추가한 후 CreateReport 함수를 호출하여 오즈 뷰어를 실행합니다.

COM 구성 요소에 추가

C# .NET의 [프로젝트] > [참조 추가] 메뉴를 클릭합니다.

참조 추가 다이얼로그의 [COM] 탭에서 "OZRViewer ActiveX Control module"을 선택하고 [선택] 버튼을 클릭한 후 [확인] 버튼을 클릭합니다.

도구 상자 창의 구성 요소 항목에서 마우스 오른쪽 버튼을 클릭하여 나타나는 팝업 메뉴에서 [항목 추가/제거] 메뉴를 클릭합니다.

도구 상자 사용자 지정 다이얼로그에서 [COM 구성 요소] 탭을 선택한 후 "EXOZViewer50 Control"을 체크하고 [확인] 버튼을 클릭하면

오즈 뷰어 컨트롤이 구성 요소에 추가됩니다.

폼에 오즈 뷰어 추가

폼에 "EXOZViewer50 Control"을 추가합니다.

스크립트 입력

디자인한 폼을 더블클릭하여 나타나는 스크립트 창에서 "WindowsApplication1.Form1"의 "Form1_Load(object sender, System.EventArgs e)" 이벤트에 아래와 같이 스크립트를 입력합니다.

axEXOZViewer301.CreateReport("connection.server=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr");

Additional Information: axEXOZViewer301은 폼에 추가된 EXOZViewer50 Control 이름입니다.

뷰어 실행

[디버그] > [시작] 메뉴를 클릭하여 프로젝트를 실행합니다.


Applet 뷰어

Applet 뷰어의 경우 뷰어 설치 및 버전 업데이트 관리를 사용자 PC에 설치된 JRE가 실행합니다.

기능 추가, 버그 패치 등으로 인해 사용자 PC에 설치된 뷰어를 업데이트하려면 웹 서버의 특정 폴더에 뷰어 설치 파일을 복사한 후 뷰어 설치 패러미터 뿐만 아니라 deployJava.js 경로가 추가된 웹 페이지를 사용자가 다시 실행할 수 있도록 웹 페이지를 디자인하시기 바랍니다. 이때 뷰어 설치 패러미터 중 ozversion을 업데이트할 뷰어 버전으로 수정하시기 바랍니다.


시스템 요구 사항

시스템 요구 사항 - Applet 뷰어

·JRE 1.6 이상 NPAPI 플러그인을 지원하는 운영체제 및 웹 브라우저


뷰어 설치, 실행

뷰어 설치, 실행 - Applet 뷰어

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사한 후 관련 패러미터를 웹 페이지에 추가합니다.

웹 서버의 특정 폴더에 뷰어 설치 파일 복사

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사합니다.

웹 페이지에 뷰어 설치/실행 및 보고서 바인딩 패러미터 추가

JRE를 설치하고 자바 Applet을 디플로이할 수 있도록 deployJava.js 경로를 설정한 후 Applet 뷰어를 웹 브라우저에 디플로이할 수 있도록 deployOZ.js 경로를 설정합니다.

다음으로 연동할 자바 버전, 뷰어 설치 파일 경로, 뷰어 ID, 뷰어 버전, 오즈 서버 정보, 보고서 이름 등을 설정합니다.

...

<script src="http://java.com/js/deployJava.js"></script>

<script src="http://127.0.0.1:8080/ozrviewer/deployOZ.js"></script>

<script language="JavaScript">

   var viewerName="OZViewer";

   var javaVersion="1.6.0";

   var appletParameter = new Array (

       "id="+viewerName,

       "width=100%",

       "height=100%",

       "codebase=http://127.0.0.1:8080/ozrviewer/oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=category_path/sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

...

script src를 이용하여 deployJava.js, deployOZ.js 파일 경로를, viewerName에 뷰어 ID를, javaVersion에 연동할 자바 버전을, id에 뷰어 ID를 설정한 viewerName을, width/height에 뷰어를 표시할 영역의 너비/높이를, codebase에 뷰어 설치 파일 경로를, ozversion에 뷰어 버전을 설정합니다.

connection.servlet에 오즈 서버 경로를, connection.reportname에 바인딩할 보고서 경로와 이름을, viewer.isframe에 뷰어 창 표시 형태를 설정합니다.

뷰어 실행

뷰어를 설치 및 실행하고 보고서를 바인딩하는 웹 페이지를 웹 브라우저에서 실행한 후 보고서가 바인딩되는지 확인합니다.


다른 응용 프로그램과 뷰어 연동

다른 응용 프로그램과 뷰어 연동 - Applet 뷰어

오즈 리포트 Applet 뷰어는 Applet을 지원하는 다른 응용 프로그램과 연동하여 실행할 수 있습니다.

본 도움말에서는 Eclipse를 이용하여 Applet, Swing 프로그램과 연동하는 방법에 대해 설명합니다.


Applet 연동

Applet 연동 - Applet 뷰어

오즈 뷰어 jar 파일을 Applet 프로젝트에 추가하고 뷰어 객체를 생성한 후 getPanel() 함수를 호출하여 오즈 뷰어를 실행합니다.

프로젝트에 추가

오즈 뷰어 jar 파일을 Eclipse에서 생성한 프로젝트의 lib 폴더에 복사합니다.

프로젝트 Properties 다이얼로그를 실행하여 "Java Build Path" 옵션을 클릭하고 [Libraries] 탭을 클릭한 후 [Add JARs] 버튼을 클릭하여 ozviewer.jar 파일을 "JARs and class folers on the build path" 옵션에 추가합니다.

스크립트 입력

OZReportAPI.getOZReport()를 호출하여 OZReportViewer 객체를 생성하고 OZReportViewer 객체의 init()을 호출하여 뷰어를 시작한 후 getPanel()을 호출하여 리턴된 Panel을 대상 컴포넌트의 child로 추가합니다.

import java.awt.*;

import java.awt.event.*;

import java.util.Hashtable;

import javax.swing.JApplet;

import javax.swing.SwingUtilities;

import oz.api.OZEmbededEvent;

import oz.api.OZEmbededListener;

import oz.api.OZReportAPI;

import oz.api.OZReportViewer;

public class MainApplet extends JApplet

{

   public void init()

   {

       super.init();

       this.setLayout(new BorderLayout());

       JButton button = new JButton("뷰어 임베디드");

       button.addActionListener(new ActionListener()

       {

           public void actionPerformed(ActionEvent arg0)

           {

               Hashtable<String, String> params = new Hashtable<String, String>();

               params.put("connection.servlet", "http://127.0.0.1:8080/oz/server");

               params.put("connection.reportname", "sample.ozr");

               params.put("viewer.isframe", "false");

               params.put("viewer.exportcommand", "true");

               OZEmbededListener action = new OZEmbemdedAction();

               OZReportViewer OZViewer = OZReportAPI.getOZReport(MainApplet.this, params);

               OZViewer.init(action);

               Panel applet = OZViewer.getPanel();

               MainApplet.this.add(applet, BorderLayout.CENTER);

               Toolkit tk = Toolkit.getDefaultToolkit();

               EventQueue evtQ = tk.getSystemEventQueue();

               evtQ.postEvent(new ComponentEvent(SwingUtilities.getWindowAncestor(applet), ComponentEvent.COMPONENT_RESIZED));

           }

       });

       this.add(button, BorderLayout.NORTH);

   }

   public static class OZEmbemdedAction implements OZEmbededListener

   {

       public void action(OZEmbededEvent e)

       {

           Object[] param = e.getParams();

           switch(e.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = e.getCommand();

                   if(OZReportApplet.eventidOZExportCommand.equals(command))

                   {

                       //param[0] : code

                       //param[1] : path

                       //param[2] : filename

                       //param[3] : pagecount

                       //param[4] : filepaths

                   }

                   break;

           }

       }

   }

}


Swing 연동

Swing 연동 - Applet 뷰어

오즈 뷰어 jar 파일을 Swing 프로젝트에 추가하고 뷰어 객체를 생성한 후 getPanel() 함수를 호출하여 오즈 뷰어를 실행합니다.

프로젝트에 추가

오즈 뷰어 jar 파일을 Eclipse에서 생성한 프로젝트의 lib 폴더에 복사합니다.

프로젝트 Properties 다이얼로그를 실행하여 "Java Build Path" 옵션을 클릭하고 [Libraries] 탭을 클릭한 후 [Add JARs] 버튼을 클릭하여 ozviewer.jar 파일을 "JARs and class folers on the build path" 옵션에 추가합니다.

스크립트 입력

OZReportAPI.getOZReport()를 호출하여 OZReportViewer 객체를 생성하고 OZReportViewer 객체의 init()을 호출하여 뷰어를 시작한 후 getPanel()을 호출하여 리턴된 Panel을 대상 컴포넌트의 child로 추가합니다.

import java.awt.*;

import java.awt.event.*;

import java.util.Hashtable;

import javax.swing.JButton;

import javax.swing.JFrame;

import javax.swing.SwingUtilities;

import oz.api.OZEmbededEvent;

import oz.api.OZEmbededListener;

import oz.api.OZReportAPI;

import oz.api.OZReportViewer;

public class MainFrame extends JFrame

{

   public static void main(String[] args)

   {

       final MainFrame frame = new MainFrame();

       frame.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);

       frame.setSize(1200, 1000);

       frame.setBackground(Color.DARK_GRAY);

       frame.setTitle("임베디드 애플릿 뷰어");

       frame.setLayout(new BorderLayout());

       JButton button = new JButton("뷰어 임베디드");

       button.addActionListener(new ActionListener()

      {

           public void actionPerformed(ActionEvent arg0)

          {

               Hashtable<String, String> params = new Hashtable<String, String>();

               params.put("connection.servlet", "http://127.0.0.1:8080/oz/server");

               params.put("connection.reportname", "sample.ozr");

               params.put("viewer.isframe","false");

               params.put("viewer.exportcommand", "true");

               OZEmbededListener action = new OZEmbemdedAction();

               OZReportViewer OZViewer = OZReportAPI.getOZReport(null, params);

               OZViewer.init(action);

               Panel panel = OZViewer.getPanel();

               frame.getContentPane().add(panel, BorderLayout.CENTER);

               Toolkit tk = Toolkit.getDefaultToolkit();

               EventQueue evtQ = tk.getSystemEventQueue();

               evtQ.postEvent(new ComponentEvent(SwingUtilities.getWindowAncestor(panel), ComponentEvent.COMPONENT_RESIZED));

              }

          });

           frame.getContentPane().add(button, BorderLayout.NORTH);

           frame.setVisible(true);

      }

   public static class OZEmbemdedAction implements OZEmbededListener

  {

       public void action(OZEmbededEvent e)

      {

           Object[] param = e.getParams();

           switch(e.getEventType())

          {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = e.getCommand();

                   if(OZReportApplet.eventidOZExportCommand.equals(command))

                  {

                       //param[0] : code

                       //param[1] : path

                       //param[2] : filename

                       //param[3] : pagecount

                       //param[4] : filepaths

                  }

                   break;

           }

      }

  }

}


Flash 뷰어

Flash 뷰어는 Adobe Flash Player에 임베디드되어 실행되는 뷰어로, 사용자 PC의 웹 브라우저 임시 폴더에 다운로드되며, 웹 브라우저의 환경 설정에 따라 웹 브라우저가 종료될 때 뷰어도 삭제됩니다.


시스템 요구 사항

시스템 요구 사항 - Flash 뷰어

·Adobe Flash Player 11.0 이상을 지원하는 운영체제 및 웹 브라우저


뷰어 실행

뷰어 실행 - Flash 뷰어

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사한 후 관련 패러미터를 웹 페이지에 추가합니다.

웹 서버의 특정 폴더에 뷰어 설치 파일 복사

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사합니다.

웹 페이지에 뷰어 실행 및 보고서 바인딩 패러미터 추가

사용자 PC에 Adobe Flash Player가 설치된 경우 Flash 뷰어를 Adobe Flash Player에 임베디드하고, 설치되지 않은 경우 Adobe Flash Player 다운로드 경로를 설정합니다.

다음으로 뷰어 설치 파일 경로, 뷰어 ID, 오즈 서버 정보, 보고서 이름 등을 설정합니다.

<!-- saved from url=(0014)about:internet -->

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework

for building rich Internet applications that get delivered via the

Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org

//-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<title></title>

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<style>

body { margin: 0px; overflow:hidden }

</style>

<script language="JavaScript" type="text/javascript">

<!--

//-----------------------------------------------------------------------------

//Globals

//Major version of Flash required

var requiredMajorVersion = 10;

//Minor version of Flash required

var requiredMinorVersion = 0;

//Minor version of Flash required

var requiredRevision = 0;

//-----------------------------------------------------------------------------

//-->

</script>

</head>

<body scroll="no">

<script language="JavaScript" type="text/javascript">

<!--

//Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

//Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

 //DO NOT MODIFY THE FOLLOWING FOUR LINES

 //Location visited after installation is complete if installation is required

 var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

 var MMredirectURL = window.location;

 document.title = document.title.slice(0, 47) + " - Flash Player Installation";

 var MMdoctitle = document.title;

 AC_FL_RunContent(

   "src", "http://127.0.0.1:8080/ozrviewer/playerProductInstall",

   "FlashVars", "MMredirectURL=" + MMredirectURL + '&MMplayerType=' + MMPlayerType + '&MMdoctitle=' + MMdoctitle+"",

   "width", "100%",

   "height", "100%",

   "align", "middle",

   "id", "playerProductInstall",

   "quality", "high",

   "bgcolor", "#ffffff",

   "name", "playerProductInstall",

   "allowScriptAccess", "sameDomain",

   "type", "application/x-shockwave-flash",

   "pluginspage", "http://www.adobe.com/go/getflashplayer"

 );

} else if(hasRequestedVersion) {

 //if we've detected an acceptable version

 //embed the Flash Content SWF when all tests are passed

 function SetOZParamters_OZViewer() {

   var oz;

   if(navigator.appName.indexOf("Microsoft") != -1) {

     oz = window["OZViewer"];

   } else {

     oz = document["OZViewer"];

   }

   oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

   oz.sendToActionScript("connection.reportname", "category_path/sample.ozr");

   return true;

 }

 AC_FL_RunContent(

   "src", "http://127.0.0.1:8080/ozrviewer/OZViewer10",

   "width", "100%",

   "height", "100%",

   "align", "middle",

   "id", "OZViewer",

   "quality", "high",

   "bgcolor", "#ffffff",

   "name", "OZViewer",

   "allowScriptAccess", "sameDomain",

   "type", "application/x-shockwave-flash",

   "pluginspage", "http://www.adobe.com/go/getflashplayer",

   "flashVars", "flash.objectid=OZViewer"

 );

} else { //flash is too old or we can't detect the plugin

 var alternateContent = 'Alternate HTML content should be placed here. '

                        + 'This content requires the Adobe Flash Player. '

                        + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

 document.write(alternateContent); //insert non-flash content

}

//-->

</script>

</body>

</html>

script src를 이용하여 AC_OETags.js, ozutil.js, ozjscript.js 파일 경로를, AC_FL_RunContent 함수를 이용하여 src에 OZViewer10.swf 파일의 경로를, width/height에 뷰어를 표시할 영역의 너비/높이를, id에 뷰어 ID를, name에 뷰어 이름, flashVars에 Adobe Flash Player에서 인식할 뷰어 ID를 설정합니다.

SetOZParamters_뷰어ID 함수를 이용하여 connection.servlet에 오즈 서버 경로를, connection.reportname에 바인딩할 보고서 경로와 이름을 설정합니다.

뷰어 실행

뷰어를 실행하고 보고서를 바인딩하는 웹 페이지를 웹 브라우저에서 실행한 후 보고서가 바인딩되는지 확인합니다.


WPF 뷰어

WPF 뷰어는 .NET 프로그램에 임베디드되어 실행되는 뷰어입니다.


시스템 요구 사항

시스템 요구 사항 - WPF 뷰어

·.NET Framework 3.5 with Service Pack 1 이상을 지원하는 환경


.NET에서 임베디드

.NET에서 임베디드 - WPF 뷰어

오즈 뷰어 dll 파일을 프로젝트의 Reference에 추가하고 오즈 뷰어 객체를 생성한 후 getPanel() 함수를 호출하여 오즈 뷰어를 임베디드합니다.

오즈 뷰어 dll 파일을 Reference에 추가합니다.

Microsoft Visual Studio .NET을 실행하여 새로운 프로젝트를 생성한 후 [Reference] > [Add Reference] 메뉴를 클릭합니다.

Add Reference 다이얼로그의 [Browse] 탭에서 오즈 뷰어를 구성하는 dll 파일(OZWPFViewer_Lib.dll)을 추가합니다.

오즈 뷰어를 임베디드하는 스크립트를 입력합니다.

OZReportAPI.getOZReport() 함수를 호출하여 OZReportViewer 객체를 생성하고 OZReportViewer 객체의 init()을 호출하여 뷰어를 시작한 후 getPanel()을 호출하여 리턴된 Panel을 대상 컴포넌트의 child로 추가하여 뷰어를 임베디드합니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   public partial class MainWindow : Window

  {

       public MainWindow()

      {

           InitializeComponent();

           //보고서를 호출할 패러미터 설정

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           params.Add("viewer.exportcommand", "true");

           try

          {

               //뷰어에서 생성하는 이벤트를 얻을 경우 이벤트 핸들러 생성

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

              {

                   Object[] param = events.getParams();

                   switch(events.getEventType())

                  {

                       case OZEmbededEvent.OZEVENT_COMMAND :

                           String command = events.getCommand();

                           if("OZExportCommand".Equals(command))

                          {

                               //param[0] : code

                               //param[1] : path

                               //param[2] : filename

                               //param[3] : pagecount

                               //param[4] : filepaths

                          }

                           break;

                  }

               };

               OZReportViewer OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Panel panel = OZViewer.getPanel();

               LayoutRoot.Children.Add(panel);

           }

           catch(Exception e)

          {

               Debug.WriteLine(e.Message);

          }

      }

   }

}


HTML5JS 뷰어

HTML5JS 뷰어는 HTML5 기반의 웹 브라우저에서 임베디드되어 실행되는 뷰어로, 사용자 PC의 웹 브라우저 임시 폴더에 다운로드되며, 웹 브라우저의 환경 설정에 따라 웹 브라우저가 종료될 때 뷰어도 삭제됩니다.


시스템 요구 사항

시스템 요구 사항 - HTML5JS 뷰어

·HTML5 표준을 지원하는 운영체제 및 웹 브라우저


뷰어 실행

뷰어 실행 - HTML5JS 뷰어

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사한 후 관련 패러미터를 웹 페이지에 추가합니다.

웹 서버의 특정 폴더에 뷰어 설치 파일 복사

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사합니다.

웹 페이지에 뷰어 실행 및 보고서 바인딩 패러미터 추가

HTML5JS 뷰어를 실행하도록 웹 페이지를 HTML5 형식으로 선언합니다.

다음으로 뷰어 설치 파일 경로, 뷰어ID, 오즈 서버 정보, 보고서 이름 등을 설정합니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","category_path/sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

script src를 이용하여 jquery-1.8.3.min.js, jquery-ui.min.js, jquery.dynatree.js, OZJSViewer.js 파일 경로를, link rel을 이용하여 jquery-ui.css, ui.dynatree.css 파일 경로를, div 태그를 이용하여 width/height에 뷰어를 표시할 영역의 너비/높이를, id에 뷰어 ID를 설정합니다.

getElementById 함수를 이용하여 뷰어 ID를 설정하고 SetOZParamters_뷰어ID 함수를 이용하여 connection.servlet에 오즈 서버 경로를, connection.reportname에 바인딩할 보고서 경로와 이름을 설정한 후 start_ozjs 함수를 이용하여 뷰어를 실행합니다.

뷰어 실행

뷰어를 실행하고 보고서를 바인딩하는 웹 페이지를 웹 브라우저에서 실행한 후 보고서가 바인딩되는지 확인합니다.

Additional Information: HTML5JS 뷰어를 모바일 UI로 실행하려면 웹 페이지를 아래와 같이 작성하시기 바랍니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>

<meta name="viewport" content="width=device-width,initial-scale=1,user-scalable=no"/>

<script src="http://code.jquery.com/jquery-1.9.1.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.10.3/themes/smoothness/jquery-ui.css"/>

<script src="http://code.jquery.com/ui/1.10.3/jquery-ui.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/mobile/1.4.5/jquery.mobile-1.4.5.min.css"/>

<script src="http://code.jquery.com/mobile/1.4.5/jquery.mobile-1.4.5.min.js"></script>

<link rel="stylesheet" type="text/css" href="http://dev.jtsage.com/cdn/simpledialog/latest/jquery.mobile.simpledialog.min.css"/>

<script type="text/javascript" src="http://dev.jtsage.com/cdn/simpledialog/latest/jquery.mobile.simpledialog2.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<script src="http://127.0.0.1:8080/ozrviewer/jquery.mouseSwipe.js" type="text/javascript"></script>

</head>

<body style="height:100%">

<div id="OZViewer" style="width:100%;height:100%;overflow:hidden"></div>

<script type="text/javascript">

  function SetOZParamters_OZViewer(){

     var oz;

     oz = document.getElementById("OZViewer");

     oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

     oz.sendToActionScript("connection.reportname","category_path/sample.ozr");

     return true;

  }

  start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/", true);

</script>

</body>

</html>


HTML5SVG 뷰어

HTML5SVG 뷰어는 HTML5 기반의 웹 브라우저에서 임베디드되어 실행되는 뷰어로, 사용자 PC의 웹 브라우저 임시 폴더에 다운로드되며, 웹 브라우저의 환경 설정에 따라 웹 브라우저가 종료될 때 뷰어도 삭제됩니다.

HTML5SVG 뷰어를 이용하려면 오즈 서버뿐만 아니라 오즈 스케줄러 서버도 함께 연동하여야 합니다.


시스템 요구 사항

시스템 요구 사항 - HTML5SVG 뷰어

·HTML5 표준 및 SVG를 지원하는 운영체제 및 웹 브라우저


뷰어 실행

뷰어 실행 - HTML5SVG 뷰어

오즈 스케줄러 서버와 오즈 서버를 HTML5SVG 뷰어와 연동할 수 있도록 설정한 후 웹 서버의 특정 폴더에 뷰어 설치 파일을 복사한 후 관련 패러미터를 웹 페이지에 추가합니다.

오즈 스케줄러 서버 설정

오즈 스케줄러 서버의 conf 폴더에 있는 html5svgviewer.properties 파일에 아래와 같은 옵션이 설정되어 있는지 확인합니다.(옵션에 대한 설명은 OZ Scheduler Administrator's Guide를 참고하세요.)

html5SVGViewerRepositoryFilePath=%SCH_HOME%/SVGViewerRepository

deleteFileTime=20

오즈 스케줄러 서버의 conf 폴더에 있는 ozscheduler.properties 파일에 html5svgviewer.properties 경로를 설정합니다.

...

path.scheduler_svgviewer.file=%SCH_HOME%/conf/html5svgviewer.properties

오즈 스케줄러 서버의 lib 폴더에 json-simple-1.1.1.jar 파일이 있는지 확인합니다.

오즈 스케줄러 서버의 bin 폴더에 있는 scheduler.bat 파일에 json-simple-1.1.1.jar 경로를 설정합니다.

...

set OZSchLib=%OZSchLib%;%OZSCHEDULER_HOME%\lib\json-simple-1.1.1.jar

echo Loading OZScheduler...

...

모든 설정을 완료한 후 오즈 스케줄러 서버를 재시작합니다.

오즈 서버 설정

오즈 서버의 conf 폴더에 있는 schedulerforhtml5svgviewer.properties 파일을 열어 오즈 스케줄러 정보를 설정합니다. 대용량 보고서의 경우 오즈 스케줄러 서버를 여러 개 연결하면 속도 개선 효과가 있습니다.

sch1.scheduler_ip=첫번째 스케줄러 서버 IP

sch1.scheduler_port=첫번째 스케줄러 서버 포트번호

sch2.scheduler_ip=두번째 스케줄러 서버 IP

sch2.scheduler_port=두번째 스케줄러 서버 포트번호

...

세션 키를 설정할 경우 오즈 서버의 conf 폴더에 있는 spmgr.properties 파일을 열어 아래와 같은 옵션을 설정합니다.(옵션에 대한 설명은 OZ Enterprise Server Administrator's Guide를 참고하세요.)

...

svgviewerbind_sessionkey=세션 키

오즈 서버의 classes 폴더에 있는 ozserver.properties 파일을 열어 schedulerforhtml5svgviewer.properties 경로를 설정합니다.

...

path.scheduler.properties.file=%OZ_HOME%/conf/schedulerforhtml5svgviewer.properties

모든 설정을 완료한 후 오즈 서버와 연결된 WAS를 재시작합니다.

웹 서버의 특정 폴더에 뷰어 설치 파일 복사

웹 서버의 특정 폴더에 뷰어 설치 파일을 복사합니다.

웹 페이지에 뷰어 실행 및 보고서 바인딩 패러미터 추가

HTML5SVG 뷰어를 실행하도록 웹 페이지를 HTML5 형식으로 선언합니다.

다음으로 뷰어 설치 파일 경로, 뷰어ID, 오즈 서버 정보, 보고서 이름 등을 설정합니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","category_path/sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

script src를 이용하여 jquery-1.8.3.min.js, jquery-ui.min.js, jquery.dynatree.js, OZJSSVGViewer.js 파일 경로를, link rel을 이용하여 jquery-ui.css, ui.dynatree.css 파일 경로를, div 태그를 이용하여 width/height에 뷰어를 표시할 영역의 너비/높이를, id에 뷰어 ID를 설정합니다.

getElementById 함수를 이용하여 뷰어 ID를 설정하고 SetOZParamters_뷰어ID 함수를 이용하여 connection.servlet에 오즈 서버 경로를, connection.reportname에 바인딩할 보고서 경로와 이름을 설정한 후 start_ozjs 함수를 이용하여 뷰어를 실행합니다.

뷰어 실행

뷰어를 실행하고 보고서를 바인딩하는 웹 페이지를 웹 브라우저에서 실행한 후 보고서가 바인딩되는지 확인합니다.

Additional Information: HTML5SVG 뷰어를 모바일 UI로 실행하려면 웹 페이지를 아래와 같이 작성하시기 바랍니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>

<meta name="viewport" content="width=device-width,initial-scale=1,user-scalable=no"/>

<script src="http://code.jquery.com/jquery-1.9.1.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.10.3/themes/smoothness/jquery-ui.css"/>

<script src="http://code.jquery.com/ui/1.10.3/jquery-ui.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/mobile/1.4.5/jquery.mobile-1.4.5.min.css"/>

<script src="http://code.jquery.com/mobile/1.4.5/jquery.mobile-1.4.5.min.js"></script>

<link rel="stylesheet" type="text/css" href="http://dev.jtsage.com/cdn/simpledialog/latest/jquery.mobile.simpledialog.min.css"/>

<script type="text/javascript" src="http://dev.jtsage.com/cdn/simpledialog/latest/jquery.mobile.simpledialog2.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

<script src="http://127.0.0.1:8080/ozrviewer/jquery.mouseSwipe.js" type="text/javascript"></script>

</head>

<body style="height:100%">

<div id="OZViewer" style="width:100%;height:100%;overflow:hidden"></div>

<script type="text/javascript">

  function SetOZParamters_OZViewer(){

     var oz;

     oz = document.getElementById("OZViewer");

     oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

     oz.sendToActionScript("connection.reportname","category_path/sample.ozr");

     return true;

  }

  start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/", true);

</script>

</body>

</html>


Android 뷰어

Android 뷰어는 Eclipse 프로젝트를 이용하여 실행합니다.


시스템 요구 사항

시스템 요구 사항 - Android 뷰어

·OS : Android 4.0 이상을 지원하는 환경

·IDE : Eclipse 4.2(Juno) 이상


뷰어 실행

뷰어 실행 - Android 뷰어

Eclipse 프로젝트에 오즈 뷰어를 추가하고 Java Build Path에 설정한 후 Activity Class를 생성하고, 오즈 뷰어를 표시할 View를 만듭니다.

Eclipse 프로젝트에 오즈 뷰어 추가

프로젝트의 libs 폴더에 ozrv_android.jar, android-support-v4.jar 파일을 추가합니다.

프로젝트의 libs 폴더에 armeabi 폴더를 만들고, armeabi 폴더에 libskia_android.so 파일과 libozrv.so 파일을 추가합니다.

프로젝트 Properties 다이얼로그를 실행하여 "Java Build Path" 옵션을 클릭하고 [Libraries] 탭을 클릭한 후 [Add JARs] 버튼을 클릭하여 ozrv_android.jar, android-support-v4.jar 파일을 "JARs and class folers on the build path" 옵션에 추가합니다.

스크립트 입력

Activity를 생성한 후 오즈 뷰어를 실행할 수 있도록 스크립트를 추가합니다.

package com.forcs.ozreportviewer;

import oz.api.OZReportAPI;

import oz.api.OZReportViewer;

import android.app.Activity;

import android.os.Bundle;

import android.util.Log;

import android.widget.FrameLayout;

public class OZViewerActivity extends Activity

{

   OZReportViewer viewer = null;

   // libskia_android.so 파일과 libozrv.so 파일 Loading

   static

   {

       try {

           // so 파일은 아래 순서와 같이 로딩되어야함

          System.loadLibrary("skia_android");

          System.loadLibrary("ozrv");

       } catch (Throwable e) {

           Log.e("lib", e.getLocalizedMessage(), e);

       }

   }

   @Override

   public void onCreate(Bundle savedInstanceState)

   {

       super.onCreate(savedInstanceState);

       // 오즈 뷰어 패러미터 설정

       String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

       params += "\n" + "connection.reportname=category_path/sample.ozr";

       // 오즈 뷰어를 표시할 View 또는 ViewGroup 생성

       FrameLayout flayout = new FrameLayout(this);

       // 오즈 뷰어 생성

       viewer = OZReportAPI.createViewer(flayout, params);

       // 오즈 뷰어를 Activity View에 설정

       setContentView(flayout);

   }

   @Override

   public void onDestroy()

   {

       super.onDestroy();

       if(viewer != null)

       {

           viewer.dispose();

           viewer = null;

       }

   }

}

AndroidManifest.xml 설정

AndroidManifest.xml을 아래와 같이 설정합니다.

<manifest xmlns:android="http://schemas.android.com/apk/res/android"

   package="com.forcs.ozreportviewer"

   android:versionCode="1"

   android:versionName="1.0" >

   <uses-sdk

       android:minSdkVersion="10"

       android:targetSdkVersion="15" />

   <application

       android:icon="@drawable/ic_launcher"

       android:label="@string/app_name"

       android:theme="@style/AppTheme" >

       <activity

           android:name=".OZViewerActivity"

           android:label="@string/title_activity_ozviewer"

          android:windowSoftInputMode="adjustResize"

          android:configChanges = "orientation" >

           <intent-filter>

               <action android:name="android.intent.action.MAIN" />

               <category android:name="android.intent.category.LAUNCHER" />

           </intent-filter>

       </activity>

   </application>

  <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />

  <uses-permission android:name="android.permission.INTERNET" />

  <uses-permission android:name="android.permission.RECORD_AUDIO" />

  <uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" />

</manifest>

뷰어 실행

프로젝트를 실행합니다.


폰트 포함

폰트 포함 - Android 뷰어

보고서를 PDF, XLS 등으로 저장할 때 윈도우에서는 제공된 폰트가 Android에서는 제공되지 않아 미리보기된 것과 다르게 글꼴이 저장될 수 있습니다.

이럴 경우 모바일 앱에 폰트를 포함하여 배포하여야 합니다.

만일 폰트 라이선스 문제로 폰트를 포함할 수 없는 경우 Android에서 호환되는 폰트로 보고서를 디자인하시기 바랍니다.

기존 Eclipse 프로젝트에 아래 과정을 추가하시기 바랍니다.

Eclipse 프로젝트에 폰트 파일 추가

프로젝트의 assets 폴더에 res 폴더를 만들고, res 폴더에 폰트 파일을 추가합니다.

폰트 정보 설정

param.oz 파일 편집 창에서 폰트 정보를 입력합니다.

...

font.fontnames=font_dotum,font_gulim,font_malgun

font.font_dotum.url=res://dotum.ttf

font.font_dotum.name=돋움

font.font_gulim.url=res://gulim.ttf

font.font_gulim.name=굴림

font.font_malgun.url=res://malgun.ttf

font.font_malgun.name=맑은고딕

...


iOS 뷰어

iOS 뷰어는 Xcode 프로젝트를 이용하여 실행합니다.


시스템 요구 사항

시스템 요구 사항 - iOS 뷰어

·OS : iOS 7.0 이상을 지원하는 환경

·IDE : Xcode 5.0 이상


뷰어 실행

뷰어 실행 - iOS 뷰어

Xcode 프로젝트에 오즈 뷰어를 추가한 후 오즈 서버 정보와 보고서 파일 이름을 설정하고, 오즈 뷰어를 표시할 View를 추가합니다.

Xcode 프로젝트 생성

Xcode를 실행하여 새로운 프로젝트를 만듭니다.

Choose a template for your new project 다이얼로그에서 "Single View Application"을 선택합니다.

Choose options for your new project 다이얼로그에서 Product Name, Company Identifier 등의 옵션을 설정합니다. 이때 "Use Automatic Reference Counting" 옵션은 반드시 체크 해지하시기 바랍니다. 옵션 설정 후 [Next] 버튼을 클릭합니다.

프로젝트를 저장할 경로를 선택한 후 [Create] 버튼을 클릭하여 프로젝트를 생성합니다.

Xcode 프로젝트에 오즈 뷰어 추가

프로젝트가 저장된 경로에 임의의 폴더를 만듭니다.(본 도움말에서는 OZViewer로 폴더를 만듬)

오즈 뷰어 패치 파일을 OZViewer 폴더에 압축 해제합니다.

Project Navigator 창에서 프로젝트 이름을 마우스 오른쪽 버튼으로 클릭하여 나타나는 팝업 메뉴 중 [Add Files to "프로젝트 이름"] 메뉴를 클릭합니다. 프로젝트 저장 경로의 OZViewer 폴더를 선택하고, "Create groups for any added folders" 옵션을 체크하고, Add to targets에 표시된 프로젝트 이름을 체크한 후 [Add] 버튼을 클릭합니다.

OZViewer 폴더의 파일 중 README.TXT 파일을 열어, README.TXT 파일에 명시된대로 라이브러리를 추가합니다.

스크립트 입력

ViewController.h 파일에 아래와 같이 스크립트를 입력합니다.

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

@end

ViewController.m 파일에 아래와 같이 스크립트를 입력합니다.

#import "ViewController.h"

@interface ViewController ()

@end

@implementation ViewController

-(id)initWithNibName:(NSString *)nibNameOrNil bundle:(NSBundle *)nibBundleOrNil

{

   self = [super initWithNibName:nibNameOrNil bundle:nibBundleOrNil];

   if (self) {

       // Custom initialization

   }

   return self;

}

- (void) createViewer {

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                        @"connection.reportname=category_path/sample.ozr";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

}

- (void)viewDidLoad

{

   [super viewDidLoad];

   // Do any additional stup after loading the view, typically from a nib.

   // View가 Load될 때 오즈 뷰어를 실행하는 createViewer 함수 호출

   [self performSelector:@selector(createViewer) withObject:nil afterDelay:0.1];

}

- (void)viewDidUnload

{

   [super viewDidUnload];

   // Release any retained subviews of the main view.

}

- (BOOL)shouldAutorotateToInterfaceOrientation:(UIInterfaceOrientation)interfaceOrientation

{

   return (interfaceOrientation != UIInterfaceOrientationPortraitUpsideDown);

}

@end

View 설정

ViewController.xib를 선택합니다.

오즈 뷰어를 표시할 View를 추가하고, View의 Utilities 창에서 속성과 크기 등을 설정합니다.

Placeholders에서 File's Owner을 클릭하고, View의 Utilities 창에서 Show the Connections inspector 아이콘을 클릭합니다. Outlets에서 _reportView 오른쪽 옆에 있는 라디오 버튼을 클릭한 후 오즈 뷰어를 표시할 View 영역으로 드래그 & 드롭합니다.

뷰어 실행

Run 아이콘을 클릭하여 프로젝트를 실행합니다.


폰트 포함

폰트 포함 - iOS 뷰어

보고서를 PDF, XLS 등으로 저장할 때 윈도우에서는 제공된 폰트가 iOS에서는 제공되지 않아 미리보기된 것과 다르게 글꼴이 저장될 수 있습니다.

이럴 경우 모바일 앱에 폰트를 포함하여 배포하여야 합니다.

만일 폰트 라이선스 문제로 폰트를 포함할 수 없는 경우 iOS에서 호환되는 폰트로 보고서를 디자인하시기 바랍니다.

기존 Xcode 프로젝트에 아래 과정을 추가하시기 바랍니다.

Xcode 프로젝트에 폰트 파일 추가

Project Navigator 창에서 프로젝트 이름을 마우스 오른쪽 버튼으로 클릭하여 나타나는 팝업 메뉴 중 [Add Files to "프로젝트 이름"] 메뉴를 클릭합니다. 폰트 파일을 선택하고, "Create folder reference for any added folders" 옵션을 체크하고, Add to targets에 표시된 프로젝트 이름을 체크한 후 [Add] 버튼을 클릭합니다.

폰트 정보 설정

뷰어를 호출하는 ViewController.m 파일에 폰트 정보를 설정하는 패러미터를 추가합니다.

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"font.fontnames=font_dotum,font_gulim,font_malgun\n"

                         @"font.font_dotum.url=res://dotum.ttf\n"

                         @"font.font_dotum.name=돋움\n"

                         @"font.font_gulim.url=res://gulim.ttf\n"

                         @"font.font_gulim.name=굴림\n"

                         @"font.font_malgun.url=res://malgun.ttf\n"

                         @"font.font_malgun.name=맑은고딕";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

...

폰트 포함 확인

Products에서 app을 마우스 오른쪽 버튼으로 클릭하여 나타나는 팝업 메뉴 중 [Show in Finder] 메뉴를 클릭합니다. Debug 다이얼로그에서 응용 프로그램을 마우스 오른쪽 버튼으로 클릭하여 나타나는 팝업 메뉴 중 [패키지 내용 보기] 메뉴를 클릭하여 폰트 파일이 추가되어있는지 확인합니다.


WinRT 뷰어

WinRT 뷰어는 Visual Studio 2012 버전 이상의 C#, C++/CX 프로젝트를 이용하여 실행합니다.


시스템 요구 사항

시스템 요구 사항 - WinRT 뷰어

·OS : Windows 8.1 이상을 지원하는 환경

·IDE : Visual Studio 2012 이상


뷰어 실행 - C# 기준

뷰어 실행 - C# 기준 - WinRT 뷰어

Visual Studio 프로젝트에 오즈 뷰어 추가

C# 프로젝트를 생성합니다.

제품 패치 파일 중 ozrv, res, custom_ui 폴더를 프로젝트 경로에 위치하도록 합니다.(Visual Studio 2012에서는 common 폴더에 StandardStyles.xaml 파일이 위치하여야 합니다.)

빌드할 플랫폼에 따라 ARM/x86/x64 폴더를 선택한 후 해당 폴더에 있는 모든 파일을 ozrv 폴더로 복사합니다.

Visual Studio 솔루션 탐색기에서 "참조"를 마우스로 우측 선택하여 참조 추가를 선택합니다.

참조 관리자 Dialog에서 좌측 하단의 "찾아보기"를 선택하여 oz.winmd, OZWRTManagedRuntime.winmd, ZXing.winmd 파일을 추가한 후 "찾아보기" 위에 있는 "Windows"를 선택한 다음 [확장] 탭에서 "Microsoft Visual C++ 2012/2013 Runtime Package for Windows"를 체크하고 [확인] 버튼을 누릅니다.

Visual Studio 솔루션 탐색기에서 프로젝트를 마우스 우측 선택하여 "추가 -> 새 폴더(D)"를 추가합니다. 추가한 폴더 이름은 res로 하며 동일하게 폴더를 한 개 더 추가하여 폴더 이름을 "custom_ui"로 만듭니다.

추가된 res 폴더를 마우스 우측 선택하여 "추가 -> 기존 항목(G)"을 선택하여 프로젝트 경로의 res 폴더의 이미지를 전체 선택하여 프로젝트에 추가합니다.

custom_ui 폴더도 마찬가지로 마우스 우측 선택하여 프로젝트 경로의 custom_ui 폴더의 이미지를 전체 선택하여 프로젝트에 추가합니다.

custom_ui와 res 폴더에 추가된 xaml 파일의 속성 창을 실행하여 [고급] 탭에서 "빌드 작업" 옵션을 "Page"로 설정합니다.

App.xaml 파일을 열어 아래 코드를 추가합니다.

<Application.Resources>

   <ResourceDictionary>

       <ResourceDictionary.MergedDictionaries>

           <!--

          플랫폼 모양 및 느낌의 일반적인 측면을 정의하는 스타일입니다.

          Visual Studio 프로젝트 및 항목 템플릿에 필요합니다.

           -->

          <ResourceDictionary Source="res/OZXElementStyles.xaml"/>

       </ResourceDictionary.MergedDictionaries>

   </ResourceDictionary>

</Application.Resources>

MainPage.xaml에 뷰어를 올릴 Border를 아래와 같이 추가합니다.

<Border x:Name="_viewerFrame" Margin="0, 0, 0, 0"/>

MainPage.xaml.cs에 namespace를 아래와 같이 추가합니다.

using oz.api;

Viewer 객체를 아래와 같이 선언합니다.

private OZReportViewer _viewer = null;

스크립트 입력

오즈 뷰어를 실행할 수 있도록 스크립트를 추가합니다.

using System;

using System.Collections.Generic;

using System.IO;

using System.Linq;

using Windows.Foundation;

using Windows.Foundation.Collections;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

using Windows.UI.Xaml.Controls.Primitives;

using Windows.UI.Xaml.Data;

using Windows.UI.Xaml.Input;

using Windows.UI.Xaml.Media;

using Windows.UI.Xaml.Navigation;

using oz.api;

namespace OZWinRTViewerSample

{

   public sealed partial class MainPage : Page

   {

       private OZReportViewer _viewer = null;

       public MainPage()

       {

           this.InitializeComponent();

           onCreate();

      }

       public void onCreate()

       {

           try

           {

               if (_viewer != null) {

                   _viewer.Dispose();

               }

               string param = "connection.servlet=http://127.0.0.1:8080/oz/server";

               param += "\n" + "connection.reportname=category_path/sample.ozr";

               _viewer = OZReportAPI.CreateViewer(_viewerFrame, param);

           }

           catch (Exception ex)

           {

               string s = ex.Message;

           }

       }

   }

}

Package.appxmanifest 설정

Package.appxmanifest를 더블 클릭하여, [기능] 탭 클릭한 후 인터넷(클라이언트), 마이크, 웹캠 항목을 체크합니다.

뷰어 실행

프로젝트를 실행합니다.


뷰어 실행 - C++/CX 기준

뷰어 실행 - C++/CX 기준 - WinRT 뷰어

Visual Studio 프로젝트에 오즈 뷰어 추가

C++/CX 프로젝트를 생성합니다.

제품 패치 파일 중 ozrv, res, custom_ui 폴더를 프로젝트 경로에 위치하도록 합니다.(Visual Studio 2012에서는 common 폴더에 StandardStyles.xaml 파일이 위치하여야 합니다.)

빌드할 플랫폼에 따라 ARM/x86/x64 폴더를 선택한 후 해당 폴더에 있는 모든 파일을 ozrv 폴더로 복사합니다.

Visual Studio 솔루션 탐색기에서 프로젝트 마우스 우측 선택하여 "속성"을 선택합니다. "속성" 다이얼로그에서 [공용속성] 탭을 선택하여 "참조"를 선택한 뒤 [새 참조 추가(N)…] 버튼을 누릅니다. oz.winmd, OZWRTManagedRuntime.winmd, ZXing.winmd 파일을 "찾아보기"를 이용하여 선택한 후 [확인] 버튼을 누릅니다.

Visual Studio 솔루션 탐색기에서 프로젝트를 마우스 우측 선택하여 "추가 -> 새 필터(F)"를 추가합니다. 추가한 필터 이름은 res로 하며 동일하게 필터를 한 개 더 추가하여 필터 이름을 "custom_ui"로 만듭니다.

추가된 res 필터를 마우스 우측 선택하여 "추가 -> 기존 항목(G)"을 선택하여 프로젝트 경로의 res 필터의 이미지를 전체 선택하여 프로젝트에 추가합니다.

custom_ui 필터도 마찬가지로 마우스 우측 선택하여 프로젝트 경로의 custom_ui 필터의 이미지를 전체 선택하여 프로젝트에 추가합니다.

custom_ui와 res 필터에 추가된 xaml 파일의 속성 창을 실행하여 [일반] 탭에서 "항목 형식" 옵션을 "XAML 페이지"로 설정합니다.

App.xaml 파일을 열어 아래 코드를 추가합니다.

<Application

   x:Class="OZWinRTViewerSample.App"

   xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

   xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

   xmlns:local="using:OZWinRTSample2">

   <Application.Resources>

       <ResourceDictionary>

           <ResourceDictionary.MergedDictionaries>

               <!--

              플랫폼 모양 및 느낌의 일반적인 측면을 정의하는 스타일입니다.

              Visual Studio 프로젝트 및 항목 템플릿에 필요합니다.

               -->

               <ResourceDictionary Source="res/OZXElementStyles.xaml"/>

           </ResourceDictionary.MergedDictionaries>

       </ResourceDictionary>

   </Application.Resources>

</Application>

MainPage.xaml에 뷰어를 올릴 Border를 아래와 같이 추가합니다.

<Border x:Name="_viewerFrame" Margin="0, 0, 0, 0"/>

MainPage.xaml.h / MainPage.xaml.cpp에 namespace를 아래와 같이 추가합니다.

using namespace oz::api;

MainPage.xaml.h 파일에 Viewer 객체 및 onCreate() 함수를 선언합니다.

private:

  OZReportViewer^ _viewer;

public:

  void onCreate();

스크립트 입력

오즈 뷰어를 실행할 수 있도록 스크립트를 추가합니다.

#include "pch.h"

#include "MainPage.xaml.h"

using namespace oz::api;

using namespace OZWinRTViewerSample;

using namespace Platform;

using namespace Windows::Foundation;

using namespace Windows::Foundation::Collections;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

using namespace Windows::UI::Xaml::Controls::Primitives;

using namespace Windows::UI::Xaml::Data;

using namespace Windows::UI::Xaml::Input;

using namespace Windows::UI::Xaml::Media;

using namespace Windows::UI::Xaml::Navigation;

MainPage::MainPage()

{

   InitializeComponent();

   onCreate();

}

void OZWinRTViewerSample::MainPage::onCreate()

{

   try

   {

       if (_viewer != nullptr) {

           _viewer = nullptr;

  }

       Platform::String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server";

       param += "\n" + "connection.reportname=category_path/sample.ozr";

       _viewer = OZReportAPI::CreateViewer(_viewerFrame, param);

  }

   catch (Platform::Exception^ ex)

  {

       Platform::String^ s = ex->Message;

  }

}

Package.appxmanifest 설정

Package.appxmanifest를 더블 클릭하여, [기능] 탭을 클릭한 후 인터넷(클라이언트), 마이크, 웹캠 항목을 체크합니다.

뷰어 실행

프로젝트를 실행합니다.


뷰어 패러미터

본 장에서는 뷰어에서 사용하는 패러미터에 대해 설명합니다.


arrow

콜아웃 기능 시 사용하는 화살표의 속성 제어에 관한 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
arrow.arrowshape | O | O | O | O | O | X | X | X | X
arrow.arrowsize | O | O | O | O | O | X | X | X | X
arrow.arrowtype | O | O | O | O | O | X | X | X | X
arrow.changeable | O | O | O | O | O | X | X | X | X
arrow.linecolor | O | O | O | O | O | X | X | X | X
arrow.linedash | O | O | O | O | O | X | X | X | X
arrow.linethickness | O | O | O | O | O | X | X | X | X
arrow.linetype | O | O | O | O | O | X | X | X | X
arrow.movable | O | O | O | O | O | X | X | X | X
arrow.multiscreen_visible_type | O | X | X | X | X | X | X | X | X
arrow.tooltiptext | O | O | O | O | O | X | X | X | X

O

Only e-Form


arrow.arrowshape

화살표 모양을 설정합니다.

Value

circle 원

diamond 마름모

opentriangle 열린 삼각형

semicircle 반원

sharptriangle 뾰족한 삼각형

triangle 삼각형 (기본 값)


arrow.arrowsize

화살표 크기를 설정합니다.

Reference

기본 값은 "10"입니다.


arrow.arrowtype

화살표 방향을 설정합니다.

Value

both 양쪽 방향

normal 정방향 (기본 값)

reverse 역방향


arrow.changeable

속성 변환 가능 여부를 설정합니다.

Value

true 속성 변환 가능 (기본 값)

false 속성 변환 불가


arrow.linecolor

선 색을 설정합니다.

Reference

기본 값은 "000000"입니다.


arrow.linedash

선의 스타일을 점선으로 설정합니다.

Reference

"점선 간격" 형태로 설정하시기 바랍니다.


arrow.linethickness

선 두께를 설정합니다.

Reference

기본 값은 "1"입니다.


arrow.linetype

선 타입을 설정합니다.

Value

backslash 역슬래쉬 (기본 값)

horizontal 수평

slash 슬래쉬

vertical 수직


arrow.movable

이동 가능 여부를 설정합니다.

Value

true 이동 가능 (기본 값)

false 이동 불가


arrow.multiscreen_visible_type

멀티 스크린 환경에서 화살표 표시 타입을 설정합니다.

Value

always 양쪽 스크린 모두 화살표가 표시됨 (기본 값)

mainscreenonly 메인 스크린에만 화살표가 표시됨

subscreenonly 서브 스크린에만 화살표가 표시됨


arrow.tooltiptext

툴팁에 표시할 텍스트를 설정합니다.


bankbook

통장 프린터 관련 정보를 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
bankbook.linethick1 | O | O | O | O | O | X | X | X | X
bankbook.linethick2 | O | O | O | O | O | X | X | X | X


bankbook.linethick1

선의 두께를 설정합니다.

Reference

기본 값은 0.2이며 단위는 pt 입니다.

통장 프린터로 선을 인쇄할 때 적용되는 규칙은 다음과 같습니다.

·컴포넌트 선 두께 < bankbook.linethick1

선 인쇄 안됨

·bankbook.linethick1 =< 컴포넌트 선 두께 < bankbook.linethick2

한 줄로 인쇄됨

·bankbook.linethick2 =< 컴포넌트 선 두께

두 줄로 인쇄됨


bankbook.linethick2

선의 두께를 설정합니다.

Reference

기본 값은 0.3이며 단위는 pt 입니다.

통장 프린터로 선을 인쇄할 때 적용되는 규칙은 bankbook.linethick1 패러미터를 참고하시기 바랍니다.


circle

콜아웃 기능 시 사용하는 원의 속성 제어에 관한 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
circle.bordercolor | O | O | O | O | O | X | X | X | X
circle.borderthickness | O | O | O | O | O | X | X | X | X
circle.changeable | O | O | O | O | O | X | X | X | X
circle.fillcolor | O | O | O | O | O | X | X | X | X
circle.movable | O | O | O | O | O | X | X | X | X
circle.multiscreen_visible_type | O | X | X | X | X | X | X | X | X
circle.tooltiptext | O | O | O | O | O | X | X | X | X
circle.transparent | O | O | O | O | O | X | X | X | X

O

Only e-Form


circle.bordercolor

테두리 색을 설정합니다.

Reference

기본 값은 "000000"입니다.


circle.borderthickness

테두리 두께를 설정합니다.

Reference

기본 값은 "1"입니다.


circle.changeable

속성 변환 가능 여부를 설정합니다.

Value

true 속성 변환 가능 (기본 값)

false 속성 변환 불가


circle.fillcolor

바탕색을 설정합니다.

Reference

기본 값은 "FFFFFF"입니다.


circle.movable

이동 가능 여부를 설정합니다.

Value

true 이동 가능 (기본 값)

false 이동 불가


circle.multiscreen_visible_type

멀티 스크린 환경에서 원 표시 타입을 설정합니다.

Value

always 양쪽 스크린 모두 원이 표시됨 (기본 값)

mainscreenonly 메인 스크린에만 원이 표시됨

subscreenonly 서브 스크린에만 원이 표시됨


circle.tooltiptext

툴팁에 표시할 텍스트를 설정합니다.


circle.transparent

바탕의 투명 여부를 설정합니다.

Value

true 투명

false 불투명 (기본 값)


comment

편집 모드 또는 주석 모드 옵션을 설정합니다.

Android/iOS/WinRT 뷰어에서는 편집 모드로 칭하고, 그 외 뷰어에서는 주석 모드로 칭합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
comment.all | O | O | O | O | O | X | O | O | O
comment.autohide | X | X | X | X | X | X | O | O | O
comment.bgcolor | O | O | O | O | O | X | X | X | X
comment.clear | O | O | O | O | O | X | O | O | O
comment.colorbuttons | O | O | O | O | O | X | O | O | O
comment.confirmclear | O | O | O | O | O | X | O | O | O
comment.drawborder | O | X | O | X | O | X | O | O | O
comment.drawborder_color | O | X | O | X | O | X | O | O | O
comment.drawborder_colors | O | X | O | X | O | X | X | X | X
comment.drawborder_thick | O | X | O | X | O | X | O | O | O
comment.drawborder_transparency | O | X | O | X | O | X | O | O | O
comment.eraser | O | O | O | O | O | X | O | O | O
comment.fillbackground | O | X | O | X | O | X | O | O | O
comment.fillbackground_color | O | X | O | X | O | X | O | O | O
comment.fillbackground_colors | O | X | O | X | O | X | X | X | X
comment.fillbackground_transparency | O | X | O | X | O | X | O | O | O
comment.hideatinputmode | O | O | O | O | O | X | O | O | O
comment.highlightpen | O | O | O | O | O | X | O | O | O
comment.highlightpen_color | O | O | O | O | O | X | O | O | O
comment.highlightpen_colors | O | O | O | O | X | X | X | X | X
comment.highlightpen_thick | O | O | O | O | O | X | O | O | O
comment.highlightpen_transparency | O | O | O | O | O | X | O | O | O
comment.mode | O | O | O | O | O | X | O | O | O
comment.pen | O | O | O | O | O | X | O | O | O
comment.pen_color | O | O | O | O | O | X | O | O | O
comment.pen_colors | O | O | O | O | X | X | X | X | X
comment.pen_thick | O | O | O | O | O | X | O | O | O
comment.selectedpen | O | O | O | O | O | X | O | O | O
comment.sizebuttons | O | O | O | O | O | X | O | O | O

O

Only e-Form


comment.all

편집 모드 또는 주석 모드 아이콘 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

Android/iOS/WinRT 뷰어에서는 메인 툴바에 편집 모드 아이콘이 표시됩니다.

그 외 뷰어에서는 메인 툴바에 주석 모드 아이콘이 표시되고, 뷰어 창의 팝업 메뉴에 [주석 모드] 메뉴가 표시됩니다.


comment.autohide

편집 툴바를 자동으로 숨길지 여부를 설정합니다.

Value

true 일정 시간 후 자동으로 숨겨짐 (기본 값)

false 보고서를 탭하면 숨겨지고 다시 탭하면 표시됨


comment.bgcolor

주석 툴바 배경색을 설정합니다.

Reference

기본 값은 "F0F0F0"입니다.


comment.clear

편집/주석 툴바에 모두 지우기 아이콘 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


comment.colorbuttons

색 설정 아이콘의 활성화 또는 표시 여부를 설정합니다.

Value

true Android/iOS/WinRT 뷰어에서는 색 설정 아이콘을 활성화. 그 외 뷰어에서는 색 설정 아이콘을 표시 (기본 값)

false Android/iOS/WinRT 뷰어에서는 색 설정 아이콘을 비활성화. 그 외 뷰어에서는 색 설정 아이콘을 표시 안 함


comment.confirmclear

모두 지우기 아이콘 클릭 시 삭제 확인창 표시 여부를 설정합니다.

Value

true 확인창 표시

false 확인창 표시 안 함 (기본 값)


comment.drawborder

테두리 그리기 아이콘의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


comment.drawborder_color

입력 컴포넌트의 테두리를 그릴 때 테두리의 색을 설정합니다.

Reference

기본 값은 "0FFF26"입니다.


comment.drawborder_colors

테두리 그리기 아이콘의 색 그룹을 설정합니다.

Reference

기본 값은 "0FFF26,FF9AE9,8CF9F9"입니다.

테두리 그리기 아이콘의 색 그룹에는 최대 6개의 색을 표시할 수 있으며, 테두리의 색을 여러 개 설정할 경우 콤마(,)를 구분자로하여 값을 나열합니다.

색상 값을 잘못 설정한 경우 해당 색상만 "0FFF26"으로 적용됩니다.

HTML5JS 뷰어는 PC 환경에서만 지원됩니다.


comment.drawborder_thick

입력 컴포넌트의 테두리를 그릴 때 테두리의 두께를 설정합니다.

Reference

기본 값은 6입니다.


comment.drawborder_transparency

입력 컴포넌트의 테두리를 그릴 때 테두리 색의 투명도를 설정합니다.

Reference

기본 값은 25입니다.

0~100 사이의 값으로 설정할 수 있으며, 작은 값으로 설정할수록 투명해집니다.


comment.eraser

지우개 아이콘의 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


comment.fillbackground

바탕색 채우기 아이콘의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


comment.fillbackground_color

입력 컴포넌트의 바탕색을 채울 때 바탕의 색을 설정합니다.

Reference

기본 값은 "0FFF26"입니다.


comment.fillbackground_colors

바탕색 채우기 아이콘의 색 그룹을 설정합니다.

Reference

기본 값은 "0FFF26,FF9AE9,8CF9F9"입니다.

바탕색 채우기 아이콘의 색 그룹에는 최대 6개의 색을 표시할 수 있으며, 바탕색을 여러 개 설정할 경우 콤마(,)를 구분자로하여 값을 나열합니다.

색상 값을 잘못 설정한 경우 해당 색상만 "0FFF26"으로 적용됩니다.

HTML5JS 뷰어는 PC 환경에서만 지원됩니다.


comment.fillbackground_transparency

입력 컴포넌트의 바탕색을 채울 때 바탕색의 투명도를 설정합니다.

Reference

기본 값은 25입니다.

0~100 사이의 값으로 설정할 수 있으며, 작은 값으로 설정할수록 투명해집니다.


comment.hideatinputmode

편집/주석 모드가 아닐 때 보고서에 추가한 주석을 숨길지 여부를 설정합니다.

Value

true 편집/주석 모드가 아닌 경우 주석을 숨김

false 주석을 항상 표시 (기본 값)


comment.highlightpen

형광펜 아이콘의 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


comment.highlightpen_color

형광펜 색을 설정합니다.

Reference

기본 값은 "0FFF26"입니다.

comment.highlightpen_colors를 이용하여 형광펜 색 아이콘 그룹을 설정한 경우 comment.highlightpen_colors에서 설정한 첫 번째 색이 기본 형광펜 색으로 설정됩니다.


comment.highlightpen_colors

형광펜 색 아이콘 그룹의 색을 설정합니다.

Reference

기본 값은 "0FFF26,FF9AE9,8CF9F9"입니다.

형광펜 색 아이콘 그룹에는 최대 6개의 색을 표시할 수 있으며, 형광펜 색을 여러 개 설정할 경우 콤마(,)를 구분자로하여 값을 나열합니다.

색상 값을 잘못 설정한 경우 해당 색상만 "0FFF26"으로 적용됩니다.


comment.highlightpen_thick

형광펜 두께를 설정합니다.

Reference

기본 값은 10입니다.


comment.highlightpen_transparency

형광펜 투명도를 설정합니다.

Reference

기본 값은 25입니다.

0~100 사이의 값으로 설정할 수 있으며, 작은 값으로 설정할수록 투명해집니다.


comment.mode

주석 실행 모드를 설정합니다.

Value

true Android/iOS/WinRT 뷰어에서는 편집 모드로 실행. 그 외 뷰어에서는 주석 모드로 실행

false Android/iOS/WinRT 뷰어에서는 입력 모드로 실행. 그 외 뷰어에서는 viewer.screentool 패러미터 값에 따름 (기본 값)


comment.pen

펜 아이콘의 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


comment.pen_color

펜 색을 설정합니다.

Reference

기본 값은 "000000"입니다.

comment.pen_colors를 이용하여 펜 색 아이콘 그룹을 설정한 경우 comment.pen_colors에서 설정한 첫 번째 색이 기본 펜 색으로 설정됩니다.


comment.pen_colors

펜 색 아이콘 그룹의 색을 설정합니다.

Reference

기본 값은 "000000,FF0000,0000FF"입니다.

펜 색 아이콘 그룹에는 최대 6개의 색을 표시할 수 있으며, 펜 색을 여러 개 설정할 경우 콤마(,)를 구분자로하여 값을 나열합니다.

색상 값을 잘못 설정한 경우 해당 색상만 "000000"으로 적용됩니다.


comment.pen_thick

펜 두께를 설정합니다.

Reference

기본 값은 1입니다.


comment.selectedpen

주석을 그릴 때 기본적으로 선택할 펜 타입을 설정합니다.

Value

drawborder 테두리 그리기

eraser 지우개

fillbackground 바탕색 채우기

highlightpen 형광펜

pen 펜 (기본 값)


comment.sizebuttons

두께 설정 바/아이콘의 활성화 또는 표시 여부를 설정합니다.

Value

true Android/iOS/WinRT 뷰어에서는 두께 설정 바를 활성화. 그 외 뷰어에서는 두께 설정 아이콘을 표시 (기본 값)

false Android/iOS/WinRT 뷰어에서는 두께 설정 바를 비활성화. 그 외 뷰어에서는 두께 설정 아이콘을 표시 안 함


connection

오즈 서버 연결 정보 및 보고서 관련 정보를 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
connection.2dbarcodeurl | O | O | X | O | X | X | X | X | X
connection.args# | O | O | O | O | O | O | O | O | O
connection.autopageque | O | O | X | O | X | X | O | O | O
connection.clientcachetype | O | O | O | O | O | O | O | O | O
connection.clientdmtype | O | O | O | O | O | X | O | O | O
connection.compresseddatamodule | O | O | O | O | O | X | O | O | O
connection.compressedForm | O | O | O | O | O | X | O | O | O
connection.datafromserver | O | O | O | O | O | O | O | O | O
connection.displayname | O | O | O | O | O | O | O | O | O
connection.extraparam | O | O | X | O | X | X | X | X | X
connection.fetchtype | O | O | O | O | O | X | O | O | O
connection.footerreportname | O | O | O | O | O | O | O | O | O
connection.formfromserver | O | O | X | O | X | X | O | O | O
connection.frameworkurl | O | O | O | O | O | O | O | O | O
connection.headerreportname | O | O | O | O | O | O | O | O | O
connection.id | O | O | O | O | O | O | O | O | O
connection.inputjson | O | O | O | O | O | X | O | O | O
connection.memorypercent | O | O | X | O | X | X | O | O | O
connection.openfile | O | O | X | O | X | X | O | O | O
connection.pageque | O | O | X | O | X | X | O | O | O
connection.pagequebundle | O | O | X | O | X | X | O | O | O
connection.password | O | O | O | O | O | O | O | O | O
connection.pcount | O | O | O | O | O | O | O | O | O
connection.port | O | O | X | O | X | X | O | O | O
connection.refreshperiod | O | O | O | O | O | X | O | O | O
connection.reportname | O | O | O | O | O | O | O | O | O
connection.server | O | O | X | O | X | X | O | O | O
connection.serverdmtype | O | O | O | O | O | O | O | O | O
connection.servlet | O | O | O | O | O | O | O | O | O
connection.usebareserver | O | X | X | X | X | X | X | X | X
connection.usescheduleddata | O | O | O | O | O | O | O | O | O
connection.usewinhttp | O | X | X | X | X | X | X | X | X

O

Only e-Form


connection.2dbarcodeurl

뷰어와 연동할 2D 바코드 URL을 설정합니다.


connection.args#

폼 패러미터 값을 설정합니다.

Reference

#은 숫자 값으로 몇 번째 패러미터인지를 알려주는 번호이며, 1부터 connection.pcount에 설정한 값까지 사용할 수 있습니다.

패러미터 값은 "패러미터이름=패러미터값" 형태로 설정합니다.

예를 들어, 폼 패러미터 중 Country는 Korea로, City는 Seoul로 설정할 경우 아래와 같이 패러미터 값을 설정합니다.(아래 태그는 ActiveX 뷰어 기준입니다.)

<param name = "connection.pcount" value="2">

<param name = "connection.args1" value="Country=Korea">

<param name = "connection.args2" value="City=Seoul">


connection.autopageque

임시 파일 생성 여부를 설정합니다.

Value

true 임시 파일 생성함

false 임시 파일 생성 안 함 (기본 값)

Reference

시스템의 가용 페이지 파일 메모리 사용량 비율이 connection.memorypercent에 설정한 값 보다 클 경우 임시 파일을 생성한 후 보고서를 바인딩합니다.

보고서가 100 페이지 바인딩 될 때마다 메모리 사용량을 체크합니다.


connection.clientcachetype

리파지토리로부터 받은 파일의 캐시 타입을 설정합니다.

Value

none 캐시를 사용하지 않음

memory 메모리에 캐시함 (기본 값)

file 임시 폴더에 파일 남겨둠

disconnection 파일을 받는 중 네트웍 연결이 끊어졌거나 뷰어가 비정상 종료된 후에 다시 접속을 시도하면 받은 파일 이후부터 이어 받음

crypt 파일을 암호화

Reference

메모리에 캐시할 경우 오즈 뷰어가 같은 보고서를 다시 불러올 때 오즈 서버로부터 파일을 받지 않고 캐시된 파일을 표시합니다.

임시 폴더에 파일을 남겨둘 경우 암호화하여 파일을 사용자가 읽을 수 없도록 할 수 있으며 현재 클라이언트에 캐시된 파일의 버전(서버에서 받을 때 마지막 수정된 날짜)을 리파지토리 서버에 보내 파일을 새로 받을지를 결정합니다.

캐시 타입은 ","를 구분자로 하며, 중복하여 설정할 수 있습니다.

Flash, HTML5, Android, iOS, WinRT 뷰어의 경우 file, disconnection, crypt로 설정해도 memory로 동작합니다.

"connection.clientcachetype=none"인 경우에는 보고서를 OZD 파일로 저장할 수 없습니다.


connection.clientdmtype

오즈 뷰어의 데이터 모듈 처리 방식을 설정합니다.

Value

normal 오즈 서버로부터 데이터 모듈을 모두 받은 후 보고서 바인딩 시작

memory 오즈 서버로부터 데이터 모듈을 메모리로 받으면서 보고서 바인딩을 동시에 진행 (기본 값)

file 오즈 서버로부터 데이터 모듈을 파일로 받으면서 보고서 바인딩을 동시에 진행

Reference

데이터 모듈 받는 작업과 보고서 바인딩 작업을 하나의 스레드로 처리하는 기존 방식에 성능을 높이고 응답 시간을 줄이기 위해 각 작업을 별도의 쓰레드로 나누어 병렬 처리하는 방식을 추가하였습니다. 또한 낮은 시스템 사양에서 안정적인 운영을 위해 데이터 모듈을 파일로 받는 모드를 지원합니다.

Flash, HTML5, Android, iOS, WinRT 뷰어의 경우 file로 설정해도 memory로 동작합니다.


connection.compresseddatamodule

오즈 서버에 데이터 모듈 요청 시 압축 여부를 설정합니다.

Value

true 압축된 데이터 모듈 요청

false 압축되지 않은 데이터 모듈 요청 (기본 값)


connection.compressedForm

서버에 보고서 폼 요청 시 압축 여부를 설정합니다.

Value

true 압축

false 압축 안 함 (기본 값)


connection.datafromserver

데이터를 서버로부터 가져올지 여부를 설정합니다.

Value

true 서버에서 데이터를 가져옴 (기본 값)

false 로컬에 캐시된 데이터를 가져옴

Reference

"connection.datafromserver=false"로 설정하여도 connection.usescheduleddata 또는 odi.odiname.usescheduledata의 값을 설정하지 않거나 빈 값으로 설정하면 서버로부터 데이터를 가져옵니다.


connection.displayname

오즈 뷰어의 보고서 트리 또는 페이지 축소판 창에 표시할 보고서 이름을 설정합니다.

Reference

표시 이름은 엑셀로 익스포트 시 엑셀 시트명으로("displayname#") 저장됩니다.

페이지 축소판 창에 보고서 이름을 표시하려면 viewer.thumbnailsection_makerule 패러미터 값을 true로 설정하시기 바랍니다.


connection.extraparam

뷰어와 연동된 외부 모듈에 전달할 패러미터를 설정합니다.


connection.fetchtype

오즈 서버의 데이터 모듈 처리 방식을 설정합니다.

Value

batch 모든 데이터의 데이터 모듈 생성 작업을 완료한 후 데이터 모듈을 전송함 (기본 값)

concurrent 데이터 모듈 생성과 전송 작업을 동시에 실행


connection.footerreportname

보고서의 페이지 풋터로 사용될 보고서 이름을 설정합니다.

Reference

페이지 풋터 보고서에 있는 폼 패러미터 값을 설정하려면 connection.pcount와 connection.args# 패러미터를 이용하시기 바랍니다.

페이지 풋터 보고서와 바디 보고서(connection.reportname에 설정한 보고서)에 추가된 폼 패러미터 중 동일한 이름의 폼 패러미터가 있을 경우 바디 보고서의 폼 패러미터 값이 페이지 풋터 보고서의 폼 패러미터에도 적용됩니다.

바디 보고서가 OZD 파일이거나 복합 보고서일 경우에는 패러미터 값이 적용되지 않습니다.

페이지 풋터로 사용되는 보고서는 캐시 기능이 지원되지 않습니다.

페이지 풋터에 있는 컴포넌트의 크기가 바인딩되는 보고서의 용지 크기보다 클 경우 보고서가 비정상적으로 바인딩되므로 주의하시기 바랍니다.


connection.formfromserver

보고서 파일을 서버로부터 가져올지 여부를 설정합니다.

Value

true 서버로부터 가져옴 (기본 값)

false 로컬에 캐시된 파일을 가져옴


connection.frameworkurl

프레임웍 URL을 설정합니다.


connection.headerreportname

보고서의 페이지 헤더로 사용될 보고서 이름을 설정합니다.

Reference

패러미터 관한 자세한 사항은 connection.footerreportname을 참고하시기 바랍니다.


connection.id

사용자 ID를 설정합니다.

Reference

기본 값은 guest입니다.


connection.inputjson

입력 컴포넌트의 값을 뷰어 패러미터로 설정합니다.

Reference

보고서가 바인딩될 때 패러미터로 설정한 값이 입력 컴포넌트 값으로 적용됩니다. 단, OnAddToPage, OnEndBind 이벤트에서 자바 스크립트를 이용하여 입력 컴포넌트의 값을 설정한 경우 자바 스크립트로 설정한 값으로 적용됩니다.

입력 컴포넌트의 값은 JSON 형식의 문자열로, "FormID":"컴포넌트 값" 형태로 설정하시기 바랍니다. 단, FormID를 설정하지 않은 컴포넌트는 "컴포넌트 이름":"컴포넌트 값" 형태로 설정하시기 바랍니다.

패러미터 값을 JSON 형식이 아닌 문자열로 설정하거나 패러미터 값에 FormID 또는 컴포넌트 이름이 중복된 경우 패러미터가 적용되지 않습니다.


connection.memorypercent

가용 페이지 파일 메모리 사용량 비율(%)을 설정합니다.

Reference

기본 값은 90입니다.

"connection.autopageque=true"인 경우에 적용됩니다.


connection.openfile

오즈 뷰어에 표시할 OZD 파일을 OZURL 형식으로 설정합니다.

Reference

OZURL 형식은 오즈 리파지토리 경로(ozp://), 웹 서버 경로(http://), 로컬 경로(file://), 모바일 앱의 리소스 경로(res://)로 설정할 수 있습니다.

로컬 경로 설정 시 전체 경로뿐만 아니라 상대 경로도 설정 가능합니다.

Android 뷰어의 리소스 경로는 프로젝트의 assets 폴더이며 iOS/WinRT 뷰어의 리소스 경로는 프로젝트 폴더입니다.

서버 API로 생성된 ODI 파일을 바인딩할 때 서버 리파지토리의 이미지 파일을 표시하려면 OZ 서버의 접속 정보를 설정하여야 합니다.


connection.pageque

바인딩이 완료된 보고서 중 메모리에 로드할 페이지 수를 설정합니다.

Reference

설정된 숫자만큼만 메모리에 로드되며, 나머지는 페이지별로 파일에 저장하고 해당 페이지 호출 시 메모리에 로드됩니다.

기본 값은 -1이며, 기본 값으로 설정하면 전체 페이지를 메모리에 로드합니다.


connection.pagequebundle

한 파일로 저장되는 페이지 수를 설정합니다.

Reference

connection.pageque 값을 설정한 경우에 적용됩니다.

기본 값은 0이며, 기본 값으로 설정하면 한 파일에 한 페이지씩 저장합니다.

너무 큰 값을 설정할 경우 페이지 이동 시 이동 시간이 지연되는 경우가 있으니 5~20 사이의 값으로 설정할 것을 권장합니다.


connection.password

사용자 패스워드를 설정합니다.

Reference

기본 값은 guest입니다.


connection.pcount

값을 설정할 폼 패러미터 개수를 설정합니다.


connection.port

오즈 서버의 포트 번호를 설정합니다.

Reference

오즈 서버의 타입이 데몬 형태일 경우에 적용됩니다.


connection.refreshperiod

보고서 새로 고침 주기를 설정합니다.


connection.reportname

오즈 뷰어에 표시할 보고서 파일의 경로와 이름을 설정합니다.

Reference

보고서 파일은 오즈 서버의 리파지토리 디렉터리에 존재해야 합니다.


connection.server

오즈 서버의 IP 또는 도메인명을 설정합니다.

Reference

오즈 서버의 타입이 데몬 형태일 경우에 적용됩니다.


connection.serverdmtype

오즈 서버의 데이터 모듈 생성 옵션을 설정합니다.

Value

file 파일 이용

memory 메모리 이용 (기본 값)

Reference

데이터 모듈이 대용량일 경우 file로 설정하여 오즈 서버의 부하를 줄일 수 있습니다.


connection.servlet

오즈 서버 URL을 설정합니다.

Reference

오즈 서버의 타입이 서블릿 형태일 경우에 적용되며, connection.server 패러미터와 함께 사용할 수 없습니다.


connection.usebareserver

베어 서버(로컬 서버)를 기동할지 여부를 설정합니다.

Value

true 베어 서버(로컬 서버) 기동

false 베어 서버(로컬 서버) 기동 안 함 (기본 값)

Reference

베어 서버를 기동하면 서버가 아닌 클라이언트에서 데이터 바인딩을 수행합니다.


connection.usescheduleddata

보고서 미리보기 시 사용할 데이터 모듈 파일(*.SDM)의 파일명을 설정합니다.

Reference

스케줄러 등에 의해 미리 생성된 데이터 모듈 파일(*.SDM)을 이용하여 보고서를 보고자 할 때 사용합니다.

SDM 파일의 경로는 오즈 리파지토리 경로(ozp://), 웹 서버 경로(http://), 로컬 경로(file://)로 설정할 수 있습니다.

단, Flash, HTML5 뷰어는 오즈 서버 환경 설정 파일 중 conf/srmngr.properties 파일의 datamodule_path에 설정한 경로를 기준으로 하여 상대 경로로 설정합니다. 또한, srmngr.properties 파일의 use_scheduled_data 옵션을 true로 설정하여야 합니다.

"connection.datafromserver=false"로 설정하여야 적용됩니다.


connection.usewinhttp

WinHttp 사용 여부를 설정합니다.

Value :

true | OS 버전에 따라 WinINet 사용 여부 결정
false | OS 버전에 상관없이 WinINet 사용 (기본 값)

Reference

"connection.usewinhttp=true"로 설정하면 OS 버전이 NT 계열일 경우 WinHttp를 사용하고 그 외 버전에서는 WinINet을 사용하며, connection.fetchtype이 "batch"로만 동작합니다.

단, WinHttp 방식으로 오즈 서버 연결 시 에러가 발생하면 false로 동작됩니다.


csv

CSV 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
csv.addseparator | O | O | O | O | O | O | O | O | O
csv.charset | O | O | O | O | O | O | O | O | O
csv.exceptfirstpage | O | O | O | O | O | O | O | O | O
csv.filename | O | O | O | O | O | O | O | O | X
csv.maxrowinafile | O | O | O | O | O | O | O | O | O
csv.pageline | O | O | O | O | O | O | O | O | O
csv.pagestyle | O | O | O | O | O | O | O | O | O
csv.pagetitle | O | O | O | O | O | O | O | O | O
csv.path | O | O | X | O | X | X | O | O | X
csv.removerange | O | O | O | O | O | O | O | O | O
csv.removeseparator | O | O | O | O | O | O | O | O | O
csv.saveastable | O | O | O | O | O | O | O | O | O
csv.separator | O | O | O | O | O | O | O | O | O
csv.splitmergedcell_at_saveastable | O | O | O | O | O | O | O | O | O


csv.addseparator

자릿수 구분 기호 추가 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

CSV/Text 저장 옵션 다이얼로그


csv.charset

인코딩 옵션을 설정합니다.

Value

ansi ANSI (기본 값)

unicode 유니코드

See Also

CSV/Text 저장 옵션 다이얼로그


csv.exceptfirstpage

라인 제거 옵션 중 첫 페이지 제외 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

CSV/Text 저장 옵션 다이얼로그


csv.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


csv.maxrowinafile

한 파일에 저장할 최대 행 수를 설정합니다.

Reference

최대 행 수에 따라 파일이 분할되어 CSV 파일로 저장됩니다.

단, 최대 행 수가 한 페이지에 바인딩된 행 수 보다 작은 경우 최대 행 수는 무시되고, 페이지 단위로 파일이 분할됩니다.

한 페이지에 있는 데이터는 두 개의 CSV 파일로 분리되지 않습니다. 예를 들어, 전체 4페이지이고 매 페이지마다 행이 10개인 보고서에서 패러미터 값을 15로 설정하면 1페이지의 10개와 2페이지의 5개가 하나의 CSV 파일로 저장되어야 하지만 2페이지의 데이터는 두 번째 CSV 파일에 생성됩니다. 그 결과, 10개의 행을 가진 4개의 CSV 파일로 저장됩니다.


csv.pageline

페이지 간격 줄 수 옵션을 설정합니다.

Reference

매 페이지 끝에 설정한 줄 수만큼 빈 줄을 추가합니다.

csv.pagestyle을 이용하여 페이지 구분형태를 함께 설정한 경우 페이지 구분형태를 먼저 추가하고 다음 줄에 지정한 줄 수만큼의 빈 줄이 추가됩니다.

See Also

CSV/Text 저장 옵션 다이얼로그


csv.pagestyle

구분형태 옵션을 설정합니다.

Value

None None (기본 값)

n <PAGE> n <PAGE>

n <PAGE> --- n <PAGE> ---

--- n <PAGE> --- n <PAGE>

<PAGE> n <PAGE> n

<PAGE> n --- <PAGE> n ---

--- <PAGE> n --- <PAGE> n

Reference

구분형태는 'n', '---' 와 '<PAGE>'의 조합으로 구성되며, 'n'는 해당 보고서의 페이지 번호를 나타내고, '<PAGE>'는 csv.pagetitle에서 정의한 문자열입니다. csv.pagetitle을 'Page'로 설정하고 csv.pagestyle 값을 '--- n <PAGE>'로 설정하면 각 페이지는 다음과 같이 표시됩니다.

--------------------------------------- 1Page

None으로 설정하면 페이지 구분 없이 저장하고 그 외 값으로 설정하면 보고서의 매 페이지 끝에 페이지 구분 텍스트를 추가하여 저장합니다.

None 이외의 값으로 선택했을 때 구분형태 문자열 중 <PAGE>를 대체할 문자열을 설정하는 방법은 csv.pagetitle을 참고하시기 바랍니다.

See Also

CSV/Text 저장 옵션 다이얼로그


csv.pagetitle

<PAGE> 옵션을 설정합니다.

Reference

기본 값은 page입니다.

See Also

csv.pagestyle

CSV/Text 저장 옵션 다이얼로그


csv.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


csv.removerange

라인 제거 옵션을 체크하고, 제거할 라인 범위를 "시작라인,끝라인" 형태로 설정합니다.

See Also

CSV/Text 저장 옵션 다이얼로그


csv.removeseparator

자릿수 구분 기호 제거 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

CSV/Text 저장 옵션 다이얼로그


csv.saveastable

테이블 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

CSV/Text 저장 옵션 다이얼로그


csv.separator

구분자 옵션을 설정합니다.

Value

tab tab

space space

| |

/ /

~ ~

comma comma (기본 값)

empty empty

Other 그 외 값

See Also

CSV/Text 저장 옵션 다이얼로그


csv.splitmergedcell_at_saveastable

병합된 라벨을 분할하여 저장할지 여부를 설정합니다.

Value

true 병합된 라벨을 분할하여 저장

false 병합된 상태로 저장 (기본 값)

Reference

"csv.saveastable=true"인 경우에 적용됩니다.


eform

e-form 뷰어 실행 시 기본 동작 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
eform.checkbox_type | X | X | X | X | X | X | O | O | O
eform.custom_ui | O | X | X | X | O | X | O | O | O
eform.dialog_autoclose_at_itemclick | X | X | X | X | X | X | O | O | O
eform.functionbutton_display_type | O | O | O | O | O | X | O | O | O
eform.hidecontrols | O | O | O | O | O | X | O | O | O
eform.highlightpen_guide | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_allowzoom | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_dpi | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_facingmode | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_flashmode | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_iconposition | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_prev_next_iconposition | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_show_choose_button | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_show_save_button | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_show_toolbar | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_toolbar_facing | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_toolbar_flash | X | X | X | X | X | X | O | O | O
eform.imagepicker_camera_zoom | X | X | X | X | X | X | O | O | O
eform.imagepicker_id_info | X | X | X | X | X | X | O | O | O
eform.inputeventcommand | O | O | O | O | O | X | O | O | O
eform.prev_next_navigation_rule | O | O | O | O | O | X | O | O | O
eform.radiobutton_type | X | X | X | X | X | X | O | O | O
eform.resourceparam | O | X | X | X | X | X | X | X | X
eform.show_prev_next_input | O | X | X | X | X | X | O | O | O
eform.signpad_highlightcolor | O | X | X | X | X | X | O | O | O
eform.signpad_iconalignment | X | X | X | X | X | X | O | O | O
eform.signpad_iconposition | X | X | X | X | X | X | O | O | O
eform.signpad_prev_next_iconposition | X | X | X | X | X | X | O | O | O
eform.signpad_type | O | O | O | O | O | X | O | O | O
eform.signpad_viewtype | O | X | X | X | O | X | O | O | O
eform.signpad_zoom | X | X | X | X | X | X | O | O | O
eform.textbox_iconalignment | X | X | X | X | X | X | O | O | O
eform.textbox_passwordchar | O | O | O | O | O | X | O | O | O
eform.textbox_use_highlight | X | X | X | X | X | X | O | O | O
eform.togglebutton_type | O | O | O | O | X | X | O | O | O
eform.usemultiscreen | O | X | X | X | X | X | X | X | X
eform.voicerecorder_recording_timeout | X | X | X | X | X | X | O | O | O

O

Only e-Form


eform.checkbox_type

체크 박스의 실행 타입을 설정합니다.

Value

dialog_at_prev_next 이전/다음 순서로 인해 체크 박스가 선택된 경우 다이얼로그 형태로 실행

direct 미리보기 화면에서 직접 선택 (기본 값)

ensurevisible_at_prev_next 이전/다음 순서로 인해 체크 박스가 선택된 경우 체크 박스가 화면에 표시되도록 보고서를 자동으로 스크롤하고, 이전/다음 동작을 멈춤


eform.custom_ui

서명 패드의 가이드라인을 설정합니다.

Reference

기본 값은 공백입니다.

패러미터 값은 {"signpad":{"Key1":"Value1","Key2":"Value2",...,"Keyn":"Valuen"}} 형태로 설정합니다.

설정 가능한 Key는 아래와 같습니다.

Key | 설명
guideline_color | 가이드라인 색 (기본 값 : C0C0C0)
guideline_shape | 가이드라인 표시 타입 (기본 값 : none) none으로 설정하면 가이드라인이 표시되지 않고, underline으로 설정하면 가이드라인이 언더라인으로 표시됨
guideline_style | 가이드라인 선 스타일 (기본 값 : dashed) dashed로 설정하면 가이드라인이 점선으로 표시되고 solid로 설정하면 가이드라인이 실선으로 표시됨
guideline_thickness | 가이드라인 두께 (기본 값 : 5)
guideline_transparency | 가이드라인 투명도 (기본 값 : 128) 0 ~ 255 사이의 값으로 설정해야 하며, 작은 값으로 설정할수록 투명해짐

가이드라인 관련 기능을 사용하려면 eform.signpad_type 패러미터 값을 direct가 아닌 값으로 설정하시기 바랍니다.


eform.dialog_autoclose_at_itemclick

다이얼로그에서 아이템을 선택하면 다이얼로그를 닫을지 여부를 설정합니다.

Value

true 다이얼로그를 닫음

false 다이얼로그를 닫지 않음 (기본 값)

Reference

패러미터 값을 true로 설정할 경우 다이얼로그에는 [확인] 버튼이 표시되지 않고, 다이얼로그에서 아이템을 선택하면 입력 컴포넌트에 값이 적용되고 다이얼로그가 자동으로 닫힙니다.

패러미터는 콤보 박스와 라디오 버튼에서만 적용됩니다.

단, 라디오 버튼에서 이 기능을 사용하려면 라디오 버튼을 라디오 버튼 그룹으로 그룹핑하고 라디오 버튼 그룹의 "선택 안 함 가능" 과 "다중 선택 가능" 속성 값을 "아니오"로 설정한 후 eform.radiobutton_type 패러미터 값을 dialog 또는 dialog_at_prev_next로 설정하시기 바랍니다.


eform.functionbutton_display_type

보고서를 미리보기/저장/인쇄할 때 콤보 박스, DateTimePicker, NumericUpDown의 기능 버튼 표시 여부를 설정합니다.

Value

alwayshide 콤보 박스, DateTimePicker, NumericUpDown의 기능 버튼을 항상 표시 안 함

alwaysshow 콤보 박스, DateTimePicker, NumericUpDown의 기능 버튼을 항상 표시

showpreviewonly 콤보 박스, DateTimePicker, NumericUpDown의 기능 버튼을 미리보기 시에만 표시하고 저장/인쇄 시에는 표시 안 함 (기본 값)


eform.hidecontrols

보고서에 추가된 모든 입력 컴포넌트를 숨길지 여부를 설정합니다.

Value

true 숨김

false 입력 컴포넌트의 Visible 속성 값에 따름 (기본 값)

Reference

패러미터 값을 true로 설정할 경우 보고서를 저장하거나 인쇄할 때에 입력 컴포넌트를 포함하지 않습니다.

단, ozd로 저장할 경우에는 무조건 false로 적용됩니다.


eform.highlightpen_guide

형광펜, 테두리 그리기, 바탕색 채우기 아이콘으로 가이드한 입력 컴포넌트를 이전/다음 컴포넌트로 설정합니다.

Value

none 사용 안 함 (기본 값)

reorder 형광펜, 테두리 그리기, 바탕색 채우기 아이콘으로 가이드한 입력 컴포넌트 순서 기준으로 이전/다음 컴포넌트의 순서를 재배열함

Reference

가이드 기능은 입력 컴포넌트의 이전/다음을 디자인 시점에 설정하는 것이 아니라 미리보기 시점에 형광펜, 테두리 그리기, 바탕색 채우기 아이콘을 이용하여 유동적으로 설정하고자 할 때 사용합니다.

편집 모드에서 가이드할 선을 그리면 해당 선에 닿는 모든 입력 컴포넌트가 이전/다음 컴포넌트 리스트에 추가됩니다.

현재 선택된 컴포넌트가 가이드된 컴포넌트인 경우 이전/다음 이동 시 가이드된 컴포넌트끼리만 이동됩니다.

이전/다음 컴포넌트 리스트에서 삭제하려면 편집 툴바의 지우개를 이용하시기 바랍니다.

가이드 기능을 사용하려면 eform.highlightpen_guide=reorder, comment.all=true로 설정한 후 comment.selectedpen 패러미터를 highlightpen, drawborder, fillbackground 중 하나의 값으로 설정하시기 바랍니다


eform.imagepicker_camera_allowzoom

ImagePicker를 이용하여 화면을 촬영할 때 카메라의 확대 배율 조절 가능 여부를 설정합니다.

Value

true 화면을 확대하여 촬영 가능

false 100% 화면으로만 촬영 가능 (기본 값)

Reference

패러미터 값을 true로 설정할 경우 촬영 화면 영역에서 "Pinch to Zoom" 동작을 하면 확대 배율을 나타나는 텍스트가 표시되고, 촬영 화면을 확대하여 촬영할 수 있습니다.

촬영을 완료하거나 카메라를 전면/후면으로 변경한 경우에는 확대 배율이 100%로 초기화됩니다.

해당 기능을 사용하려면 ImagePicker의 ImagePickMode 속성 값을 카메라로 설정하시기 바랍니다.


eform.imagepicker_camera_dpi

ImagePicker의 카메라 DPI를 설정합니다.

Reference

기본 값은 96입니다.


eform.imagepicker_camera_facingmode

ImagePicker를 이용하여 사진을 촬영할 때 카메라 화면의 전면/후면 동작 모드를 설정합니다.

Value

back 후면 카메라 (기본 값)

front 전면 카메라


eform.imagepicker_camera_flashmode

카메라의 플래시 동작 모드를 설정합니다.

Value

auto 자동

off 끔 (기본 값)

on 켬


eform.imagepicker_camera_iconposition

ImagePicker를 이용하여 사진을 촬영할 때 [촬영], [닫기] 버튼의 위치를 설정합니다.

Value

camera_bottom 카메라 영역의 바깥쪽 하단 중앙에 [촬영], [닫기] 순서로 버튼을 표시함 (기본 값)

camera_top 카메라 영역의 바깥쪽 상단 중앙에 [촬영], [닫기] 순서로 버튼을 표시함

viewer_bottom 뷰어 영역의 하단 왼쪽에 [촬영] 버튼을, 오른쪽에 [닫기] 버튼을 표시함

viewer_middle 뷰어 영역의 가운데 위치의 왼쪽에 [촬영] 버튼을, 오른쪽에 [닫기] 버튼을 표시함

viewer_top 뷰어 영역의 상단 왼쪽에 [촬영] 버튼을, 오른쪽에 [닫기] 버튼을 표시함

Reference

[촬영], [닫기] 버튼은 기본적으로 [촬영], [닫기] 순서로 표시됩니다. 그러나 [촬영], [닫기] 버튼의 위치를 [이전], [다음] 버튼의 위치와 같은 위치로 설정하고 [이전], [다음] 버튼의 위치를 "_left"로 끝나는 값으로 설정하면 맨 오른쪽 영역에 [닫기], [촬영] 순서로 표시됩니다.

예를 들어, eform.imagepicker_camera_prev_next_iconposition=camera_top_left, eform.imagepicker_camera_iconposition=camera_top으로 설정한 경우 카메라 영역 바깥쪽 상단의 맨 왼쪽에는 [이전], [다음] 순서로 버튼이 표시되고, 맨 오른쪽에는 [닫기], [촬영] 순서로 버튼이 표시됩니다.


eform.imagepicker_camera_prev_next_iconposition

ImagePicker에 표시되는 [이전], [다음] 버튼의 표시 위치를 설정합니다.

Value

camera_bottom 카메라 영역 바깥쪽 하단의 맨 왼쪽에는 [이전] 버튼을 표시하고, 카메라 영역 바깥쪽 하단의 맨 오른쪽에는 [다음] 버튼을 표시함

camera_bottom_left 카메라 영역 바깥쪽 하단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시함

camera_top 카메라 영역 바깥쪽 상단의 맨 왼쪽에는 [이전] 버튼을 표시하고, 카메라 영역 바깥쪽 상단의 맨 오른쪽에는 [다음] 버튼을 표시함 (기본 값)

camera_top_left 카메라 영역 바깥쪽 상단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시함

viewer_bottom 뷰어 영역 하단의 맨 왼쪽에는 [이전] 버튼을 표시하고, 뷰어 영역 하단의 맨 오른쪽에는 [다음] 버튼을 표시함

viewer_bottom_left 뷰어 영역 하단의 맨 왼쪽에는 [이전], [다음] 순서로 버튼을 표시함

viewer_top 뷰어 영역 상단의 맨 왼쪽에는 [이전] 버튼을 표시하고, 뷰어 영역 상단의 맨 오른쪽에는 [다음] 버튼을 표시함

viewer_top_left 뷰어 영역 상단의 맨 왼쪽에는 [이전], [다음] 순서로 버튼을 표시함


eform.imagepicker_camera_show_choose_button

[갤러리(앨범)] 버튼의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

버튼의 텍스트는 모바일 장비에 따라 [갤러리] 또는 [앨범]으로 표시되며, [촬영]/[닫기] 버튼의 위치가 viewer_middle일 때는 [촬영] 버튼의 아래쪽에, 그 외 경우에는 [촬영] 버튼의 오른쪽에 표시됩니다.

[갤러리(앨범)] 버튼으로 모바일 장비에 저장된 이미지를 선택하면 [촬영] 버튼이 [재촬영]으로 변경됩니다.

표시된 이미지를 삭제하려면 [재촬영] 버튼을 클릭한 후 [닫기] 버튼을 클릭합니다.

Android 뷰어의 경우 오즈 뷰어를 실행하는 스크립트에 아래와 같이 스크립트를 추가하여야 합니다.

@Override

protected void onActivityResult(int requestCode, int resultCode, Intent data) {

  if(ozviewer != null) {

     //requestCode: 호출된 Activity에 대한 식별 코드

     //resultCode: 사용자 동작에 대한 결과 코드

     //data: 갤러리에서 선택한 이미지 정보를 가진 Intent

     ozviewer.onActivityResult(this, requestCode, resultCode, data);

  }

}

ImagePicker가 도장/신분증 스캔으로 동작할 경우에는 false로 동작합니다.

See Also

eform.imagepicker_camera_iconposition


eform.imagepicker_camera_show_save_button

[저장] 버튼의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

ImagePicker로 사진을 촬영하고 [저장] 버튼을 클릭하면 갤러리(앨범)에 "OZ Mobile"이 추가되고, 해당 갤러리(앨범)에 ImagePicker에 표시된 이미지가 JPG 형태로 저장됩니다.

[저장] 버튼은 [촬영]/[닫기] 버튼의 위치가 viewer_middle일 때는 [촬영] 버튼의 아래쪽에, 그 외 경우에는 [촬영] 버튼의 오른쪽에 표시됩니다. 만일 [갤러리(앨범)] 버튼이 표시된 경우 [갤러리(앨범)] 버튼의 아래쪽에, 그 외 경우에는 [갤러리(앨범)] 버튼의 오른쪽에 표시됩니다.

ImagePicker가 도장/신분증 스캔으로 동작할 경우에는 false로 동작합니다.

See Also

eform.imagepicker_camera_iconposition


eform.imagepicker_camera_show_toolbar

ImagePicker를 이용하여 사진을 촬영할 때 촬영 화면 상단에 카메라 툴바를 표시할지 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

카메라 툴바에 표시할 아이콘이 없는 경우 패러미터 값을 true로 설정하여도 false로 동작됩니다.

ImagePicker가 도장/신분증 스캔으로 동작할 경우에는 false로 동작합니다.


eform.imagepicker_camera_toolbar_facing

카메라 화면 전환 아이콘의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

"eform.imagepicker_camera_show_toolbar=true"인 경우에 적용됩니다.

카메라 화면 전환을 지원하지 않는 카메라인 경우에는 카메라 화면 전환 아이콘이 비활성화 상태로 표시됩니다.

Android 단말기의 경우 카메라 화면 전환은 SDK API 9 이상(진저브레드 2.3 OS)에서만 지원됩니다.


eform.imagepicker_camera_toolbar_flash

플래시 아이콘의 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

Reference

"eform.imagepicker_camera_show_toolbar=true"인 경우에 적용됩니다.

플래시를 지원하지 않는 카메라인 경우에는 플래시 아이콘이 비활성화 상태로 표시됩니다.

플래시 아이콘을 클릭하면 "off, auto, on" 순서로 변경됩니다.


eform.imagepicker_camera_zoom

ImagePicker가 실행될 때 보고서 확대 배율을 설정합니다.

Reference

기본 값은 500입니다.


eform.imagepicker_id_info

신분증 스캔 옵션을 설정합니다.

Reference

신분증 스캔 옵션은 신분증 ID, 제목, 크기, 여백, 마스크 정보 등이 설정된 JSON 형식의 문자열로 작성하여야 합니다.

신분증 스캔 옵션을 설정하는 아이템 Key는 아래와 같습니다.

ids | 신분증 정보를 설정합니다. id : 신분증 ID name : 신분증 선택 창에 표시할 이름 size : 스캔할 신분증의 크기. "너비x높이" 형태로 설정. 단위는 mm margin : 신분증과 배경 사이의 여백. 기본 값은 0. 단위는 mm. 신분증을 스캔할 때 신분증 밑에 있는 배경을 함께 촬영할 경우 설정. 가로 방향 기준으로 여백을 적용하고 세로 방향은 ImagePicker의 크기에 맞게 자동 적용됨. 여백을 크게 설정하여 신분증 크기가 작아질 때 ImagePicker 크기의 30%까지만 작아짐 mask : 신분증 영역 중 마스크 처리할 영역. 마스크 처리한 영역은 모자이크 처리됨 name : 마스크 이름 area : 마스크 위치. "X좌표,Y좌표,너비,높이" 형태로 설정. 단위는 mm
choice | 신분증 선택 창의 제목과 표시할 신분증을 설정합니다. ids에서 설정한 신분증이 한 개이거나 items가 설정되지 않은 경우 ids에 맨 처음 추가된 신분증으로 스캔됩니다. title : 신분증 선택 창의 제목 items : 신분증 선택 창에 표시할 신분증 ID. 콤마(,)를 구분자로 하여 여러 개 설정
options | 신분증 스캔 기타 옵션을 설정합니다. shootaction : [촬영] 버튼의 동작 모드. 즉시 촬영할 경우 forceshoot, 포커스를 재조정할 경우 refocusing으로 설정. 기본 값은 forceshoot

위 아이템 Key를 이용하여 신분증 스캔 옵션을 아래와 같은 형태로 작성한 후 패러미터 값으로 설정합니다.

{

   "ids":

   [

       {

           "id":"1",

           "name":"운전면허증_최신",

           "size":"86x54",

           "margin":"3",

           "mask":

           [

               {"name":"주민번호","area":"33,19,28,3"},

               {"name":"운전면허번호","area":"54,9,28,6"},

               {"name":"발급번호","area":"71,39,9,3"},

               {"name":"발급날짜","area":"32,47,15,3"}

           ]

       },

       {

           "id":"2",

           "name":"운전면허증_구형",

           "size":"86x54",

           "margin":"3",

           "mask":

           [

               {"name":"주민번호","area":"47,19,30,3.5"},

               {"name":"운전면허번호","area":"54,8,28,6"},

               {"name":"발급번호","area":"71,39,9,3"},

               {"name":"발급날짜","area":"32,47,15,3"}

           ]

       },

       {

           "id":"3",

           "name":"주민등록증",

           "size":"86x54",

           "margin":"3",

           "mask":

           [

               {"name":"주민번호","area":"7,22,36,4"},

               {"name":"발급날짜","area":"32,41,26,4"}

           ]

       },

       {

           "id":"4",

           "name":"외국인등록증",

           "size":"86x54",

           "margin":"3",

           "mask":

           [

               {"name":"외국인등록번호1","area":"39,12,26,4"},

               {"name":"외국인등록번호2","area":"7,42.5,18,7"},

               {"name":"성명","area":"39,20,30,4"},

               {"name":"성별","area":"74.5,12,4,4"},

               {"name":"국가지역","area":"39,27.5,30,4"},

               {"name":"체류자격","area":"39,35,30,4"},

               {"name":"발급일자","area":"64,41,15,3"}

           ]

       }

   ],

   "choice":{"title":"신분증을 선택하세요.","items":"1,2,3,4"},

   "options":{"shootaction":"refocusing"}

}


eform.inputeventcommand

OZEFormInputEventCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


eform.prev_next_navigation_rule

필수 입력 속성 값이 "예"인 입력 컴포넌트끼리 이전/다음을 설정합니다.

Value

default 사용 안 함 (기본 값)

either_required_or_order 이전/다음 기능 실행 시 필수 입력 속성 값에 따라 필수 입력 속성 값이 "예"인 입력 컴포넌트끼리 이동하거나 디자인 시점에 설정한 순서대로 이동

required_only 이전/다음 기능 실행 시 필수 입력 속성 값이 "예"인 입력 컴포넌트로 이동

Reference

해당 기능을 사용하려면 이전/다음 FormID를 설정하지 않고, eform.highlightpen_guide=none, multiscreen.highlightpen_guide=false로 설정하시기 바랍니다.


eform.radiobutton_type

라디오 버튼의 실행 타입을 설정합니다.

Value

dialog 다이얼로그 형태로 실행

dialog_at_prev_next 다른 컴포넌트의 이전/다음 순서가 라디오 버튼인 경우에만 다이얼로그 형태로 실행

direct 보고서 화면에서 직접 선택하는 형태로 실행 (기본 값)

ensurevisible_at_prev_next 다른 컴포넌트의 이전/다음 순서가 라디오 버튼인 경우 라디오 버튼이 화면에 표시되도록 보고서를 자동으로 스크롤하고, 이전/다음 동작을 멈춤

Reference

eform.radiobutton_type 패러미터 값을 dialog 또는 dialog_at_prev_next로 설정한 경우 라디오 버튼을 클릭하면 같은 그룹으로 지정된 라디오 버튼을 다이얼로그 형태로 한꺼번에 표시하고, 다이얼로그의 오른쪽 상단에 [취소], [확인] 버튼이 표시됩니다.


eform.resourceparam

입력 컴포넌트의 리소스 관련 패러미터를 설정합니다.

Reference

기본 값은 공백입니다.

패러미터 값은 "Key1=Value1,Key2=Value2,...,Keyn=Valuen" 형태로 설정합니다.

설정 가능한 Key는 아래와 같습니다. 단, 서명만 가능합니다.

Key | 설명
prev_url | [이전] 버튼 이미지 경로 (활성화 상태)
prev_disable_url | [이전] 버튼 이미지 경로 (비활성화 상태)
next_url | [다음] 버튼 이미지 경로 (활성화 상태)
next_disable_url | [다음] 버튼 이미지 경로 (비활성화 상태)
reset_url | [초기화] 버튼 이미지 경로
complete_url | [완료] 버튼 이미지 경로
window_bgcolor | 입력창 배경 색 (기본 값 : DADDE1)
title_bgcolor | 제목 영역 배경 색 (기본 값 : DADDE1)
title_fontname | 제목 글꼴 이름
title_fontsize | 제목 글꼴 크기 (기본 값 : 12)
title_fontcolor | 제목 글꼴 색 (기본 값 : 000000)

설정 가능한 이미지 포맷은 JPG, PNG, GIF, BMP이며, 이미지의 높이가 30이 아닌 경우 높이 30에 맞춰 동일비율로 확대/축소됩니다.

eform.resourceparam 패러미터를 사용하여 서명 창의 [이전], [다음], [초기화], [완료] 버튼 이미지 경로를 설정하려면 eform.signpad_type=dialog, eform.show_prev_next_input=true로 설정하시기 바랍니다.

제목 글꼴 크기를 31보다 크게 설정한 경우 제목이 잘려서 표시됩니다.


eform.show_prev_next_input

[이전], [다음] 버튼의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

[이전], [다음] 버튼은 모바일 App 뷰어에서 지원됩니다. 단, 서명은 서명 타입이 dialog일 때 ActiveX 뷰어에서도 지원합니다.

[이전], [다음] 버튼의 표시 위치는 컴포넌트에 따라 다르게 표시됩니다.

·서명은 eform.signpad_prev_next_iconposition 패러미터 값에 따라 표시됩니다.

·텍스트 박스는 eform.textbox_iconalignment 패러미터 값에 따라 표시됩니다.

·라디오 버튼, 콤보 박스, DateTimePicker, NumericUpDown은 값 선택 창의 왼쪽 상단에 [이전], [다음] 버튼이 표시되고, 오른쪽 상단에 [취소], [확인] 버튼이 표시됩니다. 단, 라디오 버튼은 eform.radiobutton_type 패러미터 값이 dialog인 경우에만 표시됩니다.

·ImagePicker는 eform.imagepicker_camera_prev_next_iconposition 패러미터 값에 따라 표시됩니다.

·녹음은 녹음 창의 왼쪽 상단에 [이전] 버튼이 표시되고, 오른쪽 상단에 [다음] 버튼이 표시됩니다.

"viewer.pagedisplay=singlepage"인 경우에는 현재 페이지에서만 이전/다음 컴포넌트로 이동할 수 있으며, 그 외 경우에는 다른 페이지에 있는 컴포넌트로 이동할 수 있습니다. 단, "viewer.pagenavigate_by_prev_next=true"로 설정하면 페이지 표시 옵션과 상관없이 다른 페이지에 있는 컴포넌트로 이동할 수 있습니다.

패러미터 값을 true로 설정하여도 이전과 다음으로 이동할 컴포넌트가 모두 없는 경우 [이전], [다음] 버튼은 화면에 표시되지 않습니다.

See Also

eform.signpad_type


eform.signpad_highlightcolor

서명 가능한 영역을 하이라이팅할 색을 설정합니다.

Reference

기본 값은 "FF0000"입니다.

패러미터를 설정하려면 eform.signpad_type 패러미터를 direct가 아닌 값으로 설정하시기 바랍니다.


eform.signpad_iconalignment

서명 타입이 keypad일 때 서명에 표시되는 [이전], [다음], [초기화], [완료] 버튼의 수평 정렬 방식을 설정합니다.

Value

justify 서명 패드 상단의 맨 왼쪽에 [이전], [초기화] 또는 [이전], [다음] 버튼을 표시하고, 맨 오른쪽에 [완료], [다음] 또는 [초기화], [완료] 버튼을 표시함 (기본 값)

left 서명 패드 상단의 맨 왼쪽에 [이전], [다음], [초기화], [완료] 버튼을 표시함

right 서명 패드 상단의 맨 오른쪽에 [이전], [다음], [초기화], [완료] 버튼을 표시함

Reference

서명 버튼의 순서는 eform.signpad_prev_next_iconposition 패러미터 값에 따라 표시됩니다.


eform.signpad_iconposition

서명 타입이 zoom일 때 [초기화], [완료] 버튼의 위치를 설정합니다.

Value

sign_bottom 서명 영역의 바깥쪽 하단 중앙에 [초기화], [완료] 순서로 버튼을 표시함 (기본 값)

sign_top 서명 영역의 바깥쪽 상단 중앙에 [초기화], [완료] 순서로 버튼을 표시함

viewer_bottom 뷰어 영역의 하단 왼쪽에 [초기화] 버튼을, 오른쪽에 [완료] 버튼을 표시함

viewer_top 뷰어 영역의 상단 왼쪽에 [초기화] 버튼을, 오른쪽에 [완료] 버튼을 표시함

Reference

[초기화], [완료] 버튼은 서명 영역의 바깥쪽 또는 뷰어 영역의 양옆에 표시됩니다. 그러나 [이전], [다음] 버튼의 위치와 같은 위치에 표시될 경우 [이전], [다음] 버튼의 위치에 따라 오른쪽에 표시될 수 있습니다.

See Also

eform.signpad_prev_next_iconposition, eform.signpad_type


eform.signpad_prev_next_iconposition

서명에 표시되는 [이전], [다음] 버튼의 표시 위치를 설정합니다.

Value

sign_bottom 서명 타입이 zoom일 때에는 서명 영역 바깥쪽 하단의 맨 왼쪽에는 [이전] 버튼을 표시하고, 서명 영역 바깥쪽 하단의 맨 오른쪽에는 [다음] 버튼을 표시함. [초기화], [완료] 버튼의 위치는 eform.signpad_iconposition 패러미터 값을 따름. 서명 타입이 keypad일 때에는 서명 패드 하단의 맨 왼쪽에 [이전], [초기화] 순서로 버튼을 표시하고, 맨 오른쪽에 [완료], [다음] 순서로 버튼을 표시함

sign_bottom_left 서명 타입이 zoom일 때에는 서명 영역 바깥쪽 하단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시함. [초기화], [완료] 버튼의 위치는 eform.signpad_iconposition 패러미터 값을 따름. 서명 타입이 keypad일 때에는 서명 패드 하단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시하고, 맨 오른쪽에 [초기화], [완료] 순서로 버튼을 표시함

sign_top 서명 타입이 zoom일 때에는 서명 영역 바깥쪽 상단의 맨 왼쪽에는 [이전] 버튼을 표시하고, 서명 영역 바깥쪽 상단의 맨 오른쪽에는 [다음] 버튼을 표시함. [초기화], [완료] 버튼의 위치는 eform.signpad_iconposition 패러미터 값을 따름. 서명 타입이 keypad일 때에는 서명 패드 상단의 맨 왼쪽에 [이전], [초기화] 순서로 버튼을 표시하고, 맨 오른쪽에 [완료], [다음] 순서로 버튼을 표시함 (기본 값)

sign_top_left 서명 타입이 zoom일 때에는 서명 영역 바깥쪽 상단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시함. [초기화], [완료] 버튼의 위치는 eform.signpad_iconposition 패러미터 값을 따름. 서명 타입이 keypad일 때에는 서명 패드 상단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시하고, 맨 오른쪽에 [초기화], [완료] 순서로 버튼을 표시함

viewer_bottom 서명 타입이 zoom일 때에는 뷰어 영역 하단의 맨 왼쪽에는 [이전] 버튼을 표시하고, 뷰어 영역 하단의 맨 오른쪽에는 [다음] 버튼을 표시함. [초기화], [완료] 버튼의 위치는 eform.signpad_iconposition 패러미터 값을 따름. 서명 타입이 keypad일 때에는 서명 패드 상단의 맨 왼쪽에 [이전], [초기화] 순서로 버튼을 표시하고, 맨 오른쪽에 [완료], [다음] 순서로 버튼을 표시함

viewer_bottom_left 서명 타입이 zoom일 때에는 뷰어 영역 하단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시함. [초기화], [완료] 버튼의 위치는 eform.signpad_iconposition 패러미터 값을 따름. 서명 타입이 keypad일 때에는 서명 패드 상단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시하고, 맨 오른쪽에 [초기화], [완료] 순서로 버튼을 표시함

viewer_top 서명 타입이 zoom일 때에는 뷰어 영역 상단의 맨 왼쪽에는 [이전] 버튼을 표시하고, 뷰어 영역 상단의 맨 오른쪽에는 [다음] 버튼을 표시함. [초기화], [완료] 버튼의 위치는 eform.signpad_iconposition 패러미터 값을 따름. 서명 타입이 keypad일 때에는 서명 패드 상단의 맨 왼쪽에 [이전], [초기화] 순서로 버튼을 표시하고, 맨 오른쪽에 [완료], [다음] 순서로 버튼을 표시함

viewer_top_left 서명 타입이 zoom일 때에는 뷰어 영역 상단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시함. [초기화], [완료] 버튼의 위치는 eform.signpad_iconposition 패러미터 값을 따름. 서명 타입이 keypad일 때에는 서명 패드 상단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시하고, 맨 오른쪽에 [초기화], [완료] 순서로 버튼을 표시함

Reference

서명 타입이 keypad일 때 eform.signpad_iconalignment 패러미터 값에 따라 서명 버튼을 왼쪽과 오른쪽에 두 개씩 나누어 표시하는 것이 아니라 왼쪽 또는 오른쪽 중 한쪽으로 모아서 표시할 수 있습니다.

See Also

eform.signpad_type


eform.signpad_type

서명 타입을 선택합니다.

Value

dialog 서명을 클릭하면 창 하단에 모달 다이얼로그 형태로 서명 패드가 표시됨

direct 서명을 클릭하여 바로 서명

keypad 서명을 클릭하면 창 하단에 서명 패드가 표시됨

zoom 서명을 클릭하면 보고서가 확대되면서 서명이 하이라이팅됨

Reference

뷰어 타입별로 지원하는 서명 타입은 아래와 같습니다.

Viewer Type | Signpad Type
ActiveX, HTML5JS | dialog, direct(기본 값)
Applet, Flash, WPF | direct(기본 값)
Android, iOS, WinRT | dialog, keypad(기본 값), zoom


eform.signpad_viewtype

서명 패드 표시 타입을 설정합니다.

Value

fittoframe 서명 패드 전체 영역을 서명 영역으로 표시

keepratio 서명의 크기 비율대로 서명 영역을 표시 (기본 값)

scrollable 서명 패드 전체 영역을 서명 영역으로 표시하고 하단에 가로 스크롤 표시

Reference

패러미터 값 중 scrollable은 HTML5JS/Android/iOS/WinRT 뷰어에서만 동작하며, 해당 기능을 사용하려면 eform.signpad_type 패러미터를 dialog 또는 keypad로 설정하시기 바랍니다.


eform.signpad_zoom

서명 타입이 zoom일 때 보고서 확대 배율을 설정합니다.

Reference

기본 값은 500입니다.

See Also

eform.signpad_type


eform.textbox_iconalignment

텍스트 박스에 표시되는 [이전], [다음], [완료] 버튼의 수평 정렬 방식을 설정합니다.

Value

justify 텍스트 입력 창 상단의 맨 왼쪽에 [이전], [다음] 순서로 버튼을 표시하고, 맨 오른쪽에 [완료] 버튼을 표시함 (기본 값)

left 텍스트 입력 창 상단의 맨 왼쪽에 [이전], [다음], [완료] 순서로 버튼을 표시함

right 텍스트 입력 창 상단의 맨 오른쪽에 [이전], [다음], [완료] 순서로 버튼을 표시함


eform.textbox_passwordchar

텍스트 박스에 표시되는 패스워드 문자를 설정합니다.

Value

asterisk *로 표시됨

bullet ●로 표시됨 (기본 값)

Reference

Flash 뷰어는 텍스트 박스에 마우스가 오버되거나 포커스가 설정된 경우 패러미터 값과 상관없이 항상 *로 표시되고, 그 외 경우에는 패러미터 값에 따라 표시됩니다.

HTML5JS 뷰어는 텍스트 박스에 마우스가 오버되거나 포커스가 설정된 경우 패러미터 값과 상관없이 항상 ●로 표시되고, 그 외 경우에는 패러미터 값에 따라 표시됩니다.

iOS 뷰어는 텍스트 박스에 포커스가 설정된 경우 패러미터 값과 상관없이 항상 ●로 표시되고, 그 외 경우에는 패러미터 값에 따라 표시됩니다.

그 외 뷰어는 패러미터 값에 따라 표시됩니다.


eform.textbox_use_highlight

하이라이팅 효과를 텍스트 박스에 적용할지 여부를 설정합니다.

Value

true 하이라이팅 효과를 적용

false 하이라이팅 효과를 적용 안 함 (기본 값)


eform.togglebutton_type

토글 버튼의 실행 타입을 설정합니다.

Value

dialog_at_prev_next 이전/다음 순서로 인해 토글 버튼이 선택된 경우 다이얼로그 형태로 실행

direct 미리보기 화면에서 직접 선택 (기본 값)

ensurevisible_at_prev_next 이전/다음 순서로 인해 토글 버튼이 선택된 경우 토글 버튼이 화면에 표시되도록 보고서를 자동으로 스크롤하고, 이전/다음 동작을 멈춤


eform.usemultiscreen

멀티 스크린 기능 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)

Reference

멀티 스크린 기능을 사용하려면 고객 사이트에서 사용하는 멀티 스크린 연동 프로그램이 정상적으로 구동되어야하며, OZMultiscreen.dll 파일이 오즈 뷰어 실행 파일과 같은 경로에 위치하여야 합니다.

멀티 스크린 환경에서는 틀 고정 기능은 동작하지 않습니다.


eform.voicerecorder_recording_timeout

녹음 제한 시간을 설정합니다.

Reference

기본 값은 0이며, 단위는 초입니다.

0~3600 사이의 값으로 설정해야 하며, 0으로 설정하면 제한 시간 없이 녹음됩니다.


eform_xml

eform_xml 파일 저장 관련 상세 저장 옵션을 설정합니다.

eform_xml 파일로 저장 시에는 저장 옵션 중 저장 후 바로 실행, 한파일로 저장, 모든 문서 저장만 지원합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
eform_xml.filename | O | O | O | O | O | X | O | O | O
eform_xml.groupbyreport | O | O | O | O | O | X | O | O | O
eform_xml.path | O | O | O | O | O | X | O | O | O

O

Only e-Form


eform_xml.filename

파일 이름을 설정합니다.


eform_xml.groupbyreport

입력 컴포넌트의 값을 XML 형식의 문자열로 가져올 때 보고서별로 구분할지 여부를 설정합니다.

Value

true 보고서별로 구분

false 보고서별로 구분 안 함 (기본 값)

Reference

패러미터 값에 따라 리턴되는 XML 형태는 다음과 같습니다.

·false

<ozform>

   <컴포넌트 1의 이름>값</컴포넌트 1의 이름>

   <컴포넌트 2의 이름>값</컴포넌트 2의 이름>

   ...

</ozform>

·true

<ozform>

 <report name="첫 번째 보고서의 표시이름">

   <컴포넌트 1의 이름>값</컴포넌트 1의 이름>

   <컴포넌트 2의 이름>값</컴포넌트 2의 이름>

  ...

 </report>

 <report name="두 번째 보고서의 표시이름">

   <컴포넌트 1의 이름>값</컴포넌트 1의 이름>

   <컴포넌트 2의 이름>값</컴포넌트 2의 이름>

  ...

 </report>

 ...

</ozform>


eform_xml.path

저장 경로를 설정합니다.


etcmenu

다른 메뉴에 표시할 메뉴를 설정합니다.

다른 메뉴의 서브 메뉴 그룹과 순서는

·file(open, close, closeall, save, print)

·screentool(handtool, edittool)

·option(showtree, refresh, addmemo, savedm)

·pageselection(pagenavigator)

·pagecontrol(pagesetup, inversepaper, singlepagecontinuous_fittowidth, singlepage_fittoframe)

·finds(find)

·About

·Help

입니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
etcmenu.about | O | O | O | O | O | O | O | O | O
etcmenu.addarrow | O | O | O | O | O | X | X | X | X
etcmenu.addcircle | O | O | O | O | O | X | X | X | X
etcmenu.addline | O | O | O | O | O | X | X | X | X
etcmenu.addmemo | O | O | O | O | O | X | X | X | X
etcmenu.addrectangle | O | O | O | O | O | X | X | X | X
etcmenu.close | O | O | O | O | O | X | O | O | O
etcmenu.closeall | O | O | O | O | O | X | O | O | O
etcmenu.copyinputdata_json | O | O | O | O | O | X | O | O | O
etcmenu.copyinputdata_xml | O | O | O | O | O | X | O | O | O
etcmenu.edittool | O | O | O | O | O | X | X | X | X
etcmenu.find | O | O | O | O | O | X | O | O | O
etcmenu.handtool | O | O | O | O | O | X | X | X | X
etcmenu.help | O | O | O | O | O | O | O | O | O
etcmenu.inputparameter | X | X | X | X | X | X | O | O | O
etcmenu.inversepaper | O | O | O | O | O | X | O | O | O
etcmenu.multiscreenguide | O | X | X | X | X | X | X | X | X
etcmenu.open | O | O | O | O | O | X | O | O | O
etcmenu.ozdhistory | X | X | X | X | X | X | O | O | O
etcmenu.pagenavigator | O | O | O | O | O | O | O | O | O
etcmenu.pagesetup | O | O | O | O | O | X | O | O | O
etcmenu.parameter | X | X | X | X | X | X | O | O | O
etcmenu.print | O | O | O | O | O | O | O | O | O
etcmenu.refresh | O | O | O | O | O | X | O | O | O
etcmenu.save | O | O | O | O | O | O | O | O | O
etcmenu.savedm | O | O | O | O | O | X | O | O | O
etcmenu.showthumbnail | O | O | O | O | O | X | O | O | O
etcmenu.showtree | O | O | O | O | O | O | O | O | O
etcmenu.singlepage_fittoframe | O | O | O | O | O | O | O | O | O
etcmenu.singlepagecontinuous_fittowidth | O | O | O | O | O | O | O | O | O
etcmenu.textselecttool | O | O | O | O | O | X | X | X | X

O

Only e-Form


etcmenu.about

다른 메뉴에 [제품정보] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.addarrow

다른 메뉴에 [화살표 추가] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


etcmenu.addcircle

다른 메뉴에 [원 추가] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


etcmenu.addline

다른 메뉴에 [선 추가] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


etcmenu.addmemo

다른 메뉴에 [메모 추가] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


etcmenu.addrectangle

다른 메뉴에 [사각형 추가] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


etcmenu.close

다른 메뉴에 [닫기] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.closeall

다른 메뉴에 [모두 닫기] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.copyinputdata_json

다른 메뉴에 [입력 데이터 복사 (json)] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

[입력 데이터 복사 (json)] 메뉴를 클릭하면 현재 보고서의 입력 컴포넌트에 입력된 데이터를 JSON 형식의 문자열로 치환한 후 클립보드에 복사합니다.

단, Android 뷰어에서는 텍스트 편집이 가능한 APP을 선택할 수 있는 다이얼로그가 실행되고, 사용자가 선택한 APP으로 문자열이 전달됩니다.

e-Form 디자이너에서 미리보기한 경우에는 true로 적용됩니다.


etcmenu.copyinputdata_xml

다른 메뉴에 [입력 데이터 복사 (xml)] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

[입력 데이터 복사 (xml)] 메뉴를 클릭하면 현재 보고서의 입력 컴포넌트에 입력된 데이터를 XML 형식의 문자열로 치환한 후 클립보드에 복사합니다.

단, Android 뷰어에서는 텍스트 편집이 가능한 APP을 선택할 수 있는 다이얼로그가 실행되고, 사용자가 선택한 APP으로 문자열이 전달됩니다.

e-Form 디자이너에서 미리보기한 경우에는 true로 적용됩니다.


etcmenu.edittool

다른 메뉴에 [편집 모드] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.find

다른 메뉴에 [찾기] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함

Reference

Android/iOS/WinRT 뷰어에서는 "true"가 기본 값이고, 그 외 뷰어에서는 "false"가 기본 값입니다.


etcmenu.handtool

다른 메뉴에 [손 모드] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.help

다른 메뉴에 [도움말] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.inputparameter

다른 메뉴에 [패러미터 입력] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

패러미터가 없는 보고서에서는 [패러미터 입력] 메뉴가 비활성화됩니다.


etcmenu.inversepaper

다른 메뉴에 [용지 방향 전환] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

[용지 방향 전환] 메뉴를 클릭할 경우 체크 표시를 하여 토글 효과를 나타냅니다.


etcmenu.multiscreenguide

다른 메뉴에 [안내 모드] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

Reference

이 기능을 사용하려면 eform.usemultiscreen=true로 설정하시기 바랍니다.


etcmenu.open

다른 메뉴에 [열기] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.ozdhistory

다른 메뉴에 [저장 이력 보기] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

Reference

[저장 이력 보기] 메뉴는 입력 컴포넌트 변경 이력이 저장된 OZD인 경우에만 표시되고, 그 외 경우에는 etcmenu.ozdhistory 패러미터 값과 상관없이 항상 표시되지 않습니다.

iOS 뷰어에서는 8.0 이상에서만 [저장 이력 보기] 메뉴를 사용할 수 있습니다.

저장 이력 기능은 OZD 저장 시 입력 컴포넌트 변경 이력을 저장하고 저장된 이력을 조회할 수 있는 기능입니다.

해당 기능을 사용하려면 ozd.includeedithistory=true로 뷰어 패러미터를 설정하고 OZR을 바인딩한 후 입력 컴포넌트 값을 변경하고 보고서를 OZD 형식으로 저장합니다. 저장한 OZD 파일을 열면 [다른 메뉴]-[저장 이력 보기] 메뉴가 표시되고, [저장 이력 보기] 메뉴를 선택하면 저장 이력을 조회할 수 있습니다.

저장 이력 리스트는 아래와 같은 규칙으로 표시됩니다.

·OZD 파일로 저장한 날짜와 시간이 내림차순으로 정렬됩니다.

·OZD 파일로 저장 시 ozsystem.user_name, ozsystem.user_id 패러미터 값이 저장 이력의 날짜 아래에 "user_name (user_id)" 형태로 표시되고 ozsystem.user_id 패러미터 값만 설정한 경우 "user_id" 형태로 표시됩니다. 패러미터 값을 모두 설정하지 않은 경우 날짜와 시간만 표시됩니다.

항목별 상세 이력은 아래와 같은 규칙으로 표시됩니다.

·페이지 별로 그룹되어 표시됩니다.

·컴포넌트 명은 FormID가 있으면 FormID로, FormID가 없으면 컴포넌트 이름으로 표시됩니다. 또한, FormID 혹은 컴포넌트 이름이 중복된 경우에도 별도로 저장하여 표시됩니다.

·저장되는 컴포넌트와 표시 내용은 아래와 같습니다.

컴포넌트 | 표시 내용
CheckBox | 체크 여부를 표시하는 아이콘과 텍스트
RadioButtonGroup | RadioButtonGroup으로 그룹핑된 RadioButton 중 체크된 RadioButton의 텍스트
TextBox | 텍스트
SignPad | 서명 보기 아이콘 서명 보기 아이콘을 선택하면 팝업창이 실행되고 서명한 내용 확인 가능
ImagePicker | 이미지 보기 아이콘 이미지 보기 아이콘을 선택하면 팝업창이 실행되고 이미지 확인 가능
ComboBox | 선택된 아이템의 텍스트
NumericUpDown | 숫자 값
DateTimePicker | 날짜
VoiceRecorder | 녹음 듣기 아이콘 녹음 듣기 아이콘을 선택하면 플레이어가 실행되고 녹음한 내용 확인 가능


etcmenu.pagenavigator

다른 메뉴에 [페이지 네비게이터] 또는 [페이지 선택 창] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

Reference

Android/iOS/WinRT 뷰어에서는 [페이지 네비게이터] 메뉴가 표시되고, 그 외 뷰어에서는 [페이지 선택 창] 메뉴가 표시됩니다.


etcmenu.pagesetup

다른 메뉴에 [페이지 설정] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.parameter

다른 메뉴에 [조회 툴바] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

조회 툴바가 없는 보고서에서는 [조회 툴바] 메뉴가 비활성화됩니다.


etcmenu.print

다른 메뉴에 [인쇄] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함

Reference

Android/iOS/WinRT 뷰어에서는 "true"가 기본 값이고, 그 외 뷰어에서는 "false"가 기본 값입니다.


etcmenu.refresh

다른 메뉴에 [보고서 새로 고침] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.save

다른 메뉴에 [저장] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함

Reference

Android/iOS/WinRT 뷰어에서는 "true"가 기본 값이고, 그 외 뷰어에서는 "false"가 기본 값입니다.


etcmenu.savedm

다른 메뉴에 [데이터 저장] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


etcmenu.showthumbnail

다른 메뉴에 [페이지 축소판 보기] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.showtree

다른 메뉴에 [트리 보기] 메뉴 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


etcmenu.singlepage_fittoframe

다른 메뉴에 [화면 크기에 맞춰 한 페이지씩 보기] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


etcmenu.singlepagecontinuous_fittowidth

다른 메뉴에 [너비에 맞춰 한 페이지씩 연속 보기] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


etcmenu.textselecttool

다른 메뉴에 [텍스트 선택 모드] 메뉴 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

[텍스트 선택 모드] 메뉴는 다른 메뉴와 다르게 패러미터 값을 true로 설정하면 비활성화된 상태로 표시됩니다. 활성화 상태로 메뉴를 표시하려면 viewer.usetextselectmenu 패러미터 값도 true로 설정하여야 합니다.


excel

XLS 파일 저장 관련 상세 저장 옵션을 설정합니다.

Android/iOS 뷰어에서 XLS 파일 형식으로 저장하려면 아래와 같은 설정이 필요합니다.

[Android]

·Eclipse 프로젝트에 라이브러리 추가

libozrvpack_xlswriter.so

[iOS]

·Xcode 프로젝트에 라이브러리 추가

libozrvpack_xlswriter.a

·스크립트 추가

해당 기능을 사용하기 전에 __OZExportPack_load_excel2003() 함수 호출

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
excel.autofit | O | O | O | O | O | O | O | O | O
excel.autofitheight | O | O | O | O | O | O | O | O | O
excel.autofitwidth | O | O | O | O | O | O | O | O | O
excel.convertedimagedpi | O | O | O | O | O | O | O | O | O
excel.filename | O | O | O | O | O | O | O | O | X
excel.freezepanes_column | O | O | O | O | O | O | O | O | O
excel.freezepanes_row | O | O | O | O | O | O | O | O | O
excel.insert_horizontal_pagebreaks | O | O | O | O | O | O | O | O | O
excel.largebundle | O | O | O | O | O | X | O | O | O
excel.matchmode | O | O | O | O | O | O | O | O | O
excel.matchsubmode | O | O | O | O | O | O | O | O | O
excel.minimum_cellheight | O | O | O | O | O | O | O | O | O
excel.minimum_cellwidth | O | O | O | O | O | O | O | O | O
excel.numberformat | O | O | O | O | O | O | O | O | O
excel.path | O | O | X | O | X | X | O | O | X
excel.removeblank | O | O | O | O | O | O | O | O | O
excel.removeoption | O | O | O | O | O | O | O | O | O
excel.removerange | O | O | O | O | O | O | O | O | O
excel.removeranges | O | O | O | O | O | O | O | O | O
excel.savebyhtml | O | O | O | O | O | O | O | O | O
excel.savefont | O | O | O | O | X | X | O | O | O
excel.savefontsize | O | O | O | O | O | O | O | O | O
excel.savelinkurl | O | O | O | O | O | O | O | O | O
excel.savemode | O | O | O | O | O | O | O | O | O
excel.savenumbertype | O | O | O | O | O | O | O | O | O
excel.savetogeneral | O | O | O | O | O | O | O | O | O
excel.showgridlines | O | O | O | O | O | O | O | O | O
excel.shrinktofit | O | O | O | O | O | O | O | O | O
excel.use_default_color_palette | O | O | O | O | O | O | O | O | O
excel.zoom | O | O | O | O | O | O | O | O | O


excel.autofit

자동 맞춤 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


excel.autofitheight

자동 맞춤 옵션 중 높이를 설정합니다.

Reference

기본 값은 1입니다.

"excel.autofit=true"일 때만 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


excel.autofitwidth

자동 맞춤 옵션 중 너비를 설정합니다.

Reference

기본 값은 1입니다.

"excel.autofit=true"일 때만 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


excel.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


excel.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


excel.freezepanes_column

틀 고정할 열 이름을 설정합니다.

Reference

A~IV 사이의 값으로 설정합니다.


excel.freezepanes_row

틀 고정할 행 번호를 설정합니다.

Reference

1~32767 사이의 값으로 설정합니다.


excel.insert_horizontal_pagebreaks

매 페이지마다 가로 방향으로 페이지 나누기를 추가할지 여부를 설정합니다.

Value

true 페이지 나누기 추가

false 페이지 나누기 추가 안 함 (기본 값)

Reference

엑셀의 시트에 2페이지 이상 익스포트되고 "excel.removeblank=false"이고 "excel.savemode=keepform"인 경우에 적용됩니다.


excel.largebundle

XLS 파일로 저장 시 기본 옵션 다이얼로그의 한페이지로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

패러미터는 모든 포맷에 공통적으로 적용되는 한페이지로 저장 옵션을 다른 포맷과 상관없이 XLS에서만 별도로 동작하도록 설정하고자 할 때 사용하시기 바랍니다.

예를 들어, excel.largebundle=true, export.largebundle=false로 설정하면 XLS에서만 한페이지로 저장 옵션이 체크되고, 다른 포맷에서는 한페이지로 저장 옵션이 체크 해지됩니다.

반대의 상황도 마찬가지로 excel.largebundle=false, export.largebundle=true로 설정하면 XLS에서만 한페이지로 저장 옵션이 체크 해지되고, 다른 포맷에서는 한페이지로 저장 옵션이 체크됩니다.

또한, 사용자가 한페이지로 저장 옵션을 체크하거나 체크 해지한 경우에도 위 규칙이 그대로 적용됩니다.

여러 페이지의 보고서를 한 페이지로 저장할 때 보고서를 미리보기하지 않고 바로 저장할 경우에는 "viewer.largebundle=true"로 설정하시기 바랍니다.

See Also

기본 옵션 다이얼로그


excel.matchmode

저장 형태 옵션을 설정합니다.

Value

columnpersheet 페이지 열별 시트 저장 (기본 값)

pagepersheet 페이지별 시트 저장

Reference

columnpersheet로 설정하면 페이지 열마다 별도의 엑셀 시트에 저장되며, pagepersheet로 설정하면 각 페이지마다 별도의 엑셀 시트로 저장됩니다.

See Also

Excel 저장 옵션 다이얼로그


excel.matchsubmode

페이지별 시트 저장 옵션의 페이지 저장 순서를 설정합니다.

Value

columnfirst Column 우선

rowfirst Row 우선 (기본 값)

Reference

"excel.matchmode=pagepersheet"인 경우에 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


excel.minimum_cellheight

셀 최소 크기 옵션 중 높이를 설정합니다.

Reference

기본 값은 1입니다.

"excel.savemode=keepform"인 경우에 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


excel.minimum_cellwidth

셀 최소 크기 옵션 중 너비를 설정합니다.

Reference

기본 값은 1입니다.

"excel.savemode=keepform"인 경우에 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


excel.numberformat

숫자형 텍스트를 숫자로 변환 옵션을 체크하고, 변환되는 셀의 표시 형식을 설정합니다.

Reference

기본 값은 #,##0입니다.

서식을 삭제하려면 패러미터 값을 default로 설정하시기 바랍니다.

See Also

Excel 저장 옵션 다이얼로그


excel.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


excel.removeblank

페이지 사이 공백 제거 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


excel.removeoption

라인 제거 옵션 중 페이지 옵션을 설정합니다.

Value

firstpageexcept 첫 페이지 제외

firstpageonly 첫 페이지만

allpage 모든 페이지 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


excel.removerange

라인 제거 옵션을 체크하고, 제거할 라인 범위를 "시작라인,끝라인" 형태로 설정합니다.

Reference

excel.removeranges 패러미터보다 우선 순위가 낮습니다.

See Also

Excel 저장 옵션 다이얼로그


excel.removeranges

라인 제거 옵션을 체크하고, 제거할 라인 범위를 "시작라인-끝라인,라인,시작라인-끝라인" 형태로 설정합니다.

Reference

excel.removerange 패러미터보다 우선 순위가 높습니다.

See Also

Excel 저장 옵션 다이얼로그


excel.savebyhtml

mht 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


excel.savefont

글꼴 옵션을 설정합니다.

See Also

Excel 저장 옵션 다이얼로그


excel.savefontsize

글꼴 크기 옵션을 설정합니다.

See Also

Excel 저장 옵션 다이얼로그


excel.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


excel.savemode

저장 방식 옵션을 설정합니다.

Value

keepform 폼 형태, 속성 유지 (기본 값)

ignoreprops 색상, 외곽라인, 셀합치기 무시

ignoreblank 분할 후 주변 셀 제거

See Also

Excel 저장 옵션 다이얼로그


excel.savenumbertype

표시 형식이 숫자인 라벨만 적용 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


excel.savetogeneral

일반(셀표시 형식)으로 변환 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

excel.numberformat 패러미터보다 우선 순위가 높습니다.

See Also

Excel 저장 옵션 다이얼로그


excel.showgridlines

눈금선 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

Excel 저장 옵션 다이얼로그


excel.shrinktofit

셀에 맞춤 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


excel.use_default_color_palette

보고서를 엑셀로 저장할 때 엑셀의 팔레트 색 구성표를 변경하지 않고 그대로 사용할지 여부를 설정합니다.

Value

true 사용 (기본 값)

false 사용 안 함

Reference

패러미터를 false로 설정하면 보고서에서 사용한 라벨의 글꼴 색, 바탕 색, 테두리 색으로 엑셀의 팔레트 기본 색을 변경합니다.

엑셀의 팔레트 색은 기본적으로 56가지 색으로, 검정과 흰색을 제외한 54가지의 색까지 오즈 뷰어에서 설정할 수 있습니다. 팔레트 색은 컴포넌트 트리에 추가된 순서대로 라벨의 글꼴 색, 바탕 색, 왼쪽 테두리 색, 위쪽 테두리 색, 아래쪽 테두리 색, 오른쪽 테두리 색 순으로 최대 54가지의 색이 설정되고 나머지 색은 무시됩니다.

만일 54가지의 색이 채워지지 않은 상태에서 보고서에 메모가 추가된 경우 메모에서 사용한 색이 라벨의 색 적용 순서와 동일하게 설정됩니다. 이때 메모의 색 순서는 첫 페이지부터 적용되고 같은 페이지 내에서는 먼저 추가한 메모에서 사용한 색부터 설정됩니다.

보고서를 엑셀로 저장할 때 라벨의 색을 화면에 보이는 그대로 저장하려면 이 패러미터와 excel.savebyhtml 패러미터 값을 false로 설정하시기 바랍니다.

excel.savebyhtml 패러미터 값이 true인 경우 패러미터는 항상 true로 동작합니다.


excel.zoom

XLS 파일을 열 때 확대/축소 배율을 설정합니다.

Reference

기본 값은 100이며, 10~400 사이의 값으로 설정합니다.


export

보고서를 파일로 저장하는 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
export.applyformat | O | O | O | O | O | O | O | O | O
export.confirmsave | O | O | X | O | X | X | X | O | X
export.displaynames | O | O | O | O | O | O | O | O | O
export.displaytargets | X | X | X | X | X | X | O | O | O
export.enablegul_ignorelocale | O | X | X | X | X | X | X | X | X
export.enablehwp_ignorelocale | O | O | O | O | O | O | O | O | O
export.executefile | O | O | X | O | X | X | O | O | O
export.exportbypage | O | O | O | O | O | O | O | O | O
export.externalmodule | O | X | X | X | X | X | X | X | X
export.filename | O | O | O | O | O | O | O | O | X
export.format | O | O | O | O | O | O | O | O | O
export.hidecontrols | O | O | O | O | O | O | O | O | O
export.largebundle | O | O | O | O | O | X | O | O | O
export.lockcontrols | O | O | O | O | O | O | O | O | O
export.mode | O | O | X | O | O | O | O | O | O
export.pagerange | O | O | O | O | O | O | O | O | O
export.pages | O | O | O | O | O | O | O | O | O
export.path | O | O | X | O | X | X | O | O | X
export.savearrow | O | O | O | O | O | O | O | O | O
export.savebarcode | O | O | O | O | O | O | O | O | O
export.savechart | O | O | O | O | O | O | O | O | O
export.savecircle | O | O | O | O | O | O | O | O | O
export.savedatamatrixbarcode | O | O | O | O | O | O | O | O | O
export.savehtml | O | O | O | O | O | O | O | O | O
export.saveimage | O | O | O | O | O | O | O | O | O
export.savelabel | O | O | O | O | O | O | O | O | O
export.saveline | O | O | O | O | O | O | O | O | O
export.savemultidoc | O | O | O | O | O | O | O | O | O
export.saveonefile | O | O | O | O | O | O | O | O | O
export.savepdf417 | O | O | O | O | O | O | O | O | O
export.saveqrbarcode | O | O | O | O | O | O | O | O | O
export.saverect | O | O | O | O | O | O | O | O | O
export.showoverwritemessage | O | O | X | O | X | X | O | O | O
export.silentexecute | O | O | X | O | X | X | O | O | O
export.target | O | O | X | O | X | X | O | O | O
export.uac | O | X | X | X | X | X | X | X | X
export.usedialogopt | O | O | O | O | O | O | O | O | O
export.useprogressbar | O | O | X | O | X | X | O | O | O
export.zip | O | O | O | O | O | O | O | O | X
export.zipfilename | O | O | O | O | O | O | O | O | X
export.zipfilename_postfix | O | O | O | O | O | O | O | O | X
export.zipfilename_prefix | O | O | O | O | O | O | O | O | X
export.zippassword | O | O | O | O | O | O | O | O | X
export.zippath | O | O | X | O | X | X | O | X | X


export.applyformat

저장 다이얼로그의 파일 형식 리스트에 표시할 파일 형식을 설정합니다.

Value

csv Comma Separated Values File(*.csv)로 설정

doc Microsoft Word Document(*.doc)로 설정

gif GIF Image(*.gif)로 설정

gul Jungum Global File(*.gul)로 설정

han97 Hangul97 File(*.hml)로 설정

html Web Page(*.html)로 설정

hwp Hangul File(*.hwp)로 설정

jpg JPEG Image(*.jpg)로 설정

mht Web Page Save File(*.mht)로 설정

nxl Haansoft Nexcel File(*.nxl)로 설정

ozd OZ Report Data File(*.ozd)로 설정

pdf Adobe PDF File(*.pdf)로 설정

png PNG Image(*.png)로 설정

ppt Microsoft Presentation(*.ppt)로 설정

svg Scalable Vector Graphics(*.svg)로 설정

tif TIFF Image(*.tif)로 설정

txt Tab Separated(*.txt)로 설정

xls Microsoft Excel 97-2003 File(*.xls)로 설정

xlsx Microsoft Excel File(*.xlsx)로 설정

Reference

파일 형식을 여러 개로 설정할 경우 콤마(,)를 구분자로하여 값을 나열합니다.

export.displaynames 패러미터보다 우선 순위가 낮습니다.

뷰어 언어가 한국어 또는 영어가 아닌 경우에는 export.applyformat=gul,hwp,han97로 설정하여도 파일 형식 리스트에 Jungum Global File(*.gul), Hangul File(*.hwp), Hangul97 File(*.hml) 형식이 표시되지 않습니다. 뷰어 언어와 상관없이 Jungum Global File(*.gul), Hangul File(*.hwp), Hangul97 File(*.hml) 형식을 항상 표시하려면 export.enablegul_ignorelocale, export.enablehwp_ignorelocale 패러미터 값을 true로 설정하시기 바랍니다.

See Also

저장 다이얼로그


export.confirmsave

저장 다이얼로그를 표시하지 않고 바로 보고서를 저장(export.mode=silent)할 경우 저장 경로를 표시하는 저장 경로 확인창의 표시 여부를 설정합니다.

Value

true 저장 경로 확인창 표시 (기본 값)

false 저장 경로 확인창 표시 안 함

See Also

저장 다이얼로그


export.displaynames

저장 다이얼로그의 파일 형식 리스트에 표시할 파일 형식을 리포트 뷰어에서 제공하는 기본 값이 아닌 다른 값으로 설정합니다.

Reference

[확장자,형식][확장자,형식]... 형태로 설정합니다.

설정 가능한 확장자는 ozd, pdf, xls, xlsx, doc, ppt, html, csv, txt, jpg, png, gif, tif, svg, hwp, han97, mht, gul, nxl입니다.

형식에 설정한 내용이 파일 형식 리스트에 표시되며, 형식에는 콤마(,)와 대괄호([, ])를 제외하고 설정하시기 바랍니다.

export.applyformat 패러미터보다 우선 순위가 높습니다.

See Also

저장 다이얼로그


export.displaytargets

저장 다이얼로그의 출력 방향에 표시되는 리스트의 표시 여부 및 순서를 변경하거나 사용자가 정의한 출력 방향을 추가합니다.

Reference

출력 방향에 표시할 리스트를 콤마(,)를 구분자로하여 값을 나열합니다.

기본 출력 방향인 disk, email, ozmail, share는 뷰어 언어에 따라 표시되고, 사용자가 정의한 출력 방향은 모든 언어에서 동일한 텍스트로 표시됩니다.

사용자가 정의한 출력 방향으로 보고서를 저장할 경우에는 export.executefile, export.savemultidoc 패러미터는 false로 동작합니다.


export.enablegul_ignorelocale

Jungum Global File(*.gul) 형식을 저장 창의 파일 형식 리스트에 표시할지 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

뷰어 언어가 한국어 또는 영어인 경우 항상 true로 적용됩니다.


export.enablehwp_ignorelocale

Hangul File(*.hwp), Hangul97 File(*.hml) 형식을 저장 창의 파일 형식 리스트에 표시할지 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

뷰어 언어가 한국어 또는 영어인 경우 항상 true로 적용됩니다.


export.executefile

기본 옵션 다이얼로그의 저장 후 바로 실행 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

기본 옵션 다이얼로그


export.exportbypage

기본 옵션 다이얼로그의 페이지별로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

"viewer.largebundle=true"인 경우에 적용됩니다.


export.externalmodule

암호화 등 외부 모듈과 연동할 때 보고서를 저장할 때 사용할 dll 파일 이름을 설정합니다.


export.filename

저장 다이얼로그의 저장 경로 옵션에 표시할 파일 이름을 설정합니다.

See Also

저장 다이얼로그


export.format

저장 다이얼로그가 실행될 때 파일 형식 리스트 중 선택할 파일 형식을 설정합니다.

Value

csv 파일 형식을 Comma Separated Values File(*.csv)로 선택

doc 파일 형식을 Microsoft Word Document(*.doc)로 선택

eform_xml 파일 형식을 eform_xml로 설정

gif 파일 형식을 GIF Image(*.gif)로 선택

gul 파일 형식을 Jungum Global File(*.gul)로 선택

han97 파일 형식을 Hangul97 File(*.hml)로 선택

html 파일 형식을 Web Page(*.html)로 선택

hwp 파일 형식을 Hangul File(*.hwp)로 선택

jpg 파일 형식을 JPEG Image(*.jpg)로 선택

mht 파일 형식을 Web Page Save File(*.mht)로 선택

nxl 파일 형식을 Haansoft Nexcel File(*.nxl)로 선택

ozd 파일 형식을 OZ Report Data File(*.ozd)로 선택

pdf 파일 형식을 Adobe PDF File(*.pdf)로 선택

png 파일 형식을 PNG Image(*.png)로 선택

ppt 파일 형식을 Microsoft Presentation(*.ppt)로 선택

svg 파일 형식을 Scalable Vector Graphics(*.svg)로 선택

tif 파일 형식을 TIFF Image(*.tif)로 선택

txt 파일 형식을 Tab Separated(*.txt)로 선택

xls 파일 형식을 Microsoft Excel 97-2003 File(*.xls)로 선택

xlsx 파일 형식을 Microsoft Excel File(*.xlsx)로 선택

Reference

보고서를 화면에 미리보기하지 않고 바로 저장(viewer.mode=export)할 때 파일 형식을 여러 개로 설정할 경우 콤마(,)를 구분자로하여 값을 나열합니다. 이때 화면에 저장 다이얼로그가 실행되지 않도록 export.mode=silent로 설정하여야 하며, 저장할 파일 경로(export.path)와 파일 이름(export.filename)도 함께 설정하여야 합니다.

eform_xml 파일 형식은 export.mode=silent로 설정한 경우에만 사용할 수 있으며, eform_xml.path, eform_xml.filename 패러미터 값을 함께 설정하시기 바랍니다.

Haansoft Nexcel File(*.nxl) 파일 형식은 기본적으로 표시되지 않는 형식이므로, export.applyformat 패러미터를 이용하여 파일 형식 리스트에 표시되도록 설정한 경우에만 적용됩니다.

See Also

저장 다이얼로그


export.hidecontrols

저장 다이얼로그의 출력 방향, 저장 경로, 옵션 버튼을 숨길지 여부를 설정합니다.

Value

true 출력 방향, 저장 경로, 찾기 버튼, 옵션 버튼 숨김

false 모든 옵션 표시 (기본 값)

option 옵션 버튼 숨김

See Also

export.lockcontrols


export.largebundle

기본 옵션 다이얼로그의 한페이지로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

여러 페이지의 보고서를 한 페이지로 저장할 때 보고서를 미리보기하지 않고 바로 저장할 경우에는 "viewer.largebundle=true"로 설정하시기 바랍니다.

See Also

기본 옵션 다이얼로그


export.lockcontrols

저장 다이얼로그의 파일 형식, 출력 방향, 저장 경로, [찾기] 버튼, [옵션] 버튼의 비활성화 여부를 설정합니다.

Value

true 출력 방향, 저장 경로, [찾기] 버튼, [옵션] 버튼 비활성화

false 모든 옵션 활성화 (기본 값)

format 파일 형식 비활성화

direction 출력 방향 비활성화

path 저장 경로, [찾기] 버튼 비활성화

option [옵션] 버튼 비활성화

Reference

패러미터 값은 ","를 이용하여 중복하여 설정할 수 있습니다. 예를 들어, 출력 방향과 [옵션] 버튼만 비활성화하려면 "direction,option"으로 설정하시기 바랍니다.

See Also

저장 다이얼로그


export.mode

저장 다이얼로그의 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

See Also

저장 다이얼로그


export.pagerange

기본 옵션 다이얼로그의 저장 영역 옵션을 설정합니다.

Value

all 전체 페이지 (기본 값)

current 현재 페이지

range 페이지 지정

selected 선택된 페이지

See Also

기본 옵션 다이얼로그


export.pages

저장할 페이지 범위를 "시작 페이지-끝 페이지,페이지 번호,시작 페이지-끝 페이지" 형태로 설정합니다.

Reference

"export.pagerange=range"로 설정하여야 적용됩니다.

See Also

기본 옵션 다이얼로그


export.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


export.savearrow

저장할 컴포넌트 중 화살표 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.savebarcode

저장할 컴포넌트 중 바코드 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.savechart

저장할 컴포넌트 중 차트 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.savecircle

저장할 컴포넌트 중 원 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.savedatamatrixbarcode

저장할 컴포넌트 중 DataMatrix 바코드 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.savehtml

저장할 컴포넌트 중 HTML 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.saveimage

저장할 컴포넌트 중 이미지 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.savelabel

저장할 컴포넌트 중 라벨 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.saveline

저장할 컴포넌트 중 선 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.savemultidoc

기본 옵션 다이얼로그의 모든 문서 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

각각의 파일로 저장하고자 할 경우에는 저장할 파일의 경로(export.path)와 파일명(export.filename)를 각각의 보고서마다 설정하여야하며, 파일명을 설정하지 않았을 경우에는 트리에 표시되는 이름으로 파일명이 설정됩니다.

See Also

기본 옵션 다이얼로그


export.saveonefile

기본 옵션 다이얼로그의 한파일로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

기본 옵션 다이얼로그


export.savepdf417

저장할 컴포넌트 중 PDF417 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.saveqrbarcode

저장할 컴포넌트 중 QR 바코드 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.saverect

저장할 컴포넌트 중 사각형 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


export.showoverwritemessage

저장할 파일 이름이 중복된 경우 덮어쓰기 확인 창의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


export.silentexecute

파일 익스포트 시 임시 파일로 만들어 바로 실행할지, 저장 다이얼로그를 표시할지 여부를 설정합니다.

Value

true 임시 파일 생성 후 바로 실행

false 저장 다이얼로그 표시 (기본 값)

Reference

export.silentexecute 패러미터는 툴바에서 PDF 저장, XLS 저장 등 파일 포맷이 지정된 저장 아이콘을 클릭한 경우에만 동작합니다.


export.target

저장 다이얼로그의 출력 방향 옵션을 설정합니다.

Value

disk Disk File로 설정 (기본 값)

email 메일로 설정

ozmail 오즈 메일로 설정

share 공유로 설정

Reference

Applet 뷰어는 오즈 메일만 지원합니다.

저장 다이얼로그를 표시하지 않고 바로 메일 전송할 경우 파일 경로, 파일 이름, 파일 형식을 설정하는 뷰어 패러미터 export.path, export.filename, export.format 값을 반드시 설정하여야 합니다.

출력 방향 중 share는 Android, iOS, WinRT 뷰어에서만 지원합니다. 단, iOS는 8.0 버전 이상에서만 공유 앱 선택 창이 표시되며, 그 이하 버전에서는 에러 메시지가 발생합니다.

See Also

저장 다이얼로그


export.uac

비스타 이상 윈도우에서 보고서를 저장할 때 권한 상승 기능 사용 여부를 설정합니다.

Value

true 권한 상승 기능 사용

false 권한 상승 기능 사용 안 함 (기본 값)

Reference

비스타 이상 윈도우에서 로그인한 사용자 권한과 상관없이 원하는 경로에 보고서를 저장하려면 패러미터 값을 true로 설정하시기 바랍니다.

비스타 이상 윈도우이고, 로그인한 사용자가 일반 사용자 또는 관리자 권한을 가진 사용자인 경우 패러미터 값을 true로 설정하면 저장 창에서 [찾기] 버튼을 클릭하거나 저장 경로를 직접 입력한 후 [확인] 버튼을 클릭하면 윈도우에서 제공하는 권한 상승 창이 실행됩니다.

사용자가 권한 상승을 한 경우 뷰어가 종료되기 전에는 해당 정보를 저장하므로, 그 다음 저장 시에는 권한 상승 창이 실행되지 않습니다.


export.usedialogopt

현재 표시된 보고서의 저장 다이얼로그에서 변경한 저장 옵션을 다른 보고서에도 적용할지 여부를 설정합니다.

Value

true 설정한 옵션을 다른 보고서에도 적용

false 선택된 보고서에만 적용 (기본 값)

Reference

"export.saveonefile=true"일 경우에만 적용됩니다.


export.useprogressbar

보고서 저장 시 프로그래스바의 표시 여부를 설정합니다.

Value

default 미리보기 화면에서 저장한 경우 프로그레스 바가 표시되고, 그 외의 경우 프로그레스 바가 표시되지 않음 (기본 값)

true 저장 시 프로그레스 바를 항상 표시

false 저장 시 프로그레스 바를 항상 표시 안 함


export.zip

기본 옵션 다이얼로그의 압축 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

보고서를 여러 개의 포맷으로 한꺼번에 압축하여 저장할 경우 OZD 포맷은 제외하고 설정하시기 바랍니다. OZD 포맷 포함 시 에러가 발생합니다.

압축 옵션을 체크한 경우 html.imagepath 패러미터는 동작하지 않습니다.

See Also

기본 옵션 다이얼로그


export.zipfilename

압축 파일의 파일 이름을 설정합니다.

Reference

"export.zip=true"인 경우에 적용됩니다.

See Also

저장 다이얼로그


export.zipfilename_postfix

압축 파일의 파일 이름 뒤에 추가할 접미사를 설정합니다.

Reference

"export.zip=true"인 경우에 적용됩니다.

저장 다이얼로그에는 표시되지 않고, 저장된 파일 이름에 추가됩니다.


export.zipfilename_prefix

압축 파일의 파일 이름 앞에 추가할 접두사를 설정합니다.

Reference

"export.zip=true"인 경우에 적용됩니다.

저장 다이얼로그에는 표시되지 않고, 저장된 파일 이름에 추가됩니다.


export.zippassword

기본 옵션 다이얼로그의 압축 암호 옵션을 설정합니다.

Reference

"export.zip=true"인 경우에 적용됩니다.

See Also

기본 옵션 다이얼로그


export.zippath

압축 파일의 저장 경로를 설정합니다.

Reference

"export.zip=true"인 경우에 적용됩니다.

See Also

저장 다이얼로그


find

찾기 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
find.what | O | O | O | O | O | X | O | O | O
find.direction | O | O | O | O | O | X | O | O | O
find.matchwholeword | O | O | O | O | O | X | O | O | O
find.matchcase | O | O | O | O | O | X | O | O | O


find.what

찾을 내용 옵션을 설정합니다.


find.direction

방향 옵션을 설정합니다.

Value

down 아래로 (기본 값)

up 위로


find.matchwholeword

단어 단위로 옵션을 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)


find.matchcase

대/소문자 구분 옵션을 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)


font

폰트를 설정합니다.

font 패러미터는 보고서 디자인 시 설정한 폰트가 사용자 운영 환경에 따라 지원되지 않는 경우가 있을 때 해당 폰트를 다른 폰트로 변경하는 용도로 사용합니다.

예를 들어, "바른돋움 1"과 "나눔고딕"을 사용하여 라벨을 디자인한 경우 해당 폰트가 없는 사용자는 "돋움"과 웹 폰트(NanumGothic.eot)로 변경시키려면 아래와 같은 형태로 설정합니다. (ex. ActiveX Viewer)

<param name = "font.fontnames" value="font1,font2">

<param name = "font.font1.name" value="바른돋움 1">

<param name = "font.font1.alternativefont" value="돋움">

<param name = "font.font2.name" value="나눔고딕">

<param name = "font.font2.url" value="http://127.0.0.1:8080/webfont/NanumGothic.eot">

Android/iOS 뷰어에서 font 패러미터를 사용하려면 Eclipse/Xcode 프로젝트에 폰트를 포함시켜야 합니다. 폰트 포함 방법은 뷰어 설치와 실행 부분을 참고하세요.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
font.fontname.allowedurl | O | X | X | X | X | X | X | X | X
font.fontname.alternativefont | O | X | O | X | O | O | O | O | X
font.fontname.name | O | X | O | X | O | O | O | O | X
font.fontname.replacefont | O | X | O | X | O | O | O | O | X
font.fontname.url | O | X | X | X | X | X | O | O | X
font.fontnames | O | X | O | X | O | O | O | O | X

See Also

폰트 포함(Android), 폰트 포함(iOS)


font.fontname.allowedurl

웹 폰트 경로 접속이 허용된 도메인 URL을 설정합니다.

Reference

font.fontname.url 패러미터에 설정된 웹 폰트 경로를 접속할 때 특정 도메인에서만 접속 가능하도록 설정된 경우 패러미터에 해당 URL을 설정하시기 바랍니다.

단, 패러미터 값이 font.fontname.url 패러미터 값과 동일한 경우에는 생략 가능합니다.


font.fontname.alternativefont

대체 폰트 이름을 설정합니다.

Reference

보고서 디자인 시 설정한 폰트가 사용자 운영 환경에 따라 지원되지 않는 경우가 있을 때 해당 폰트에 적용시킬 폰트 이름을 설정합니다.

font.fontname.url 패러미터보다 우선 순위가 낮습니다.

잘못된 값을 설정한 경우 사용자 운영 환경의 기본 글꼴로 적용됩니다.

See Also

font


font.fontname.name

다른 폰트로 변경할 폰트 이름을 설정합니다.

Reference

보고서 디자인 시 설정한 폰트가 사용자 운영 환경에 따라 지원되지 않는 경우가 있을 때 웹 폰트 또는 대체 폰트로 변경할 폰트 이름을 설정합니다.

패러미터 값은 보고서 디자인 시 컴포넌트에 설정한 폰트 이름을 설정하시기 바랍니다.

See Also

font


font.fontname.replacefont

교체할 폰트 이름을 설정합니다.

Reference

설정한 폰트가 사용자 운영 환경에 없는 경우 font.fontname.url 패러미터가 적용되고, 웹 폰트 다운로드를 실패한 경우 font.fontname.alternativefont 패러미터가 적용됩니다.

See Also

font


font.fontname.url

웹 폰트 URL을 설정합니다.

Reference

보고서 디자인 시 설정한 폰트가 사용자 운영 환경에 따라 지원되지 않는 경우가 있을 때 해당 폰트에 적용시킬 웹 폰트 URL을 설정합니다.

font.fontname.alternativefont 패러미터보다 우선 순위가 높습니다. 단, 웹 폰트 다운로드를 실패한 경우 font.fontname.alternativefont 패러미터 값이 적용됩니다.

잘못된 URL을 설정한 경우 사용자 운영 환경의 기본 글꼴로 적용됩니다.

See Also

font


font.fontnames

font 패러미터 설정 시 사용할 폰트 이름을 설정합니다.

Reference

웹 폰트 URL, 대체 폰트 등 font 관련 패러미터를 설정할 때 폰트를 구분할 앨리어스를 설정합니다.

여러 개 설정할 경우 콤마(",")를 구분자로하여 설정합니다.

See Also

font


gif

GIF 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
gif.filename | O | O | O | O | O | O | X | X | X
gif.path | O | O | X | O | X | X | X | X | X
gif.savecomment | O | O | O | O | O | X | X | X | X
gif.zoom | O | O | O | O | O | O | X | X | X

O

Only e-Form


gif.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


gif.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


gif.savecomment

GIF 파일로 저장할 때 주석을 포함하여 저장할지 여부를 설정합니다.

Value

true 주석 포함하여 저장

false 주석 저장 안 함 (기본 값)


gif.zoom

확대/축소 비율 옵션을 설정합니다.

Reference

기본 값은 100이며, 10~1000 사이의 값으로 설정합니다.

See Also

GIF 저장 옵션 다이얼로그


global

언어와 다중 보고서 관련 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
global.address_updatetype | X | X | X | X | X | X | O | O | O
global.concatpage | O | O | O | O | O | O | O | O | O
global.concatthumbnail | O | O | O | O | O | X | O | O | X
global.continuouspagenumber_at_concatthumbnail | O | O | O | O | O | X | O | O | X
global.eachpagenumberatconcatpage | O | O | O | O | O | O | O | O | O
global.inheritparameter | O | O | O | O | O | O | O | O | O
global.language | O | O | O | O | O | O | O | O | O
global.pagesetup_unit | O | O | O | O | O | X | O | O | O
global.processorid | O | O | O | O | O | O | O | O | O
global.resourcefile | O | O | O | O | O | O | O | O | X
global.reusedatamoduletype | O | O | O | O | O | O | O | O | O
global.showerroronce | O | O | O | O | O | X | O | O | O
global.stopchildwhenerror | O | O | O | O | O | X | O | O | O
global.timezone | O | O | O | O | O | O | O | O | O
global.use_preview_progressbar | O | O | O | O | O | O | O | O | O
global.useeachprintopt_at_concatpage | O | O | O | O | O | O | O | O | X


global.address_updatetype

위치 정보 업데이트 타입을 설정합니다.

Value

none 위치 정보 업데이트 안 함 (기본 값)

once 위치 정보를 한 번만 업데이트

tracking 위치 정보를 한 번만 업데이트

Reference

패러미터 값을 "once"로 설정하면 보고서의 OnLocationUpdated 이벤트가 한 번 호출되고, 위치 정보 업데이트가 중지됩니다.

패러미터 값을 "tracking"으로 설정하면 위치 정보가 변경될 때마다 보고서의 OnLocationUpdated 이벤트가 호출됩니다. 단, "tracking" 상태에서 보고서를 저장하거나 인쇄하면 위치 정보 업데이트가 자동으로 중지됩니다.


global.concatpage

멀티 보고서를 하나의 보고서처럼 사용할지 여부를 설정합니다.

Value

true 하나의 보고서처럼 사용

false 각각의 보고서로 사용 (기본 값)

Reference

"true"로 설정할 경우 툴바의 페이지 이동 또는 페이지 선택창에서 페이지 이동이 모두 하나의 보고서처럼 적용되며, 인쇄 및 저장 시에도 동일하게 적용됩니다.

보고서별로 용지 정보를 유지하여 저장하려면 xls로 저장 시에는 "페이지별 시트 저장"과 "mht 형식으로 저장" 옵션을 체크하여야 하며, doc로 저장 시에는 "XML 형식으로 저장" 옵션을 체크하여야 합니다.

ppt로 저장할 경우 첫 번째 보고서의 용지 정보가 다른 보고서에도 적용되어 저장됩니다.

See Also

Excel 저장 옵션 다이얼로그, Word 저장 옵션 다이얼로그


global.concatthumbnail

페이지 축소판 창에 모든 보고서를 표시할지 여부를 설정합니다.

Value

true 페이지 축소판 창에 모든 보고서를 표시

false 페이지 축소판 창에 현재 선택된 보고서만 표시 (기본 값)

Reference

패러미터 값을 true로 설정하면 뷰어 창에 열린 모든 보고서의 페이지 축소판 이미지가 표시되고, 페이지 번호는 보고서별로 설정됩니다.


global.continuouspagenumber_at_concatthumbnail

페이지 축소판 창에 표시되는 페이지 번호를 이전 보고서와 이어서 표시할지 여부를 설정합니다.

Value

true 페이지 축소판 창에 표시되는 페이지 번호를 이전 보고서와 이어서 표시

false 페이지 축소판 창에 표시되는 페이지 번호를 보고서별로 표시 (기본 값)

Reference

"global.concatthumbnail=true"인 경우에 적용됩니다.


global.eachpagenumberatconcatpage

멀티 보고서를 하나의 보고서처럼 설정한 경우 각각의 보고서별로 페이지 번호를 부여할지 여부를 설정합니다.

Value

true 각각의 보고서별로 페이지 번호 부여

false 모든 보고서의 전체 페이지를 기준으로 페이지 번호 부여 (기본 값)

Reference

"global.concatpage=true"인 경우에 적용됩니다.


global.inheritparameter

다중 보고서 호출 시 부모 보고서의 패러미터 값을 자식 보고서가 상속받을지 여부를 설정합니다.

Value

true 부모 보고서의 패러미터 값을 상속 받음

false 부모 보고서의 패러미터 값을 상속 받지 않음 (기본 값)

Reference

자식 보고서의 인쇄, 저장 등의 옵션 값을 부모 보고서와 동일하게 설정할 경우 값을 global.inheritparameter 패러미터 값을 "true"로 설정하시기 바랍니다.


global.language

오즈 뷰어의 언어를 "언어명_국가명" 형태로 설정합니다.

Reference

값을 설정하지 않으면 기본 값으로 시스템 언어에 맞게 설정됩니다.

각 나라별 언어명과 국가명을 설정하려면 "언어 코드와 국가 코드표"를 참고하시기 바랍니다.


global.pagesetup_unit

페이지 설정 다이얼로그의 사용 단위계를 설정합니다.

Value

pt 포인트

inch 인치

cm 센티미터 (기본 값)


global.processorid

오즈 서버 로그에 기록할 프로세스 ID를 설정합니다.

Reference

기본 값은 공백입니다.

설정한 값은 서버 로그 중 아래 위치에 표시됩니다.

2017-09-22 09:17:44,733 [http-bio-8080-exec-7] DEBUG FrameworkRequestDataModule  - [processorid] Function Type [132 : GET_DATAMODULE]

해당 패러미터는 여러 개의 뷰어가 하나의 오즈 서버로 연결된 경우 오즈 서버 로그를 기록할 때 뷰어의 프로세스 ID를 구분하는 용도로 사용하시기 바랍니다.


global.resourcefile

프로그레스바의 타이틀과 메시지를 정의한 xml 파일의 경로를 설정합니다.

Reference

xml 파일은 UTF-8 인코딩 방식으로 작성하여야 하며 오즈 뷰어에서는 프로그레스바의 타이틀과 코멘트를 설정할 수 있습니다.

·바인딩 프로그레스바의 창 제목과 상단 메시지 설정

<?xml version="1.0" encoding="UTF-8"?>

<VIEWERSTRINGRESOURCE VERSION="1.0">

<TYPE id="PROGRESSBAR_OZ">오즈 뷰어</TYPE>

<TYPE id="PROGRESSBAR_TITLE">보고서를 바인딩합니다.</TYPE>

</VIEWERSTRINGRESOURCE>

·저장 프로그레스바의 상단 메시지와 하단 메시지 설정

<?xml version="1.0" encoding="UTF-8"?>

<VIEWERSTRINGRESOURCE VERSION="1.0">

<TYPE id="EXPORT_PROGRESSBAR_TITLE">보고서를 저장합니다.</TYPE>

<TYPE id="EXPORT_PROGRESSBAR_MESSAGE">저장 중...</TYPE>

</VIEWERSTRINGRESOURCE>

·인쇄 프로그레스바의 상단 메시지와 하단 메시지 설정

<?xml version="1.0" encoding="UTF-8"?>

<VIEWERSTRINGRESOURCE VERSION="1.0">

<TYPE id="PRINT_PROGRESSBAR_TITLE">보고서를 인쇄합니다.</TYPE>

<TYPE id="PRINT_PROGRESSBAR_MESSAGE">인쇄 중...</TYPE>

</VIEWERSTRINGRESOURCE>

뷰어 타입별로 지원하는 Key는 아래와 같습니다.

Viewer Type | Key | Resource File Path
ActiveX, Applet, WPF | PROGRESSBAR_TITLE, PROGRESSBAR_OZ, EXPORT_PROGRESSBAR_TITLE, EXPORT_PROGRESSBAR_MESSAGE, PRINT_PROGRESSBAR_TITLE, PRINT_PROGRESSBAR_MESSAGE | 오즈 리파지토리 경로(ozp://), 웹 서버 경로(http://), 로컬 경로(file://)
Flash, HTML5 | PROGRESSBAR_TITLE, PROGRESSBAR_OZ | 뷰어의 res 폴더에 xml 파일을 위치시킨 후 패러미터 값에는 파일 이름만 설정
Android | EXPORT_PROGRESSBAR_MESSAGE | 프로젝트의 assets 폴더에 xml 파일을 위치시킨 후 패러미터 값에는 res://파일 이름 형태로 설정
iOS | PROGRESSBAR_TITLE, EXPORT_PROGRESSBAR_MESSAGE | 프로젝트 폴더에 xml 파일을 위치시킨 후 패러미터 값에는 res://파일 이름 형태로 설정


global.reusedatamoduletype

보고서 바인딩 시 재사용할 데이터 타입을 설정합니다.

Value

none 데이터 재사용 안 함 (기본 값)

odi ODI 데이터 재사용

Reference

데이터 재사용 기능을 사용하면 클라이언트에 캐시된 동일한 데이터가 있을 경우 서버로 데이터를 요청하지 않고 캐시된 데이터를 재사용하므로, 데이터 바인딩 시간 및 서버 부하를 줄일 수 있습니다.

global.reusedatamoduletype 패러미터 값을 odi로 설정한 경우 아래 조건을 모두 만족하는 경우에만 ODI 데이터가 재사용됩니다.

1)ODI 주소, 카테고리, 파일 이름이 모두 동일한 경우

2)ODI에 추가된 사용자 지정 패러미터 값이 모두 동일한 경우

3)리포트 디자이너에서 설정한 데이터셋의 최대 행 수와 사용 속성 값이 모두 동일한 경우

4)뷰어가 재실행되지 않은 경우

5)보고서의 데이터가 새로 고침되지 않은 경우

웹 페이지를 새로 고침하여 뷰어를 재실행하거나 보고서 새로 고침 다이얼로그, 조회 툴바, ReBind 함수로 데이터를 새로 고침한 경우 데이터 재사용 기능이 동작하지 않습니다.

단, 멀티 보고서 환경에서 뷰어를 재실행하거나 하나의 OZR에 동일한 ODI가 2개 이상 추가된 경우 데이터 요청은 한번만 실행하고, 그 이후 데이터는 재사용합니다.


global.showerroronce

다중 보고서 바인딩 시 에러가 발생할 경우 에러 메시지를 한 번만 표시할지 여부를 설정합니다.

Value

true 모든 보고서의 바인딩이 끝난 후 에러 메시지 한 번만 표시

false 에러 발생 시마다 에러 메시지 표시 (기본 값)


global.stopchildwhenerror

다중 보고서 바인딩 시 에러가 발생하면 보고서 바인딩을 중지할지 여부를 설정합니다.

Value

true 에러가 발생하면 보고서 바인딩 중지

false 에러가 발생해도 보고서 계속 바인딩 (기본 값)


global.timezone

표준 시간대를 설정합니다.

Reference

설정한 표준 시간대는 데이터 타입이 Date, Time, DateTime(TimeStamp)인 데이터 필드 또는 SystemType이 Date, Time, Date/Time인 시스템 필드를 바인딩하는 텍스트에 적용됩니다.

표준 시간대를 설정하는 TimeZone 코드는 "TimeZone 정의 코드표"를 참고하시기 바랍니다.


global.use_preview_progressbar

보고서를 바인딩할 때 프로그레스 창을 한 번만 실행할지 여부를 설정합니다.

Value

true 한 번만 실행

false 보고서 개수만큼 실행 (기본 값)

Reference

보고서가 바인딩될 때 표시되는 프로그레스 창은 보고서 개수만큼 실행과 종료를 반복하므로, 멀티 보고서 환경에서는 프로그레스 창이 계속 깜빡거리는 것처럼 보일 수 있습니다.

이런 경우 패러미터를 이용하시기 바랍니다.

패러미터 값을 "true"로 설정하면 맨 처음 보고서가 바인딩될 때 프로그레스 창을 한 번 실행하고 마지막 보고서가 바인딩되는 시점에 프로그레스 창이 종료됩니다.

프로그레스 창은 "보고서를 바인딩 중입니다. (현재 보고서 번호/전체 보고서 개수)" 형태로 메시지가 표시됩니다.

보고서 번호 및 개수는 "viewer.childcount 패러미터 값 + 1"로 결정됩니다.

패러미터 값이 "true"인 경우 viewer.useimageprogressbar, viewer.useprogressbar 패러미터는 적용되지 않습니다.


global.useeachprintopt_at_concatpage

현재 보고서에서 설정한 인쇄 옵션을 현재 보고서에만 적용할지 여부를 설정합니다.

Value

true 현재 보고서에만 적용

false 다른 보고서에도 적용 (기본 값)

Reference

"global.concatpage=true"인 경우에 적용됩니다.

패러미터 값이 true인 경우 OZPrintCommand 이벤트와 OZUserActionCommand 이벤트는 보고서 개수만큼 발생합니다.


gul

정음글로벌 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
gul.convertedimagedpi | O | X | X | X | X | X | X | X | X
gul.filename | O | X | X | X | X | X | X | X | X
gul.path | O | X | X | X | X | X | X | X | X
gul.saveastable | O | X | X | X | X | X | X | X | X


gul.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


gul.filename

파일 이름을 설정합니다.

See Also

저장 다이얼로그


gul.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


gul.saveastable

테이블 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

정음 Global 저장 옵션 다이얼로그


han97

한글97 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
han97.convertedimagedpi | O | O | O | O | O | O | O | O | O
han97.filename | O | O | O | O | O | O | O | O | X
han97.path | O | O | X | O | X | X | O | O | X
han97.saveastable | O | O | O | O | O | O | O | O | O
han97.savelinktoc | O | O | O | O | O | O | O | O | O
han97.savelinkurl | O | O | O | O | O | O | O | O | O


han97.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


han97.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


han97.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


han97.saveastable

테이블 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

Reference

hml로 저장된 폼을 한글 97에서 열었을 경우 글꼴에 "맞는 글꼴 없음"으로 표시됩니다.

라벨 크기 고정 기능이 지원되지 않습니다. (한글 97에서 지원되지 않음)

테이블 형식으로 보고서를 저장할 경우 테이블의 이미지가 저장되지 않습니다. (한글 97에서 지원되지 않음)

한글 97에서 저장한 폼의 경우 한글 2002 버전에서는 열리나 그 이후 버전(한글 2004/한글 2005 등)에서 열리지 않습니다. (한글 97에서 지원되지 않음)

See Also

한글 97 저장 옵션 다이얼로그


han97.savelinktoc

목차 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


han97.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


hdm

HDM 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
hdm.charset | O | O | O | O | O | X | O | O | O
hdm.extension | O | O | O | O | O | X | O | O | O
hdm.filename | O | O | O | O | O | X | O | O | X
hdm.indent | O | O | O | O | O | X | O | O | O
hdm.maxrowinafile | O | O | O | O | O | X | O | O | O
hdm.path | O | O | X | O | X | X | O | O | X
hdm.save_description_as_title | O | O | O | O | O | X | O | O | O
hdm.separator | O | O | O | O | O | X | O | O | O


hdm.charset

인코딩 옵션을 설정합니다.

Value

ansi ANSI (기본 값)

unicode 유니코드

See Also

데이터 저장 다이얼로그


hdm.extension

파일 확장자를 설정합니다.

Value

csv csv

txt txt (기본 값)

xla xla

xls xls

xlsx xlsx

xml xml

Reference

hdm.filename 패러미터 값에 파일명과 확장자를 모두 설정하였을 경우 이 패러미터 값은 무시되고 hdm.filename에 설정한 확장자로 파일이 저장됩니다.

hdm.filename 패러미터 값에 파일명만 설정하였을 경우 이 패러미터 값에 설정한 확장자로 파일이 저장됩니다.

파일 확장자가 csv 또는 txt일 경우에만 데이터 저장 다이얼로그의 저장 옵션이 적용됩니다. 그 외에는 데이터 저장 다이얼로그의 저장 옵션 중 저장 경로만 적용됩니다.

파일 확장자를 xml로 설정한 경우 저장된 파일은 UTF-8로 인코딩됩니다.

See Also

데이터 저장 다이얼로그


hdm.filename

파일 이름을 설정합니다.

See Also

데이터 저장 다이얼로그


hdm.indent

들여쓰기 기능 사용 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

데이터 저장 다이얼로그


hdm.maxrowinafile

파일 확장자를 csv로 설정하여 저장할 때 한 파일에 저장할 최대 행 수를 설정합니다.


hdm.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


hdm.save_description_as_title

데이터를 저장할 때 컬럼 제목을 필드 설명으로 적용할지 여부를 설정합니다.

Value

true 컬럼 제목을 필드 설명으로 설정

false 컬럼 제목을 필드 이름으로 설정 (기본 값)

Reference

필드 설명이 지원되는 데이터 셋(ODI 데이터 셋, CSV 데이터 셋, Join 데이터 셋)에서만 지원됩니다.

데이터 필드 설명이 빈 값인 경우 패러미터 값과 상관없이 필드 이름이 컬럼 제목으로 적용됩니다.


hdm.separator

구분자 옵션을 설정합니다.

Value

tab tab (기본 값)

space space

| |

/ /

~ ~

comma comma

Other 그 외 값

Reference

구분자를 Other로 선택하고 활성화된 사용자 정의 텍스트 박스에 값을 입력하면 오즈에서 기본으로 제공되는 구분자 외에도 사용자가 여러 가지 구분자를 정의할 수 있습니다.

See Also

데이터 저장 다이얼로그


hml

한글 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
hml.convertedimagedpi | O | O | O | O | O | O | O | O | O
hml.filename | O | O | O | O | O | O | O | O | X
hml.keeplabelsize | O | O | O | O | O | O | O | O | O
hml.orientation | O | O | O | O | O | O | O | O | O
hml.papersize | O | O | O | O | O | O | O | O | O
hml.path | O | O | X | O | X | X | O | O | X
hml.saveastable | O | O | O | O | O | O | O | O | O
hml.saveasxml | O | O | O | O | O | O | O | O | O
hml.savelinktoc | O | O | O | O | O | O | O | O | O
hml.savelinkurl | O | O | O | O | O | O | O | O | O
hml.savetobackground | O | O | O | O | O | O | O | O | O
hml.savetoheaderfooter | O | O | O | O | O | O | O | O | O
hml.verttoparagraph | O | O | O | O | O | O | O | O | O


hml.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


hml.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


hml.keeplabelsize

라벨 크기 고정 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

한글에서 글 상자의 높이가 어느 수치 이하이면 더 이상 줄어들지 않는데 글 상자에 글을 채울 때 자동으로 글 상자 크기가 늘어나 원본 라벨의 크기가 일치하지 않는 문제가 있습니다. "hml.keeplabelsize=true"로 설정하면 원본 라벨의 크기를 유지할 수 있습니다.

See Also

한글 저장 옵션 다이얼로그


hml.orientation

익스포트된 한글 파일의 용지 방향을 변경합니다.

Value

빈 문자 보고서에 설정된 용지 방향을 따름 (기본 값)

landscape 가로 방향으로 변경

portrait 세로 방향으로 변경


hml.papersize

익스포트된 한글 파일의 용지 크기를 변경합니다.

Value

빈 문자 보고서에 설정된 용지 크기를 따름 (기본 값)

A3 A3로 변경

A4 A4로 변경

A5 A5로 변경

B5 B5로 변경

LEGAL LEGAL로 변경

LETTER LETTER로 변경


hml.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


hml.saveastable

테이블 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

한글 저장 옵션 다이얼로그


hml.saveasxml

XML 형식으로 저장할지 여부를 설정합니다.

Value

true XML 형식으로 저장 (기본 값)

false 바이너리 형식으로 저장

Reference

Android/iOS 뷰어에서 바이너리 형식으로 저장하려면 아래와 같은 설정이 필요합니다.

[Android]

·Eclipse 프로젝트에 라이브러리 추가

libozrvpack_hwpwriter.so

[iOS]

·Xcode 프로젝트에 라이브러리 추가

libozrvpack_hwpwriter.a

·스크립트 추가

해당 기능을 사용하기 전에 __OZExportPack_load_hwp() 함수 호출


hml.savelinktoc

목차 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


hml.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


hml.savetobackground

백그라운드 밴드를 바탕쪽에 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

보고서에서 페이지별로 백그라운드 밴드를 설정하였을 경우 한글 바탕쪽의 기능 상 첫 번째 페이지에 설정한 백그라운드 밴드가 다음 페이지에도 반복되어 표시됩니다.

See Also

한글 저장 옵션 다이얼로그


hml.savetoheaderfooter

페이지 헤더/풋터 밴드를 머리말/꼬리말 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

보고서에서 페이지 헤더 또는 풋터 밴드를 생략하거나 스크립트로 특정 페이지의 페이지 번호를 생략할 경우 "페이지 헤더/풋터 밴드를 머리말/꼬리말에 저장" 옵션을 적용하여 한글 파일로 저장하면 한글의 기능 상 페이지 번호가 모든 페이지에 표시됩니다.

ex) 보고서에서 "2, 4, 5" 페이지의 페이지 번호가 표시되었을 경우 한글 파일로 저장하면 "1, 2, 3, 4, 5"로 모든 페이지에 쪽 번호가 표시됩니다.

"Page_Of_Total" 시스템 라벨을 한글의 쪽 번호로 저장될 경우 현재 페이지는 정상적으로 적용되나 전체 페이지 수는 보고서에 바인딩된 전체 페이지 수와 동일하게 표시됩니다.

ex) "3/3" 페이지의 한글 파일을 편집하여 페이지 수가 증가하였을 경우 "4/3"으로 전체 페이지는 보고서와 동일하게 "3"으로 표시됩니다.

See Also

한글 저장 옵션 다이얼로그


hml.verttoparagraph

세로를 문단으로 설정 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

"세로를 문단으로 설정" 옵션을 적용하여 저장한 한글 파일은 한글 프로그램의 특성으로 인하여 문단 편집 시 표 또는 라벨의 위치가 변경될 수 있으므로 기본 글꼴 크기가 10pt에서 8pt로 변경됩니다.

See Also

한글 저장 옵션 다이얼로그


html

HTML 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
html.charset | O | O | O | O | O | O | O | O | O
html.convertedimagedpi | O | O | O | O | O | O | O | O | O
html.filename | O | O | O | O | O | O | O | O | X
html.fontsize | O | O | O | O | O | O | O | O | O
html.horizontal | O | O | O | O | O | O | O | O | O
html.imagepath | O | O | X | O | X | X | X | X | X
html.imagesrcpath | O | O | O | O | X | X | X | X | X
html.largebundle | O | O | O | O | O | X | O | O | O
html.offsetx | O | O | O | O | O | O | O | O | O
html.offsety | O | O | O | O | O | O | O | O | O
html.pagetitle | O | O | O | O | O | O | O | O | O
html.password | O | O | O | O | O | O | O | O | O
html.path | O | O | X | O | X | X | O | O | X
html.savealt | O | O | O | O | O | O | O | O | O
html.savebypage | O | O | O | O | O | O | O | O | O
html.savelinktoc | O | O | O | O | O | O | O | O | O
html.savelinkurl | O | O | O | O | O | O | O | O | O
html.templatepath | O | O | O | O | O | O | O | O | O
html.version | O | O | O | O | O | O | O | O | O
html.vertical | O | O | O | O | O | O | O | O | O


html.charset

인코딩 옵션을 설정합니다.

Value

ansi ANSI (기본 값)

unicode 유니코드

utf-8 UTF-8

Reference

Android, iOS, WinRT 뷰어에서는 "ansi"로 설정할 경우 "utf-8"로 적용됩니다.

See Also

HTML 저장 옵션 다이얼로그


html.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


html.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


html.fontsize

글꼴 크기 설정 옵션을 체크하고, 글꼴 크기를 설정합니다.

See Also

HTML 저장 옵션 다이얼로그


html.horizontal

라인수 옵션 중 수평을 설정합니다.

Reference

"html.savebypage=false"인 경우에 적용됩니다.

See Also

HTML 저장 옵션 다이얼로그


html.imagepath

이미지 경로 옵션을 설정합니다.

Reference

이미지, 바코드, 차트 등 이미지로 저장되는 컴포넌트의 저장 경로를 설정합니다.

이미지 경로는 html 파일의 "img src" 태그 값에도 적용되며, 이미지 경로를 설정하지 않은 경우에는 html 파일이 저장되는 경로와 같은 경로에 이미지가 저장됩니다. 이미지가 저장되는 경로와 다른 경로로 "img src" 태그 값을 지정하려면 html.imagesrcpath 패러미터를 이용하시기 바랍니다.


html.imagesrcpath

HTML 파일로 저장 시 "img src" 태그에 적용할 이미지 경로를 설정합니다.

Reference

이 패러미터는 "img src" 태그 값만 설정하는 패러미터로, 이미지를 저장하는 경로가 아닙니다. 이미지 저장 경로는 html.imagepath 패러미터를 이용하여 설정하시기 바랍니다. 예를 들어, 이미지, 바코드, 차트 등이 포함된 보고서를 저장할 때 html 파일 이름이 sample.html, html.imagesrcpath=c:\temp\, html.imagepath=c:\images\인 경우 이미지, 바코드, 차트 등의 이미지는 c:\images\ 경로에 저장되고, html 파일의 "img src" 태그 값은 "c:\temp\sample_html_일련번호.jpg"로 적용됩니다.


html.largebundle

HTML 파일로 저장 시 기본 옵션 다이얼로그의 한페이지로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

모든 포맷에 공통적으로 적용되는 한페이지로 저장 옵션을 다른 포맷과 상관없이 HTML에서만 별도로 동작하도록 설정하고자 할 때 이 패러미터를 사용하시기 바랍니다.

예를 들어, html.largebundle=true, export.largebundle=false로 설정하면 HTML에서만 한페이지로 저장 옵션이 체크되고, 다른 포맷에서는 한페이지로 저장 옵션이 체크 해지됩니다.

반대의 상황도 마찬가지로 html.largebundle=false, export.largebundle=true로 설정하면 HTML에서만 한페이지로 저장 옵션이 체크 해지되고, 다른 포맷에서는 한페이지로 저장 옵션이 체크됩니다.

또한, 사용자가 한페이지로 저장 옵션을 체크하거나 체크 해지한 경우에도 위 규칙이 그대로 적용됩니다.

여러 페이지의 보고서를 한 페이지로 저장할 때 보고서를 미리보기하지 않고 바로 저장할 경우에는 "viewer.largebundle=true"로 설정하시기 바랍니다.

See Also

기본 옵션 다이얼로그


html.offsetx

오프셋 옵션 중 X축을 설정합니다.

See Also

HTML 저장 옵션 다이얼로그


html.offsety

오프셋 옵션 중 Y축을 설정합니다.

See Also

HTML 저장 옵션 다이얼로그


html.pagetitle

제목 옵션을 설정합니다.

See Also

HTML 저장 옵션 다이얼로그


html.password

암호 옵션을 설정합니다.

Reference

암호는 1byte 문자만 설정하시기 바랍니다.

만일, 1byte 문자가 아닌 문자로 설정한 경우 HTML 저장 옵션에 암호가 표시되지만, 실제 저장 시에는 암호 없이 저장됩니다.

암호를 입력받는 웹 페이지를 고객 환경에 맞게 변경하려면 고객용 템플릿 페이지를 디자인한 후 html.templatepath 패러미터 값에 템플릿 페이지 경로를 설정하시기 바랍니다.


html.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


html.savealt

컴포넌트의 대체 텍스트를 포함하여 저장할지 여부를 설정합니다.

Value

true 대체 텍스트 저장

false 대체 텍스트 저장 안 함 (기본 값)

Reference

대체 텍스트는 img 태그 안에 alt 속성으로 저장되며, 이미지로 저장되는 컴포넌트만 적용됩니다.

이미지로 저장되는 컴포넌트는 HTML 라벨, 차트, 바코드, 사용자 컴포넌트, 도형입니다. 단, HTML 라벨은 이미지 스타일이 "고정", "가로고정", "세로고정", "가로고정,중앙으로", "세로고정,중앙으로", "동일비율", "동일비율,중앙으로"인 경우에만 적용됩니다.


html.savebypage

페이지별 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

HTML 저장 옵션 다이얼로그


html.savelinktoc

목차 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


html.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


html.templatepath

암호가 설정된 HTML 파일로 보고서를 저장할 때 암호를 입력받는 템플릿 페이지의 경로를 설정합니다.

Reference

템플릿 페이지의 경로는 Http URL, File URL, OZ URL 등의 형식으로 설정할 수 있습니다.

템플릿 페이지는 아래 규칙에 맞게 작성하여야 합니다.

템플릿 페이지 내용 중 수정 가능한 부분은 아래와 같습니다. 그 외 부분을 수정할 경우 에러 메시지가 발생하고, 암호화된 파일로 저장할 수 없습니다.

·수정 가능한 라인은 13 ~ 16, 40 ~ 44 라인입니다.

·43 라인에 입력된 Decrypt(var Argument1) 함수는 반드시 호출되어야 합니다.

·form id 및 패스워드 입력용 텍스트 박스의 id는 frm 및 pwd가 아닌 다른 값으로 변경할 수 있습니다.

See Also

html.password


html.version

HTML의 버전을 설정합니다.

Value

none 버전 없음 (기본 값)

4.01 4.01

See Also

HTML 저장 옵션 다이얼로그


html.vertical

라인수 옵션 중 수직을 설정합니다.

Reference

"html.savebypage=false"인 경우에 적용됩니다.

See Also

HTML 저장 옵션 다이얼로그


information

오즈 뷰어 트랙잭션 로그 관련 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
information.debug | O | O | O | O | X | X | O | O | O
information.lockconsole | O | O | O | O | X | X | O | O | O
information.matchparamvalue | O | O | O | O | O | O | O | O | O


information.debug

뷰어 콘솔 로그 정보의 수준(Level)을 설정합니다.

Value

true 뷰어 수행에 필요한 디버깅용 메시지를 자바 콘솔에 출력

false(none) 뷰어 수행에 필요한 디버깅용 메시지를 자바 콘솔에 출력하지 않음 (기본 값)

error 에러 메시지만 출력

info 일반 정보만 출력

debug 에러, 일반 정보, 디버그 등 모든 메시지 출력


information.lockconsole

<Ctrl + Z>, <Ctrl + Shift + Z> 키를 누를 경우 뷰어 콘솔 창의 표시 여부를 설정합니다.

Value

true 콘솔 창 표시 안 함

false 콘솔 창 표시 (기본 값)


information.matchparamvalue

보고서에 추가된 폼/ODI 패러미터 값이 뷰어 패러미터로 설정되지 않은 경우 에러메시지를 자바 콘솔과 메시지 창에 표시할지 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

HTML5 뷰어에서는 메시지 창에만 표시됩니다.


jpg

JPEG 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
jpg.filename | O | O | O | O | O | O | O | O | X
jpg.path | O | O | X | O | X | X | O | O | X
jpg.quality | O | O | O | O | O | O | O | O | O
jpg.savecomment | O | O | O | O | O | X | O | O | O
jpg.zoom | O | O | O | O | O | O | O | O | O

O

Only e-Form


jpg.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


jpg.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


jpg.quality

품질 옵션을 설정합니다.

Reference

기본 값은 100이며, 0 ~ 100 사이의 값으로 설정합니다.

See Also

JPG 저장 옵션 다이얼로그


jpg.savecomment

JPEG 파일로 저장할 때 주석을 포함하여 저장할지 여부를 설정합니다.

Value

true 주석 포함하여 저장

false 주석 저장 안 함 (기본 값)


jpg.zoom

확대/축소 비율 옵션을 설정합니다.

Reference

기본 값은 100이며, 10~1000 사이의 값으로 설정합니다.

See Also

JPG 저장 옵션 다이얼로그


line

콜아웃 기능 시 사용하는 선의 속성 제어에 관한 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
line.changeable | O | O | O | O | O | X | X | X | X
line.dashtype | O | O | O | O | O | X | X | X | X
line.linecolor | O | O | O | O | O | X | X | X | X
line.linedash | O | O | O | O | O | X | X | X | X
line.linethickness | O | O | O | O | O | X | X | X | X
line.linetype | O | O | O | O | O | X | X | X | X
line.movable | O | O | O | O | O | X | X | X | X
line.multiscreen_visible_type | O | X | X | X | X | X | X | X | X
line.tooltiptext | O | O | O | O | O | X | X | X | X

O

Only e-Form


line.changeable

속성 변환 가능 여부를 설정합니다.

Value

true 속성 변환 가능 (기본 값)

false 속성 변환 불가


line.dashtype

점선 형태를 설정합니다.

Value

dash 사각 점선 (기본 값)

rounddot 둥근 점선

Reference

사각 점선은 line.linedash 패러미터의 첫 번째 값이 사각 점선의 너비로, line.linethickness 패러미터 값이 사각 점선의 높이로 적용되고, line.linedash 패러미터의 두 번째 숫자 값이 간격으로 적용됩니다.

둥근 점선은 line.linethickness 패러미터 값이 둥근 점선의 지름으로 적용되고, line.linedash 패러미터의 두 번째 숫자 값이 간격으로 적용됩니다.

점선 형태를 둥근 점선으로 설정할 경우 선 부드럽게 표시 기능을 이용하면 원형에 가까운 모양으로 둥근 점선을 표현할 수 있습니다.

See Also

viewer.antialiasing


line.linecolor

선 색을 설정합니다.

Reference

기본 값은 "000000"입니다.


line.linedash

선의 스타일을 점선으로 설정합니다.

Reference

"점선 간격" 형태로 설정하시기 바랍니다.


line.linethickness

선 두께를 설정합니다.

Reference

기본 값은 "1"입니다.


line.linetype

선 타입을 설정합니다.

Value

backslash 역슬래쉬 (기본 값)

horizontal 수평

slash 슬래쉬

vertical 수직


line.movable

이동 가능 여부를 설정합니다.

Value

true 이동 가능 (기본 값)

false 이동 불가


line.multiscreen_visible_type

멀티 스크린 환경에서 선 표시 타입을 설정합니다.

Value

always 양쪽 스크린 모두 선이 표시됨 (기본 값)

mainscreenonly 메인 스크린에만 선이 표시됨

subscreenonly 서브 스크린에만 선이 표시됨


line.tooltiptext

툴팁에 표시할 텍스트를 설정합니다.


mail

오즈 메일 관련 정보를 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
mail.attachname | O | O | X | O | X | X | O | O | O
mail.auth | O | O | X | O | X | X | X | X | X
mail.bcc | O | O | X | O | X | X | O | O | O
mail.body | O | O | X | O | X | X | O | O | O
mail.bodytype | O | O | X | O | X | X | X | X | X
mail.cc | O | O | X | O | X | X | O | O | O
mail.from | O | O | X | O | X | X | X | X | X
mail.id | O | O | X | O | X | X | X | X | X
mail.mode | O | O | X | O | X | X | X | X | X
mail.password | O | O | X | O | X | X | X | X | X
mail.port | O | O | X | O | X | X | X | X | X
mail.server | O | O | X | O | X | X | X | X | X
mail.showbodyeditor | O | O | X | O | X | X | X | X | X
mail.subject | O | O | X | O | X | X | O | O | O
mail.target | O | O | X | O | X | X | X | X | X
mail.to | O | O | X | O | X | X | O | O | O


mail.attachname

첨부 파일 이름을 설정합니다.

Reference

mail.attachname 패러미터를 설정하지 않는 경우 export.mode 패러미터 값에 따라 아래와 같이 설정됩니다.

·export.mode=normal인 경우

connection.reportname 또는 connection.openfile에 설정된 보고서 이름이 첨부 파일 이름으로 설정됩니다.

·export.mode=silent인 경우

xxx.filename 패러미터로 설정한 값이 첨부 파일 이름으로 설정됩니다.


mail.auth

보내는 메일 서버(SMTP) 인증 필요 옵션의 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

메일 설정 다이얼로그


mail.bcc

숨은 참조 옵션을 설정합니다.

See Also

메일 전송 다이얼로그


mail.body

내용 옵션을 설정합니다.

See Also

메일 전송 다이얼로그


mail.bodytype

오즈 메일의 본문 메시지 형식을 설정합니다.

Value

text 텍스트 타입으로 메시지 형식 설정 (기본 값)

html HTML 타입으로 메시지 형식 설정

Reference

mail.bodytype=html일 경우에도 메일 전송 다이얼로그에서 본문 내용이 html 태그가 적용된 모습이 아닌, 작성한 html 태그가 그대로 표시되므로 mail.showbodyeditor=false로 설정하여 사용하시기 바랍니다.

See Also

메일 전송 다이얼로그


mail.cc

참조 옵션을 설정합니다.

See Also

메일 전송 다이얼로그


mail.from

보내는 사람 옵션을 설정합니다.

See Also

메일 설정 다이얼로그


mail.id

사용자 이름 옵션을 설정합니다.

Reference

"mail.auth=true"일 경우에 적용됩니다.

See Also

메일 설정 다이얼로그


mail.mode

메일 전송 다이얼로그와 메일 설정 다이얼로그의 표시 여부를 설정합니다.

Value

normal 다이얼로그 표시 (기본 값)

silent 다이얼로그 표시 안 함

See Also

메일 전송 다이얼로그, 메일 설정 다이얼로그


mail.password

암호 옵션을 설정합니다.

Reference

"mail.auth=true"일 경우에 적용됩니다.

See Also

메일 설정 다이얼로그


mail.port

서버 포트번호 옵션을 설정합니다.

Reference

기본 값은 25입니다.

See Also

메일 설정 다이얼로그


mail.server

서버 주소 옵션을 설정합니다.

See Also

메일 설정 다이얼로그


mail.showbodyeditor

내용 옵션의 표시 여부를 설정합니다.

Value

true 내용 옵션 표시 (기본 값)

false 내용 옵션 표시 안 함

See Also

메일 전송 다이얼로그


mail.subject

제목 옵션을 설정합니다.

See Also

메일 전송 다이얼로그


mail.target

저장 다이얼로그의 출력 방향을 메일 또는 오즈 메일로 설정합니다.

Value

ozmail 오즈 메일 (기본 값)

email 메일

Reference

이 패러미터는 툴바의 MAIL 전송 아이콘(toolbar.mail=true)을 클릭하여 나타나는 저장 다이얼로그에서만 적용됩니다.

Applet 뷰어는 오즈 메일만 지원합니다.

See Also

저장 다이얼로그


mail.to

받는 사람 옵션을 설정합니다.

See Also

메일 전송 다이얼로그


memo

다이나믹 메모 컴포넌트의 속성 제어에 관한 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
memo.backgroundalpha | O | O | O | O | O | X | O | O | O
memo.bottombordercolor | O | O | O | O | O | X | O | O | O
memo.bottomInternalmargin | O | O | O | O | O | X | O | O | O
memo.bottomleft_border_radius | O | O | O | O | O | X | O | O | O
memo.bottomline | O | O | O | O | O | X | O | O | O
memo.bottomlinedash | O | O | O | O | O | X | O | O | O
memo.bottomlinedashoffset | O | O | O | O | O | X | O | O | O
memo.bottomright_border_radius | O | O | O | O | O | X | O | O | O
memo.caption | O | O | O | O | O | X | O | O | O
memo.changeable | O | O | O | O | O | X | O | O | O
memo.clip | O | O | O | O | O | X | O | O | O
memo.editable | O | O | O | O | O | X | O | O | O
memo.effect | O | O | O | O | O | X | O | O | O
memo.fillcolor | O | O | O | O | O | X | O | O | O
memo.fontcolor | O | O | O | O | O | X | O | O | O
memo.fontname | O | O | O | O | O | X | O | O | X
memo.fontsize | O | O | O | O | O | X | O | O | O
memo.fontstretch | O | O | O | O | O | X | O | O | O
memo.fontstyle | O | O | O | O | O | X | O | O | O
memo.gradientcolor | O | O | O | O | O | X | O | O | O
memo.gradienttype | O | O | O | O | O | X | O | O | O
memo.halign | O | O | O | O | O | X | O | O | O
memo.leftbordercolor | O | O | O | O | O | X | O | O | O
memo.leftInternalmargin | O | O | O | O | O | X | O | O | O
memo.leftline | O | O | O | O | O | X | O | O | O
memo.leftlinedash | O | O | O | O | O | X | O | O | O
memo.leftlinedashoffset | O | O | O | O | O | X | O | O | O
memo.movable | O | O | O | O | O | X | O | O | O
memo.multiscreen_visible_type | O | X | X | X | X | X | X | X | X
memo.rightbordercolor | O | O | O | O | O | X | O | O | O
memo.rightInternalmargin | O | O | O | O | O | X | O | O | O
memo.rightline | O | O | O | O | O | X | O | O | O
memo.rightlinedash | O | O | O | O | O | X | O | O | O
memo.rightlinedashoffset | O | O | O | O | O | X | O | O | O
memo.spacing | O | O | O | O | O | X | O | O | O
memo.stretch | O | O | O | O | O | X | O | O | O
memo.text_rotation | O | O | O | O | O | X | O | O | O
memo.textindent | O | O | O | O | O | X | O | O | O
memo.topbordercolor | O | O | O | O | O | X | O | O | O
memo.topInternalmargin | O | O | O | O | O | X | O | O | O
memo.topleft_border_radius | O | O | O | O | O | X | O | O | O
memo.topline | O | O | O | O | O | X | O | O | O
memo.toplinedash | O | O | O | O | O | X | O | O | O
memo.toplinedashoffset | O | O | O | O | O | X | O | O | O
memo.topright_border_radius | O | O | O | O | O | X | O | O | O
memo.transparent | O | O | O | O | O | X | O | O | O
memo.usegradient | O | O | O | O | O | X | O | O | O
memo.valign | O | O | O | O | O | X | O | O | O
memo.wordwrap | O | O | O | O | O | X | O | O | O
memo.wordwraptype | O | O | O | O | O | X | O | O | O
memo.wrapspace | O | O | O | O | O | X | O | O | O

O

Only e-Form


memo.backgroundalpha

바탕색의 투명도를 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

0~255 사이의 값으로 설정해야 하며, 작은 값으로 설정할수록 투명해집니다.


memo.bottombordercolor

아래쪽 테두리 색을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.bottomInternalmargin

아래쪽 내부 여백을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.bottomleft_border_radius

아래쪽과 왼쪽이 교차되는 테두리의 둥근 정도를 "아래쪽 왼쪽" 형태로 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

아래쪽 테두리와 왼쪽 테두리의 둥근 정도가 같을 경우 하나의 값만 입력합니다. 즉, 아래쪽과 왼쪽의 둥근 정도를 모두 50으로 설정할 경우 "50 50"으로 설정하지 않고 "50"으로 설정합니다.

둥근 테두리 기능은 메모의 테두리가 단일 실선으로 화면에 표시될 때 적용됩니다.


memo.bottomline

아래쪽 테두리 두께를 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

테두리를 다중선으로 설정하려면 "두께 간격 두께 간격 두께 ... 두께"형태로 설정합니다.


memo.bottomlinedash

아래쪽 테두리 점선을 "점선 간격" 형태로 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

테두리가 다중선일 때 선마다 다르게 설정하려면 "점선 간격;점선 간격;점선 간격;...;점선 간격" 형태로 설정합니다.


memo.bottomlinedashoffset

아래쪽 테두리 점선 옵셋을 설정합니다.

Reference

기본 값은 빈 값("")입니다.


memo.bottomright_border_radius

아래쪽과 오른쪽이 교차되는 테두리의 둥근 정도를 "아래쪽 오른쪽" 형태로 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

아래쪽 테두리와 오른쪽 테두리의 둥근 정도가 같을 경우 하나의 값만 입력합니다. 즉, 아래쪽과 오른쪽의 둥근 정도를 모두 50으로 설정할 경우 "50 50"으로 설정하지 않고 "50"으로 설정합니다.

둥근 테두리 기능은 메모의 테두리가 단일 실선으로 화면에 표시될 때 적용됩니다.


memo.caption

텍스트를 설정합니다.

Reference

기본 값은 빈 값("")입니다.


memo.changeable

속성 변환 가능 여부를 설정합니다.

Value

true 속성 변환 가능 (기본 값)

false 속성 변환 불가


memo.clip

클리핑 여부를 설정합니다.

Value

true 클리핑

false 클리핑 안 함

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.editable

편집 가능 여부를 설정합니다.

Value

true 편집 가능 (기본 값)

false 편집 불가


memo.effect

텍스트 효과를 설정합니다.

Value

basic Basic

outline Outline

dimension 3D

engrave Engrave

segments Segments

hollow Hollow

shadow Shadow

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.fillcolor

바탕색을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.fontcolor

글꼴색을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.fontname

글꼴을 설정합니다.

Reference

기본 값은 굴림입니다.


memo.fontsize

글꼴 크기를 설정합니다.

Reference

기본 값은 10입니다.


memo.fontstretch

장평을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

1~600 사이의 값으로 설정해야 하며, 범위를 벗어난 값을 설정할 경우 기본 값으로 설정됩니다.


memo.fontstyle

글꼴 스타일을 설정합니다.

Value

plain 보통

bold 굵게

italic 기울임꼴

bolditalic 굵은 기울임꼴

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.gradientcolor

그라데이션 색을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.gradienttype

그라데이션 방향과 시작 위치를 설정합니다.

Value

left_center_right 가로 모서리에서

right_center_left 가로 가운데에서

left_right 가로 정방향

right_left 가로 역방향

top_center_bottom 세로 모서리에서

bottom_center_top 세로 가운데에서

top_bottom 세로 정방향

bottom_top 세로 역방향

lefttop_center_bottomright 상향 대각선 모서리에서

bottomright_center_lefttop 상향 대각선 가운데에서

lefttop_bottomright 상향 대각선 정방향

bottomright_lefttop 상향 대각선 역방향

leftbottom_center_righttop 하향 대각선 모서리에서

righttop_center_leftbottom 하향 대각선 가운데에서

leftbottom_righttop 하향 대각선 정방향

righttop_leftbottom 하향 대각선 역방향

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.halign

텍스트 수평 정렬 방식을 설정합니다.

Value

left 왼쪽 정렬

center 가운데 정렬

right 오른쪽 정렬

distributed 균등 분할

justify 양쪽 맞춤

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.leftbordercolor

왼쪽 테두리 색을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.leftInternalmargin

왼쪽 내부 여백을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.leftline

왼쪽 테두리 두께를 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

테두리를 다중선으로 설정하려면 "두께 간격 두께 간격 두께 ... 두께"형태로 설정합니다.


memo.leftlinedash

왼쪽 테두리 점선을 "점선 간격" 형태로 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

테두리가 다중선일 때 선마다 다르게 설정하려면 "점선 간격;점선 간격;점선 간격;...;점선 간격" 형태로 설정합니다.


memo.leftlinedashoffset

왼쪽 테두리 점선 옵셋을 설정합니다.

Reference

기본 값은 빈 값("")입니다.


memo.movable

이동 가능 여부를 설정합니다.

Value

true 이동 가능 (기본 값)

false 이동 불가


memo.multiscreen_visible_type

멀티 스크린 환경에서 메모 표시 타입을 설정합니다.

Value

always 양쪽 스크린 모두 메모가 표시됨 (기본 값)

mainscreenonly 메인 스크린에만 메모가 표시됨

subscreenonly 서브 스크린에만 메모가 표시됨


memo.rightbordercolor

오른쪽 테두리 색을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.rightInternalmargin

오른쪽 내부 여백을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.rightline

오른쪽 테두리 두께를 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

테두리를 다중선으로 설정하려면 "두께 간격 두께 간격 두께 ... 두께"형태로 설정합니다.


memo.rightlinedash

오른쪽 테두리 점선을 "점선 간격" 형태로 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

테두리가 다중선일 때 선마다 다르게 설정하려면 "점선 간격;점선 간격;점선 간격;...;점선 간격" 형태로 설정합니다.


memo.rightlinedashoffset

오른쪽 테두리 점선 옵셋을 설정합니다.

Reference

기본 값은 빈 값("")입니다.


memo.spacing

자간을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.stretch

메모의 텍스트 출력 방향 속성을 설정합니다.

Value

horizontal 가로 쓰기

counterclockwise 가로 쓰기를 반시계 방향으로 회전하여 출력

vertical_2byte 세로 쓰기를 1byte 문자만 시계 방향으로 회전하여 출력

vertical 세로 쓰기

clockwise 가로 쓰기를 시계 방향으로 회전하여 출력

horizontal_2byte 가로 쓰기를 2byte 문자만 반시계 방향으로 회전하여 출력

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.text_rotation

텍스트 회전 정도를 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

89 ~ -89 사이의 값으로 설정합니다.

텍스트가 회전된 경우 memo.stretch 패러미터는 동작하지 않습니다.


memo.textindent

들여쓰기 값을 설정합니다.

Reference

기본 값은 0입니다.


memo.topbordercolor

위쪽 테두리 색을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.topInternalmargin

위쪽 내부 여백을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.topleft_border_radius

위쪽과 왼쪽이 교차되는 테두리의 둥근 정도를 "위쪽 왼쪽" 형태로 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

위쪽 테두리와 왼쪽 테두리의 둥근 정도가 같을 경우 하나의 값만 입력합니다. 즉, 위쪽과 왼쪽의 둥근 정도를 모두 50으로 설정할 경우 "50 50"으로 설정하지 않고 "50"으로 설정합니다.

둥근 테두리 기능은 메모의 테두리가 단일 실선으로 화면에 표시될 때 적용됩니다.


memo.topline

위쪽 테두리 두께를 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

테두리를 다중선으로 설정하려면 "두께 간격 두께 간격 두께 ... 두께"형태로 설정합니다.


memo.toplinedash

위쪽 테두리 점선을 "점선 간격" 형태로 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

테두리가 다중선일 때 선마다 다르게 설정하려면 "점선 간격;점선 간격;점선 간격;...;점선 간격" 형태로 설정합니다.


memo.toplinedashoffset

위쪽 테두리 점선 옵셋을 설정합니다.

Reference

기본 값은 빈 값("")입니다.


memo.topright_border_radius

위쪽과 오른쪽이 교차되는 테두리의 둥근 정도를 "위쪽 오른쪽" 형태로 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

위쪽 테두리와 오른쪽 테두리의 둥근 정도가 같을 경우 하나의 값만 입력합니다. 즉, 위쪽과 오른쪽의 둥근 정도를 모두 50으로 설정할 경우 "50 50"으로 설정하지 않고 "50"으로 설정합니다.

둥근 테두리 기능은 메모의 테두리가 단일 실선으로 화면에 표시될 때 적용됩니다.


memo.transparent

바탕의 투명 여부를 설정합니다.

Value

true 투명

false 불투명

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.usegradient

그라데이션 사용 여부를 설정합니다.

Value

true 그라데이션 사용

false 그라데이션 사용 안 함

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.valign

텍스트 수직 정렬 방식을 설정합니다.

Value

top 위쪽 정렬

middle 중간 정렬

bottom 아래쪽 정렬

distributed 균등 분할

justify 양쪽 맞춤

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.wordwrap

자동 줄바꾸기 여부를 설정합니다.

Value

true 자동 줄바꾸기

false 자동 줄바꾸기 안 함

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


memo.wordwraptype

자동 줄바꾸기 타입을 설정합니다.

Value

default 기본 (기본 값)

ignorespace 공백 무시

nonasciiword 단어 잘림 방지

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.

default로 설정하면 공백을 그대로 표시하고 ignorespace로 설정하면 각 줄의 첫 글자가 공백일 경우 공백을 제거합니다. nonasciiword로 설정하면 띄어쓰기 단위로 줄바꿈하여 줄바꿈 시 단어가 잘리지 않습니다.


memo.wrapspace

줄 간격을 설정합니다.

Reference

패러미터 값을 설정하지 않은 경우 보고서의 기본 라벨에 설정된 값으로 적용됩니다.


mht

MHT 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
mht.convertedimagedpi | O | O | O | O | O | O | O | O | O
mht.filename | O | O | O | O | O | O | O | O | X
mht.largebundle | O | O | O | O | O | X | O | O | O
mht.password | O | O | O | O | O | O | O | O | O
mht.path | O | O | X | O | X | X | O | O | X
mht.savefont | O | O | O | O | X | X | O | O | O
mht.savefontsize | O | O | O | O | O | O | O | O | O
mht.savelinkurl | O | O | O | O | O | O | O | O | O
mht.templatepath | O | O | O | O | O | O | O | O | O


mht.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


mht.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


mht.largebundle

MHT 파일로 저장 시 기본 옵션 다이얼로그의 한페이지로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

모든 포맷에 공통적으로 적용되는 한페이지로 저장 옵션을 다른 포맷과 상관없이 MHT에서만 별도로 동작하도록 설정하고자 할 때 이 패러미터를 사용하시기 바랍니다.

예를 들어, mht.largebundle=true, export.largebundle=false로 설정하면 MHT에서만 한페이지로 저장 옵션이 체크되고, 다른 포맷에서는 한페이지로 저장 옵션이 체크 해지됩니다.

반대의 상황도 마찬가지로 mht.largebundle=false, export.largebundle=true로 설정하면 MHT에서만 한페이지로 저장 옵션이 체크 해지되고, 다른 포맷에서는 한페이지로 저장 옵션이 체크됩니다.

또한, 사용자가 한페이지로 저장 옵션을 체크하거나 체크 해지한 경우에도 위 규칙이 그대로 적용됩니다.

여러 페이지의 보고서를 한 페이지로 저장할 때 보고서를 미리보기하지 않고 바로 저장할 경우에는 "viewer.largebundle=true"로 설정하시기 바랍니다.

See Also

기본 옵션 다이얼로그


mht.password

암호 옵션을 설정합니다.

Reference

암호는 1byte 문자만 설정하시기 바랍니다.

만일, 1byte 문자가 아닌 문자로 설정한 경우 MHT 저장 옵션에 암호가 표시되지만, 실제 저장 시에는 암호 없이 저장됩니다.

암호를 입력받는 웹 페이지를 고객 환경에 맞게 변경하려면 고객용 템플릿 페이지를 디자인한 후 mht.templatepath 패러미터 값에 템플릿 페이지 경로를 설정하시기 바랍니다.

See Also

mht.templatepath


mht.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


mht.savefont

글꼴 옵션을 설정합니다.

See Also

MHT 저장 옵션 다이얼로그


mht.savefontsize

글꼴 크기 옵션을 설정합니다.

See Also

MHT 저장 옵션 다이얼로그


mht.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


mht.templatepath

암호가 설정된 MHT 파일로 보고서를 저장할 때 암호를 입력받는 템플릿 페이지의 경로를 설정합니다.

Reference

템플릿 페이지의 경로는 Http URL, File URL, OZ URL 등의 형식으로 설정할 수 있습니다.

템플릿 페이지는 아래 규칙에 맞게 작성하여야 합니다.

템플릿 페이지 내용 중 수정 가능한 부분은 아래와 같습니다. 그 외 부분을 수정할 경우 에러 메시지가 발생하고, 암호화된 파일로 저장할 수 없습니다.

·수정 가능한 라인은 13 ~ 16, 40 ~ 44 라인입니다.

·43 라인에 입력된 Decrypt(var Argument1) 함수는 반드시 호출되어야 합니다.

·form id 및 패스워드 입력용 텍스트 박스의 id는 frm 및 pwd가 아닌 다른 값으로 변경할 수 있습니다. 단, id를 변경한 후 Decrypt() 함수에서 사용한 id도 함께 변경하시기 바랍니다.

See Also

mht.password


multiscreen

멀티 스크린 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
multiscreen.autoscroll_when_commented | O | X | X | X | X | X | X | X | X
multiscreen.checkbox_type | O | X | X | X | X | X | X | X | X
multiscreen.comment_mode | O | X | X | X | X | X | X | X | X
multiscreen.custom_ui | O | X | X | X | X | X | X | X | X
multiscreen.extraparam | O | X | X | X | X | X | X | X | X
multiscreen.highlight_border | O | X | X | X | X | X | X | X | X
multiscreen.highlightpen_guide | O | X | X | X | X | X | X | X | X
multiscreen.ignore_disable_color_inputcomponent | O | X | X | X | X | X | X | X | X
multiscreen.inputpad_pos | O | X | X | X | X | X | X | X | X
multiscreen.main_disable_types | O | X | X | X | X | X | X | X | X
multiscreen.prev_next_page_icon_disable_url | O | X | X | X | X | X | X | X | X
multiscreen.prev_next_page_icon_margin | O | X | X | X | X | X | X | X | X
multiscreen.prev_next_page_icon_size | O | X | X | X | X | X | X | X | X
multiscreen.prev_next_page_icon_url | O | X | X | X | X | X | X | X | X
multiscreen.radiobutton_type | O | X | X | X | X | X | X | X | X
multiscreen.screentype | O | X | X | X | X | X | X | X | X
multiscreen.show_prev_next_page_icon | O | X | X | X | X | X | X | X | X
multiscreen.show_scrollbar | O | X | X | X | X | X | X | X | X
multiscreen.showthumbnail | O | X | X | X | X | X | X | X | X
multiscreen.signpad_type | O | X | X | X | X | X | X | X | X
multiscreen.signpad_viewtype | O | X | X | X | X | X | X | X | X
multiscreen.signpad_window_transparency | O | X | X | X | X | X | X | X | X
multiscreen.sub_disable_types | O | X | X | X | X | X | X | X | X
multiscreen.thumbnail_icon_margin | O | X | X | X | X | X | X | X | X
multiscreen.thumbnail_icon_url | O | X | X | X | X | X | X | X | X
multiscreen.thumbnail_title | O | X | X | X | X | X | X | X | X
multiscreen.thumbnailviewsize | O | X | X | X | X | X | X | X | X
multiscreen.viewmode | O | X | X | X | X | X | X | X | X
multiscreen.zoom | O | X | X | X | X | X | X | X | X

O

Only e-Form


multiscreen.autoscroll_when_commented

메인 스크린에 주석을 추가하면 서브 스크린 화면에서도 바로 확인할 수 있도록 서브 스크린에 표시된 보고서를 자동으로 스크롤할지 여부를 설정합니다.

Value

true 자동 스크롤

false 자동 스크롤 안 함 (기본 값)


multiscreen.checkbox_type

체크 박스의 실행 타입을 설정합니다.

Value

direct 보고서 화면에서 직접 선택하는 형태로 실행 (기본 값)

ensurevisible_at_prev_next 다른 컴포넌트의 이전/다음 순서가 체크 박스인 경우 체크 박스가 화면에 표시되도록 보고서를 자동으로 스크롤하고, 이전/다음 동작을 멈춤


multiscreen.comment_mode

서브 모니터의 주석 실행 모드를 설정합니다.

Value

comment 주석 모드로 실행

input 입력 모드로 실행 (기본 값)

Reference

메인 모니터와 서브 모니터는 동시에 주석 모드로 설정할 수 없습니다.

즉, 이 패러미터와 comment.mode 패러미터 값을 둘 다 comment로 설정하면 메인 모니터는 comment로 동작하고 서브 모니터는 input으로 동작합니다.

또한, 메인 모니터가 주석 모드일 때 서브 모니터를 주석 모드로 변경하면 메인 모니터가 입력 모드로 자동 변경됩니다. 반대로 서브 모니터가 주석 모드일 때 메인 모니터를 주석 모드로 변경하면 서브 모니터가 입력 모드로 자동 변경됩니다.


multiscreen.custom_ui

멀티 스크린에서 입력 창의 글꼴 색, 배경 색, 버튼 이미지 경로, 가이드라인을 설정합니다.

Reference

기본 값은 공백입니다.

패러미터 값은 {"Key1":"Value1","Key2":"Value2",...,"Keyn":"Valuen"} 형태로 설정합니다.

설정 가능한 Key는 아래와 같습니다.

Key | 설명
cancel_url | [닫기] 버튼 이미지 경로
combo_item_selected_color | 라디오 버튼/콤보박스의 선택된 아이템의 배경 색 (기본 값 : DDDDDD)
complete_url | [확인] 버튼 이미지 경로
datetimepicker_next_url | DateTimePicker 다음 달로 이동하는 [다음] 버튼 이미지 경로
datetimepicker_pre_url | DateTimePicker 이전 달로 이동하는 [이전] 버튼 이미지 경로
datetimepicker_saturday_font_color | DateTimePicker의 토요일 글꼴 색 (기본 값 : 3598DB)
datetimepicker_selected_bg_color | DateTimePicker의 선택한 날짜 배경 색 (기본 값 : 1BBC9B)
datetimepicker_selected_font_color | DateTimePicker의 선택한 날짜 글꼴 색 (기본 값 : FFFFFF)
datetimepicker_show_unselect | DateTimePicker의 입력 창에 [선택안함] 버튼 표시 여부 (기본 값 : false)
datetimepicker_sunday_font_color | DateTimePicker의 일요일 글꼴 색 (기본 값 : FF4000)
datetimepicker_title_font_color | DateTimePicker 년도와 달을 나타내는 영역 글꼴 색 (기본 값 : FFFFFF)
datetimepicker_title_text | DateTimePicker 입력 창 제목. DateTimePicker의 툴팁 텍스트가 빈 값인 경우에 적용됨
datetimepicker_today_font_color | DateTimePicker의 오늘 글꼴 색 (기본 값 : 1BBC9B)
datetimepicker_unselect_url | DateTimePicker 입력 창의 [선택안함] 버튼 이미지 경로
datetimepicker_week_bg_color | DateTimePicker 요일 표시 영역 배경 색 (기본 값 : DDDDDD)
keypad_backspace_url | 키패드 백스페이스 버튼 이미지 경로
keypad_handwrite_url | 키패드 handwrite 버튼 이미지 경로
keypad_key_outline_color | 키패드 키 테두리 색 (기본 값 : 4A6077)
keypad_keypad_url | 키패드의 문자 키패드 버튼 이미지 경로
keypad_ok_bg_color | 키패드 [확인] 버튼 배경 색 (기본 값 : 1BBC9B)
keypad_ok_font_color | 키패드 [확인] 버튼 글꼴 색 (기본 값 : 1BBC9B)
keypad_small_key_font_color | 키패드의 쌍모음, 쌍자음 글꼴 색 (기본 값 : AAAAAA)
keypad_special_key_bg_color | 키패드 스페셜 키 배경 색 (기본 값 : DDDDDD)
keypad_special_key_font_color | 키패드 스페셜 키 글꼴 색 (기본 값 : 333333)
list_show_unselect | 라디오 버튼과 콤보 박스의 입력 창에 [선택안함] 버튼 표시 여부 (기본 값 : false)
list_title_text | 라디오 버튼과 콤보 박스의 입력 창 제목. 라디오 버튼과 콤보 박스의 툴팁 텍스트가 빈 값인 경우에 적용됨
list_unselect_url | 라디오 버튼과 콤보 박스 입력 창의 [선택안함] 버튼 이미지 경로
main_bg_color | 입력 창의 배경 색(기본 값 : 4A6077)
next_disable_url | [다음] 버튼 이미지 경로 (비활성화 상태)
next_url | [다음] 버튼 이미지 경로 (활성화 상태)
prev_disable_url | [이전] 버튼 이미지 경로 (비활성화 상태)
prev_url | [이전] 버튼 이미지 경로 (활성화 상태)
reset_url | [다시쓰기] 버튼 이미지 경로
signpad_guideline_color | 서명 패드 가이드라인 색 (기본 값 : C0C0C0)
signpad_guideline_shape | 서명 패드 가이드라인 표시 타입 (기본 값 : none) none으로 설정하면 가이드라인이 표시되지 않고, underline으로 설정하면 가이드라인이 언더라인으로 표시됨
signpad_guideline_style | 서명 패드 가이드라인 선 스타일 (기본 값 : dashed) dashed로 설정하면 가이드라인이 점선으로 표시되고 solid로 설정하면 가이드라인이 실선으로 표시됨
signpad_guideline_thickness | 서명 패드 가이드라인 두께 (기본 값 : 5)
signpad_guideline_transparency | 서명 패드 가이드라인 투명도 (기본 값 : 128) 0 ~ 255 사이의 값으로 설정해야 하며, 작은 값으로 설정할수록 투명해짐
signpad_title_text | 서명 입력 창 제목 서명의 툴팁 텍스트가 빈 값인 경우에 적용됨. 단, 그룹 서명이고 서명 패드 표시 타입이 FitToFrame인 경우 툴팁 텍스트와 상관없이 signpad_title_text에서 설정한 값으로 적용됨
textbox_title_text | 텍스트 박스 입력 창 제목. 텍스트 박스의 툴팁 텍스트가 빈 값인 경우에 적용됨
title_bgcolor | 제목 영역 배경 색(기본 값 : 2D3E77)
title_font_color | 제목 영역 글꼴 색(기본 값 : FFFFFF)

이미지 파일의 경로는 Http URL, File URL 형식으로 설정할 수 있습니다.

만일, 이미지 경로를 공백으로 설정하거나 해당 경로에 이미지 파일이 없을 경우 기본 이미지로 표시됩니다.

설정 가능한 이미지 포맷은 JPG, PNG, GIF, BMP입니다.

서명 패드 가이드라인 관련 기능을 사용하려면 multiscreen.signpad_type 패러미터 값을 direct가 아닌 값으로 설정하시기 바랍니다.


multiscreen.extraparam

멀티 스크린 모듈에 전달할 패러미터를 설정합니다.

Reference

기본 값은 공백입니다.

패러미터 값은 "Key1=Value1,Key2=Value2,...,Keyn=Valuen" 형태로 설정합니다.

설정 가능한 Key는 아래와 같습니다.

Key | 설명
block_subscreen_at_edit | 모달 방식으로 입력 창 실행할지 여부 (기본 값 : false)
cancel_url | [취소] 버튼 이미지 경로
complete_url | [확인] 버튼 이미지 경로
input_title_position | 입력 다이얼로그의 타이틀 위치 (기본 값 : default)
next_disable_icon_url | 네비게이션 윈도우의 [다음] 버튼 이미지 경로 (비활성화 상태)
next_disable_url | [다음] 버튼 이미지 경로 (비활성화 상태)
next_icon_url | 네비게이션 윈도우의 [다음] 버튼 이미지 경로 (활성화 상태)
next_url | [다음] 버튼 이미지 경로 (활성화 상태)
prev_disable_icon_url | 네비게이션 윈도우의 [이전] 버튼 이미지 경로 (비활성화 상태)
prev_disable_url | [이전] 버튼 이미지 경로 (비활성화 상태)
prev_icon_url | 네비게이션 윈도우의 [이전] 버튼 이미지 경로 (활성화 상태)
prev_url | [이전] 버튼 이미지 경로 (활성화 상태)
reset_url | [초기화] 버튼 이미지 경로
sign_area_min_height | 서명 영역의 최소 높이 비율 (1 ~ 100) 단일 서명이고, multiscreen.signpad_type 패러미터 값이 dialog 또는 keypad이고, multiscreen.signpad_viewtype 패러미터 값이 fittoframe 또는 keepratio인 경우에만 적용됨 sign_area_min_height를 설정한 경우 signzoom은 적용되지 않음
signpad_background_color | 서명 패드 배경 색 (기본 값 : DADDE1) 서명의 실행 타입이 dialog이거나 keypad인 경우에만 적용됨
tablet | 연동할 멀티 스크린 제조사 ex) wacom, aha, moneual, securityvally, accu
tablet_dpi | 입력 다이얼로그의 타이틀 아이콘의 dpi (기본 값 : 96)
tablet_number | 서브 모니터로 설정할 모니터 tablet_number를 설정한 경우 tablet_size는 적용되지 않음
tablet_size | 멀티 스크린 화면 해상도. "가로/세로" 형태로 설정
tablet_window_rect | 서브 모니터에 표시되는 윈도우의 좌표 및 크기. "X/Y/WIDTH/HEIGHT" 형태로 설정
title_bgcolor | 제목 영역 배경 색 (기본 값 : DADDE1)
updatenow | 입력 컴포넌트의 값이 변경되면 바로 보고서에 적용할지 여부 (기본 값 : false)
use_sign_pressure | 서명 시 필압 사용 여부 (기본 값 : true)
zoomin_url | 툴 윈도우의 [확대] 버튼 이미지 경로
zoomout_url | 툴 윈도우의 [축소] 버튼 이미지 경로
zoomreset_url | 툴 윈도우의 [복원] 버튼 이미지 경로

이미지 파일의 경로는 Http URL, File URL 형식으로 설정할 수 있습니다.

만일, 이미지 경로를 공백으로 설정하거나 해당 경로에 이미지 파일이 없을 경우 기본 이미지로 표시됩니다.

설정 가능한 이미지 포맷은 JPG, PNG, GIF, BMP이며, 이미지의 높이가 40이 아닌 경우 높이 40에 맞춰 동일비율로 확대/축소됩니다.

멀티 스크린 장비의 해상도에 따라 이미지를 다르게 설정하려면 이미지 경로를 JSON 형식의 문자열로 설정하시기 바랍니다.

예를 들어, [확인] 버튼의 이미지 경로를 장비의 해상도에 따라 자동으로 적용하려면 아래와 같이 설정하시기 바랍니다.

multiscreen.extraparam=tablet=wacom,tablet_size=1080/1920,complete_url=["http://localhost:8080/10.bmp","http://localhost:8080/20.bmp","http://localhost:8080/30.bmp"]

input_title_position을 default로 설정할 경우 제목은 버튼 사이에 1줄로 표시되고, top으로 설정할 경우 버튼 상단에 2줄로 표시됩니다.

tablet_dpi는 96 ~ 300 사이의 값으로 설정 가능하며, 툴 윈도우 zoom 아이콘, 네비게이션 윈도우 이전/다음 아이콘, 컴포넌트 입력 다이얼로그 타이틀의 높이와 URL로 설정된 아이콘이 설정한 값으로 적용됩니다.

tablet_window_rect의 값 중 0보다 작은 값이 하나라도 있을 경우 설정한 값은 모두 무시되고 기본 값으로 적용됩니다. 또한, WIDTH/HEIGHT 값이 모니터 해상도의 WIDTH/HEIGHT의 1/2보다 작을 경우 모니터 해상도의 WIDTH/HEIGHT의 1/2로 설정되고, X와 WIDTH를 합한 값 또는 Y와 HEIGHT를 합한 값이 모니터 해상도의 WIDTH/HEIGHT 값보다 클 경우 WIDTH/HEIGHT는 모니터 해상도의 WIDTH/HEIGHT를 넘지 않는 최대 값으로 설정됩니다.

signpad_background_color는 서명의 실행 타입이 dialog인 경우 multiscreen.signpad_window_transparency 패러미터 값에 따라 서명 패드의 배경 색이 투명해질 수 있습니다.

서명과 라디오 버튼의 경우 해당 기능을 사용하려면 다이얼로그에서 입력 값을 전달받을 수 있도록 뷰어 패러미터를 설정하시기 바랍니다.

제목 영역 배경 색과 [이전]/[다음]/[다시쓰기]/[취소] 버튼의 이미지 경로를 설정하려면 multiscreen.custom_ui 패러미터 값을 빈 값으로 설정하시기 바랍니다.

See Also

multiscreen.radiobutton_type


multiscreen.highlight_border

서브 스크린에서 입력 창이 실행될 때 메인 스크린에 표시되는 컴포넌트의 테두리 색과 두께를 설정합니다.

Reference

패러미터 값은 {"Key1":"Value1","Key2":"Value2",...,"Keyn":"Valuen"} 형태로 설정합니다.

설정 가능한 Key는 아래와 같습니다.

Key | 설명
alpha | 테두리 색 알파 값 (기본 값 : 128)
color | 테두리 색 (기본 값 : FF0000)
thickness | 테두리 두께 (기본 값 : 5)


multiscreen.highlightpen_guide

형광펜으로 가이드한 입력 컴포넌트를 이전/다음 컴포넌트로 설정합니다.

Value

false 디자인 시점에 설정한 순서대로 이전/다음 순서를 정함

reorder 형광펜으로 가이드한 입력 컴포넌트 순서 기준으로 이전/다음 컴포넌트의 순서를 재배열함 (기본 값)


multiscreen.ignore_disable_color_inputcomponent

비활성화 상태인 입력 컴포넌트를 활성화 상태처럼 표시할지 여부를 설정합니다.

Value

true 모든 입력 컴포넌트를 활성화 상태처럼 표시

false 활성화 상태인 입력 컴포넌트만 활성화 상태로 표시 (기본 값)


multiscreen.inputpad_pos

입력 컴포넌트 편집 창의 표시 위치를 설정합니다.

Value

bottom 화면 아래 표시 (기본 값)

bycomponent 편집 창을 실행한 입력 컴포넌트의 위치에 따라 표시


multiscreen.main_disable_types

메인 스크린에서 비활성화시킬 입력 컴포넌트를 설정합니다.

Value

button 버튼

checkbox 체크 박스

combobox 콤보 박스

datetimepicker DateTimePicker

imagepicker ImagePicker

numericupdown NumericUpDown

radiobutton 라디오 버튼

signpad 서명

textbox 텍스트 박스

voicerecorder 녹음

Reference

컴포넌트를 여러 개 설정할 경우 콤마(,)를 구분자로하여 값을 나열합니다.


multiscreen.prev_next_page_icon_disable_url

이전/다음 페이지 이동 비활성화 아이콘의 url을 설정합니다.

Reference

콤마(",")를 구분자로하여 이전, 다음 순서로 아이콘의 url을 설정합니다.

해당 기능을 사용하려면 multiscreen.show_prev_next_page_icon=true로 설정하시기 바랍니다.


multiscreen.prev_next_page_icon_margin

이전/다음 버튼 페이지 이동 아이콘의 여백을 설정합니다.

Reference

콤마(",")를 구분자로하여 가로 여백, 세로 여백 순서로 아이콘의 여백을 설정합니다.

값을 설정하지 않은 경우 왼쪽/오른쪽에 10픽셀씩 여백이 적용되며, 위쪽/아래쪽의 정가운데에 아이콘이 표시됩니다.

아이콘을 화면 가운데로 표시하려면 가로 여백을 10보다 큰 값으로 설정하고, 아이콘을 화면 상단에 표시하려면 세로 여백을 음수 값으로, 화면 하단에 표시하려면 세로 여백을 양수 값으로 설정하시기 바랍니다.

해당 기능을 사용하려면 multiscreen.show_prev_next_page_icon=true로 설정하시기 바랍니다.


multiscreen.prev_next_page_icon_size

이전/다음 페이지 이동 버튼 아이콘의 크기를 설정합니다.

Reference

콤마(",")를 구분자로하여 너비, 높이 순서로 아이콘의 크기를 설정합니다.

해당 기능을 사용하려면 multiscreen.show_prev_next_page_icon=true로 설정하시기 바랍니다.


multiscreen.prev_next_page_icon_url

이전/다음 페이지 이동 활성화 아이콘의 url을 설정합니다.

Reference

콤마(",")를 구분자로하여 이전, 다음 순서로 아이콘의 url을 설정합니다.

해당 기능을 사용하려면 multiscreen.show_prev_next_page_icon=true로 설정하시기 바랍니다.


multiscreen.radiobutton_type

라디오 버튼의 실행 타입을 설정합니다.

Value

dialog 다이얼로그 형태로 실행 (기본 값)

dialog_at_prev_next 다른 컴포넌트의 이전/다음 순서가 라디오 버튼인 경우에만 다이얼로그 형태로 실행

direct 보고서 화면에서 직접 선택하는 형태로 실행

ensurevisible_at_prev_next 다른 컴포넌트의 이전/다음 순서가 라디오 버튼인 경우 라디오 버튼이 화면에 표시되도록 보고서를 자동으로 스크롤하고, 이전/다음 동작을 멈춤


multiscreen.screentype

멀티 스크린 환경에서 뷰어를 표시할 모니터 타입을 설정합니다.

Value

monitor 메인 모니터에 표시 (기본 값)

submonitor 서브 모니터에 표시

Reference

서브 모니터에서는 뷰어 프레임이 표시되지 않습니다. 그러므로 프레임 관련 패러미터가 동작하지 않습니다.

모니터 타입을 서브 모니터로 설정하려면 viewer.isframe 패러미터를 true 혹은 inprocess로 설정하시기 바랍니다.

또한, 뷰어를 서브 모니터에 표시할 경우 multiscreen 패러미터 그룹은 적용되지 않습니다.


multiscreen.show_prev_next_page_icon

이전/다음 페이지 이동 아이콘의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


multiscreen.show_scrollbar

멀티 스크린 환경에서 서브 모니터의 세로 스크롤 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


multiscreen.showthumbnail

보고서 바인딩 완료 후 페이지 축소판 창을 서브 스크린에 바로 표시할지 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


multiscreen.signpad_type

멀티 스크린 환경에서 서명의 실행 타입을 설정합니다.

Value

dialog 서명을 클릭하면 해당 컴포넌트 위에 모달 다이얼로그 형태로 서명 패드가 표시됨

direct 서명을 클릭하여 바로 서명

keypad 서명을 클릭하면 창 하단에 서명 패드가 표시됨 (기본 값)


multiscreen.signpad_viewtype

multiscreen.signpad_type

멀티 스크린 환경에서 서명 패드 표시 타입을 설정합니다.

Value

fittoframe 서명 패드 전체 영역을 서명 영역으로 표시

keepratio 서명의 크기 비율대로 서명 영역을 표시 (기본 값)

scrollable 서명 패드 전체 영역을 서명 영역으로 표시하고 하단에 가로 스크롤 표시

Reference

패러미터 값을 scrollable로 설정하려면 multiscreen.signpad_type 패러미터를 dialog 또는 keypad로 설정하시기 바랍니다.


multiscreen.signpad_window_transparency

멀티 스크린 환경에서 서명 창의 배경 투명도를 설정합니다.

Reference

기본 값은 100입니다.

0~255 사이의 값으로 설정해야 하며, 작은 값으로 설정할수록 투명해집니다.

제목 영역은 투명도가 적용되지 않습니다.

"multiscreen.signpad_type=dialog"인 경우에만 적용됩니다.


multiscreen.sub_disable_types

서브 스크린에서 비활성화시킬 입력 컴포넌트를 설정합니다.

Value

button 버튼

checkbox 체크 박스

combobox 콤보 박스

datetimepicker DateTimePicker

imagepicker ImagePicker

numericupdown NumericUpDown

radiobutton 라디오 버튼

signpad 서명

textbox 텍스트 박스

voicerecorder 녹음

Reference

컴포넌트를 여러 개 설정할 경우 콤마(,)를 구분자로하여 값을 나열합니다.


multiscreen.thumbnail_icon_margin

서브 스크린에 표시되는 페이지 축소판 보기 아이콘의 여백을 설정합니다.

Reference

기본 값은 10, 10이며, 단위는 퍼센트입니다.

콤마(",")를 구분자로하여 왼쪽 여백, 위쪽 여백 순서로 아이콘의 여백을 설정합니다.

0~100 사이의 값으로 설정해야 하며, 100으로 설정한 경우 오른쪽 하단에 표시됩니다.


multiscreen.thumbnail_icon_url

서브 스크린에 표시되는 페이지 축소판 보기 아이콘의 이미지를 설정합니다.

Reference

이미지 파일의 경로는 Http URL, File URL 형식으로 설정할 수 있습니다.

만일, 이미지 경로를 공백으로 설정하거나 해당 경로에 이미지 파일이 없을 경우 기본 이미지로 표시됩니다.

설정 가능한 이미지 포맷은 JPG, PNG, GIF, BMP입니다.

페이지 축소판 보기 아이콘의 크기는 multiscreen.extraparam의 tablet_dpi 값에 따라 적용되며, 서브 스크린 높이의 1/30에 맞춰 동일비율로 확대/축소됩니다.


multiscreen.thumbnail_title

서브 스크린에 표시되는 페이지 축소판 창의 제목을 설정합니다.

Reference

기본 값은 페이지 축소판입니다.


multiscreen.thumbnailviewsize

서브 스크린에 표시되는 페이지 축소판 창의 너비를 설정합니다.

Reference

기본 값은 30이며, 단위는 퍼센트입니다.

서브 스크린 창 너비를 기준으로 적용되며, 10 ~ 90 사이의 값으로 설정 가능합니다.


multiscreen.viewmode

멀티 스크린 뷰어의 보고서 보기 모드를 설정합니다.

Value

fittoframe 화면 크기에 맞추기

fittowidth 너비에 맞추기 (기본 값)


multiscreen.zoom

보고서 화면의 비율을 설정합니다.

Reference

기본 값은 100입니다.

비율은 50부터 1000까지 설정할 수 있습니다.


odi

보고서 데이터셋 정보 (ODI) 관련 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
odi.odiname.args# | O | O | O | O | O | O | O | O | O
odi.odiname.clientdmtype | O | O | O | O | O | O | O | O | O
odi.odiname.compresseddatamodule | O | O | O | O | O | O | O | O | O
odi.odiname.disconnectcache | O | O | X | O | X | X | O | O | O
odi.odiname.fetchtype | O | O | O | O | O | O | O | O | O
odi.odiname.frameworkurl | O | O | O | O | O | O | O | O | O
odi.odiname.pcount | O | O | O | O | O | O | O | O | O
odi.odiname.ozserver.pass | O | O | O | O | O | O | O | O | O
odi.odiname.ozserver.port | O | O | X | O | X | X | O | O | O
odi.odiname.ozserver.server | O | O | X | O | X | X | O | O | O
odi.odiname.ozserver.servlet | O | O | O | O | O | O | O | O | O
odi.odiname.ozserver.user | O | O | O | O | O | O | O | O | O
odi.odiname.serverdmtype | O | O | O | O | O | O | O | O | O
odi.odiname.usescheduleddata | O | O | O | O | O | O | O | O | O
odi.odinames | O | O | O | O | O | O | O | O | O


odi.odiname.args#

ODI에 추가된 사용자 지정 패러미터 값을 설정합니다.

Reference

#은 숫자 값으로 몇 번째 패러미터인지를 알려주는 번호이며, 1부터 odi.odiname.pcount에 설정한 값까지 사용할 수 있습니다.

패러미터 값은 "패러미터이름=패러미터값" 형태로 설정합니다.

예를 들어, ODI 패러미터 중 Country는 Korea로, City는 Seoul로 설정할 경우 아래와 같이 패러미터 값을 설정합니다.(아래 태그는 ActiveX 뷰어 기준입니다.)

<param name = "odi.odinames" value="sales">

<param name = "odi.sales.pcount" value="2">

<param name = "odi.sales.args1" value="Country=Korea">

<param name = "odi.sales.args2" value="City=Seoul">

See Also

odi.odinames


odi.odiname.clientdmtype

오즈 뷰어의 데이터 모듈 처리 방식을 설정합니다.

Value

normal 오즈 서버로부터 데이터 모듈을 모두 받은 후 보고서 바인딩 시작

memory 오즈 서버로부터 데이터 모듈을 메모리로 받으면서 보고서 바인딩을 동시에 진행 (기본 값)

file 오즈 서버로부터 데이터 모듈을 파일로 받으면서 보고서 바인딩을 동시에 진행

Reference

odi.odiname.clientdmtype은 ODI의 데이터 셋을 대상으로 하고 connection.clientdmtype은 전체 ODI를 대상으로 합니다.

Flash, HTML5, Android, iOS, WinRT 뷰어의 경우 file로 설정해도 memory로 동작합니다.


odi.odiname.compresseddatamodule

오즈 서버에 데이터 모듈 요청 시 압축 여부를 설정합니다.

Value

true 압축된 데이터 모듈 요청

false 압축되지 않은 데이터 모듈 요청 (기본 값)


odi.odiname.disconnectcache

데이터 모듈 파일(*.SDM)을 받은 중 네트웍 연결이 끊어졌거나 뷰어가 비정상 종료된 후 다시 접속을 시도할 경우 받은 파일 이후부터 이어받을지 여부를 설정합니다.

Value

true 이어받음

false 이어받지 않음 (기본 값)


odi.odiname.fetchtype

오즈 서버의 데이터 모듈 처리 방식을 설정합니다.

Value

batch 모든 데이터의 데이터 모듈 생성 작업을 완료한 후 데이터 모듈을 전송함 (기본 값)

concurrent 데이터 모듈 생성과 전송 작업을 동시에 실행

Reference

connection.fetchtype은 전체 ODI를 대상으로 하며 설정 내용은 동일합니다.


odi.odiname.frameworkurl

프레임웍 URL을 설정합니다.


odi.odiname.pcount

ODI에 추가된 사용자 지정 패러미터 개수를 설정합니다.


odi.odiname.ozserver.pass

사용자 패스워드를 설정합니다.

Reference

기본 값은 guest입니다.

보고서 파일을 가져오는 서버와 다른 서버에서 데이터 모듈을 가져오고자 할 경우 설정합니다.


odi.odiname.ozserver.port

데몬 타입의 오즈 서버 포트를 설정합니다.

Reference

폼 파일을 가져오는 서버와 다른 서버에서 데이터를 가져오고자 할 경우 설정합니다.


odi.odiname.ozserver.server

데몬 타입의 오즈 서버 IP를 설정합니다.

Reference

폼 파일을 가져오는 서버와 다른 서버에서 데이터를 가져오고자 할 경우 설정합니다.

USL 사용 여부는 서버별로 설정할 수 없습니다. 즉, 폼 파일을 가져오는 서버의 USL 사용 옵션과 동일한 ODI 서버를 설정하여야 하며, 다르게 설정할 때는 데이터를 바인딩할 수 없습니다.


odi.odiname.ozserver.servlet

서블릿 타입의 오즈 서버 IP를 설정합니다.

Reference

폼 파일을 가져오는 서버와 다른 서버에서 데이터를 가져오고자 할 경우 설정합니다.

USL 사용 여부는 서버별로 설정할 수 없습니다. 즉, 폼 파일을 가져오는 서버의 USL 사용 옵션과 동일한 ODI 서버를 설정하여야 하며, 다르게 설정할 때는 데이터를 바인딩할 수 없습니다.


odi.odiname.ozserver.user

사용자 ID를 설정합니다.

Reference

기본 값은 guest입니다.

보고서 파일을 가져오는 서버와 다른 서버에서 데이터 모듈을 가져오고자 할 경우 설정합니다.


odi.odiname.serverdmtype

오즈 서버의 데이터 모듈 생성 옵션을 설정합니다.

Value

file 파일 이용

memory 메모리 이용 (기본 값)

Reference

데이터 모듈이 대용량일 경우 file로 설정하여 오즈 서버의 부하를 줄일 수 있습니다.


odi.odiname.usescheduleddata

보고서 미리보기 시 사용할 데이터 모듈 파일(*.SDM)의 파일명을 설정합니다.

Reference

스케줄러 등에 의해 미리 생성된 데이터 모듈 파일(*.SDM)을 이용하여 보고서를 보고자 할 때 사용합니다.

SDM 파일의 경로는 오즈 리파지토리 경로(ozp://), 웹 서버 경로(http://), 로컬 경로(file://)로 설정할 수 있습니다.

단, Flash, HTML5 뷰어는 오즈 서버 환경 설정 파일 중 conf/srmngr.properties 파일의 datamodule_path에 설정한 경로를 기준으로 하여 상대 경로로 설정합니다. 또한, srmngr.properties 파일의 use_scheduled_data 옵션을 true로 설정하여야 합니다.

"connection.datafromserver=false"로 설정하여야 적용됩니다.


odi.odinames

ODI 이름을 설정합니다.

Reference

ODI 이름을 여러 개 설정하려면 콤마(,)를 구분자로하여 ODI 이름을 나열합니다.


ozd

OZD 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
ozd.filename | O | O | O | O | O | X | O | O | X
ozd.includeedithistory | X | X | X | X | X | X | O | O | O
ozd.includeedits | O | O | O | O | O | X | O | O | O
ozd.includeimage | O | O | O | O | O | X | O | O | O
ozd.memoallowed | O | O | O | O | O | X | O | O | X
ozd.password | O | O | O | O | O | X | O | O | O
ozd.path | O | O | X | O | X | X | O | O | X
ozd.saveall | O | O | O | O | O | X | O | O | O

O

Only e-Form


ozd.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


ozd.includeedithistory

입력 컴포넌트 변경 이력 저장 여부를 설정합니다.

Value

true 저장

false 저장 안 함 (기본 값)

Reference

입력 컴포넌트 변경 이력 저장 기능은 OZR 형식의 보고서를 OZD 형식으로 저장할 경우에만 사용할 수 있습니다. 해당 기능을 사용하려면 ozd.includeedits 패러미터와 이 패러미터를 true로 설정한 후 OZD 형식으로 저장하시기 바랍니다.

입력 컴포넌트 변경 이력 저장 기능이 이미 적용된 OZD 파일은 패러미터 값과 상관없이 항상 변경 이력이 저장됩니다.

기존에 저장된 변경 이력을 초기화하려면 ozd.includeedits 패러미터를 false로 설정한 후 OZD 형식으로 저장하시기 바랍니다.


ozd.includeedits

편집 내용 포함 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

OZD 저장 옵션 다이얼로그


ozd.includeimage

이미지 포함 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

OZD 저장 옵션 다이얼로그


ozd.memoallowed

메모, 콜 아웃 도형(선, 화살표, 사각형, 원)의 추가 허용 여부를 설정합니다.

Value

true 허용 (기본 값)

false 허용 안 함

Reference

OZR 파일을 OZD 형식의 파일로 저장할 경우에만 적용됩니다.

패러미터 값이 false로 설정된 상태에서 저장된 OZD 파일을 오즈 뷰어에서 열기하면 메모와 콜아웃 도형을 추가할 수 없도록 관련 아이콘(메모 추가, 선 추가, 화살표 추가, 사각형 추가, 원 추가)이 비활성화됩니다.


ozd.password

암호 옵션을 설정합니다.

See Also

OZD 저장 옵션 다이얼로그


ozd.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


ozd.saveall

모든 보고서 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

OZD 저장 옵션 다이얼로그


ozsystem

시스템 필드 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
ozsystem.location_address | O | O | O | O | O | O | O | O | O
ozsystem.user_id | O | O | O | O | O | O | O | O | O
ozsystem.user_name | O | O | O | O | O | O | O | O | O


ozsystem.location_address

시스템 필드 중 Location_Address 값을 설정합니다.

Reference

Location_Address는 OZR/OZD 파일에 상관없이 패러미터 값이 적용됩니다.


ozsystem.user_id

시스템 필드 중 User_ID와 Creator_ID 값을 설정합니다.

Reference

User_ID는 OZR/OZD 파일에 상관없이 패러미터 값이 적용됩니다.

Creator_ID는 OZR을 미리보기한 경우에만 적용됩니다. OZD를 미리보기한 경우에는 OZD 저장 시 시스템 라벨에 표시된 값이 적용됩니다.


ozsystem.user_name

시스템 필드 중 User_Name과 Creator_Name 값을 설정합니다.

Reference

User_Name은 OZR/OZD 파일에 상관없이 패러미터 값이 적용됩니다.

Creator_Name은 OZR을 미리보기한 경우에만 적용됩니다. OZD를 미리보기한 경우에는 OZD 저장 시 시스템 라벨에 표시된 값이 적용됩니다.


pdf

PDF 파일 저장 관련 상세 저장 옵션을 설정합니다.

Android/iOS 뷰어에서 PDF 파일 형식으로 저장하려면 아래와 같은 설정이 필요합니다.

[Android]

·Eclipse 프로젝트에 라이브러리 추가

libozrvpack_pdfwriter.so

[iOS]

·Xcode 프로젝트에 라이브러리 추가

libozrvpack_pdfwriter.a

·스크립트 추가

해당 기능을 사용하기 전에 __OZExportPack_load_pdf() 함수 호출

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
pdf.author | O | O | O | O | O | O | O | O | O
pdf.changeable | O | O | O | O | O | O | O | O | O
pdf.contentscopy | O | O | O | O | O | O | O | O | O
pdf.converted_jpg_quality | O | O | O | O | O | O | O | O | O
pdf.convertedimagedpi | O | O | O | O | O | O | O | O | O
pdf.creator | O | O | O | O | O | O | O | O | O
pdf.filename | O | O | O | O | O | O | O | O | X
pdf.fontembedding | O | O | X | O | X | X | X | X | X
pdf.fontembedding_prefix | O | O | X | O | X | X | X | X | X
pdf.keyword | O | O | O | O | O | O | O | O | O
pdf.masterpassword | O | O | O | O | O | O | O | O | O
pdf.navigationpanes | O | O | O | O | O | O | O | O | O
pdf.pagedisplay | O | O | O | O | O | O | O | O | O
pdf.path | O | O | X | O | X | X | O | O | X
pdf.printable | O | O | O | O | O | O | O | O | O
pdf.save_tree_as_bookmark | O | O | O | O | O | O | O | O | O
pdf.savecharttoimage | O | O | O | O | O | O | O | O | O
pdf.savecomment | O | O | O | O | O | X | O | O | O
pdf.savelinktoc | O | O | O | O | O | O | O | O | O
pdf.savelinkurl | O | O | O | O | O | O | O | O | O
pdf.subject | O | O | O | O | O | O | O | O | O
pdf.title | O | O | O | O | O | O | O | O | O
pdf.userpassword | O | O | O | O | O | O | O | O | O

O

Only e-Form


pdf.author

작성자 옵션을 설정합니다.

Reference

기본 값은 Forcs co., Ltd.입니다.

See Also

PDF 저장 옵션 다이얼로그


pdf.changeable

변경 허용 옵션을 설정합니다.

Value

none 없음

commenting_filling_in_formfields_and_signing 주석 달기, 양식 필드 채우기 및 서명

pagelayout_filling_in_formfields_and_signing 페이지 레이아웃, 양식 필드 채우기 및 서명

any_except_extracting_of_pages 페이지 추출을 제외한 모두 (기본 값)

See Also

PDF 저장 옵션 다이얼로그


pdf.contentscopy

내용 복사 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

PDF 저장 옵션 다이얼로그


pdf.converted_jpg_quality

PDF 파일로 저장할 때 JPEG로 변환되는 이미지의 품질을 설정합니다.

Reference

기본 값은 100이며, 0 ~ 100 사이의 값으로 설정합니다.

보고서를 PDF로 저장할 때 이미지 라벨의 이미지 형식이 JPEG 또는 GIF 포맷이 아닌 경우 이미지를 JPEG로 변환한 후 PDF로 저장합니다.

이때, 이미지를 JPEG로 변환하는 과정에서 JPEG로 변환한 이미지의 데이터 크기가 원본 이미지의 데이터 크기보다 클 경우 저장된 PDF 파일의 크기도 커지는 문제점이 있습니다. 만일, 이미지의 손실이 있어도 PDF 파일의 크기를 줄이고자할 경우 패러미터 값을 100보다 작은 값으로 설정하시기 바랍니다.


pdf.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


pdf.creator

응용프로그램 옵션을 설정합니다.

Reference

기본 값은 OZ Report Viewer입니다.

See Also

PDF 저장 옵션 다이얼로그


pdf.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


pdf.fontembedding

폰트 포함 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

PDF 저장 옵션 다이얼로그


pdf.fontembedding_prefix

폰트를 포함하여 보고서 저장 시 폰트 이름 앞에 추가할 접두사를 설정합니다.

Reference

이 기능을 사용하려면 pdf.fontembedding 패러미터를 true로 설정하세요.


pdf.keyword

키워드 옵션을 설정합니다.

See Also

PDF 저장 옵션 다이얼로그


pdf.masterpassword

마스터 암호 옵션을 설정합니다.

See Also

PDF 저장 옵션 다이얼로그


pdf.navigationpanes

저장된 PDF 파일을 열었을 때 PDF Reader의 탐색 창 표시 옵션을 설정합니다.

Value

none 탐색 창 표시 안 함 (기본 값)

bookmarks 탐색 창에 책갈피 표시

page_thumbnails 탐색 창에 페이지 축소판 표시

Reference

책갈피 기능을 사용하려면 PDF로 익스포트할 보고서에 목차 라벨이 설정되어야 합니다.


pdf.pagedisplay

저장된 PDF 파일을 열었을 때 PDF Reader의 페이지 표시 방식을 설정합니다.

Value

enable_scrolling 스크롤링을 활성화하여 페이지를 계속 표시

single_page_view 한 페이지씩 표시 (기본 값)

two_page_scrolling 계속 스크롤링하여 연결된 페이지를 표시

two_page_view 두 페이지씩 연결하여 표시


pdf.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


pdf.printable

인쇄 허용 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

PDF 저장 옵션 다이얼로그


pdf.save_tree_as_bookmark

PDF 파일의 책갈피를 트리 창의 구조와 동일하게 저장할지 여부를 설정합니다.

Value

true 트리 창 구조와 동일하게 저장

false 목차 링크와 URL 링크를 단일 구조로 저장 (기본 값)


pdf.savecharttoimage

차트를 이미지로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

PDF 저장 옵션 다이얼로그


pdf.savecomment

PDF 파일로 저장할 때 주석을 포함하여 저장할지 여부를 설정합니다.

Value

true 주석 포함하여 저장

false 주석 저장 안 함 (기본 값)


pdf.savelinktoc

목차 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


pdf.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


pdf.subject

주제 옵션을 설정합니다.

See Also

PDF 저장 옵션 다이얼로그


pdf.title

제목 옵션을 설정합니다.

See Also

PDF 저장 옵션 다이얼로그


pdf.userpassword

사용자 암호 옵션을 설정합니다.

See Also

PDF 저장 옵션 다이얼로그


png

PNG 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
png.filename | O | O | O | O | O | O | O | O | X
png.path | O | O | X | O | X | X | O | O | X
png.savecomment | O | O | O | O | O | X | O | O | O
png.zoom | O | O | O | O | O | O | O | O | O

O

Only e-Form


png.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


png.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


png.savecomment

PNG 파일로 저장할 때 주석을 포함하여 저장할지 여부를 설정합니다.

Value

true 주석 포함하여 저장

false 주석 저장 안 함 (기본 값)


png.zoom

확대/축소 비율 옵션을 설정합니다.

Reference

기본 값은 100이며, 10~1000 사이의 값으로 설정합니다.

See Also

PNG 저장 옵션 다이얼로그


ppt

PPT 파일 저장 관련 상세 저장 옵션을 설정합니다.

Android/iOS 뷰어에서 PPT 파일 형식으로 저장하려면 아래와 같은 설정이 필요합니다.

[Android]

·Eclipse 프로젝트에 라이브러리 추가

libozrvpack_pptwriter.so

[iOS]

·Xcode 프로젝트에 라이브러리 추가

libozrvpack_pptwriter.a

·스크립트 추가

해당 기능을 사용하기 전에 __OZExportPack_load_ppt() 함수 호출

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
ppt.convertedimagedpi | O | O | O | O | O | O | O | O | O
ppt.filename | O | O | O | O | O | O | O | O | X
ppt.path | O | O | X | O | X | X | O | O | X
ppt.saveastable | O | O | O | O | O | O | O | O | O


ppt.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


ppt.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


ppt.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


ppt.saveastable

테이블 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

PPT 저장 옵션 다이얼로그


print

인쇄 관련 상세 옵션을 설정합니다.

Android 뷰어에서 인쇄 기능을 사용하려면 Android 버전이 4.4 kitkat 이상이어야 하고, ozprint_android.jar 파일이 프로젝트에 로딩되어야 합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
print.adjust | O | O | O | O | O | X | X | X | X
print.alldocument | O | O | O | O | O | O | X | X | X
print.chart_areafigures_at_grayscale | O | O | X | O | X | X | X | X | X
print.close | O | O | X | O | X | X | X | X | X
print.collate | O | O | O | O | O | X | X | X | X
print.copies | O | O | O | O | O | X | X | X | X
print.dividepage | O | O | O | O | X | X | X | X | X
print.duplex | O | O | X | O | X | X | X | X | X
print.duplexprintbyreport_at_concatpage | O | O | X | O | X | X | O | O | X
print.externalmodule | O | O | X | O | X | X | X | X | X
print.externalmoduleex | O | O | X | O | X | X | X | X | X
print.gray | O | O | X | O | X | X | X | O | X
print.jobname | O | O | X | O | X | X | X | X | X
print.lockfileprint | O | O | X | X | X | X | X | X | X
print.lockopt | O | O | O | O | O | X | O | O | X
print.mode | O | O | X | O | X | X | X | X | X
print.noprintermessage | O | O | X | O | X | X | X | X | X
print.once | O | O | O | O | O | X | O | O | X
print.orientation | O | O | X | O | X | X | X | O | X
print.pageorder | O | O | O | O | X | X | O | O | X
print.pageorient | O | O | O | O | X | X | O | O | X
print.pagerange | O | O | O | O | O | O | X | O | X
print.pages | O | O | O | O | O | O | X | O | X
print.pagesinone | O | O | O | O | X | X | O | O | X
print.per_page_in_largebundle | O | O | X | O | X | X | X | X | X
print.printbypage | O | O | X | O | X | X | X | X | X
print.printername | O | O | X | O | X | X | X | X | X
print.properties | O | X | X | O | X | X | X | X | X
print.reports | O | X | X | X | O | O | X | X | X
print.scaling | O | O | X | O | X | X | X | X | X
print.shownoprinter | O | O | X | O | X | X | X | X | X
print.size | O | O | X | O | X | X | X | X | X
print.skip | O | O | O | O | O | X | O | O | X
print.spoolpages | O | O | X | O | X | X | X | X | X
print.style | O | O | O | O | X | X | O | O | X
print.trayname | O | O | X | X | X | X | X | X | X
print.usedefaultpaper | O | O | X | O | X | X | X | X | X
print.usedialogopt | O | O | O | O | X | X | X | X | X
print.useprinterpaper | O | O | X | O | X | X | X | X | X
print.useprintstop | O | O | X | O | X | X | X | X | X
print.useprogressbar | O | O | X | O | X | X | X | X | X
print.useselectedreport | O | X | X | X | O | O | X | X | X


print.adjust

용지에 맞춰 인쇄 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

인쇄 다이얼로그


print.alldocument

모든 문서 인쇄 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

인쇄 다이얼로그


print.chart_areafigures_at_grayscale

보고서를 흑백으로 인쇄할 때 차트의 색은 무시하고 패턴과 테두리를 적용하여 인쇄할지 여부를 설정합니다.

Value

true 패턴과 테두리를 적용하여 인쇄 함

false 화면에 보이는 대로 인쇄 함 (기본 값)

Reference

패러미터를 true로 설정하면 차트의 색은 인쇄하지 않고, 패턴과 테두리를 적용하여 인쇄합니다.

인쇄되는 패턴은 차트 마법사의 [면 패턴]에서 설정한 패턴 순서로 인쇄되며, 설정한 패턴이 없을 경우 기본 패턴 순서로 인쇄됩니다. 또한, 테두리는 검은색으로 인쇄됩니다.

프린터 속성 창에서 컬러 옵션이 "예"로 설정된 경우 흑백 프린터일 경우에도 컬러 프린터로 인식되어, 해당 패러미터가 적용되지 않습니다.


print.close

인쇄 후 뷰어 창을 닫을지 여부를 설정합니다.

Value

true 인쇄 후 뷰어 창 닫음

false 인쇄 후 뷰어 창 닫지 않음 (기본 값)

Reference

StandAlone 뷰어에서만 사용합니다.


print.collate

한 부씩 인쇄 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

인쇄 다이얼로그


print.copies

인쇄 매수를 설정합니다.

Reference

기본 값은 1입니다.

See Also

인쇄 다이얼로그


print.dividepage

용지에 맞춰서 분할 인쇄 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

인쇄 옵션 다이얼로그


print.duplex

양면인쇄를 설정합니다.

Value

빈 문자 프린터에 설정된 양면 인쇄 옵션 값을 따름 (기본 값)

none 없음

duplexvertical 긴 쪽으로 넘김

duplexhorizontal 짧은 쪽으로 넘김

See Also

인쇄 옵션 다이얼로그


print.duplexprintbyreport_at_concatpage

보고서가 바뀌면 새로운 용지로 인쇄할지 여부를 설정합니다.

Value

true 새로운 용지로 인쇄

false 이전 보고서에 이어서 인쇄 (기본 값)

Reference

이 패러미터는 여러 개의 보고서를 하나의 보고서처럼 바인딩한 상태에서 양면 인쇄 또는 모아찍기 인쇄할 때 보고서가 바뀌면 용지도 바꿔서 인쇄하고자 할 때 사용합니다.

예를 들어, 3페이지인 보고서 두 개를 global.concatpage=true로 설정하여 하나의 보고서처럼 바인딩한 상태에서 용지당 4페이지씩 모아찍기로 인쇄하면 1~4페이지 즉, 첫 번째 보고서와 두 번째 보고서의 1페이지가 첫 번째 용지에 인쇄됩니다. 이때 두 번째 보고서를 새로운 용지에 인쇄하려면 패러미터 값을 true로 설정하시기 바랍니다.

global.concatpage 패러미터와 print.collate 패러미터 값이 true인 경우에 적용됩니다.


print.externalmodule

보고서를 인쇄할 때 사용할 외부 모듈을 설정합니다.

Reference

로컬 경로 설정 시 전체 경로뿐만 아니라 상대 경로도 설정 가능합니다.


print.externalmoduleex

보고서를 인쇄할 때 사용할 외부 모듈을 설정합니다.

Reference

로컬 경로 설정 시 전체 경로뿐만 아니라 상대 경로도 설정 가능합니다.


print.gray

흑백 인쇄 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Value :

See Also

인쇄 옵션 다이얼로그


print.jobname

인쇄 시 프린터 스풀에 표시되는 작업명을 설정합니다.


print.lockfileprint

파일로 인쇄 옵션의 표시 및 비활성화 여부를 설정합니다.

Value

none 활성화하여 표시 (기본 값)

invisible 표시 안 함

disable 비활성화하여 표시

See Also

인쇄 다이얼로그


print.lockopt

인쇄 옵션 변경 불가능 여부를 설정합니다.

Value

true 변경 불가능

false 변경 가능 (기본 값)

Reference

true로 설정하면 인쇄 다이얼로그의 모든 옵션이 비활성화됩니다.

See Also

인쇄 다이얼로그


print.mode

인쇄 모드를 설정합니다.

Value

showprintdlg/true 인쇄 다이얼로그 표시. 미리보기 화면에서 인쇄한 경우 프로그레스 바가 표시되고, 그 외의 경우 프로그레스 바가 표시되지 않음 (기본 값)

showprogress 인쇄 다이얼로그 표시. 인쇄 시 프로그레스 바를 항상 표시

silent/false 인쇄 다이얼로그를 표시하지 않고 인쇄. 미리보기 화면에서 인쇄한 경우 프로그레스 바가 표시되고, 그 외의 경우 프로그레스 바가 표시되지 않음


print.noprintermessage

사용 가능한 프린터가 없을 경우 화면에 표시할 에러 메시지를 설정합니다.

Reference

"print.shownoprinter=true"인 경우에 적용됩니다.

패러미터를 설정하지 않거나 값을 빈 문자로 설정하면 "사용자 PC에 사용할 수 있는 프린터가 존재하지 않습니다. 기본 프린터 혹은 지정된 프린터를 확인하십시오."라는 에러 메시지가 표시됩니다.

See Also

인쇄 다이얼로그


print.once

인쇄 횟수를 한 번으로 제한합니다.

Value

true 인쇄를 한 번으로 제한

false 인쇄 횟수 제한 없음 (기본 값)

Reference

true로 설정하면 보고서를 인쇄한 후에는 툴바의 인쇄 아이콘이 비활성화됩니다.


print.orientation

용지 방향 옵션을 설정합니다.

Value

portrait 세로

landscape 가로

Reference

기본 값은 원본 보고서에서 설정한 용지 방향입니다.

원본 보고서의 용지 방향 설정과 다를 경우 사용자가 설정한 용지 방향에 맞춰 보고서 사이즈를 확대 및 축소합니다.

See Also

인쇄 다이얼로그


print.pageorder

모아찍기의 인쇄 순서 옵션을 설정합니다.

Value

horizontal 수평 (기본 값)

vertical 수직

See Also

인쇄 옵션 다이얼로그


print.pageorient

모아찍기의 인쇄 방향 옵션을 설정합니다.

Value

horizontal 가로 (기본 값)

vertical 세로

Reference

Android 뷰어는 다른 뷰어와 다르게 인쇄 방향에 따라 용지 방향이 자동으로 조정되지 않습니다. 다른 뷰어에서 인쇄된 것과 동일하게 모아찍기하려면 먼저 메인 툴바에서 용지 방향을 변경한 후 모아찍기하시기 바랍니다.

See Also

인쇄 옵션 다이얼로그


print.pagerange

인쇄 범위 옵션을 설정합니다.

Value

all 모두 (기본 값)

current 현재 페이지

range 페이지 지정

selected 선택된 페이지

selectedreport 리포트 지정

Reference

패러미터 값을 selectedreport로 설정한 경우 인쇄 아이콘을 클릭하면 리포트 선택 다이얼로그가 먼저 표시되고, [확인] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다. 리포트 선택 다이얼로그에는 OZR/OZD에 추가된 리포트가 리스트 형태로 표시됩니다.

리포트 지정 기능은 ActiveX, HTML5 뷰어에서만 지원되며, 해당 기능을 사용하려면 print.useselectedreport 패러미터 값을 true로 설정하시기 바랍니다.

See Also

인쇄 다이얼로그


print.pages

인쇄할 페이지 범위를 "시작 페이지-끝 페이지,페이지 번호,시작 페이지-끝 페이지" 형태로 설정합니다.

Reference

"print.pagerange=range"인 경우에 적용됩니다.

See Also

인쇄 다이얼로그


print.pagesinone

모아찍기의 한 페이지에 인쇄할 페이지 수 옵션을 설정합니다.

Reference

"print.style=gather"인 경우에 적용됩니다.

See Also

인쇄 옵션 다이얼로그


print.per_page_in_largebundle

페이지 별 인쇄 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

인쇄 옵션 다이얼로그


print.printbypage

보고서를 인쇄할 때 페이지 구조 보기 창에 표시된 행 단위로 프린터 스풀에 전송할지 여부를 설정합니다.

Value

true 페이지 구조 보기 창에 표시된 행 단위로 프린터 스풀에 전송

false 전체 보고서를 한꺼번에 전송 (기본 값)

Reference

"viewer.mode=print"인 경우에 적용됩니다.

이 패러미터 값이 true인 경우 print.collate 패러미터는 항상 false로 동작합니다.

보고서에 페이지를 표시하는 시스템 라벨(Page_Number, Total_Page, Page_Of_Total)이 추가된 경우 이 패러미터는 동작하지 않습니다.


print.printername

프린터 이름을 설정합니다.

Reference

기본 값은 기본 프린터입니다.

프린터 설정 시 대/소문자를 구분합니다.

주어진 문자열로 일치하는 프린터를 찾고 일치하는 프린터가 없는 경우 문자열을 포함하는 프린터를 검색합니다.

검색된 프린터가 없을 경우에는 기본 프린터로 설정되며, 검색된 프린터가 여러 개일 경우에는 기본 프린터를 우선적으로 선택하고, 기본 프린터가 없을 경우 맨 처음 검색된 프린터로 설정됩니다.

See Also

인쇄 다이얼로그


print.properties

인쇄 다이얼로그에서 프린터 이름 콤보 박스 옆에 [속성] 버튼을 표시할지 여부를 설정합니다.

Value

true [속성] 버튼 표시

false [속성] 버튼 표시 안 함(기본 값)

Reference

[속성] 버튼을 클릭하면 클라이언트 PC의 제어판에서 제공하는 프린터 자체의 속성 창이 실행됩니다.

프린터 자체의 속성 창에서 설정한 용지 크기, 용지 방향, 양면 인쇄, 흑백 인쇄, 용지 공급 옵션은 무시됩니다.

오즈 뷰어와 프린터 자체의 속성 창에서 인쇄 매수를 1보다 큰 값으로 설정할 경우 두 값을 더한 값으로 인쇄 매수가 적용됩니다.(예를 들어, 오즈 뷰어 1매, 프린터 자체 속성 1매일 경우에는 총 1매가 출력되고, 오즈 뷰어 1매, 프린터 자체 속성 2매일 경우에는 총 3매가 출력됩니다.)

한 부씩 인쇄 옵션은 먼저 오즈 뷰어에서 설정한 한 부씩 인쇄 여부와 인쇄 매수를 적용하여 인쇄한 후 프린터 자체 속성 창에서 설정한 한 부씩 인쇄 여부와 인쇄 매수를 적용하여 인쇄됩니다.

모아찍기 옵션이 적용된 경우 오즈 뷰어와 프린터 자체의 옵션을 중복 적용하여 모아찍기됩니다.


print.reports

리포트 지정 기능을 사용할 때 인쇄할 리포트 번호를 "시작 리포트-끝 리포트,리포트 번호,시작 리포트-끝 리포트" 형태로 설정합니다.

Reference

이 패러미터는 "print.useselectedreport=true"이고 "print.pagerange=selectedreport"인 경우에 적용됩니다.


print.scaling

인쇄 배율을 1부터 100 사이의 값을 설정합니다.

Reference

기본 값은 100입니다.

See Also

인쇄 옵션 다이얼로그


print.shownoprinter

사용 가능한 프린터가 없을 경우 에러 메시지 표시 여부를 설정합니다.

Value

true 에러 메시지 표시

false 에러 메시지 표시 안 함 (기본 값)


print.size

인쇄할 용지 옵션을 설정합니다.

See Also

인쇄 다이얼로그


print.skip

보고서를 인쇄하지 않도록 설정합니다.

Value

true 인쇄 안 함

false 인쇄 (기본 값)

Reference

이 패러미터는 다중 보고서 인쇄 환경에서 해당 보고서를 제외하고 인쇄하고자 할 때 사용합니다.

패러미터 값을 true로 설정하여도 툴바의 인쇄 아이콘은 비활성화되지 않으며, 사용자가 인쇄를 실행한 경우 인쇄 불가 알림 메시지 창이 표시됩니다.

global.concatpage=true로 설정하여 여러 개의 보고서를 한 보고서처럼 바인딩한 경우 이 패러미터 값은 각각의 보고서 단위로 적용됩니다.

인쇄에서 제외된 보고서도 인쇄 관련 이벤트는 발생하며, 인쇄 실패로 리턴됩니다.


print.spoolpages

스풀링 페이지 옵션을 설정합니다.

Reference

기본 값은 100입니다.

See Also

인쇄 옵션 다이얼로그


print.style

인쇄 스타일을 설정합니다.

Value

normal 기본 인쇄 (기본 값)

gather 모아찍기

See Also

인쇄 옵션 다이얼로그


print.trayname

용지 공급 옵션을 설정합니다.

See Also

인쇄 옵션 다이얼로그


print.usedefaultpaper

프린터의 기본 용지로 출력할지 여부를 설정합니다.

Value

true 프린터 기본 용지 사용

false 보고서에 정의된 용지 사용 (기본 값)


print.usedialogopt

현재 보고서의 인쇄 옵션을 다른 보고서에서도 적용하여 인쇄할지 여부를 설정합니다.

Value

true 다른 보고서에도 적용

false 현재 표시된 보고서에만 적용 (기본 값)

Reference

이 패러미터는 보고서를 인쇄할 때만 적용되는 패러미터로, 현재 보고서에서 설정한 인쇄 다이얼로그 옵션이 다른 보고서의 인쇄 다이얼로그에는 영향을 주지 않습니다.

예를 들어, 두 개의 보고서를 바인딩한 상태에서 첫 번째 보고서의 인쇄 다이얼로그에서 인쇄 매수를 "2"로 설정하고 "모든 문서 인쇄"를 체크한 후 저장하면 두 번째 보고서도 인쇄 매수가 "2"로 적용되어 인쇄됩니다. 보고서 인쇄를 완료한 후 두 번째 보고서의 인쇄 다이얼로그를 실행하면 인쇄 매수는 "2"가 아니라 "1"로 표시됩니다.

"global.concatpage=false"이고, "print.alldocument=true"인 경우에 적용됩니다.


print.useprinterpaper

보고서를 인쇄할 때 프린터에 설정된 기본 용지로 인쇄할지 여부를 설정합니다.

Value

true 프린터의 기본 용지로 설정

false 보고서의 용지에 따름 (기본 값)

Reference

print.size 패러미터보다 우선 순위가 낮습니다.


print.useprintstop

인쇄 시 데이터 스풀 전송 중지 기능의 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)

Reference

패러미터를 true로 설정하면 인쇄 시 상태 다이얼로그에 [중지] 버튼이 나타나고 스풀 전송을 중지할 수 있습니다.

"viewer.mode=print", "viewer.largebundle=true", "print.printbypage=true"로 설정한 경우에는 해당 기능을 사용할 수 없습니다.


print.useprogressbar

인쇄 시 프로그레스바의 표시 여부를 설정합니다.

Value

default print.mode 설정 값에 따라 표시 여부를 결정 (기본 값)

true 표시

false 표시 안 함


print.useselectedreport

인쇄 범위에 리포트 지정 옵션을 표시할지 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

print.useselectedreport 패러미터 값을 true로 설정한 경우 인쇄 다이얼로그의 인쇄 범위에 리포트 지정 옵션과 [리포트 선택] 버튼이 표시됩니다.


rectangle

콜아웃 기능 시 사용하는 사각형의 속성 제어에 관한 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
rectangle.bordercolor | O | O | O | O | O | X | X | X | X
rectangle.borderthickness | O | O | O | O | O | X | X | X | X
rectangle.changeable | O | O | O | O | O | X | X | X | X
rectangle.fillcolor | O | O | O | O | O | X | X | X | X
rectangle.movable | O | O | O | O | O | X | X | X | X
rectangle.multiscreen_visible_type | O | X | X | X | X | X | X | X | X
rectangle.roundingvalue | O | O | O | O | O | X | X | X | X
rectangle.tooltiptext | O | O | O | O | O | X | X | X | X
rectangle.transparent | O | O | O | O | O | X | X | X | X

O

Only e-Form


rectangle.bordercolor

테두리 색을 설정합니다.

Reference

기본 값은 "000000"입니다.


rectangle.borderthickness

테두리 두께를 설정합니다.

Reference

기본 값은 "1"입니다.


rectangle.changeable

속성 변환 가능 여부를 설정합니다.

Value

true 속성 변환 가능 (기본 값)

false 속성 변환 불가


rectangle.fillcolor

바탕색을 설정합니다.

Reference

기본 값은 "FFFFFF"입니다.


rectangle.movable

이동 가능 여부를 설정합니다.

Value

true 이동 가능 (기본 값)

false 이동 불가


rectangle.multiscreen_visible_type

멀티 스크린 환경에서 사각형 표시 타입을 설정합니다.

Value

always 양쪽 스크린 모두 사각형이 표시됨 (기본 값)

mainscreenonly 메인 스크린에만 사각형이 표시됨

subscreenonly 서브 스크린에만 사각형이 표시됨


rectangle.roundingvalue

사각형의 모서리 곡선 값을 설정합니다.

Reference

기본 값은 "0"입니다.


rectangle.tooltiptext

툴팁에 표시할 텍스트를 설정합니다.


rectangle.transparent

바탕의 투명 여부를 설정합니다.

Value

true 투명

false 불투명 (기본 값)


repository_agent

리파지토리 서버 관련 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
repository_agent.clientcachetype | O | O | O | O | O | O | O | O | O
repository_agent.local.root_path | O | O | X | O | X | X | O | O | O
repository_agent.ozserver.pass | O | O | O | O | O | O | O | O | O
repository_agent.ozserver.port | O | O | X | O | X | X | O | O | O
repository_agent.ozserver.server | O | O | X | O | X | X | O | O | O
repository_agent.ozserver.servlet | O | O | O | O | O | O | O | O | O
repository_agent.ozserver.user | O | O | O | O | O | O | O | O | O
repository_agent.pass | O | O | O | O | O | O | O | O | O
repository_agent.server_baseline_datetime | O | O | O | O | O | O | O | O | O
repository_agent.try_license_check | O | O | X | O | X | X | X | X | X
repository_agent.try_usl_check | O | O | O | O | O | X | O | O | O
repository_agent.type | O | O | O | O | O | O | O | O | O
repository_agent.user | O | O | O | O | O | O | O | O | O
repository_agent.usl_parm_args# | O | O | O | O | O | X | O | O | O
repository_agent.usl_parm_pcount | O | O | O | O | O | X | O | O | O
repository_agent.webserver.root_path | O | O | X | O | X | X | O | O | O


repository_agent.clientcachetype

서버 리파지토리의 파일을 클라이언트로 전송할 때 클라이언트에 캐시하는 방식을 설정합니다.

Value

file 파일로 캐시

memory 메모리에 캐시

none 캐시 안 함

crypt 암호화하여 캐시

Reference

여러 개 설정할 경우 콤마(",")를 구분자로 조합하여 설정합니다.

none을 제외한 file, memory, crypt 옵션은 ","를 이용하여 중복하여 설정할 수 있습니다.

none으로 설정한 경우 보고서를 OZD 파일로 저장할 수 없습니다.

Flash, HTML5, Android, iOS, WinRT 뷰어의 경우 file, crypt로 설정해도 memory로 동작합니다.


repository_agent.local.root_path

보고서를 가져올 로컬 시스템의 루트 경로를 설정합니다.


repository_agent.ozserver.pass

사용자 패스워드를 설정합니다.

Reference

기본 값은 guest입니다.


repository_agent.ozserver.port

데몬 타입의 오즈 서버 포트를 설정합니다.


repository_agent.ozserver.server

데몬 타입의 오즈 서버 IP를 설정합니다.


repository_agent.ozserver.servlet

서블릿 타입의 오즈 서버 URL을 설정합니다.


repository_agent.ozserver.user

사용자 ID를 설정합니다.

Reference

기본 값은 guest입니다.


repository_agent.pass

사용자 패스워드를 설정합니다.

Reference

기본 값은 guest입니다.


repository_agent.server_baseline_datetime

바인딩할 리파지토리 아이템(OZR, ODI, ozp:// 경로로 설정된 파일)의 체크인 기준 시간을 설정합니다.

Reference

이 패러미터는 보고서를 최근에 체크인된 버전이 아니라 특정 시간 또는 특정 시간보다 전에 체크인된 버전으로 바인딩하는 용도로 사용됩니다.

해당 기능을 사용하려면 리파지토리 서버가 히스토리 기능이 가능한 타입이어야 하며, 뷰어 및 서버에서 캐시 기능을 사용하지 않도록 설정하여야 합니다.

패러미터 값은 아래 4가지 형식 중 하나로 설정하여야 하며, 아래 형식이 아닌 경우 최근에 체크인된 버전으로 바인딩됩니다.

·yyyy-MM-dd

·yyyy-MM-dd HH

·yyyy-MM-dd HH:mm

·yyyy-MM-dd HH:mm:ss

위 형식 중 HH, mm, ss를 생략한 형식은 00으로 적용됩니다.

패러미터 값에서 지정한 시간 또는 그 전에 체크인된 파일을 찾을 수 없을 경우 바인딩 에러가 발생합니다.


repository_agent.try_license_check

오즈 서버에 접속할 사용자 정보의 전송 여부를 설정합니다.

Value

true 전송

false 전송 안 함 (기본 값)

Reference

패러미터 값이 true인 경우 사용자 PC의 IP와 Mac Address 정보를 오즈 서버로 전송합니다. 오즈 서버는 전송받은 사용자 정보가 오즈 서버에 등록된 사용자 정보와 일치할 경우에만 보고서를 전송합니다.


repository_agent.try_usl_check

USL 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

오즈 서버가 USL을 사용할 경우 뷰어에서도 USL을 체크함으로 설정하여야 동작합니다.

Android/iOS 뷰어에서는 아래와 같은 설정이 필요합니다.

[Android]

·Eclipse 프로젝트에 라이브러리 추가

OZUSLClientDES128.so

OZUSLClientSession.so

[iOS]

·Xcode 프로젝트에 라이브러리 추가

OZUSLClientDES128.a

OZUSLClientSession.a

·스크립트 추가

오즈 뷰어를 로딩하기 전에 __OZPack_load_OZUSLClient() 함수 호출

...

- (void) createViewer {

NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                    @"connection.reportname=category_path/sample.ozr";

__OZPack_load_OZUSLClient();

OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

self.viewer = reportViewer;

[reportViewer release];

}

...


repository_agent.type

보고서를 가지고 올 방식을 설정합니다.

Value

from_webserver 웹 서버에서 가져옴

from_local 로컬에서 가져옴

from_ozserver 오즈 서버에서 가져옴

from_ozp OZD 파일을 가져옴


repository_agent.user

사용자 ID를 설정합니다.

Reference

기본 값은 guest입니다.


repository_agent.usl_parm_args#

USL 패러미터 값을 설정합니다.

Reference

#은 숫자 값으로 몇 번째 패러미터인지를 알려주는 번호이며, 1부터 repository_agent.usl_parm_pcount에 설정한 값까지 사용할 수 있습니다.

"repository_agent.try_usl_check=true"로 설정한 후 이 패러미터로 USL 패러미터 값을 설정하지 않으면 리포트의 기본 패러미터인 폼 패러미터가 USL 패러미터로 동작됩니다.


repository_agent.usl_parm_pcount

USL 패러미터 개수를 설정합니다.


repository_agent.webserver.root_path

보고서를 가져올 웹 서버의 루트 경로를 설정합니다.


svg

SVG 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
svg.convertedimagedpi | O | O | O | O | O | O | O | O | O
svg.filename | O | O | O | O | O | O | O | O | X
svg.horizontalpagegap | O | O | O | O | O | O | O | O | O
svg.path | O | O | X | O | X | X | O | O | X
svg.savealternativetext | O | O | X | X | X | O | X | X | X
svg.savecomment | O | O | O | O | O | X | O | O | O
svg.savelinkurl | O | O | O | O | O | O | O | O | O
svg.savemultipage | O | O | O | O | O | O | O | O | O
svg.verticalpagegap | O | O | O | O | O | O | O | O | O

O

Only e-Form


svg.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 72이며, 단위는 dpi입니다.

svg.convertedimagedpi 패러미터는 그리기 형태가 사용자 컴포넌트인 라벨만 적용됩니다.


svg.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


svg.horizontalpagegap

보고서를 한 파일로 저장할 때 SVG 뷰어 창과 페이지 사이의 왼쪽 간격을 설정합니다.

Reference

기본 값은 "10"입니다.

음수 값으로 설정할 경우 기본 값으로 적용되고, 실수 값으로 설정할 경우 소수점 이하 값을 버림하여 적용됩니다.

페이지 너비가 다른 보고서를 한 파일로 저장할 경우 너비가 가장 큰 페이지에 svg.horizontalpagegap 패러미터 값을 적용시킨 후 나머지 페이지는 너비가 가장 큰 페이지 기준으로 가운데 정렬하여 저장됩니다.

"svg.savemultipage=true"인 경우에 적용됩니다.


svg.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


svg.savealternativetext

SVG 파일로 저장할 때 대체 텍스트를 포함하여 저장할지 여부를 설정합니다.

Value

true 대체 텍스트 포함하여 저장

false 대체 텍스트 저장 안 함 (기본 값)


svg.savecomment

SVG 파일로 저장할 때 주석을 포함하여 저장할지 여부를 설정합니다.

Value

true 주석 포함하여 저장

false 주석 저장 안 함 (기본 값)


svg.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


svg.savemultipage

한 파일에 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

SVG 저장 옵션 다이얼로그


svg.verticalpagegap

보고서를 한 파일로 저장할 때 페이지 사이의 위/아래 간격을 설정합니다.

Reference

기본 값은 "10"입니다.

음수 값으로 설정할 경우 기본 값으로 적용되고, 실수 값으로 설정할 경우 소수점 이하 값을 버림하여 적용됩니다.

"svg.savemultipage=true"인 경우에 적용됩니다.


text

텍스트 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
text.addseparator | O | O | O | O | O | O | O | O | O
text.charset | O | O | O | O | O | O | O | O | O
text.exceptfirstpage | O | O | O | O | O | O | O | O | O
text.filename | O | O | O | O | O | O | O | O | X
text.pageline | O | O | O | O | O | O | O | O | O
text.pagestyle | O | O | O | O | O | O | O | O | O
text.pagetitle | O | O | O | O | O | O | O | O | O
text.path | O | O | X | O | X | X | O | O | X
text.removerange | O | O | O | O | O | O | O | O | O
text.removeseparator | O | O | O | O | O | O | O | O | O
text.saveastable | O | O | O | O | O | O | O | O | O
text.separator | O | O | O | O | O | O | O | O | O
text.splitmergedcell_at_saveastable | O | O | O | O | O | O | O | O | O


text.addseparator

자릿수 구분 기호 추가 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

CSV/Text 저장 옵션 다이얼로그


text.charset

인코딩 옵션을 설정합니다.

Value

ansi ANSI (기본 값)

unicode 유니코드

See Also

CSV/Text 저장 옵션 다이얼로그


text.exceptfirstpage

라인 제거 옵션 중 첫 페이지 제외 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

두 번째 페이지부터 text.removerange에서 설정한 특정 라인을 제외하고 저장합니다.

See Also

CSV/Text 저장 옵션 다이얼로그


text.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


text.pageline

페이지 간격 줄 수 옵션을 설정합니다.

Reference

매 페이지 끝에 설정한 줄 수만큼 빈 줄을 추가합니다.

text.pagestyle을 이용하여 페이지 구분형태를 함께 설정한 경우 페이지 구분형태를 먼저 추가하고 다음 줄에 지정한 줄 수만큼의 빈 줄이 추가됩니다.

See Also

CSV/Text 저장 옵션 다이얼로그


text.pagestyle

구분형태 옵션을 설정합니다.

Value

None None (기본 값)

n <PAGE> n <PAGE>

n <PAGE> --- n <PAGE> ---

--- n <PAGE> --- n <PAGE>

<PAGE> n <PAGE> n

<PAGE> n --- <PAGE> n ---

--- <PAGE> n --- <PAGE> n

Reference

구분형태는 'n', '---' 와 '<PAGE>'의 조합으로 구성되며, 'n'는 해당 보고서의 페이지 번호를 나타내고, '<PAGE>'는 csv.pagetitle에서 정의한 문자열입니다. csv.pagetitle을 'Page'로 설정하고 csv.pagestyle 값을 '--- n <PAGE>'로 설정하면 각 페이지는 다음과 같이 표시됩니다.

--------------------------------------- 1Page

None으로 설정하면 페이지 구분 없이 저장하고 그 외 값으로 설정하면 보고서의 매 페이지 끝에 페이지 구분 텍스트를 추가하여 저장합니다.

None 이외의 값으로 선택했을 때 구분형태 문자열 중 <PAGE>를 대체할 문자열을 설정하는 방법은 text.pagetitle을 참고하시기 바랍니다.

See Also

CSV/Text 저장 옵션 다이얼로그


text.pagetitle

<PAGE> 옵션을 설정합니다.

Reference

기본 값은 page입니다.

See Also

text.pagestyle

CSV/Text 저장 옵션 다이얼로그


text.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


text.removerange

라인 제거 옵션을 체크하고, 제거할 라인 범위를 "시작라인,끝라인" 형태로 설정합니다.

See Also

CSV/Text 저장 옵션 다이얼로그


text.removeseparator

자릿수 구분 기호 제거 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

CSV/Text 저장 옵션 다이얼로그


text.saveastable

테이블 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

CSV/Text 저장 옵션 다이얼로그


text.separator

구분자 옵션을 설정합니다.

Value

tab tab (기본 값)

space space

| |

/ /

~ ~

comma comma

empty empty

Other 그 외 값

See Also

CSV/Text 저장 옵션 다이얼로그


text.splitmergedcell_at_saveastable

병합된 라벨을 분할하여 저장할지 여부를 설정합니다.

Value

true 병합된 라벨을 분할하여 저장

false 병합된 상태로 저장 (기본 값)

Reference

"text.saveastable=true"인 경우에 적용됩니다.


tiff

TIFF 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
tiff.dpi | O | O | O | O | O | O | O | O | O
tiff.encode | O | O | O | O | O | O | O | O | O
tiff.filename | O | O | O | O | O | O | O | O | X
tiff.height | O | O | O | O | O | O | O | O | O
tiff.jpg_quality | O | O | O | O | O | O | O | O | O
tiff.path | O | O | X | O | X | X | O | O | X
tiff.savecomment | O | O | O | O | O | X | O | O | O
tiff.savemultipage | O | O | O | O | O | O | O | O | O
tiff.sizemode | O | O | O | O | O | O | O | O | O
tiff.width | O | O | O | O | O | O | O | O | O
tiff.zoom | O | O | O | O | O | O | O | O | O

O

Only e-Form


tiff.dpi

해상도 옵션을 설정합니다.

Reference

기본 값은 72이며, 단위는 dpi입니다.

See Also:

TIFF 저장 옵션 다이얼로그


tiff.encode

인코딩 방식 옵션을 설정합니다.

Value

G3 G3 인코딩 방식으로 저장 (기본 값)

G4 G4 인코딩 방식으로 저장

JPG JPG 인코딩 방식으로 저장

See Also:

TIFF 저장 옵션 다이얼로그


tiff.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


tiff.height

높이 옵션을 설정합니다.

Reference

기본 값은 0입니다.

TIFF의 파일의 최대 높이는 보고서의 복잡도 및 뷰어를 실행하는 jvm에 설정된 heap 사이즈의 크기에 따라 달라질 수 있습니다. 만일 jvm에서 사용 가능한 heap 사이즈를 초과하여 높이를 설정할 경우 에러 메시지가 발생합니다.

See Also:

TIFF 저장 옵션 다이얼로그


tiff.jpg_quality

인코딩 방식을 JPG로 선택하여 저장할 때 JPG 이미지의 품질을 설정합니다.

Reference

기본 값은 100이며, 0 ~ 100 사이의 값으로 설정합니다.

이 패러미터를 사용하려면 tiff.encode=jpg로 설정하시기 바랍니다.


tiff.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


tiff.savecomment

TIFF 파일로 저장할 때 주석을 포함하여 저장할지 여부를 설정합니다.

Value

true 주석 포함하여 저장

false 주석 저장 안 함 (기본 값)


tiff.savemultipage

한 파일에 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also:

TIFF 저장 옵션 다이얼로그


tiff.sizemode

파일의 크기 조정 옵션을 설정합니다.

Value

zoom 비율 (기본 값)

size 크기 지정

dpi 해상도에 따라 크기 결정

Reference

패러미터를 zoom으로 설정하면 비율 옵션이 체크되고 확대/축소 비율을 설정할 수 있으며, size로 설정하면 크기 옵션이 체크되고 너비, 높이를 설정할 수 있습니다. dpi로 설정하면 해상도에 따라 크기 결정 옵션이 체크되고 해상도를 설정할 수 있습니다.

See Also:

TIFF 저장 옵션 다이얼로그


tiff.width

너비 옵션을 설정합니다.

Reference

기본 값은 0입니다.

TIFF의 파일의 최대 너비는 보고서의 복잡도 및 뷰어를 실행하는 jvm에 설정된 heap 사이즈의 크기에 따라 달라질 수 있습니다. 만일 jvm에서 사용 가능한 heap 사이즈를 초과하여 높이를 설정할 경우 에러 메시지가 발생합니다.

See Also:

TIFF 저장 옵션 다이얼로그


tiff.zoom

확대/축소 비율을 설정합니다.

Reference

10~1000 사이의 값으로 설정합니다.

See Also:

TIFF 저장 옵션 다이얼로그


toolbar

뷰어 툴바 형태 및 아이콘에 대한 옵션을 설정합니다.

Reference

툴바 표시 여부는 viewer.usetoolbar 패러미터를 이용하시기 바랍니다.

툴바 아이콘 설정 값 중 disable에 대한 동작 규칙은 다음과 같습니다.

·disable로 설정된 아이콘의 기능은 Script() 또는 ScriptEx() 함수로 실행할 경우에도 동작하지 않습니다.

·disable은 툴바 아이콘 표시 여부를 설정하는 true/false와 콤마(",")를 구분자로 조합하여 사용할 수 있습니다. 화면에 표시하고 비활성화시킬 경우에는 "true,disable"로, 화면에 표시하지 않고 비활성화시킬 경우에는 "false,disable"로 설정하시기 바랍니다.

·만일 "true,disable" 또는 "false,disable"로 설정하지 않고 "disable"로만 설정할 경우 표시 여부는 아이콘의 표시 여부 기본 값에 따라 결정됩니다. 예를 들어, 인쇄 아이콘(toolbar.print)의 경우 기본적으로 표시되는 아이콘이므로 "disable"만 설정할 경우 화면에는 표시되고 비활성화되며, 모두 닫기 아이콘(toolbar.closeall)의 경우 기본적으로 표시되지 않는 아이콘이므로 "disable"만 설정할 경우 화면에 표시되지 않고 기능만 비활성화됩니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
toolbar.about | O | O | O | O | O | O | O | O | O
toolbar.addarrow | O | O | O | O | O | X | X | X | X
toolbar.addcircle | O | O | O | O | O | X | X | X | X
toolbar.addimage | X | X | X | X | X | X | O | O | O
toolbar.addline | O | O | O | O | O | X | X | X | X
toolbar.addmemo | O | O | O | O | O | X | O | O | O
toolbar.addrectangle | O | O | O | O | O | X | X | X | X
toolbar.autohide | X | X | X | X | X | X | O | O | O
toolbar.bgcolor | O | O | X | O | X | X | X | X | O
toolbar.close | O | O | O | O | O | X | O | O | O
toolbar.closeall | O | O | O | O | O | X | O | O | O
toolbar.csv | O | O | O | O | O | O | O | O | O
toolbar.currentpage | O | O | O | O | O | O | X | X | X
toolbar.doc | O | O | O | O | O | O | O | O | O
toolbar.edittool | O | O | O | O | O | X | X | X | X
toolbar.etc | O | O | O | O | O | O | O | O | O
toolbar.exit | O | X | X | X | X | X | X | X | X
toolbar.file | O | O | O | O | O | O | O | O | O
toolbar.find | O | O | O | O | O | X | O | O | O
toolbar.finds | O | O | O | O | O | X | O | O | O
toolbar.gif | O | O | O | O | O | O | X | X | X
toolbar.gul | O | X | X | X | X | X | X | X | X
toolbar.han97 | O | O | O | O | O | O | O | O | O
toolbar.handtool | O | O | O | O | O | X | X | X | X
toolbar.help | O | O | O | O | O | O | X | X | X
toolbar.hml | O | O | O | O | O | O | O | O | O
toolbar.html | O | O | O | O | O | O | O | O | O
toolbar.iconheight | O | O | X | O | X | X | X | X | X
toolbar.iconposition | O | O | O | O | O | O | O | O | O
toolbar.iconwidth | O | O | X | O | X | X | X | X | X
toolbar.inputparameter | O | O | O | O | O | X | O | O | O
toolbar.inversepaper | O | O | O | O | O | X | O | O | O
toolbar.jpg | O | O | O | O | O | O | O | O | O
toolbar.mail | O | O | X | O | X | X | X | X | X
toolbar.mht | O | O | O | O | O | O | O | O | O
toolbar.multiscreenguide | O | X | X | X | X | X | X | X | X
toolbar.nxl | O | O | O | O | O | O | O | O | O
toolbar.open | O | O | O | O | O | X | O | O | O
toolbar.option | O | O | O | O | O | X | O | O | O
toolbar.ozd | O | O | O | O | O | X | O | O | O
toolbar.page | O | O | O | O | O | O | O | O | O
toolbar.pagecontrol | O | O | O | O | O | O | X | X | X
toolbar.pagedisplaysize | O | O | O | O | O | O | X | X | X
toolbar.pagenavigator | X | X | X | X | X | X | O | O | O
toolbar.pagesetup | O | O | O | O | O | X | O | O | O
toolbar.parameter | O | O | O | O | O | X | O | O | O
toolbar.pdf | O | O | O | O | O | O | O | O | O
toolbar.png | O | O | O | O | O | O | O | O | O
toolbar.ppt | O | O | O | O | O | O | O | O | O
toolbar.print | O | O | O | O | O | O | O | O | O
toolbar.refresh | O | O | O | O | O | X | O | O | O
toolbar.save | O | O | O | O | O | O | O | O | O
toolbar.savedm | O | O | O | O | O | X | O | O | O
toolbar.showthumbnail | O | O | O | O | O | X | O | O | O
toolbar.showtree | O | O | O | O | O | O | O | O | O
toolbar.singlepage_fittoframe | O | O | O | O | O | O | O | O | O
toolbar.singlepagecontinuous_fittowidth | O | O | O | O | O | O | O | O | O
toolbar.svg | O | O | O | O | O | O | O | O | O
toolbar.textselecttool | O | O | O | O | O | X | X | X | X
toolbar.tiff | O | O | O | O | O | O | O | O | O
toolbar.totalpage | O | O | O | O | O | O | X | X | X
toolbar.txt | O | O | O | O | O | O | O | O | O
toolbar.useseparator | O | O | O | O | O | O | X | X | X
toolbar.viewmode | O | X | O | X | X | X | X | X | X
toolbar.xls | O | O | O | O | O | O | O | O | O
toolbar.xlsx | O | O | O | O | O | O | O | O | X
toolbar.zoom | O | O | O | O | O | O | X | X | X
toolbar.zoomin | O | O | O | O | O | O | X | X | X
toolbar.zoomlist | O | O | O | O | O | O | X | X | X
toolbar.zoomout | O | O | O | O | O | O | X | X | X
toolbar.zoomreset | O | O | O | O | O | O | X | X | X
toolbar.zoomtype | O | O | O | O | O | O | X | X | X

O

Only e-Form


toolbar.about

제품 정보 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.addarrow

화살표 추가 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.addcircle

원 추가 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.addimage

이미지 추가 아이콘의 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

Reference

이미지 추가 아이콘은 카메라와 사진으로 구성되어 있으며, 편집 툴바에 표시됩니다.


toolbar.addline

선 추가 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.addmemo

메모 추가 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화

Reference

메모 추가 아이콘은 Android/iOS/WinRT 뷰어에서는 편집 툴바에 표시되고, 그 외 뷰어에서는 메인 툴바에 표시됩니다.


toolbar.addrectangle

사각형 추가 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.autohide

툴바를 자동으로 숨길지 여부를 설정합니다.

Value

true 일정 시간 후 자동으로 숨겨짐 (기본 값)

false 보고서를 탭하면 숨겨지고 다시 탭하면 표시됨


toolbar.bgcolor

툴바 바탕색을 설정합니다.


toolbar.close

보고서 닫기 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.closeall

모든 보고서 닫기 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.csv

CSV 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.currentpage

페이지 번호를 입력하는 텍스트 박스의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화

Reference

"toolbar.page=true"인 경우에 적용됩니다.


toolbar.doc

워드 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.edittool

편집 모드 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.etc

다른 메뉴 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


toolbar.exit

종료 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.


toolbar.file

파일 아이콘 그룹의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


toolbar.find

찾기 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


toolbar.finds

찾기 관련 아이콘 그룹의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


toolbar.gif

GIF 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.gul

정음 Global 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.han97

한글97 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.handtool

손 모드 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.help

도움말 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.hml

한글 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.html

HTML 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.iconheight

아이콘의 세로 크기를 설정합니다.

Reference

기본 값은 26입니다.


toolbar.iconposition

아이콘 그룹의 위치를 설정합니다.

Reference

아이콘 그룹명은 file, screentool, option, pageselection, page, zoom, pagecontrol, finds, parameter, about, help, exit, etc이며, "/"를 구분자로 조합하여 설정할 수 있습니다.


toolbar.iconwidth

아이콘의 세로 크기를 설정합니다.

Reference

기본 값은 26입니다.


toolbar.inputparameter

패러미터 입력 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.inversepaper

용지 방향 변경 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함

disable 비활성화

Reference

Android/iOS/WinRT 뷰어에서는 "false"가 기본 값이고, 그 외 뷰어에서는 "true"가 기본 값입니다.

용지 방향 변경 시 밴드의 높이가 변경되는 용지의 높이보다 클 경우에는 용지 방향을 바꿀 수 없으므로 용지 방향 아이콘이 비활성화됩니다.


toolbar.jpg

Jpeg 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.mail

오즈 메일 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.mht

MHT 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.multiscreenguide

안내 모드 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화

Reference

이 기능을 사용하려면 eform.usemultiscreen=true로 설정하시기 바랍니다.


toolbar.nxl

한컴 넥셀 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화

Reference

한컴 넥셀 파일 형식은 기본적으로 표시되지 않는 포맷으로, 패러미터 값을 true로 적용하려면 export.applyformat 또는 export.displaynames 패러미터를 이용하여 한컴 넥셀 파일 형식을 설정하시기 바랍니다.


toolbar.open

열기 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.option

옵션 아이콘 그룹의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함

disable 비활성화

Reference

Android/iOS/WinRT 뷰어에서는 "false"가 기본 값이고, 그 외 뷰어에서는 "true"가 기본 값입니다.

옵션 아이콘 그룹은 메모 추가, 선 추가, 화살표 추가, 사각형 추가, 원 추가, 데이터 저장 아이콘로 구성되어 있으며, 선 추가, 화살표 추가, 사각형 추가, 원 추가 아이콘은 toolbar.addline, toolbar.addarrow, toolbar.addrectangle, toolbar.addcircle 패러미터를 true로 설정하여야 표시됩니다.


toolbar.ozd

OZD 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.page

페이지 이동 아이콘 그룹의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함

disable 비활성화

Reference

Android/iOS/WinRT 뷰어에서는 "false"가 기본 값이고, 그 외 뷰어에서는 "true"가 기본 값입니다.


toolbar.pagecontrol

페이지 설정 관련 아이콘 그룹의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


toolbar.pagedisplaysize

페이지 이동 아이콘 그룹 중 현재 페이지와 전체 페이지를 나타내는 영역의 크기를 설정합니다.

Reference

"toolbar.page=true"인 경우에 적용됩니다.


toolbar.pagenavigator

페이지 네비게이터 툴바의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


toolbar.pagesetup

페이지 설정 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.parameter

조회 툴바의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화

Reference

패러미터를 true로 설정해도 보고서에 조회 툴바가 없을 경우 조회 툴바가 표시되지 않습니다.


toolbar.pdf

PDF 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.png

PNG 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.ppt

PPT 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.print

인쇄 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함

disable 비활성화

Reference

Android/iOS/WinRT 뷰어에서는 "false"가 기본 값이고, 그 외 뷰어에서는 "true"가 기본 값입니다.


toolbar.refresh

새로고침 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.save

저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함

disable 비활성화

Reference

Android/iOS/WinRT 뷰어에서는 "false"가 기본 값이고, 그 외 뷰어에서는 "true"가 기본 값입니다.


toolbar.savedm

데이터 모듈 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함

disable 비활성화

Reference

Android/iOS/WinRT 뷰어에서는 "false"가 기본 값이고, 그 외 뷰어에서는 "true"가 기본 값입니다.


toolbar.showthumbnail

페이지 축소판 보기 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.showtree

트리 보기 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.singlepage_fittoframe

화면 크기에 맞춰 한 페이지씩 보기 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함

disable 비활성화

Reference

Android/iOS/WinRT 뷰어에서는 "false"가 기본 값이고, 그 외 뷰어에서는 "true"가 기본 값입니다.


toolbar.singlepagecontinuous_fittowidth

너비에 맞춰 한 페이지씩 연속 보기 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함

disable 비활성화

Reference

Android/iOS/WinRT 뷰어에서는 "false"가 기본 값이고, 그 외 뷰어에서는 "true"가 기본 값입니다.


toolbar.svg

SVG 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.textselecttool

텍스트 선택 모드 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화

Reference

텍스트 선택 모드 아이콘은 다른 아이콘과 다르게 패러미터 값을 true로 설정하면 비활성화된 상태로 표시됩니다. 활성화 상태로 아이콘을 표시하려면 viewer.usetextselectmenu 패러미터 값도 true로 설정하여야 합니다.


toolbar.tiff

TIFF 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.totalpage

페이지 이동 아이콘 그룹 중 총 페이지를 표시하는 라벨의 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

Reference

"toolbar.page=true"인 경우에 적용됩니다.


toolbar.txt

TEXT 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.useseparator

툴바 그룹 간 간격 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


toolbar.viewmode

확대/축소 배율 설정 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화

Reference

확대/축소 배율 설정 아이콘은 줌의 복원 아이콘 옆에 표시됩니다.


toolbar.xls

엑셀 97-2003 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.xlsx

엑셀 파일로 저장 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.zoom

줌 아이콘 그룹의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


toolbar.zoomin

확대 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


toolbar.zoomlist

줌 선택 콤보 박스의 리스트에 표시할 비율을 설정합니다.

Reference

줌 비율을 여러 개 설정하려면 콤마(,)를 구분자로하여 값을 나열합니다.


toolbar.zoomout

축소 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


toolbar.zoomreset

복원 아이콘의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

disable 비활성화


toolbar.zoomtype

줌 선택 콤보 박스의 표시 여부 및 비활성화 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

disable 비활성화


usercomponent

사용자 컴포넌트 관련 정보를 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
usercomponent.extraparam | O | O | O | O | O | O | O | O | O


usercomponent.extraparam

사용자 컴포넌트가 구동될 때 전달할 값을 콤마(,)를 구분자로 하여 "Key1=Value1,Key2=Value2,...,Keyn=Valuen" 형태로 설정합니다.


viewer

오즈 뷰어의 기본적인 형태나 컬러, 크기 등을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
viewer.addmarginleft | O | O | O | O | O | X | O | O | O
viewer.addmargintop | O | O | O | O | O | X | O | O | O
viewer.allowmultiframe | O | X | X | X | X | X | X | X | X
viewer.antialiasing | O | O | X | X | X | X | X | X | X
viewer.autoadjustmargin | O | O | O | O | O | X | O | O | O
viewer.autohidethumbnail | X | X | X | X | X | X | O | O | O
viewer.autohidetree | X | X | X | X | X | X | O | O | O
viewer.bankbookprintcommand | O | O | O | O | O | X | O | O | O
viewer.bgcolor | O | O | O | O | O | O | O | O | O
viewer.bgimage | O | O | O | O | O | O | O | O | O
viewer.childcount | O | O | O | O | O | O | O | O | O
viewer.closeframe | O | X | X | X | X | X | X | X | X
viewer.displaydpi | O | O | O | O | O | O | O | O | O
viewer.editmodecolor | O | O | O | O | O | X | X | X | X
viewer.emptyframe | O | O | O | O | O | O | O | O | O
viewer.errorcommand | O | O | O | O | O | O | O | O | O
viewer.exitcommand | O | O | X | O | X | X | X | X | X
viewer.exportcommand | O | O | O | O | O | O | O | O | O
viewer.external_functions_path | O | O | O | O | O | O | O | O | X
viewer.external_replacescript_path | O | O | O | O | O | O | O | O | X
viewer.externalmodule | O | X | X | X | X | X | X | X | X
viewer.extraparam | O | X | X | X | X | X | X | X | X
viewer.focus_doc_index | O | O | O | O | O | O | O | O | O
viewer.fontdpi | O | O | O | O | O | X | O | O | O
viewer.frameheight | O | O | X | O | X | X | X | X | X
viewer.frameicon | O | O | X | O | X | X | X | X | X
viewer.frameshowmode | O | O | X | O | X | X | X | X | X
viewer.frametitle | O | O | X | O | X | X | X | X | X
viewer.frametitleconcat | O | O | X | O | X | X | X | X | X
viewer.framewidth | O | O | X | O | X | X | X | X | X
viewer.framex | O | O | X | O | X | X | X | X | X
viewer.framey | O | O | X | O | X | X | X | X | X
viewer.getinformation | O | O | O | O | X | X | O | O | O
viewer.id | O | O | O | O | O | O | O | O | O
viewer.ignore_disable_color_inputcomponent | O | O | O | O | O | X | O | O | O
viewer.imageprogressbar_imagepath | O | X | X | X | X | X | X | X | X
viewer.isframe | O | O | X | O | X | X | X | X | X
viewer.ismultidocassub | O | O | O | O | O | O | O | O | O
viewer.killprocess | O | X | X | X | X | X | X | X | X
viewer.label_dataopr_silent | O | O | O | O | O | O | O | O | O
viewer.largebundle | O | O | O | O | O | X | O | O | O
viewer.linkcommand | O | O | O | O | O | X | O | O | O
viewer.mailcommand | O | O | X | O | X | X | O | O | O
viewer.marginbottom | O | O | O | O | O | X | O | O | O
viewer.marginleft | O | O | O | O | O | X | O | O | O
viewer.marginright | O | O | O | O | O | X | O | O | O
viewer.margintop | O | O | O | O | O | X | O | O | O
viewer.maxzoom | O | O | O | O | O | O | O | O | O
viewer.minzoom | O | O | O | O | O | O | O | O | O
viewer.mode | O | O | X | O | X | X | X | X | X
viewer.movepage | O | O | O | O | O | O | O | O | O
viewer.namespace | O | X | X | X | X | X | X | X | X
viewer.offsetstartpage | O | O | O | O | O | O | O | O | O
viewer.offsettotalpage | O | O | O | O | O | O | O | O | O
viewer.ozcommandurl | O | X | X | X | X | X | X | X | X
viewer.ozresource_language | O | O | O | O | O | O | O | O | O
viewer.ozscript_dateopr_silent | O | O | O | O | O | O | O | O | O
viewer.ozscript_stropr_silent | O | O | O | O | O | O | O | O | O
viewer.pagebindcommandinterval | O | O | O | O | O | O | O | O | O
viewer.pagechangecommand | O | O | O | O | O | O | O | O | O
viewer.pagedisplay | O | O | O | O | O | O | O | O | O
viewer.pagehorizontalalignment | O | O | O | O | O | O | O | O | O
viewer.pagenavigate_by_prev_next | O | O | O | O | O | X | O | O | O
viewer.pagenavigate_by_scroll | O | O | O | O | O | O | X | X | X
viewer.pageverticalalignment | O | O | O | O | O | O | O | O | O
viewer.paper_orientation | O | O | O | O | O | X | O | O | O
viewer.parentid | O | O | O | O | O | O | O | O | O
viewer.pointuptoclabel | O | O | O | O | O | X | O | O | O
viewer.postcommand | O | O | O | O | O | X | O | O | O
viewer.previewstop | O | O | X | O | X | X | X | X | X
viewer.printcommand | O | O | O | O | O | O | O | O | O
viewer.progresscommand | O | O | O | O | O | X | O | O | O
viewer.reportchangecommand | O | O | O | O | O | O | O | O | O
viewer.restore_previouszoom_doubletap | X | X | X | X | X | X | O | O | O
viewer.screentool | O | O | O | O | O | X | O | O | O
viewer.scrolltotop_at_pagemoved | O | O | O | O | O | O | O | O | O
viewer.showcontinuouspagegap | O | O | O | O | O | O | O | O | O
viewer.showerrormessage | O | O | O | O | O | O | O | O | O
viewer.showpagemargin | O | O | O | O | O | O | O | O | O
viewer.showtab | O | O | O | O | O | O | X | X | X
viewer.showthumbnail | O | O | O | O | O | X | O | O | O
viewer.showtree | O | O | O | O | O | O | O | O | O
viewer.smartframesize | O | O | X | O | X | X | X | X | X
viewer.thumbnailsection_allowclose | O | X | O | X | O | O | O | O | O
viewer.thumbnailsection_makerule | O | X | O | X | O | O | O | O | O
viewer.thumbnailsection_showclosebutton | O | X | O | X | O | O | O | O | O
viewer.thumbnailviewsize | O | O | O | O | O | X | O | O | O
viewer.totalparam | O | O | O | O | O | O | O | O | O
viewer.totalparamseparator | O | O | O | O | O | O | O | O | O
viewer.treeviewsize | O | O | O | O | O | O | O | O | O
viewer.treeviewtitle | O | O | O | O | O | O | O | O | O
viewer.useeditmode | O | O | O | O | O | X | X | X | X
viewer.useimageprogressbar | O | X | X | X | X | X | X | X | X
viewer.useinborder | O | O | O | O | O | O | O | O | O
viewer.usemenubar | O | O | O | O | X | X | X | X | X
viewer.useoutborder | O | O | O | O | O | O | X | X | X
viewer.useprogressbar | O | O | O | O | O | O | O | O | O
viewer.useractioncommand | O | O | O | O | O | O | O | O | O
viewer.usesaveasimagemenu | O | O | O | O | O | X | X | X | X
viewer.usescrollbounce | X | X | X | X | X | X | X | O | X
viewer.usestatusbar | O | O | O | O | O | O | X | X | X
viewer.usetextselectmenu | O | O | O | O | O | X | X | X | X
viewer.usetoolbar | O | O | O | O | O | O | O | O | O
viewer.viewmode | O | O | O | O | O | O | O | O | O
viewer.zoom | O | O | O | O | O | O | O | O | O
viewer.zoombydoubletap_printsize | X | X | X | X | X | X | O | O | O
viewer.zoombymouse | O | O | O | O | O | O | O | O | O

O

Only e-Form


viewer.addmarginleft

왼쪽 여백 증감 값을 설정합니다.

Reference

단위는 pt입니다.

보고서를 디자인할 때 설정한 여백에 값을 더하거나 빼서 여백을 조절할 수 있습니다.


viewer.addmargintop

위쪽 여백 증감 값을 설정합니다.

Reference

단위는 pt입니다.

보고서를 디자인할 때 설정한 여백에 값을 더하거나 빼서 여백을 조절할 수 있습니다.


viewer.allowmultiframe

하나의 웹 브라우저에서 복수의 오즈 뷰어 호출 가능 여부를 설정합니다.

Value

true 복수개의 오즈 뷰어 호출 가능

false 한 개의 오즈 뷰어만 호출 가능 (기본 값)

Reference

viewer.isframe 패러미터 값이 true 또는 inprocess이고 viewer.closeframe 패러미터 값이 false인 경우에만 적용됩니다.


viewer.antialiasing

선 부드럽게 표시 여부를 설정합니다.

Value

true 선 부드럽게 표시

false 선 부드럽게 표시 안 함 (기본 값)


viewer.autoadjustmargin

보고서의 크기에 맞추어 여백 자동 조정 여부를 설정합니다.

Value

true 여백 자동 조정

false 여백 자동 조정 안 함 (기본 값)


viewer.autohidethumbnail

페이지 축소판 창을 자동으로 숨길지 여부를 설정합니다.

Value

true 일정 시간 후 자동으로 숨겨짐 (기본 값)

false 보고서를 탭하면 숨겨지고 다시 탭하면 표시됨


viewer.autohidetree

트리 창을 자동으로 숨길지 여부를 설정합니다.

Value

true 일정 시간 후 자동으로 숨겨짐 (기본 값)

false 보고서를 탭하면 숨겨지고 다시 탭하면 표시됨


viewer.bankbookprintcommand

OZBankBookPrintCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.bgcolor

오즈 뷰어 윈도우의 바탕색을 설정합니다.


viewer.bgimage

오즈 뷰어 윈도우의 배경 이미지를 설정합니다.


viewer.childcount

하나의 오즈 뷰어에 여러 개의 보고서를 보여줄 때 메인 보고서 외에 추가되는 차일드 보고서의 개수를 설정합니다.

Reference

추가되는 차일드 보고서에 대한 패러미터 설정은 패러미터 그룹명 앞에 child#.(# : 차일드 보고서 번호)을 붙여줍니다.


viewer.closeframe

뷰어가 실행될 때 동일한 네임스페이스로 실행된 뷰어를 종료할지 여부를 설정합니다.

Value

true 뷰어 종료

false 뷰어 종료 안 함 (기본 값)

Reference

"viewer.isframe=true"인 경우에만 적용됩니다.


viewer.displaydpi

보고서의 해상도를 설정합니다.

Value

0 시스템에 설정된 dpi 사용

72 72 dpi

96 96 dpi

120 120 dpi

Reference

Flash, HTML5 뷰어의 경우 0으로 설정하면 96 dpi로 설정됩니다.


viewer.editmodecolor

편집 가능한 컴포넌트의 중심점 색을 설정합니다.


viewer.emptyframe

오즈 뷰어를 보고서가 표시되지 않은 빈 오즈 뷰어로 실행할지 여부를 설정합니다.

Value

true 빈 오즈 뷰어 실행

false 보고서 바인딩 (기본 값)


viewer.errorcommand

OZErrorCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.exitcommand

OZExitCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.exportcommand

OZExportCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.external_functions_path

리포트 템플릿의 Functions 이벤트에 적용할 함수가 입력된 파일 경로를 설정합니다.

Reference

해당 패러미터를 사용하면 공통 함수를 하나의 파일로 관리할 수 있으므로, 공통 함수를 수정할 때 여러 개의 OZR 파일을 열어서 일일이 수정해야하는 번거러움을 개선할 수 있습니다.

패러미터에서 설정한 파일에 입력된 함수와 리포트 템플릿의 Functions 이벤트에 입력된 함수를 함께 사용할 수 있습니다.

단, 함수 이름이 중복된 경우 리포트 템플릿의 Functions 이벤트에 입력된 함수로 동작합니다.

지정한 경로에 파일이 없을 경우 보고서가 바인딩되지 않습니다.


viewer.external_replacescript_path

보고서에 적용할 스크립트가 입력된 파일 경로를 설정합니다.

Reference

해당 패러미터를 설정하면 먼저 보고서에 저장된 모든 스크립트를 삭제한 후 지정한 경로의 파일 내용으로 스크립트를 적용합니다.

지정한 경로의 파일 내용이 스크립트 형식에 맞지 않을 경우 스크립트가 없는 보고서로 바인딩됩니다.

지정한 경로에 파일이 없을 경우 보고서가 바인딩되지 않습니다.

해당 기능을 사용하려면 스크립트 작성 규칙에 맞게 스크립트가 입력된 텍스트 형식 파일을 설정하시기 바랍니다.

컴포넌트별 스크립트 작성 규칙은 아래와 같습니다.

·ReportTemplate

SCRIPT_BEGIN ..EventName

//스크립트

SCRIPT_END

·Report

SCRIPT_BEGIN .ReportName.EventName

//스크립트

SCRIPT_END

·Table/Crosstab/GanttChart의 Child Label

SCRIPT_BEGIN .ReportName.Table/Crosstab/GanttChartName.ComponentName.EventName

//스크립트

SCRIPT_END

·그 외 컴포넌트

SCRIPT_BEGIN .ReportName.ComponentName.EventName

//스크립트

SCRIPT_END

오즈 스크립트는 EventName을 OZScript로 입력합니다.

자세한 스크립트 작성 규칙은 리포트 디자이너에서 컴포넌트의 [스크립트 미리보기] 팝업 메뉴를 클릭하여 나타나는 스크립트 미리보기 창에서 확인하시기 바랍니다.


viewer.externalmodule

뷰어와 연동할 외부 모듈을 설정합니다.


viewer.extraparam

뷰어와 연동된 외부 모듈에 전달할 패러미터를 설정합니다.


viewer.focus_doc_index

다중 보고서에서 모든 보고서가 바인딩된 후 화면에 표시할 보고서 인덱스(zero-based index)를 설정합니다.

Reference

기본 값은 -1입니다.

아무 값도 설정하지 않거나 잘못된 값이 설정될 경우에는 마지막으로 조회된 보고서가 표시됩니다.


viewer.fontdpi

폰트 DPI를 설정합니다.

Value

72 72 dpi (기본 값)

96 96 dpi

120 120 dpi

200 200 dpi

300 300 dpi

600 600 dpi

1200 1200 dpi

auto 자동 조정

Reference

폰트 DPI 값에 따라 글자 간격과 글자 너비가 달라지며, 텍스트에 따라 크기가 자동 조정되는 라벨의 크기도 다르게 바인딩될 수 있습니다.

보고서를 확대/축소할 때 자간이 일정하지 않을 경우 viewer.fontdpi 패러미터 값을 auto로 설정하시기 바랍니다.


viewer.frameheight

오즈 뷰어 창의 높이를 설정합니다.

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.


viewer.frameicon

뷰어 타이틀바 아이콘에 표시할 이미지 파일의 경로를 설정합니다.

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.

아이콘 이미지는 32 x 32 크기의 이미지를 사용하시기 바랍니다. 만일, 해당 크기보다 작은 크기의 이미지를 설정한 경우 Left, Top으로 이미지를 정렬한 후 빈 공간은 검정색으로 표시되며, 큰 크기의 이미지를 설정한 경우 Left, Top을 기준으로 잘린 이미지로 표시됩니다.

아이콘 이미지 파일의 경로는 Http URL, File URL, OZ URL 등의 형식으로 설정할 수 있습니다.

만일, 이미지 경로를 공백으로 설정하거나 해당 경로에 이미지 파일이 없을 경우 기본 이미지로 표시되며, 이미지 경로를 "null"로 설정할 경우 아이콘이 표시되지 않습니다.


viewer.frameshowmode

오즈 뷰어 창의 표시 옵션을 설정합니다.

Value

maximized 최대화

minimized 최소화

normal 일반 (기본 값)

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.


viewer.frametitle

뷰어 타이틀을 설정합니다.

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.

값을 설정하지 않으면 디자인 시 설정한 보고서 제목이 뷰어 타이틀에 표시되며, 이 때 보고서 제목이 설정되어 있지 않으면 "OZ 뷰어"로 표시됩니다.


viewer.frametitleconcat

보고서 제목과 뷰어 타이틀을 연결하여 표시할지 여부를 설정합니다.

Value

true 보고서 제목과 뷰어 타이틀을 연결하여 표시

false 보고서 제목과 뷰어 타이틀을 연결하지 않고 표시 (기본 값)

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.


viewer.framewidth

오즈 뷰어 창의 너비를 설정합니다.

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.


viewer.framex

오즈 뷰어 창의 좌측 상단 위치의 X 좌표를 설정합니다.

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.


viewer.framey

오즈 뷰어 창의 좌측 상단 위치의 Y 좌표를 설정합니다.

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.


viewer.getinformation

런처와 같은 외부 프로그램에서 뷰어 실행 시 바인딩 한 결과를 받고 싶을 때 사용하는 패러미터 입니다.

Value

true 결과 받음

false 결과 받지 않음 (기본 값)

Reference

전체 페이지 수를 받을 때만 가능합니다.

<oz information> </oz information>과 같은 형태로 결과가 리턴됩니다.


viewer.id

다중 보고서에서 메인 보고서와 차일드 보고서를 보고서 트리 창에 다단계 구조로 표시할 경우 메인 보고서의 ID를 설정합니다.

Reference

차일드 보고서는 child#.viewer.parentid 패러미터를 이용하여 부모 보고서 ID를 설정하여야 합니다.

See Also

viewer.parentid


viewer.ignore_disable_color_inputcomponent

비활성화 상태인 입력 컴포넌트를 활성화 상태처럼 표시할지 여부를 설정합니다.

Value

true 모든 입력 컴포넌트를 활성화 상태처럼 표시

false 활성화 상태인 입력 컴포넌트만 활성화 상태로 표시 (기본 값)

Reference

이 패러미터는 비활성화 상태인 입력 컴포넌트의 모양을 활성화된 상태처럼 표시하고자 할 때 사용합니다.

단, PC 뷰어에서 비활성화 상태인 텍스트 박스와 NumericUpDown에 마우스 커서를 위치시키면 패러미터 값이 true이어도 비활성화된 모양으로 표시되고, 마우스 커서가 다른 영역으로 이동하면 활성화된 모양으로 표시됩니다.


viewer.imageprogressbar_imagepath

이미지 프로그레스바 창에 표시할 이미지 파일 경로를 설정합니다.

Reference

이미지는 320 x 20 크기의 이미지를 사용하시기 바랍니다. 만일, 작거나 큰 이미지로 설정한 경우 320 x 20 크기에 맞게 자동으로 확대/축소됩니다.

이미지 파일의 경로는 Http URL, File URL 등의 형식으로 설정할 수 있습니다.

만일, 이미지 경로를 공백으로 설정하거나 해당 경로에 이미지 파일이 없을 경우 기본 이미지로 표시됩니다.

See Also

viewer.useimageprogressbar


viewer.isframe

오즈 뷰어의 실행 형태를 설정합니다.

Value

true 오즈 뷰어를 별도의 창으로 실행, 웹 브라우저와 독립된 형태로 실행됨 (기본 값)

false 오즈 뷰어를 웹 브라우저의 프레임 안에서 실행, 웹 브라우저와 동일한 프로세스로 실행됨

inprocess 오즈 뷰어를 별도의 창으로 실행, 웹 브라우저와 동일한 프로세스로 실행됨

Reference

"viewer.isframe=true"로 설정하면 모든 이벤트에서 첫 번째 발생하는 이벤트만 호출되며, 두 번째 이벤트부터는 호출되지 않으니 사용 시 주의바랍니다.


viewer.ismultidocassub

다중 보고서에서 차일드 보고서를 종속적인 보고서 형태로 표시할지 여부를 설정합니다.

Value

true 종속 보고서로 설정

false 대등한 보고서로 설정 (기본 값)

Reference

"viewer.ismultidocassub=true"로 설정하면 보고서 트리 창에 표시된 메인 보고서와 차일드 보고서가 계층적인 구조로 표시됩니다.


viewer.killprocess

웹 브라우저가 종료될 때 오즈 뷰어를 함께 종료할지 여부를 설정합니다.

Value

true 웹 브라우저 종료 시 오즈 뷰어도 종료 (기본 값)

false 웹 브라우저가 종료되더라도 오즈 뷰어는 종료되지 않음

Reference

"viewer.isframe=true"인 경우에만 적용됩니다.


viewer.label_dataopr_silent

데이터 연산 에러 발생 시 라벨의 텍스트를 공백으로 표시할지 여부를 설정합니다.

Value

true 에러 발생 시 라벨의 텍스트를 공백으로 표시

false 에러 발생 시 라벨의 텍스트에 에러 내용을 표시 (기본 값)

Reference

값을 true로 설정하면 데이터 라벨, 그룹 라벨, 요약 라벨, 수식 라벨, 패러미터 라벨, 시스템 라벨을 바인딩하는 중에 데이터 필드 타입 에러, 데이터 필드 인덱스 에러, 수식 필드 스크립트 에러 등 데이터 연산 시 발생하는 에러 내용을 라벨에 표시하지 않고 공백으로 표시합니다.


viewer.largebundle

보고서의 모든 페이지를 한 페이지로 통합하여 바인딩할지 여부를 설정합니다.

Value

true 한 페이지로 표시

false 페이지별로 표시 (기본 값)


viewer.linkcommand

OZLinkCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.mailcommand

OZMailCommand 이벤트의 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.marginbottom

아래쪽 여백을 설정합니다.

Reference

단위는 pt입니다.

디자인 시 설정한 여백은 무시되고, 지정한 값으로 설정됩니다.

해당 기능을 사용하려면 viewer.autoadjustmargin을 true로 설정하시기 바랍니다.


viewer.marginleft

왼쪽 여백을 설정합니다.

Reference

단위는 pt입니다.

디자인 시 설정한 여백은 무시되고, 지정한 값으로 설정됩니다.


viewer.marginright

오른쪽 여백을 설정합니다.

Reference

단위는 pt입니다.

디자인 시 설정한 여백은 무시되고, 지정한 값으로 설정됩니다.

해당 기능을 사용하려면 viewer.autoadjustmargin을 true로 설정하시기 바랍니다.


viewer.margintop

위쪽 여백을 설정합니다.

Reference

단위는 pt입니다.

디자인 시 설정한 여백은 무시되고, 지정한 값으로 설정됩니다.


viewer.maxzoom

보고서를 확대할 수 있는 최대 비율을 설정합니다.

Reference

Android, iOS, WinRT에서는 "3000"이, 그 외 뷰어에서는 "100000"이 기본 값입니다. 단, HTML5 뷰어를 모바일 UI로 실행한 경우에는 "3000"이 기본 값입니다.


viewer.minzoom

보고서를 축소할 수 있는 최소 비율을 설정합니다.

Reference

기본 값은 20입니다.

20보다 작은 값으로 설정할 경우 기본 값인 20으로 적용됩니다.


viewer.mode

뷰어의 실행 형태를 설정합니다.

Value

export 보고서를 파일로 저장

preview 보고서를 화면에 표시 즉, 미리보기 (기본 값)

print 보고서를 인쇄

Reference

저장, 미리보기, 인쇄 작업을 한꺼번에 실행시킬 경우 콤마(,) 또는 슬래쉬(/)를 구분자로하여 값을 나열합니다. 이때 나열한 순서와 상관없이 인쇄 -> 저장 -> 미리보기 순으로 실행됩니다.


viewer.movepage

보고서 바인딩이 완료된 후 화면에 표시할 페이지 번호를 설정합니다.

Reference

기본 값은 1입니다.


viewer.namespace

실행할 오즈 뷰어의 경로를 설정합니다.


viewer.offsetstartpage

시작 페이지 번호 증감 값을 설정합니다.

Reference

기본 값은 0입니다.

설정된 값은 페이지 번호를 표시하는 라벨(시스템 라벨의 필드가 "Page_Number" 또는 "Page_of_Total"인 경우)에 적용됩니다.

시작 페이지뿐만 아니라 매 페이지에도 동일한 값이 적용되며 만일 현재 페이지 번호 + viewer.offsetstartpage 값이 0보다 작으면 공백으로 출력됩니다.

만일 멀티 보고서에 "global.concatpage=true"이고 각각의 보고서에 viewer.offsettotalpage와 이 패러미터가 설정되어 있는 경우에는 총 페이지 수는 각각의 보고서에 설정된 값을 모두 더해 차감하고 시작페이지 번호는 각각의 리포트별로 차감됩니다.


viewer.offsettotalpage

총 페이지 수 증감 값을 설정합니다.

Reference

기본 값은 0입니다.

설정된 값은 총 페이지를 표시하는 라벨(시스템 라벨의 필드가 "Total_Page" 또는 "Total_of_Total"인 경우)에 적용됩니다.


viewer.ozcommandurl

뷰어를 EXE 형식으로 실행할 때 이벤트의 값을 전달받을 웹 페이지 경로를 설정합니다.

Reference

EXE 뷰어에서 이벤트 기능을 사용하려면 이벤트를 전달받을 웹 페이지를 작성한 후 viewer.ozcommandurl 패러미터 값에 해당 웹 페이지 경로를 설정하시기 바랍니다.

이벤트를 전달받는 웹 페이지는 UTF-8로 인코딩하고, 이벤트의 리턴 값도 UTF-8로 인코딩하시기 바랍니다.

발생한 이벤트 타입은 request.getParameter("command") 함수로 리턴되며, 이벤트에서 전달되는 값은 request.getParameter("oz_args#") 함수로 리턴됩니다. oz_args#는 1부터 시작되는 일련번호로 각 이벤트마다 리턴되는 개수는 각 이벤트 설명을 참고하시기 바랍니다.

·웹 페이지 작성 예

<%@ page language="java" contentType="text/html; charset=UTF-8" pageEncoding="UTF-8"%>

...

request.setCharacterEncoding("UTF-8");

String eventType = request.getParameter("command");

...

String returnValue1 = request.getParameter("oz_args1");

String returnValue2 = request.getParameter("oz_args2");

...

See Also

뷰어 이벤트


viewer.ozresource_language

리소스 라벨에 적용할 언어를 "언어 코드_국가 코드" 형태로 설정합니다.

Reference

패러미터 값에서 설정한 "언어 코드_국가 코드"가 보고서에 추가되지 않은 경우 아래와 같은 규칙으로 리소스 언어가 적용됩니다.

1)viewer.ozresource_language 패러미터 값에서 설정한 언어 코드와 일치하는 첫 번째 리소스 언어로 적용

2)1)이 없는 경우 사용자의 시스템 언어 코드와 국가 코드가 일치하는 리소스 언어로 적용

3)1), 2)가 없는 경우 사용자의 시스템 언어 코드와 일치하는 첫 번째 리소스 언어로 적용

4)모두 없는 경우 보고서에 추가된 첫 번째 리소스 언어로 적용

설정 가능한 언어명과 국가명은 "언어 코드와 국가 코드표"를 참고하시기 바랍니다.


viewer.ozscript_dateopr_silent

오즈 스크립트 함수 중 formatDate() 함수에서 에러 발생 시 에러를 무시하고 값을 공백 문자로 리턴할지 여부를 설정합니다.

Value

true 공백 문자 리턴

false SCRIPT ERROR로 리턴 (기본 값)


viewer.ozscript_stropr_silent

오즈 스크립트 함수 중 substr(), getchar(), setchar() 등 string 함수에서 에러 발생 시 에러를 무시하고 값을 공백 문자로 리턴할지 여부를 설정합니다.

Value

true 공백 문자 리턴

false SCRIPT ERROR로 리턴 (기본 값)


viewer.pagebindcommandinterval

OZPageBindCommand 이벤트를 발생시킬 주기를 설정합니다.

Reference

설정한 발생 주기에 해당하는 페이지마다 OZPageBindCommand 이벤트가 발생하며, 마지막 페이지에서는 주기와 상관없이 OZPageBindCommand 이벤트가 발생합니다.

주기를 실수로 설정한 경우 소수점은 버림 처리됩니다.


viewer.pagechangecommand

OZPageChangeCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.pagedisplay

페이지 표시 옵션을 설정합니다.

Value

continuous 연속 보기. 뷰어 창에 보고서의 모든 페이지를 세로 및 가로 방향을 유지하여 연속된 페이지로 표시. 이전/다음 기능 실행 시 다른 페이지에 있는 컴포넌트로 이동 가능

singlepage 한 페이지씩 보기. 뷰어 창에 보고서를 한 페이지씩만 표시. 이전/다음 기능 실행 시 현재 페이지에 있는 컴포넌트만 이동 가능

singlepagecontinuous 한 페이지씩 연속 보기. 뷰어 창에 보고서의 모든 페이지를 한 페이지씩 세로 방향의 연속된 페이지로 표시. 이전/다음 기능 실행 시 다른 페이지에 있는 컴포넌트로 이동 가능

Reference

ActiveX, Applet, Flash, WPF, HTML5 뷰어에서는 "singlepage"가 기본 값이고, Android, iOS, WinRT 뷰어에서는 "singlepagecontinuous"가 기본 값입니다.

이전/다음 기능 실행 시 패러미터 값이 singlepage인 경우에도 다른 페이지에 있는 컴포넌트로 이동하려면 "viewer.pagenavigate_by_prev_next=true"로 설정하세요.


viewer.pagehorizontalalignment

페이지 수평 정렬 방식을 설정합니다.

Value

center 가운데 정렬 (기본 값)

left 왼쪽 정렬

right 오른쪽 정렬


viewer.pagenavigate_by_prev_next

입력 컴포넌트가 현재 페이지의 처음/끝일 때 이전/다음 기능을 실행하면 페이지를 이전/다음 페이지로 이동시킬지 여부를 설정합니다.

Value

true 페이지 이동 허용

false 페이지 이동 허용 안 함 (기본 값)

Reference

이 패러미터는 "viewer.pagedisplay=singlepage"인 경우에 적용됩니다.


viewer.pagenavigate_by_scroll

마우스 휠을 위/아래로 움직일 때 화면이 페이지 시작/끝에 위치하면 페이지를 이전/다음 페이지로 이동시킬지 여부를 설정합니다.

Value

true 페이지 이동 허용

false 페이지 이동 허용 안 함 (기본 값)


viewer.pageverticalalignment

페이지 수직 정렬 방식을 설정합니다.

Value

bottom 아래쪽 정렬

middle 중간 정렬

top 위쪽 정렬 (기본 값)


viewer.paper_orientation

보고서의 용지 방향을 변경합니다.

Value

빈 문자 용지 방향 변경 안 함 (기본 값)

vertical 세로로 변경

horizontal 가로로 변경

Reference

세로 방향에서 가로 방향으로 변경 시 보고서에 디자인된 밴드의 높이가 가로 방향 용지의 높이보다 클 경우 보고서가 가로 방향으로 변경되지 않습니다.

"viewer.largebundle=true"인 경우에는 적용되지 않습니다.


viewer.parentid

다중 보고서에서 메인 보고서와 차일드 보고서를 보고서 트리 창에 다단계 구조로 표시할 경우 메인 보고서 즉, 부모 보고서의 ID를 설정합니다.

Reference

설정한 ID를 가진 보고서를 찾아 해당 보고서의 차일드로 보고서 트리가 생성됩니다.


viewer.pointuptoclabel

목차 라벨이 선택될 때 라벨의 중심점 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


viewer.postcommand

OZPostCommand 이벤트로 전달할 명령어와 메시지를 설정합니다.

Reference

명령어와 메시지는 세미콜론(;)울 구분자로 하여 설정합니다.


viewer.previewstop

미리보기 시 바인딩을 중지하는 기능의 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)

Reference

"viewer.previewstop=true"로 설정하면 미리보기 시 바인딩을 중단할 수 있는 다이얼로그가 나타나며 이 다이얼로그에서 [중지] 버튼을 클릭하면 바인딩을 중지합니다.


viewer.printcommand

OZPrintCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.progresscommand

OZProgressCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.reportchangecommand

OZReportChangeCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.restore_previouszoom_doubletap

화면을 더블 탭할 때 이전 화면 비율로 복원할지 여부를 설정합니다.

Value

true 이전 비율로 화면 비율 적용 (기본 값)

false viewer.zoombydoubletap_printsize 패러미터에 설정한 비율로 화면 비율 적용

Reference

보고서 보기 모드가 fittoframe, fittowidth, fittocontents 중 하나의 상태에서 화면을 더블 탭할 때 적용할 화면 비율을 설정합니다.

패러미터 값을 true로 설정하면 사용자가 이전에 변경한 비율로 화면을 확대/축소하고, 패러미터 값을 false로 설정하면 viewer.zoombydoubletap_printsize 패러미터 값으로 화면을 확대/축소합니다.

패러미터 값이 true일 때 뷰어를 실행한 후 화면 비율을 한번도 변경하지 않은 경우 이전 비율은 인쇄 크기 기준으로 100%입니다.

See Also

viewer.viewmode


viewer.screentool

뷰어 화면의 동작 모드를 설정합니다.

Value

edit 편집 모드

hand 손 모드

multiscreenguide 안내 모드

select 선택 모드

textselect 텍스트 선택 모드

Reference

패러미터 값을 설정하지 않은 경우 리포트 템플릿의 "뷰어 모드" 속성 값으로 동작합니다.

안내 모드는 멀티 스크린 환경에서 사용자가 입력해야할 컴포넌트를 안내하는 목적으로 사용됩니다. 안내 모드는 리포트 템플릿의 "뷰어 모드" 속성에는 표시되지 않고, 뷰어 패러미터로만 설정할 수 있습니다. 안내 모드를 사용하려면 eform.usemultiscreen=true로 설정하시기 바랍니다.

안내 모드 외의 다른 모드에 대한 설명은 오즈 디자이너 도움말 중 "컴포넌트 속성 > 뷰어 모드" 부분을 참고하세요.

See Also

etcmenu.textselecttool, viewer.usetextselectmenu


viewer.scrolltotop_at_pagemoved

페이지가 이동되면 수직 스크롤을 맨 위로 이동시킬지 여부를 설정합니다.

Value

true 수직 스크롤을 맨 위로 이동

false 수직 스크롤을 맨 위로 이동 안 함 (기본 값)

Reference

"viewer.pagedisplay=singlepage"일 때만 적용됩니다.


viewer.showcontinuouspagegap

여러 페이지의 보고서를 연속적으로 표시할 때 페이지 사이의 간격 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


viewer.showerrormessage

에러 메시지 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


viewer.showpagemargin

뷰어 창과 페이지 영역 사이의 간격과 페이지의 내부 여백의 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


viewer.showtab

보고서 탭 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


viewer.showthumbnail

보고서 바인딩 완료 후 페이지 축소판 창을 화면에 바로 표시할지 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

viewer.showtree 패러미터와 이 패러미터를 모두 true로 설정한 경우에는 페이지 축소판 창이 표시됩니다.


viewer.showtree

보고서 바인딩 완료 후 보고서 트리 창을 화면에 바로 표시할지 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

이 패러미터와 viewer.showthumbnail 패러미터를 모두 true로 설정한 경우에는 페이지 축소판 창이 표시됩니다.


viewer.smartframesize

오즈 뷰어 창의 크기를 보고서 한 페이지 크기에 맞추어 표시할지 여부를 설정합니다.

Value

true 한 페이지 크기에 맞춤

false 기본 크기로 표시 (기본 값)

Reference

뷰어가 별도 윈도우로 실행되는 경우에만 유효합니다.


viewer.thumbnailsection_allowclose

페이지 축소판의 섹션바에 표시된 보고서 닫기 아이콘 클릭 시 보고서를 닫을지 여부를 설정합니다.

Value

true 보고서 닫기 (기본 값)

false 보고서 닫지 않음

Reference

이 패러미터는 보고서 닫기 아이콘 클릭 시 OZUserActionCommand와 연동하여 보고서를 닫지 않고 다른 동작을 실행하고자 할 때 사용합니다.


viewer.thumbnailsection_makerule

페이지 축소판 창에 표시할 섹션 타입을 설정합니다.

Value

byreport 보고서별로 섹션을 나눠서 표시

none 섹션 표시 안 함 (기본 값)


viewer.thumbnailsection_showclosebutton

페이지 축소판의 섹션바에 보고서 닫기 아이콘의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)

Reference

보고서 닫기 아이콘으로 보고서가 닫힐 경우 OZUserActionCommand의 Close가 호출된 후 CloseByThumbnailSection이 호출됩니다. 단, viewer.thumbnailsection_allowclose 패러미터 값을 false로 설정한 경우 보고서가 닫히지 않으므로, CloseByThumbnailSection만 호출됩니다.


viewer.thumbnailviewsize

페이지 축소판 창의 너비를 설정합니다.

Reference

기본 값은 200입니다.

Android, iOS, WinRT에서는 100 ~ 1000 사이의 값으로, 그 외 뷰어에서는 33 ~ 10000 사이의 값으로 설정 가능합니다. 단, HTML5 뷰어를 모바일 UI로 실행한 경우에는 100 ~ 1000 사이의 값으로 설정 가능합니다.


viewer.totalparam

여러 개의 뷰어 패러미터를 한꺼번에 설정합니다.

Reference

패러미터이름=패러미터값구분자패러미터이름=패러미터값... 형태로 설정하며 구분자는 viewer.totalparamseparator에 설정한 값으로 입력하여야 합니다.

이 패러미터와 일반 패러미터를 동시에 설정한 경우에는 일반 패러미터가 우선시 되어 적용됩니다.


viewer.totalparamseparator

viewer.totalparam 패러미터로 여러 개의 뷰어 패러미터를 한꺼번에 설정할 때 구분자를 설정합니다.

Reference

구분자는 하나의 단일 문자뿐만 아니라 문자열로도 설정할 수 있습니다.

이 패러미터가 설정되지 않은 경우 viewer.totalparam 패러미터는 무시됩니다.


viewer.treeviewsize

보고서 트리 창의 너비를 설정합니다.

Reference

기본 값은 200입니다.

Android, iOS, WinRT에서는 100 ~ 1000 사이의 값으로, 그 외 뷰어에서는 33 ~ 10000 사이의 값으로 설정 가능합니다. 단, HTML5 뷰어를 모바일 UI로 실행한 경우에는 100 ~ 1000 사이의 값으로 설정 가능합니다.


viewer.treeviewtitle

보고서 트리 창에 표시되는 최상위 트리의 제목을 설정합니다.

Reference

기본 값은 Oz입니다.


viewer.useeditmode

오즈 뷰어를 편집 모드로 실행합니다.

Value

true 편집 모드로 실행

false 일반 모드로 실행 (기본 값)

Reference

패러미터 값을 true로 설정하면 이동가능, 편집가능, 속성변환가능 값이 "예"인 라벨은 선택된 상태로 표시됩니다.


viewer.useimageprogressbar

이미지 프로그레스바 창의 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)

Reference

패러미터 값을 true로 설정하면 프로그레스바 창이 표시되지 않고, 움직이는 gif가 표시되는 창이 표시됩니다.

대용량 보고서를 바인딩하거나 저장 등을 실행할 때 표시되는 프로그레스바의 진행율이 멈춘 것으로 보여, 오즈 뷰어가 응답없음 상태인 것처럼 보일 수 있습니다. 이럴 경우 이미지 프로그레스바 창을 표시하여 작업이 진행 중이라는 것을 나타낼 수 있습니다.

이미지 프로그레스바 창의 이미지는 viewer.imageprogressbar_imagepath 패러미터로 변경할 수 있습니다.

패러미터 값이 true인 경우 print.useprintstop 기능이 동작하지 않습니다.


viewer.useinborder

안쪽 테두리 사용 여부를 설정합니다.

Value

true 사용 (기본 값)

false 사용 안 함


viewer.usemenubar

메뉴바 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

Reference

"viewer.isframe=false"인 경우에는 적용되지 않습니다.


viewer.useoutborder

바깥쪽 테두리 사용 여부를 설정합니다.

Value

true 사용 (기본 값)

false 사용 안 함


viewer.useprogressbar

보고서를 바인딩할 때 표시되는 프로그레스바 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


viewer.useractioncommand

OZUserActionCommand 이벤트 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)


viewer.usesaveasimagemenu

뷰어 화면에서 이미지(라벨/노트), 바코드, PDF417 바코드, QR 바코드, DataMatrix 바코드, 사용자 컴포넌트(라벨/노트), 차트, ImagePicker를 마우스 오른쪽 버튼으로 클릭 시 [다른 이름으로 이미지 저장] 팝업 메뉴의 표시 여부를 설정합니다.

Value

true 표시

false 표시 안 함 (기본 값)


viewer.usescrollbounce

스크롤 바운스 효과 사용 여부를 설정합니다.

Value

true 사용 (기본 값)

false 사용 안 함

Reference

가로 페이징 보기 시에는 이 패러미터가 동작하지 않습니다.


viewer.usestatusbar

상태바 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함


viewer.usetextselectmenu

텍스트 선택 모드 사용 여부를 설정합니다.

Value

true 사용

false 사용 안 함 (기본 값)

Reference

패러미터 값을 true로 설정하면 텍스트 선택 모드를 사용할 수 있도록 뷰어 팝업 메뉴에 [텍스트 선택 모드] 메뉴를 표시하고, 메인 메뉴의 [도구] > [텍스트 선택 모드] 메뉴가 활성화됩니다.


viewer.usetoolbar

툴바 표시 여부를 설정합니다.

Value

true 표시 (기본 값)

false 표시 안 함

Reference

Android/iOS/WinRT 뷰어에서 편집 모드 아이콘과 조회 툴바를 표시하도록 설정한 경우 viewer.usetoolbar=false인 경우에도 편집 모드 아이콘과 조회 툴바는 표시됩니다.

또한, iOS/WinRT 뷰어의 뒤로 아이콘은 viewer.usetoolbar=false인 경우에도 표시됩니다.


viewer.viewmode

보고서 보기 모드를 설정합니다.

Value

normal 실제 크기

fittoframe 화면 크기에 맞추기

fittowidth 너비에 맞추기

fittocontents 표시 내용에 맞추기

printsize 인쇄 크기

Reference

Android, iOS, WinRT에서는 "fittowidth"가 기본 값이고, 그 외 뷰어에서는 "normal"이 기본 값입니다. 단, HTML5 뷰어를 모바일 UI로 실행한 경우에는 "fittowidth"가 기본 값입니다.

실제 크기는 보고서에 설정된 표시 DPI를 기준으로 표시한 크기입니다. 실제 크기로 설정한 경우 모니터 또는 모바일 장비의 해상도에 따라 화면에 표시되는 크기가 달라집니다.

화면 크기에 맞추기는 뷰어 창의 크기에 맞추어 비율을 조정합니다.

너비에 맞추기는 뷰어 창의 너비에 맞추어 비율을 조정합니다.

표시 내용에 맞추기는 뷰어 창의 너비에 맞추어 비율을 조정합니다. 너비에 맞추기 옵션과 달리, 보고서 용지의 여백을 제외하고 맞춥니다.

인쇄 크기는 보고서가 실제 출력될 크기를 100% 비율로 표시한 크기입니다. 인쇄 크기로 설정한 경우 모니터 또는 모바일 장비의 해상도와 상관없이 동일한 크기로 표시됩니다.

실제 크기가 아닌 보고서 보기 모드에서 보고서를 확대/축소하면 보기 모드는 자동으로 실제 크기로 변경됩니다. 예를 들어, "너비에 맞추기" 상태에서 툴바의 확대/축소 아이콘을 클릭하거나 모바일에서 손가락 동작으로 비율을 조정하면 보기 모드는 "실제 크기"로 자동 변경됩니다.


viewer.zoom

보고서 화면의 비율을 백분율로 설정합니다.

Reference

기본 값은 100입니다.

"viewer.viewmode=normal"일 때만 적용됩니다.

viewer.zoom 패러미터 값을 viewer.maxzoom 패러미터 값보다 크게 설정하거나, viewer.minzoom 패러미터 값보다 작게 설정할 경우 이 패러미터 값은 100%로 적용됩니다.


viewer.zoombydoubletap_printsize

화면을 더블 탭할 때 적용할 화면 비율을 인쇄 크기 기준으로 설정합니다.

Reference

기본 값은 인쇄 크기 기준으로 100%입니다.

viewer.restore_previouszoom_doubletap=false일 때 적용됩니다.


viewer.zoombymouse

PC 환경에서는 <Ctrl + 마우스 휠> 동작으로, 모바일 환경에서는 Pinch Zoom 동작으로 보고서 확대/축소 여부를 설정합니다.

Value

true 확대/축소 가능 (기본 값)

false 확대/축소 불가


word

WORD 파일 저장 관련 상세 저장 옵션을 설정합니다.

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
word.convertedimagedpi | O | O | O | O | O | O | O | O | O
word.filename | O | O | O | O | O | O | O | O | X
word.path | O | O | X | O | X | X | O | O | X
word.saveastable | O | O | O | O | O | O | O | O | O
word.saveasxml | O | X | X | X | X | X | X | X | X
word.savelinktoc | O | O | O | O | O | O | O | O | O
word.savelinkurl | O | O | O | O | O | O | O | O | O
word.savetoheaderfooter | O | O | O | O | O | O | O | O | O
word.text_wrapping_style | O | O | O | O | O | O | O | O | O


word.convertedimagedpi

이미지로 익스포트되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


word.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


word.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


word.saveastable

테이블 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

Reference

"word.saveasxml=true"인 경우에 적용됩니다.

See Also

Word 저장 옵션 다이얼로그


word.saveasxml

XML 형식으로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Word 저장 옵션 다이얼로그


word.savelinktoc

목차 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


word.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


word.savetoheaderfooter

페이지 헤더/풋터 밴드를 워드의 머리글/바닥글에 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Word 저장 옵션 다이얼로그


word.text_wrapping_style

워드의 도형 또는 그림 서식의 레이아웃 옵션 중 배치 스타일을 설정합니다.

Value

behind_text 텍스트 뒤

in_front_of_text 텍스트 앞 (기본 값)

Reference

"word.saveasxml=true"인 경우에 적용됩니다.

보고서에 테이블로 저장되는 컴포넌트가 있고, 해당 컴포넌트와 같은 위치에 라벨, 메모, 도형이 있을 경우 XML 형식으로 저장 옵션과 테이블 형식으로 저장 옵션을 체크한 후 워드로 저장하면 테이블 위에 라벨, 메모, 도형이 표시됩니다.

이때 테이블의 텍스트를 맨 앞에 표시하려면 워드에서 도형 서식 다이얼로그를 실행한 후 레이아웃 옵션의 배치 스타일을 "텍스트 뒤"로 설정하여야 합니다.

저장된 워드 파일을 열어서 배치 스타일을 매번 변경해야 하는 번거러움을 없애려면 이 패러미터 값을 "behind_text"로 설정하시기 바랍니다.

See Also

word.saveastable


xlsx

XLSX 파일 저장 관련 상세 저장 옵션을 설정합니다.

Android/iOS 뷰어에서 XLSX 파일 형식으로 저장하려면 아래와 같은 설정이 필요합니다.

[Android]

·Eclipse 프로젝트에 라이브러리 추가

libozrvpack_xlsxwriter.so

[iOS]

·Xcode 프로젝트에 라이브러리 추가

libozrvpack_xlsxwriter.a

·스크립트 추가

해당 기능을 사용하기 전에 __OZExportPack_load_excel() 함수 호출

Available Viewers

Parameter | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
xlsx.autofit | O | O | O | O | O | O | O | O | X
xlsx.autofitheight | O | O | O | O | O | O | O | O | X
xlsx.autofitwidth | O | O | O | O | O | O | O | O | X
xlsx.convertedimagedpi | O | O | O | O | O | O | O | O | X
xlsx.filename | O | O | O | O | O | O | O | O | X
xlsx.freezepanes_column | O | O | O | O | O | O | O | O | O
xlsx.freezepanes_row | O | O | O | O | O | O | O | O | O
xlsx.insert_horizontal_pagebreaks | O | O | O | O | O | O | O | O | X
xlsx.largebundle | O | O | O | O | O | X | O | O | X
xlsx.matchmode | O | O | O | O | O | O | O | O | X
xlsx.matchsubmode | O | O | O | O | O | O | O | O | X
xlsx.minimum_cellheight | O | O | O | O | O | O | O | O | X
xlsx.minimum_cellwidth | O | O | O | O | O | O | O | O | X
xlsx.modifypassword | O | O | O | O | O | O | O | O | X
xlsx.modifypassword_username | O | O | O | O | O | O | O | O | X
xlsx.numberformat | O | O | O | O | O | O | O | O | X
xlsx.openpassword | O | O | O | O | O | O | O | O | X
xlsx.path | O | O | X | O | X | X | O | O | X
xlsx.removeblank | O | O | O | O | O | O | O | O | X
xlsx.removeoption | O | O | O | O | O | O | O | O | X
xlsx.removerange | O | O | O | O | O | O | O | O | X
xlsx.removeranges | O | O | O | O | O | O | O | O | X
xlsx.savefont | O | O | O | O | O | X | O | O | X
xlsx.savefontsize | O | O | O | O | O | O | O | O | X
xlsx.savelinkurl | O | O | O | O | O | O | O | O | X
xlsx.savemode | O | O | O | O | O | O | O | O | X
xlsx.savenumbertype | O | O | O | O | O | O | O | O | X
xlsx.savetogeneral | O | O | O | O | O | O | O | O | X
xlsx.showgridlines | O | O | O | O | O | O | O | O | X
xlsx.shrinktofit | O | O | O | O | O | O | O | O | X
xlsx.zoom | O | O | O | O | O | O | O | O | O


xlsx.autofit

자동 맞춤 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


xlsx.autofitheight

자동 맞춤 옵션 중 높이를 설정합니다.

Reference

기본 값은 1입니다.

"xlsx.autofit=true"일 때만 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.autofitwidth

자동 맞춤 옵션 중 너비를 설정합니다.

Reference

기본 값은 1입니다.

"xlsx.autofit=true"일 때만 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.convertedimagedpi

이미지로 익스포트 되는 컴포넌트의 해상도를 설정합니다.

Reference

기본값은 96이며, 단위는 dpi입니다.


xlsx.filename

파일 이름을 설정합니다.

See Also

export.applyformat, export.format

저장 다이얼로그


xlsx.freezepanes_column

틀 고정할 열 이름을 설정합니다.

Reference

A~XFD 사이의 값으로 설정합니다.


xlsx.freezepanes_row

틀 고정할 행 번호를 설정합니다.

Reference

1~1048576 사이의 값으로 설정합니다.


xlsx.insert_horizontal_pagebreaks

매 페이지마다 가로 방향으로 페이지 나누기를 추가할지 여부를 설정합니다.

Value

true 페이지 나누기 추가

false 페이지 나누기 추가 안 함 (기본 값)

Reference

엑셀의 시트에 2페이지 이상 익스포트되고 "xlsx.removeblank=false"이고 "xlsx.savemode=keepform"인 경우에 적용됩니다.


xlsx.largebundle

XLS 파일로 저장 시 기본 옵션 다이얼로그의 한페이지로 저장 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

패러미터는 모든 포맷에 공통적으로 적용되는 한페이지로 저장 옵션을 다른 포맷과 상관없이 XLS에서만 별도로 동작하도록 설정하고자 할 때 사용하시기 바랍니다.

예를 들어, xlsx.largebundle=true, export.largebundle=false로 설정하면 XLSX에서만 한페이지로 저장 옵션이 체크되고, 다른 포맷에서는 한페이지로 저장 옵션이 체크 해지됩니다.

반대의 상황도 마찬가지로 xlsx.largebundle=false, export.largebundle=true로 설정하면 XLSX에서만 한페이지로 저장 옵션이 체크 해지되고, 다른 포맷에서는 한페이지로 저장 옵션이 체크됩니다.

또한, 사용자가 한페이지로 저장 옵션을 체크하거나 체크 해지한 경우에도 위 규칙이 그대로 적용됩니다.

여러 페이지의 보고서를 한 페이지로 저장할 때 보고서를 미리보기하지 않고 바로 저장할 경우에는 "viewer.largebundle=true"로 설정하시기 바랍니다.

See Also

기본 옵션 다이얼로그


xlsx.matchmode

저장 형태 옵션을 설정합니다.

Value

columnpersheet 페이지 열별 시트 저장 (기본 값)

pagepersheet 페이지별 시트 저장

Reference

columnpersheet로 설정하면 페이지 열마다 별도의 엑셀 시트에 저장되며, pagepersheet로 설정하면 각 페이지마다 별도의 엑셀 시트로 저장됩니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.matchsubmode

페이지별 시트 저장 옵션의 페이지 저장 순서를 설정합니다.

Value

columnfirst Column 우선

rowfirst Row 우선 (기본 값)

Reference

"xlsx.matchmode=pagepersheet"인 경우에 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.minimum_cellheight

셀 최소 크기 옵션 중 높이를 설정합니다.

Reference

기본 값은 1입니다.

"xlsx.savemode=keepform"인 경우에 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.minimum_cellwidth

xlsx.minimum_cellheight

셀 최소 크기 옵션 중 너비를 설정합니다.

Reference

기본 값은 1입니다.

"xlsx.savemode=keepform"인 경우에 적용됩니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.modifypassword

XLSX 파일로 저장 시 쓰기 암호를 설정합니다.

Reference

쓰기 암호는 최대 15글자까지 설정할 수 있습니다. 15글자가 넘는 경우 암호 없이 저장됩니다.


xlsx.modifypassword_username

쓰기 암호가 설정된 XLSX 파일을 열 때 화면에 표시할 사용자 이름을 설정합니다.

Reference :

빈 문자("")로 설정 시 "noname"로 적용됩니다.


xlsx.numberformat

숫자형 텍스트를 숫자로 변환 옵션을 체크하고, 변환되는 셀의 표시 형식을 설정합니다.

Reference

기본 값은 #,##0입니다.

서식을 삭제하려면 패러미터 값을 default로 설정하시기 바랍니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.openpassword

XLSX 파일로 저장 시 열기 암호를 설정합니다.

Reference

열기 암호는 최대 255글자까지 설정할 수 있습니다. 255글자가 넘는 경우 암호 없이 저장됩니다.


xlsx.path

저장 경로를 설정합니다.

See Also

저장 다이얼로그


xlsx.removeblank

페이지 사이 공백 제거 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


xlsx.removeoption

라인 제거 옵션 중 페이지 옵션을 설정합니다.

Value

firstpageexcept 첫 페이지 제외

firstpageonly 첫 페이지만

allpage 모든 페이지 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


xlsx.removerange

라인 제거 옵션을 체크하고, 제거할 라인 범위를 "시작라인,끝라인" 형태로 설정합니다.

Reference

xlsx.removeranges 패러미터보다 우선 순위가 낮습니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.removeranges

라인 제거 옵션을 체크하고, 제거할 라인 범위를 "시작라인-끝라인,라인,시작라인-끝라인" 형태로 설정합니다.

Reference

xlsx.removerange 패러미터보다 우선 순위가 높습니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.savefont

글꼴 옵션을 설정합니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.savefontsize

글꼴 크기 옵션을 설정합니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.savelinkurl

URL 링크 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

기본 옵션 다이얼로그


xlsx.savemode

저장 방식 옵션을 설정합니다.

Value

keepform 폼 형태, 속성 유지 (기본 값)

ignoreprops 색상, 외곽라인, 셀합치기 무시

ignoreblank 분할 후 주변 셀 제거

See Also

Excel 저장 옵션 다이얼로그


xlsx.savenumbertype

표시 형식이 숫자인 라벨만 적용 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


xlsx.savetogeneral

일반(셀표시 형식)으로 변환 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

Reference

xlsx.numberformat 패러미터보다 우선 순위가 높습니다.

See Also

Excel 저장 옵션 다이얼로그


xlsx.showgridlines

눈금선 옵션 체크 여부를 설정합니다.

Value

true 체크 (기본 값)

false 체크 안 함

See Also

Excel 저장 옵션 다이얼로그


xlsx.shrinktofit

셀에 맞춤 옵션 체크 여부를 설정합니다.

Value

true 체크

false 체크 안 함 (기본 값)

See Also

Excel 저장 옵션 다이얼로그


xlsx.zoom

XLS 파일을 열 때 확대/축소 배율을 설정합니다.

Reference

기본 값은 100이며, 10~400 사이의 값으로 설정합니다.


뷰어 함수

본 장에서는 뷰어에서 사용하는 함수에 대해 설명합니다.

Available Viewers

Function | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
CreateReport | O | O | O | O | O | X | O | O | O
CreateReportEx | O | O | O | O | O | X | O | O | O
GetGlobal | O | O | O | O | O | X | O | O | O
GetInformation | O | O | O | O | O | O | O | O | O
GetMemoryStreamByExport | X | X | X | X | X | X | O | O | O
GetPaperHeight | O | O | O | O | O | O | O | O | O
GetPaperWidth | O | O | O | O | O | O | O | O | O
GetTitle | O | O | O | O | O | O | O | O | O
PingOZServer | O | O | X | O | X | X | O | O | O
ReBind | O | O | O | O | O | X | O | O | O
Script | O | O | O | O | O | O | O | O | O
ScriptEx | O | O | O | O | O | O | O | O | O
SetChartStyle | O | O | O | O | O | X | O | O | O
SetGlobal | O | O | O | O | O | X | O | O | O
TriggerExternalEvent | O | O | O | O | O | X | O | O | O
TriggerExternalEventByDocIndex | O | O | O | O | O | X | O | O | O
TriggerLocationUpdated | O | X | X | X | X | X | O | O | O
TriggerLocationUpdatedByDocIndex | O | X | X | X | X | X | O | O | O

O

Only e-Form


CreateReport

설정한 뷰어 패러미터를 기준으로 뷰어에 새로운 보고서를 바인딩합니다.

Arguments

param 오즈 뷰어 패러미터와 패러미터 값. "\n"을 구분자로 하여 "패러미터이름1=패러미터값1\n...\n패러미터이름n=패러미터값n" 형태로 설정

Reference

오즈 뷰어 패러미터를 설정할 때 필수 패러미터 즉, 서버 주소(서블릿 타입 : connection.servlet, 데몬 타입 : connection.server, connection.port)와 보고서 이름(connection.reportname)을 반드시 설정해야 합니다.


Example - ActiveX 뷰어

CreateReport Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 CreateReport 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function CreateReport() {

      OZViewer.CreateReport("connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31");

   }

</script>

</head>

<body>

<input type="button" value="매출 보고서 보기" onclick="CreateReport()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.CreateReport의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.CreateReport("...

...

<object id="OZViewer"...


Example - Applet 뷰어

CreateReport Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 CreateReport 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function CreateReport() {

      OZViewer.CreateReport("connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31");

   }

</script>

</head>

<body>

<input type="button" value="매출 보고서 보기" onclick="CreateReport()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.CreateReport의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.CreateReport("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

CreateReport Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 CreateReport 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function CreateReport() {

      OZViewer.CreateReport("connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31");

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="매출 보고서 보기" onclick="CreateReport()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.CreateReport의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.CreateReport("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

CreateReport Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 CreateReport 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "매출 보고서 보기";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

          OZViewer.CreateReport("connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31");

       }

   }

}

Additional Information: OZViewer.CreateReport의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.CreateReport("...


Example - HTML5 뷰어

CreateReport Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 CreateReport 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function CreateReport() {

      OZViewer.CreateReport("connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31");

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="매출 보고서 보기" onclick="CreateReport()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.CreateReport의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.CreateReport("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

CreateReport Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.CreateReport("connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31");

...

}

...


Example - iOS 뷰어

CreateReport Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onCreateReport:(id)sender;

...

ViewController.m

...

-(IBAction)onCreateReport:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* str_param = @"connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31";

   [self.viewer CreateReport:str_param];

}

...


Example - WinRT 뷰어

CreateReport Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

private OZReportViewer _viewer = null;

public void onCreateReport()

{

   try  {

       if (_viewer == null) {

           return;

       }

       string str_param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31";

      _viewer.CreateReport(str_param);

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try  {

       if (_viewer == nullptr) {

           return;

       }

       String^ str_param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=Sales_Report.ozr\nodi.odinames=sales\nodi.sales.pcount=2\nodi.sales.args1=fromdate=2011-01-01\nodi.sales.args2=todate=2011-01-31";

      _viewer->CreateReport(str_param);

   }

   catch (Platform::Exception^ ex) {

       String^ s = ex->Message;

   }

}


CreateReportEx

설정한 뷰어 패러미터를 기준으로 뷰어에 새로운 보고서를 바인딩합니다.

Arguments

param 오즈 뷰어 패러미터와 패러미터 값. "패러미터이름1=패러미터값1delimiter...delimiter패러미터이름n=패러미터값n" 형태로 설정

delimiter 패러미터이름=패러미터값을 구분하는 구분자. 생략 가능 (기본 값 : \n)

Reference

CreateReport 함수가 뷰어 패러미터 구분자를 무조건 "\n"으로 설정하는 것과 달리 이 함수는 구분자를 원하는 형태로 설정할 수 있습니다.

오즈 뷰어 패러미터를 설정할 때 필수 패러미터 즉, 서버 주소(서블릿 타입 : connection.servlet, 데몬 타입 : connection.server, connection.port)와 보고서 이름(connection.reportname)을 반드시 설정해야 합니다.


Example - ActiveX 뷰어

CreateReportEx Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 CreateReportEx 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function CreateReportEx() {

      OZViewer.CreateReportEx("connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31", ";");

   }

</script>

</head>

<body>

<input type="button" value="매출 보고서 보기" onclick="CreateReportEx()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.CreateReportEx의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.CreateReportEx("...

...

<object id="OZViewer"...


Example - Applet 뷰어

CreateReportEx Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 CreateReportEx 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function CreateReportEx() {

      OZViewer.CreateReportEx("connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31", ";");

   }

</script>

</head>

<body>

<input type="button" value="매출 보고서 보기" onclick="CreateReportEx()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.CreateReportEx의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.CreateReportEx("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

CreateReportEx Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 CreateReportEx 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function CreateReportEx() {

      OZViewer.CreateReportEx("connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31", ";");

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="매출 보고서 보기" onclick="CreateReportEx()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.CreateReportEx의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.CreateReportEx("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

CreateReportEx Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 CreateReportEx 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "매출 보고서 보기";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

          OZViewer.CreateReportEx("connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31", ";");

       }

   }

}

Additional Information: OZViewer.CreateReportEx의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.CreateReportEx("...


Example - HTML5 뷰어

CreateReportEx Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 CreateReportEx 함수를 사용하여 뷰어에 다른 보고서를 표시하도록 하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [매출 보고서 보기] 버튼을 클릭하면, 2011년 1월 1일부터 1월 31일까지의 매출 현황을 출력하는 Sales_Report.ozr 보고서가 뷰어에 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function CreateReportEx() {

      OZViewer.CreateReportEx("connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31", ";");

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="매출 보고서 보기" onclick="CreateReportEx()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.CreateReportEx의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.CreateReportEx("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

CreateReportEx Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.CreateReportEx("connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31", ";");

...

}

...


Example - iOS 뷰어

CreateReportEx Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onCreateReportEx:(id)sender;

...

ViewController.m

...

-(IBAction)onCreateReportEx:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* str_param = @"connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31";

   [self.viewer CreateReportEx:str_param delimiter:@";"];

}

...


Example - WinRT 뷰어

CreateReportEx Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

private OZReportViewer _viewer = null;

public void onCreateReportEx()

{

   try  {

       if (_viewer == null) {

           return;

       }

       string str_param = "connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31";

      _viewer.CreateReportEx(str_param, ";");

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onCreateReportEx();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReportEx()

{

   try  {

       if (_viewer == nullptr) {

           return;

       }

       String^ str_param = "connection.servlet=http://127.0.0.1:8080/oz/server;connection.reportname=Sales_Report.ozr;odi.odinames=sales;odi.sales.pcount=2;odi.sales.args1=fromdate=2011-01-01;odi.sales.args2=todate=2011-01-31";

      _viewer->CreateReportEx(str_param, ";");

   }

   catch (Platform::Exception^ ex) {

       String^ s = ex->Message;

   }

}


GetGlobal

전역 변수 값을 가져옵니다.

Arguments

key 전역 변수 Key

docIndex 보고서 인덱스. Zero-based index. 생략 가능 (기본 값 : 0)


Example - ActiveX 뷰어

GetGlobal Example - ActiveX 뷰어

아래 예제는 웹 페이지에 두 개의 버튼을 추가하고 버튼을 클릭하면 각각 SetGlobal/GetGlobal 함수를 사용하여 전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 HTML 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function SetGlobal() {

      OZViewer.Document.SetGlobal("company", "FORCS", 0);

       //_SetGlobal도 가능함

       //OZViewer.Document_SetGlobal("company", "FORCS", 0);

   }

   function GetGlobal() {

       var result=OZViewer.Document.GetGlobal("company", 0);

       //_GetGlobal도 가능함

       //var result=OZViewer.Document_GetGlobal("company", 0);

       alert("company : " + result);

   }

</script>

</head>

<body>

<input type="button" value="전역 변수 설정" onclick="SetGlobal()">

<input type="button" value="전역 변수 리턴" onclick="GetGlobal()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.Document.GetGlobal, OZViewer.Document_GetGlobal의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.GetGlobal("...

...

<object id="OZViewer"...


Example - Applet 뷰어

GetGlobal Example - Applet 뷰어

아래 예제는 웹 페이지에 두 개의 버튼을 추가하고 버튼을 클릭하면 각각 SetGlobal/GetGlobal 함수를 사용하여 전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 HTML 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function SetGlobal() {

      OZViewer.Document.SetGlobal("company", "FORCS", 0);

       //_SetGlobal도 가능함

       //OZViewer.Document_SetGlobal("company", "FORCS", 0);

   }

   function GetGlobal() {

       var result=OZViewer.Document.GetGlobal("company", 0);

       //_GetGlobal도 가능함

       //var result=OZViewer.Document_GetGlobal("company", 0);

       alert("company : " + result);

   }

</script>

</head>

<body>

<input type="button" value="전역 변수 설정" onclick="SetGlobal()">

<input type="button" value="전역 변수 리턴" onclick="GetGlobal()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.Document.GetGlobal, OZViewer.Document_GetGlobal의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.GetGlobal("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

GetGlobal Example - Flash 뷰어

아래 예제는 웹 페이지에 두 개의 버튼을 추가하고 버튼을 클릭하면 각각 SetGlobal/GetGlobal 함수를 사용하여 전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 HTML 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 팝업 창에 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function SetGlobal() {

      OZViewer.Document_SetGlobal("company", "FORCS", 0);

   }

   function GetGlobal() {

       var result;

       result=OZViewer.Document_GetGlobal("company", 0);

       alert("company : " + result);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="전역 변수 설정" onclick="SetGlobal()">

<input type="button" value="전역 변수 리턴" onclick="GetGlobal()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.Document_GetGlobal의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_GetGlobal("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

GetGlobal Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 SetGlobal/GetGlobal 함수를 사용하여전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 콘솔 창에 출력됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button_set = new Button();

               Button button_get = new Button();

               button_set.Content = "전역 변수 설정";

               button_get.Content = "전역 변수 리턴";

               button_set.Click += new RoutedEventHandler(button_Click_set);

               button_get.Click += new RoutedEventHandler(button_Click_get);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button_set);

               stack.Children.Add(button_get);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

void button_Click_set(object sender, RoutedEventArgs e)

       {

          OZViewer.Document.SetGlobal("company", "FORCS", 0);

           //_SetGlobal도 가능함

           //OZViewer.Document_SetGlobal("company", "FORCS", 0);

       }

       void button_Click_get(object sender, RoutedEventArgs e)

       {

           var result;

           result=OZViewer.Document.GetGlobal("company", 0);

           //_GetGlobal도 가능함

           //result=OZViewer.Document_GetGlobal("company", 0);

           Debug.WriteLine("company : " + result);

       }

   }

}

Additional Information: OZViewer.Document.GetGlobal, OZViewer.Document_GetGlobal의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.GetGlobal("...


Example - HTML5 뷰어

GetGlobal Example - HTML5 뷰어

아래 예제는 웹 페이지에 두 개의 버튼을 추가하고 버튼을 클릭하면 각각 SetGlobal/GetGlobal 함수를 사용하여 전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 HTML 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 팝업 창에 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function SetGlobal(){

      OZViewer.Document_SetGlobal("company", "FORCS", 0);

   }

   function GetGlobal(){

       var result;

       result=OZViewer.Document_GetGlobal("company", 0);

       alert("company : " + result);

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="전역 변수 설정" onclick="SetGlobal()">

<input type="button" value="전역 변수 리턴" onclick="GetGlobal()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.Document_GetGlobal의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_GetGlobal("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

GetGlobal Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

   var result = viewer.Document().GetGlobal("company", 0);

   //Document_GetGlobal도 가능함

   //var result = viewer.Document_GetGlobal("company", 0);

...

}

...


Example - iOS 뷰어

GetGlobal Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onGetGlobal:(id)sender;

...

ViewController.m

...

-(IBAction)onGetGlobal:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* result = [self.viewer.Document GetGlobal:@"company" docIndex:0];

   //Document_GetGlobal도 가능함

   //NSString* result = [self.viewer Document_GetGlobal:@"company" docIndex:0];

}

...


Example - WinRT 뷰어

GetGlobal Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onGetGlobal()

{

   if (_viewer == null) {

       return;

   }

   var result = _viewer.Document.GetGlobal("company", 0);

   //Document_GetGlobal도 가능함

   //var result = _viewer.Document_GetGlobal("company", 0);

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onGetGlobal();

MainPage.xaml.cpp

void OZWinRTViewerSample::onGetGlobal()

{

   if (_viewer == nullptr)  {

       return;

   }

   Object^ obj = _viewer->Document->GetGlobal("company", 0);

   //Document_GetGlobal도 가능함

   //Object^ obj = _viewer->Document_GetGlobal("company", 0);

}


GetInformation

오즈 뷰어의 정보를 가져옵니다.

Arguments

command 오즈 뷰어의 정보를 가져오는 명령어

Reference

오즈 뷰어의 정보를 가져오는 명령어는 다음과 같습니다.

ACCESSIBLE_PAGECONTENTS

현재 페이지의 내용

스크린 리더 프로그램이 실행 중이고, 한 페이지씩 보기일 때 현재 페이지의 내용이 리턴됨

위 경우가 아닌 경우 공백이 리턴됨

COMMENT_DRAWBORDER_COLOR

테두리 그리기에서 선택한 색

e-form에서만 지원됨

COMMENT_DRAWBORDER_TRANSPARENCY

테두리 그리기에서 선택한 테두리의 투명도

e-form에서만 지원됨

COMMENT_DRAWBORDER_THICK

테두리 그리기에서 선택한 테두리의 두께

e-form에서만 지원됨

COMMENT_FILLBACKGROUND_COLOR

바탕색 채우기에서 선택한 색

e-form에서만 지원됨

COMMENT_FILLBACKGROUND_TRANSPARENCY

바탕색 채우기에서 선택한 바탕색의 투명도

e-form에서만 지원됨

COMMENT_HIGHLIGHTPEN_COLOR

형광펜 색

RGB 값으로 "Red,Green,Blue" 형태로 리턴됨

e-form에서만 지원됨

COMMENT_HIGHLIGHTPEN_THICK

형광펜 두께

e-form에서만 지원됨

COMMENT_HIGHLIGHTPEN_TRANSPARENCY

형광펜 투명도

e-form에서만 지원됨

COMMENT_MODE

편집/주석 모드

편집 모드 또는 주석 모드인 경우 "comment", 그 외 모드인 경우 "input"으로 리턴됨

e-form에서만 지원됨

COMMENT_PEN_COLOR

펜 색

RGB 값으로 "Red,Green,Blue" 형태로 리턴됨

e-form에서만 지원됨

COMMENT_PEN_THICK

펜 두께

e-form에서만 지원됨

COMMENT_SELECTEDPEN

선택된 펜 타입

펜인 경우 "pen", 형광펜인 경우 "highlightpen", 지우개인 경우 "eraser", 테두리 그리기인 경우 “drawborder”, 바탕색 채우기인 경우 “fillbackground”로 리턴됨

e-form에서만 지원됨

CURRENT_PAGE

현재 보고서의 페이지 번호 (one-based index)

CURRENT_PAGE_AT=보고서 인덱스

지정한 보고서의 현재 페이지 번호 (one-based index)

CURRENT_REPORT_INDEX

현재 보고서 인덱스 (zero-based index)

DATA_INFO

현재 보고서의 데이터 트리에 추가된 데이터 정보를 JSON 형식의 텍스트로 가져옴

리턴되는 데이터 정보는 데이터 셋 이름, 결과 셋 행 개수, 데이터 필드 이름이며, 데이터 트리에 표시된 순서대로 리턴됨

데이터 셋의 "사용" 속성 값이 예인 경우에만 리턴됨

마스터-디테일 구조가 유지된 상태로 리턴되며, 마스터 데이터 셋의 "사용" 속성 값이 아니오인 경우 마스터와 디테일 데이터 셋은 리턴되지 않음

DATA_INFO_AT=보고서 인덱스

지정한 보고서의 데이터 트리에 추가된 데이터 정보를 JSON 형식의 텍스트로 가져옴

리턴되는 데이터 정보는 데이터 셋 이름, 결과 셋 행 개수, 데이터 필드 이름이며, 데이터 트리에 표시된 순서대로 리턴됨

데이터 셋의 "사용" 속성 값이 예인 경우에만 리턴됨

마스터-디테일 구조가 유지된 상태로 리턴되며, 마스터 데이터 셋의 "사용" 속성 값이 아니오인 경우 마스터와 디테일 데이터 셋은 리턴되지 않음

지정한 보고서에 추가된 데이터가 없거나 잘못된 인덱스를 설정한 경우 "[]"로 리턴됨

DISPLAYNAME

현재 보고서의 표시 이름

DISPLAYNAME_AT=보고서 인덱스

지정한 보고서의 표시 이름

INPUT_CHECK_VALIDITY

현재 보고서에서 OnCheckValidity 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnCheckValidity 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "valid", 실패인 경우 ""로 리턴됨

단, 현재 보고서의 OnCheckValidity 이벤트에 스크립트가 입력된 버튼이 없는 경우 "valid"로 리턴됨

명령어 실행 시 현재 보고서에 편집 중인 입력 컴포넌트가 있을 경우 편집 상태를 종료함. 이때 변경된 내용이 있을 경우 컴포넌트에 값을 적용하고 포커스를 반환함(OnValueChanged, OnKillFocus 이벤트가 호출됨)

e-form에서만 지원됨

INPUT_CHECK_VALIDITY_AT=보고서 인덱스

지정한 보고서에서 OnCheckValidity 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnCheckValidity 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "valid"로 리턴됨

실행 실패 또는 잘못된 보고서 인덱스를 설정한 경우 ""로 리턴됨

단, 지정한 보고서의 OnCheckValidity 이벤트에 스크립트가 입력된 버튼이 없는 경우 "valid"로 리턴됨

명령어 실행 시 지정한 보고서에 편집 중인 입력 컴포넌트가 있을 경우 편집 상태를 종료함. 이때 변경된 내용이 있을 경우 컴포넌트에 값을 적용하고 포커스를 반환함(OnValueChanged, OnKillFocus 이벤트가 호출됨)

e-form에서만 지원됨

INPUT_CHECK_VALIDITY_AT=보고서 인덱스,PAGE_AT=페이지 인덱스

지정한 보고서의 특정 페이지에서 OnCheckValidity 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnCheckValidity 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "valid"로 리턴됨

실행 실패 또는 잘못된 보고서 인덱스와 페이지 인덱스를 설정한 경우 ""로 리턴됨

단, 지정한 보고서의 OnCheckValidity 이벤트에 스크립트가 입력된 버튼이 없는 경우 "valid"로 리턴됨

페이지 인덱스는 one-based index로 지정해야 함

명령어 실행 시 지정한 보고서의 특정 페이지에 편집 중인 입력 컴포넌트가 있을 경우 편집 상태를 종료함. 이때 변경된 내용이 있을 경우 컴포넌트에 값을 적용하고 포커스를 반환함(OnValueChanged, OnKillFocus 이벤트가 호출됨)

e-form에서만 지원됨

INPUT_CHECK_VALIDITY_CURRENT_PAGE

현재 페이지에서 OnCheckValidity 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnCheckValidity 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "valid", 실패인 경우 ""로 리턴됨

단, 현재 페이지에 OnCheckValidity 이벤트에 스크립트가 입력된 버튼이 없는 경우 "valid"로 리턴됨

명령어 실행 시 현재 페이지에서 편집 중인 입력 컴포넌트가 있을 경우 편집 상태를 종료함. 이때 변경된 내용이 있을 경우 컴포넌트에 값을 적용하고 포커스를 반환함(OnValueChanged, OnKillFocus 이벤트가 호출됨)

e-form에서만 지원됨

INPUT_CHECK_VALIDITY_PAGE_AT=페이지 인덱스

특정 페이지에서 OnCheckValidity 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnCheckValidity 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "valid"로 리턴됨

실행 실패 또는 잘못된 페이지 인덱스를 설정한 경우 ""로 리턴됨

단, 특정 페이지에 OnCheckValidity 이벤트에 스크립트가 입력된 버튼이 없는 경우 "valid"로 리턴됨

페이지 인덱스는 one-based index로 지정해야 함

명령어 실행 시 특정 페이지에서 편집 중인 입력 컴포넌트가 있을 경우 편집 상태를 종료함. 이때 변경된 내용이 있을 경우 컴포넌트에 값을 적용하고 포커스를 반환함(OnValueChanged, OnKillFocus 이벤트가 호출됨)

e-form에서만 지원됨

INPUT_JSON

현재 보고서의 입력 값을 JSON 형식의 텍스트로 가져옴

e-form에서만 지원됨

INPUT_JSON_ALL

전체 보고서의 입력 값을 합쳐서 하나의 JSON 형식 텍스트로 가져옴

e-form에서만 지원됨

INPUT_JSON_ALL_GROUP_BY_REPORT

전체 보고서의 입력 값을 보고서별로 구분하여 JSON 형식 텍스트로 가져옴

보고서별로 {"ReportDisplayName":"보고서의 표시이름","Input":{"컴포넌트의 FormID":"값",...}} 형태로 콤마(,)를 구분자로 하여 리턴됨

e-form에서만 지원됨

INPUT_JSON_AT=보고서 인덱스,PAGE_AT=페이지 인덱스

지정한 보고서의 지정한 페이지에서 입력 값을 JSON 형식의 텍스트로 가져옴

e-form에서만 지원됨

INPUT_JSON_CURRENT_PAGE

현재 페이지의 입력 값을 JSON 형식의 텍스트로 가져옴

e-form에서만 지원됨

INPUT_TRIGGER_CLICK

현재 보고서에서 OnClick 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnClick 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "true", 실패인 경우 "false"로 리턴됨

단, 현재 보고서의 OnClick 이벤트에 스크립트가 입력된 버튼이 없는 경우 "false"로 리턴됨

e-form에서만 지원됨

INPUT_TRIGGER_CLICK_AT=보고서 인덱스

지정한 보고서에서 OnClick 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnClick 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "true", 실패인 경우 "false"로 리턴됨

단, 지정한 보고서의 OnClick 이벤트에 스크립트가 입력된 버튼이 없는 경우 "false"로 리턴됨

e-form에서만 지원됨

INPUT_TRIGGER_CLICK_CURRENT_PAGE

현재 페이지에서 OnClick 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnClick 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "true", 실패인 경우 "false"로 리턴됨

단, 현재 페이지의 OnClick 이벤트에 스크립트가 입력된 버튼이 없는 경우 "false"로 리턴됨

e-form에서만 지원됨

INPUT_TRIGGER_CLICK_PAGE_AT=페이지 인덱스

특정 페이지에서 OnClick 이벤트에 스크립트가 입력된 첫 번째 버튼을 찾아 OnClick 이벤트에 입력된 스크립트 실행 결과를 가져옴

실행 성공인 경우 "true", 실패인 경우 "false"로 리턴됨

단, 특정 페이지의 OnClick 이벤트에 스크립트가 입력된 버튼이 없는 경우 "false"로 리턴됨

페이지 인덱스는 one-based index로 지정해야 함

e-form에서만 지원됨

INPUT_XML

현재 보고서의 입력 값을 XML 형식의 텍스트로 가져옴

첫 Element가 서로 다른 경우 Root Element는 ozform으로 설정되고, 그 아래에 추가됨

e-form에서만 지원됨

INPUT_XML_ALL

전체 보고서의 입력 값을 합쳐서 하나의 XML 형식 텍스트로 가져옴

첫 Element가 서로 다른 경우 Root Element는 ozform으로 설정되고, 그 아래에 추가됨

e-form에서만 지원됨

INPUT_XML_ALL_GROUP_BY_REPORT

전체 보고서의 입력 값을 보고서별로 구분하여 XML 형식 텍스트로 가져옴

Root Element는 ozform으로 설정되고, 그 아래에 report로 보고서를 구분하고, name 속성에 보고서의 표시이름이 설정됨

e-form에서만 지원됨

INPUT_XML_AT=보고서 인덱스,PAGE_AT=페이지 인덱스

지정한 보고서의 지정한 페이지에서 입력 값을 XML 형식의 텍스트로 가져옴

e-form에서만 지원됨

INPUT_XML_CURRENT_PAGE

현재 페이지의 입력 값을 XML 형식의 텍스트로 가져옴

e-form에서만 지원됨

INVALID_INFO_JSON

현재 보고서에서 필수 입력 속성 값이 예로 설정된 입력 컴포넌트 중 값이 입력되지 않은 입력 컴포넌트의 정보를 JSON 형식의 텍스트로 가져옴

e-form에서만 지원됨

INVALID_INFO_JSON_AT=보고서 인덱스

지정한 보고서에서 필수 입력 속성 값이 예로 설정된 입력 컴포넌트 중 값이 입력되지 않은 입력 컴포넌트의 정보를 JSON 형식의 텍스트로 가져옴

e-form에서만 지원됨

REPORT_COUNT

보고서 총 개수

REPORTINDEX_BY_DISPLAYNAME=표시 이름

지정한 표시 이름을 가진 보고서 인덱스 (zero-based index)

표시 이름이 중복된 경우 보고서 트리 순서 기준으로 먼저 찾아진 보고서의 인덱스가 리턴됨

TOTAL_PAGE

전체 페이지 수

TOTAL_PAGE_AT=보고서 인덱스

지정한 보고서의 전체 페이지 수

TOTAL_PAGE_OF_REPORT_FILE_AT=보고서 파일 인덱스

보고서 파일별로 전체 페이지 수를 가져옴

보고서 파일이란, connection.reportname 또는 connection.openfile로 지정한 파일 단위임. 즉, 여러 개의 보고서를 하나의 ozd로 저장한 경우 ozd 파일에 저장된 보고서 개수와 상관없이 하나의 보고서 인덱스로 적용됨. 그러므로 보고서 파일 인덱스를 ozd 파일로 설정한 경우 ozd 파일에 저장된 모든 보고서의 전체 페이지 수를 가져옴

뷰어 바인딩이 완료된 후 링크 함수 또는 CreateReport 등으로 추가된 보고서는 페이지 수를 가져올 수 없음

Additional Information:

·"xxxx_AT=보고서 인덱스" 형태의 명령어 사용 시 보고서 인덱스는 보고서 트리를 모두 펼쳤을 때 표시된 순서 기준이며, zero-based index로 설정하여야 합니다.

·global.concatpage=true일 때 현재 보고서는 보고서 창에 표시된 현재 페이지가 속한 보고서로 적용됩니다. 예를 들어, 각각 5페이지인 3개의 보고서가 global.concatpage=true가 적용되어 하나의 보고서처럼 미리보기된 경우 7페이지가 표시된 상태에서 DISPLAYNAME 명령어를 실행하면 두 번째 보고서의 표시 이름이 리턴됩니다. 즉, DISPLAYNAME_AT=1과 동일한 결과가 리턴됩니다


Example - ActiveX 뷰어

GetInformation Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetInformation 함수를 사용하여 보고서의 전체 페이지 수를 표시하도록 하는 HTML 스크립트로,

[전체 페이지 수] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 파일의 페이지 수가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function GetInformation() {

       var pagecount;

       pagecount=OZViewer.GetInformation("TOTAL_PAGE");

       alert("전체 페이지 수 : " + pagecount);

   }

</script>

</head>

<body>

<input type="button" value="전체 페이지 수" onclick="GetInformation()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.GetInformation의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.GetInformation("...

...

<object id="OZViewer"...


Example - Applet 뷰어

GetInformation Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetInformation 함수를 사용하여 보고서의 전체 페이지 수를 표시하도록 하는 HTML 스크립트로,

[전체 페이지 수] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 파일의 페이지 수가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function GetInformation() {

       var pagecount;

       pagecount=OZViewer.GetInformation("TOTAL_PAGE");

       alert("전체 페이지 수 : " + pagecount);

   }

</script>

</head>

<body>

<input type="button" value="전체 페이지 수" onclick="GetInformation()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.GetInformation의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.GetInformation("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

GetInformation Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetInformation 함수를 사용하여 보고서의 전체 페이지 수를 표시하도록 하는 HTML 스크립트로,

[전체 페이지 수] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 파일의 페이지 수가 팝업 창에 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function GetInformation() {

       var pagecount;

       pagecount=OZViewer.GetInformation("TOTAL_PAGE");

       alert("전체 페이지 수 : " + pagecount);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="전체 페이지 수" onclick="GetInformation()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.GetInformation의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.GetInformation("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

GetInformation Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 GetInformation 함수를 사용하여 보고서의 전체 페이지 수를 출력하는 스크립트로,

[전체 페이지 수] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 파일의 페이지 수가 콘솔 창에 출력됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "전체 페이지 수";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

           Debug.WriteLine("Total_Page : " + OZViewer.GetInformation("TOTAL_PAGE"));

       }

   }

}

Additional Information: OZViewer.GetInformation의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.GetInformation("...


Example - HTML5 뷰어

GetInformation Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetInformation 함수를 사용하여 보고서의 전체 페이지 수를 표시하도록 하는 HTML 스크립트로,

[전체 페이지 수] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 파일의 페이지 수가 팝업 창에 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function GetInformation(){

       var pagecount;

       pagecount=OZViewer.GetInformation("TOTAL_PAGE");

       alert("전체 페이지 수 : " + pagecount);

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="전체 페이지 수" onclick="GetInformation()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.GetInformation의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.GetInformation("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

GetInformation Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

   String total_page = viewer.GetInformation("TOTAL_PAGE");

...

}

...


Example - iOS 뷰어

GetInformation Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onGetInformation:(id)sender;

...

ViewController.m

...

-(IBAction)onGetInformation:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* total_page = [self.viewer GetInformation:@"TOTAL_PAGE"];

}

...


Example - WinRT 뷰어

GetInformation Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onGetInfomation()

{

   if (_viewer == null)  {

       return;

   }

   string total_page = _viewer.GetInformation("TOTAL_PAGE");

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onGetInfomation();

MainPage.xaml.cpp

void OZWinRTViewerSample::onGetInfomation()

{

   if (_viewer == nullptr)  {

       return;

   }

   String^ total_page = _viewer->GetInformation("TOTAL_PAGE");

}


GetMemoryStreamByExport

보고서를 Memory Stream 방식으로 익스포트하고, 익스포트된 Stream을 임시 파일로 남기지 않고 바로 서버로 전송합니다.

Arguments

param 오즈 뷰어 패러미터와 패러미터 값. "패러미터이름1=패러미터값1delimiter...delimiter패러미터이름n=패러미터값n" 형태로 설정

delimiter 패러미터이름=패러미터값을 구분하는 구분자


Example - Android 뷰어

GetMemoryStreamByExport Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.GetMemoryStreamByExport("export.format=pdf;pdf.fontembedding=true", ";");

...

}

...


Example - iOS 뷰어

GetMemoryStreamByExport Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onGetMemoryStreamByExport:(id)sender;

...

ViewController.m

...

-(IBAction)onGetMemoryStreamByExport:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* export_param = @"export.format=pdf;pdf.fontembedding=true";

   [self.viewer GetMemoryStreamByExport:export_param delimiter:@";"];

}

...


Example - WinRT 뷰어

GetMemoryStreamByExport Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onGetMemoryStreamByExport()

{

   if (_viewer == null)  {

       return;

   }

   IDictionary<string, IRandomAccessStream> exportStream = _viewer.GetMemoryStreamByExport("export.format=pdf;pdf.fontembedding=true", ";");

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onGetMemoryStreamByExport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onGetMemoryStreamByExport()

{

   if (_viewer == nullptr)  {

       return;

   }

   IMap<String^, IRandomAccessStream^>^ exportStream = _viewer->GetMemoryStreamByExport("export.format=pdf;pdf.fontembedding=true", ";");

}


GetPaperHeight

리포트의 페이지 높이를 가져옵니다.

Reference

단위는 포인트입니다.


Example - ActiveX 뷰어

GetPaperHeight Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetPaperHeight 함수를 사용하여 페이지 높이를 표시하도록 하는 HTML 스크립트로,

[페이지 높이] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 높이가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function GetPaperHeight() {

       var paperheight;

       paperheight=OZViewer.Document.GetPaperHeight();

       //_GetPaperHeight도 가능함

       //paperheight=OZViewer.Document_GetPaperHeight();

       alert("페이지 높이 : " + paperheight);

   }

</script>

</head>

<body>

<input type="button" value="페이지 높이" onclick="GetPaperHeight()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server

       <param name="viewer.isframe" value="false">

</div>

</body>

</html>

Additional Information: OZViewer.Document.GetPaperHeight, OZViewer.Document_GetPaperHeight의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.GetPaperHeight("...

...

<object id="OZViewer"...


Example - Applet 뷰어

GetPaperHeight Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetPaperHeight 함수를 사용하여 페이지 높이를 표시하도록 하는 HTML 스크립트로,

[페이지 높이] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 높이가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function GetPaperHeight() {

       var paperheight;

       paperheight=OZViewer.Document.GetPaperHeight();

       //_GetPaperHeight도 가능함

       //paperheight=OZViewer.Document_GetPaperHeight();

       alert("페이지 높이 : " + paperheight);

   }

</script>

</head>

<body>

<input type="button" value="페이지 높이" onclick="GetPaperHeight()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.Document.GetPaperHeight, OZViewer.Document_GetPaperHeight의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.GetPaperHeight("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

GetPaperHeight Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetPaperHeight 함수를 사용하여 페이지 높이를 표시하도록 하는 HTML 스크립트로,

[페이지 높이] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 높이가 팝업 창에 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function GetPaperHeight() {

       var paperheight;

       paperheight=OZViewer.Document_GetPaperHeight();

       alert("페이지 높이 : " + paperheight);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="페이지 높이" onclick="GetPaperHeight()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.Document_GetPaperHeight의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_GetPaperHeight("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

GetPaperHeight Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 GetPaperHeight 함수를 사용하여 페이지 높이를 출력하는 스크립트로,

[페이지 높이] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 높이가 콘솔 창에 출력됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "페이지 높이";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

           Debug.WriteLine("Paper_Height : " + OZViewer.Document.GetPaperHeight());

           //_GetPaperHeight도 가능함

           //Debug.WriteLine("Paper_Height : " + OZViewer.Document_GetPaperHeight());

       }

   }

}

Additional Information: OZViewer.Document.GetPaperHeight, OZViewer.Document_GetPaperHeight의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.GetPaperHeight("...


Example - HTML5 뷰어

GetPaperHeight Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetPaperHeight 함수를 사용하여 페이지 높이를 표시하도록 하는 HTML 스크립트로,

[페이지 높이] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 높이가 팝업 창에 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function GetPaperHeight(){

       var paperheight;

       paperheight=OZViewer.Document_GetPaperHeight();

       alert("페이지 높이 : " + paperheight);

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="페이지 높이" onclick="GetPaperHeight()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.Document_GetPaperHeight의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_GetPaperHeight("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

GetPaperHeight Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

   float paper_height = viewer.Document().GetPaperHeight();

   //Document_GetPaperHeight도 가능함

   //float paper_height = viewer.Document_GetPaperHeight();

...

}

...


Example - iOS 뷰어

GetPaperHeight Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onGetPaperHeight:(id)sender;

...

ViewController.m

...

-(IBAction)onGetPaperHeight:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   float paper_height = [self.viewer.Document GetPaperHeight];

   //Document_GetPaperHeight도 가능함

   //float paper_height = [self.viewer Document_GetPaperHeight];

}

...


Example - WinRT 뷰어

GetPaperHeight Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onGetPaperHeight()

{

   if (_viewer == null)  {

       return;

   }

   double paper_height = _viewer.Document.GetPaperHeight();

   //Document_GetPaperHeight도 가능함

   //double paper_height = _viewer.Document_GetPaperHeight();

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onGetPaperHeight();

MainPage.xaml.cpp

void OZWinRTViewerSample::onGetPaperHeight()

{

   if (_viewer == nullptr)  {

       return;

   }

   double paper_height = _viewer->Document->GetPaperHeight();

   //Document_GetPaperHeight도 가능함

   //double paper_height = _viewer->Document_GetPaperHeight();

}


GetPaperWidth

리포트의 페이지 너비를 가져옵니다.

Reference

단위는 포인트입니다.


Example - ActiveX 뷰어

GetPaperWidth Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetPaperWidth 함수를 사용하여 페이지 너비를 표시하도록 하는 HTML 스크립트로,

[페이지 너비] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 너비가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function GetPaperWidth() {

       var paperwidth;

       paperwidth=OZViewer.Document.GetPaperWidth();

       //_GetPaperWidth도 가능함

       //paperwidth=OZViewer.Document_GetPaperWidth();

       alert("페이지 너비 : " + paperwidth);

   }

</script>

</head>

<body>

<input type="button" value="페이지 너비" onclick="GetPaperWidth()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="viewer.isframe" value="false">

</div>

</body>

</html>

Additional Information: OZViewer.Document.GetPaperWidth, OZViewer.Document_GetPaperWidth의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.GetPaperWidth("...

...

<object id="OZViewer"...


Example - Applet 뷰어

GetPaperWidth Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetPaperWidth 함수를 사용하여 페이지 너비를 표시하도록 하는 HTML 스크립트로,

[페이지 너비] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 너비가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function GetPaperWidth() {

       var paperwidth;

       paperwidth=OZViewer.Document.GetPaperWidth();

       //_GetPaperWidth도 가능함

       //paperwidth=OZViewer.Document_GetPaperWidth();

       alert("페이지 너비 : " + paperwidth);

   }

</script>

</head>

<body>

<input type="button" value="페이지 너비" onclick="GetPaperWidth()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.Document.GetPaperWidth, OZViewer.Document_GetPaperWidth의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.GetPaperWidth("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

GetPaperWidth Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetPaperWidth 함수를 사용하여 페이지 높이를 표시하도록 하는 HTML 스크립트로,

[페이지 너비] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 너비가 팝업 창에 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function GetPaperWidth() {

       var paperwidth;

       paperwidth=OZViewer.Document_GetPaperWidth();

       alert("페이지 너비 : " + paperwidth);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="페이지 너비" onclick="GetPaperWidth()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.Document_GetPaperWidth의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_GetPaperWidth("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

GetPaperWidth Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 GetPaperWidth 함수를 사용하여 페이지 너비를 출력하는 스크립트로,

[페이지 너비] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 너비가 콘솔 창에 출력됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "페이지 너비";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

           Debug.WriteLine("Paper_Width : " + OZViewer.Document.GetPaperWidth());

           //_GetPaperWidth도 가능함

           //Debug.WriteLine("Paper_Width : " + OZViewer.Document_GetPaperWidth());

       }

   }

}

Additional Information: OZViewer.Document.GetPaperWidth, OZViewer.Document_GetPaperWidth의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.GetPaperWidth("...


Example - HTML5 뷰어

GetPaperWidth Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetPaperWidth 함수를 사용하여 페이지 높이를 표시하도록 하는 HTML 스크립트로,

[페이지 너비] 버튼을 클릭하면 오즈 뷰어에 표시된 리포트의 페이지 너비가 팝업 창에 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function GetPaperWidth(){

       var paperwidth;

       paperwidth=OZViewer.Document_GetPaperWidth();

       alert("페이지 너비 : " + paperwidth);

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="페이지 너비" onclick="GetPaperWidth()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.Document_GetPaperWidth의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_GetPaperWidth("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

GetPaperWidth Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

   float paper_width = viewer.Document().GetPaperWidth();

   //Document_GetPaperWidth도 가능함

   //float paper_width = viewer.Document_GetPaperWidth();

...

}

...


Example - iOS 뷰어

GetPaperWidth Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onGetPaperWidth:(id)sender;

...

ViewController.m

...

-(IBAction)onGetPaperWidth:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   float paper_width = [self.viewer.Document GetPaperWidth];

   //Document_GetPaperWidth도 가능함

   //float paper_width = [self.viewer Document_GetPaperWidth];

}

...


Example - WinRT 뷰어

GetPaperWidth Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onGetPaperWidth()

{

   if (_viewer == null)  {

       return;

   }

   double paper_width = _viewer.Document.GetPaperWidth();

   //Document_GetPaperWidth도 가능함

   //double paper_width = _viewer.Document_GetPaperWidth();

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onGetPaperWidth();

MainPage.xaml.cpp

void OZWinRTViewerSample::onGetPaperWidth()

{

   if (_viewer == nullptr)  {

       return;

  }

   double paper_width = _viewer->Document->GetPaperWidth();

   //Document_GetPaperWidth도 가능함

   //double paper_width = _viewer->Document_GetPaperWidth();

}


GetTitle

리포트 템플릿의 제목 즉, 보고서의 제목을 가져옵니다.


Example - ActiveX 뷰어

GetTitle Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetTitle 함수를 사용하여 보고서의 제목을 표시하도록 하는 HTML 스크립트로,

[보고서 제목] 버튼을 클릭하면 오즈 뷰어에 표시된 보고서의 제목이 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function GetTitle() {

       var reporttitle;

       reporttitle=OZViewer.Document.GetTitle();

       //_GetTitle도 가능함

       //reporttitle=OZViewer.Document_GetTitle();

       alert("보고서 제목 : " + reporttitle);

   }

</script>

</head>

<body>

<input type="button" value="보고서 제목" onclick="GetTitle()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="viewer.isframe" value="false">

</div>

</body>

</html>

Additional Information: OZViewer.Document.GetTitle, OZViewer.Document_GetTitle의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.GetTitle("...

...

<object id="OZViewer"...


Example - Applet 뷰어

GetTitle Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetTitle 함수를 사용하여 보고서의 제목을 표시하도록 하는 HTML 스크립트로,

[보고서 제목] 버튼을 클릭하면 오즈 뷰어에 표시된 보고서의 제목이 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function GetTitle() {

       var reporttitle;

       reporttitle=OZViewer.Document.GetTitle();

       //_GetTitle도 가능함

       //reporttitle=OZViewer.Document_GetTitle();

       alert("보고서 제목 : " + reporttitle);

   }

</script>

</head>

<body>

<input type="button" value="보고서 제목" onclick="GetTitle()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.Document.GetTitle, OZViewer.Document_GetTitle의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.GetTitle("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

GetTitle Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetTitle 함수를 사용하여 보고서의 제목을 표시하도록 하는 HTML 스크립트로,

[보고서 제목] 버튼을 클릭하면 오즈 뷰어에 표시된 보고서의 제목이 팝업 창에 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function GetTitle() {

       var reporttitle;

       reporttitle=OZViewer.Document_GetTitle();

       alert("보고서 제목 : " + reporttitle);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="보고서 제목" onclick="GetTitle()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.Document_GetTitle의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_GetTitle("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

GetTitle Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 GetTitle 함수를 사용하여 보고서의 제목을 출력하는 스크립트로,

[보고서 제목] 버튼을 클릭하면 오즈 뷰어에 표시된 보고서의 제목이 콘솔 창에 출력됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "보고서 제목";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

           Debug.WriteLine("Report_Title : " + OZViewer.Document.GetTitle());

           //_GetTitle도 가능함

           //Debug.WriteLine("Report_Title : " + OZViewer.Document_GetTitle());

       }

   }

}

Additional Information: OZViewer.Document.GetTitle, OZViewer.Document_GetTitle의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.GetTitle("...


Example - HTML5 뷰어

GetTitle Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 GetTitle 함수를 사용하여 보고서의 제목을 표시하도록 하는 HTML 스크립트로,

[보고서 제목] 버튼을 클릭하면 오즈 뷰어에 표시된 보고서의 제목이 팝업 창에 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function GetTitle(){

       var reporttitle;

       reporttitle=OZViewer.Document_GetTitle();

       alert("보고서 제목 : " + reporttitle);

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="보고서 제목" onclick="GetTitle()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.Document_GetTitle의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_GetTitle("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

GetTitle Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

   String report_title = viewer.Document().GetTitle();

   //Document_GetTitle도 가능함

   //String report_title = viewer.Document_GetTitle();

...

}

...


Example - iOS 뷰어

GetTitle Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onGetTitle:(id)sender;

...

ViewController.m

...

-(IBAction)onGetTitle:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* report_title = [self.viewer.Document GetTitle];

   //Document_GetTitle도 가능함

   //NSString* report_title = [self.viewer Document_GetTitle];

}

...


Example - WinRT 뷰어

GetTitle Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onGetTitle()

{

   if (_viewer == null)  {

       return;

   }

   string report_title = _viewer.Document.GetTitle();

   //Document_GetTitle도 가능함

   //string report_title = _viewer.Document_GetTitle();

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onGetTitle();

MainPage.xaml.cpp

void OZWinRTViewerSample::onGetTitle()

{

   if (_viewer == nullptr)  {

       return;

   }

   String^ report_title = _viewer->Document->GetTitle();

   //Document_GetTitle도 가능함

   //String^ report_title = _viewer->Document_GetTitle();

}


PingOZServer

오즈 서버의 동작 여부를 확인합니다.

Arguments

ip 데몬 타입 서버의 IP

port 데몬 타입 서버의 포트 번호

url 서블릿 타입 서버의 URL


Example - ActiveX 뷰어

PingOZServer Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 PingOZServer 함수를 사용하여 오즈 서버의 동작 여부를 확인하는 HTML 스크립트로,

[오즈 서버 동작 상태 확인] 버튼을 클릭하면 오즈 서버의 동작 여부가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function PingOZServer() {

       var result=OZViewer.Document.PingOZServer("http://127.0.0.1:8080/oz/server");

       //_PingOZServer도 가능함

       //var result=OZViewer.Document_PingOZServer("http://127.0.0.1:8080/oz/server");

       if(result==true) {

           alert("오즈 서버가 동작 중입니다.");

       } else {

           alert("오즈 서버가 동작하지 않습니다.");

       }

   }

</script>

</head>

<body>

<input type="button" value="오즈 서버 동작 상태 확인" onclick="PingOZServer()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.Document.PingOZServer, OZViewer.Document_PingOZServer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.PingOZServer("...

...

<object id="OZViewer"...


Example - Applet 뷰어

PingOZServer Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 PingOZServer 함수를 사용하여 오즈 서버의 동작 여부를 확인하는 HTML 스크립트로,

[오즈 서버 동작 상태 확인] 버튼을 클릭하면 오즈 서버의 동작 여부가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function PingOZServer() {

       var result=OZViewer.Document.PingOZServer("http://127.0.0.1:8080/oz/server");

       //_PingOZServer도 가능함

       //var result=OZViewer.Document_PingOZServer("http://127.0.0.1:8080/oz/server");

       if(result==true) {

           alert("오즈 서버가 동작 중입니다.");

       } else {

           alert("오즈 서버가 동작하지 않습니다.");

       }

   }

</script>

</head>

<body>

<input type="button" value="오즈 서버 동작 상태 확인" onclick="PingOZServer()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.Document.PingOZServer, OZViewer.Document_PingOZServer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.PingOZServer("...

...

var viewerName = "OZViewer";

...


Example - WPF 뷰어

PingOZServer Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 PingOZServer 함수를 사용하여 오즈 서버의 동작 여부를 출력하는 스크립트로,

[오즈 서버 동작 상태 확인] 버튼을 클릭하면 오즈 서버의 동작 여부가 콘솔 창에 출력됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "오즈 서버 동작 상태 확인";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

           var result = OZViewer.Document.PingOZServer("http://127.0.0.1:8080/oz/server");

           //_PingOZServer도 가능함

           //var result = OZViewer.Document_PingOZServer("http://127.0.0.1:8080/oz/server");

           if(result) {

               Debug.WriteLine("오즈 서버가 동작 중입니다.");

           } else {

               Debug.WriteLine("오즈 서버가 동작하지 않습니다.");

           }

       }

   }

}

Additional Information: OZViewer.Document.PingOZServer, OZViewer.Document_PingOZServer의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.PingOZServer("...


Example - Android 뷰어

PingOZServer Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.Document().PingOZServer("http://127.0.0.1:8080/oz/server");

   //Document_PingOZServer도 가능함

   //viewer.Document_PingOZServer("http://127.0.0.1:8080/oz/server");

...

}

...


Example - iOS 뷰어

PingOZServer Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onPingOZServer:(id)sender;

...

ViewController.m

...

-(IBAction)onPingOZServer:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* url = @"http://127.0.0.1:8080/oz/server";

   [self.viewer.Document PingOZServer:url];

   //Document_PingOZServer도 가능함

   //[self.viewer Document_PingOZServer:url];

}

...


Example - WinRT 뷰어

PingOZServer Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onPingOZServer()

{

   if (_viewer == null)  {

       return;

   }

   string url = "http://127.0.0.1:8080/oz/server";

   bool ping = _viewer.Document.PingOZServer(url);

   //Document_PingOZServer도 가능함

   //bool ping = _viewer.Document_PingOZServer(url);

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onPingOZServer();

MainPage.xaml.cpp

void OZWinRTViewerSample::onPingOZServer()

{

   if (_viewer == nullptr)  {

       return;

   }

   String^ url = "http://127.0.0.1:8080/oz/server";

   bool ping = _viewer->Document->PingOZServer(url);

   //Document_PingOZServer도 가능함

   //bool ping = _viewer->Document_PingOZServer(url);

}


ReBind

보고서에 패러미터를 적용하여 다시 바인딩합니다.

보고서 다시 바인딩 시 패러미터 값에 따라 라벨의 텍스트만 변경할지, 보고서만 다시 바인딩할지, 패러미터 값을 적용하여 보고서를 다시 바인딩할지 등의 바인딩 타입을 설정할 수 있습니다.

Arguments

docIndex 보고서 인덱스 (0부터 시작)

type 보고서의 바인딩 타입

param 오즈 뷰어 패러미터와 패러미터 값. "패러미터이름1=패러미터값1delimiter...delimiter패러미터이름n=패러미터값n" 형태로 설정

delimiter 패러미터이름=패러미터값을 구분하는 구분자 (기본 값 : \n). 생략 가능

keepEditing 미리보기 화면에서 추가/변경한 내용 유지 여부 (기본 값 : true). 유지되는 내용은 주석, 메모, 콜아웃 도형, 라벨의 텍스트, 입력 컴포넌트의 값임. 생략 가능

Reference

보고서의 바인딩 타입은 다음과 같습니다.

data | 데이터와 보고서를 새로 고침 바인딩 타입을 data로 설정한 경우 패러미터 값 뿐만 아니라 패러미터 값으로 인해 변경되는 데이터 셋도 새로 고침합니다. 예를 들어, 패러미터 라벨과 패러미터 값에 따라 결과 데이터가 변경되는 테이블, 패러미터 값을 이용하는 스크립트가 추가된 보고서의 경우 패러미터 라벨의 텍스트와 스크립트의 패러미터 값, 테이블의 데이터 등 모든 내용이 새로 고침됩니다. keepEditing 아규먼트 값에 따라 미리보기 화면에서 추가 및 변경한 내용의 유지 여부가 결정됩니다.
label | 라벨의 텍스트만 새로 고침 바인딩 타입을 label로 설정한 경우 패러미터 라벨의 텍스트만 변경됩니다. 예를 들어, 패러미터 라벨과 패러미터 값을 이용하는 스크립트가 추가된 보고서의 경우 패러미터 라벨의 텍스트는 변경되나, 스크립트의 패러미터 값은 변경되지 않습니다. keepEditing 아규먼트 값이 항상 true로 동작합니다. 즉, 미리보기 화면에서 추가 및 변경한 내용이 ReBind 함수 실행 후에도 그대로 유지됩니다.
report | 보고서만 새로 고침 바인딩 타입을 report로 설정한 경우 패러미터 값만 변경하고, 패러미터 값으로 인해 변경되는 데이터 셋은 새로 고침하지 않습니다. 예를 들어, 패러미터 라벨과 패러미터 값에 따라 결과 데이터가 변경되는 테이블, 패러미터 값을 이용하는 스크립트가 추가된 보고서의 경우 패러미터 라벨의 텍스트와 스크립트의 패러미터 값은 변경되나, 테이블의 데이터는 변경되지 않습니다. keepEditing 아규먼트 값에 따라 미리보기 화면에서 추가 및 변경한 내용의 유지 여부가 결정됩니다.


Example - ActiveX 뷰어

ReBind Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 ReBind 함수를 사용하여 특정 값을 제외하고 보고서를 다시 바인딩하도록 하는 HTML 스크립트로,

[보고서 다시 바인딩] 버튼을 클릭하면 city와 gender 패러미터 값을 변경하여 데이터와 보고서를 새로 고침합니다.

<html>

<head>

<script language="JavaScript">

   function ReBind() {

       var param="connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F";

      OZViewer.ReBind(0, "data", param, ";");

   }

</script>

</head>

<body>

<input type="button" value="보고서 다시 바인딩" onclick="ReBind()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.ReBind의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.ReBind("...

...

<object id="OZViewer"...


Example - Applet 뷰어

ReBind Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 ReBind 함수를 사용하여 특정 값을 제외하고 보고서를 다시 바인딩하도록 하는 HTML 스크립트로,

[보고서 다시 바인딩] 버튼을 클릭하면 city와 gender 패러미터 값을 변경하여 데이터와 보고서를 새로 고침합니다.

<html>

<head>

<script language="JavaScript">

   function ReBind() {

       var param="connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F";

      OZViewer.ReBind(0, "data", param, ";");

   }

</script>

</head>

<body>

<input type="button" value="보고서 다시 바인딩" onclick="ReBind()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.ReBind의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.ReBind("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

ReBind Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 ReBind 함수를 사용하여 특정 값을 제외하고 보고서를 다시 바인딩하도록 하는 HTML 스크립트로,

[보고서 다시 바인딩] 버튼을 클릭하면 city와 gender 패러미터 값을 변경하여 데이터와 보고서를 새로 고침합니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function ReBind() {

       var param="connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F";

      OZViewer.ReBind(0, "data", param, ";");

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="보고서 다시 바인딩" onclick="ReBind()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.ReBind의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.ReBind("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

ReBind Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 ReBind 함수를 사용하여 특정 값을 변경하여 보고서를 다시 바인딩하도록 하는 스크립트로

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 다시 바인딩] 버튼을 클릭하면 city와 gender 패러미터 값을 변경하여 데이터와 보고서를 새로 고침합니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "보고서 다시 바인딩";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

           var param = "connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F";

          OZViewer.ReBind(0, "data", param, ";");

       }

   }

}

Additional Information: OZViewer.ReBind의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.ReBind("...


Example - HTML5 뷰어

ReBind Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 ReBind 함수를 사용하여 특정 값을 제외하고 보고서를 다시 바인딩하도록 하는 HTML 스크립트로,

[보고서 다시 바인딩] 버튼을 클릭하면 city와 gender 패러미터 값을 변경하여 데이터와 보고서를 새로 고침합니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function ReBind() {

       var param="connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F";

      OZViewer.ReBind(0, "data", param, ";");

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="보고서 다시 바인딩" onclick="ReBind()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.ReBind의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.ReBind("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

ReBind Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.ReBind(0, "data", "connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F", ";");

...

}

...


Example - iOS 뷰어

ReBind Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onReBind:(id)sender;

...

ViewController.m

...

-(IBAction)onReBind:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* str_param = @"connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F";

   [self.viewer ReBind:0 type:@"data" param:str_param delimiter:@";"];

}

...


Example - WinRT 뷰어

ReBind Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onRebind()

{

   if (_viewer == null)  {

       return;

   }

   string str_param = "connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F";

  _viewer.Rebind(0, "data", str_param, ";");

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onRebind();

MainPage.xaml.cpp

void OZWinRTViewerSample::onRebind()

{

   if (_viewer == nullptr)  {

       return;

   }

   String^ str_param = "connection.pcount=2;connection.args1=city=Seoul;connection.args2=gender=F";

  _viewer->Rebind(0, "data", str_param, ";");

}


Script

오즈 뷰어 툴바 아이콘의 기능을 제어합니다.

Arguments

command 오즈 뷰어 툴바 아이콘의 기능을 제어하는 명령어

Reference

오즈 뷰어 툴바 아이콘의 기능을 제어하는 명령어는 다음과 같습니다.

about | 오즈 리포트 뷰어 정보
attacharrow | 화살표 추가
attachcircle | 원 추가
attachimage | 이미지 추가 모바일 단말기의 앨범이 실행되며 앨범의 이미지를 선택하면 이미지가 추가됨 Android/iOS/WinRT 뷰어에서만 동작함
attachimage,pickmode=타입 | 이미지 추가 타입을 camera로 설정하면 사진을 촬영한 후 촬영된 사진이 이미지로 추가됨 타입을 album으로 설정하면 모바일 단말기의 앨범이 실행되며 앨범의 이미지를 선택하면 이미지가 추가됨(기본 값) Android/iOS/WinRT 뷰어에서만 동작함
attachline | 선 추가
attachmemo | 메모 추가
attachrectangle | 사각형 추가
bankbookprint | 통장 프린터 인쇄
close | 보고서 닫기
close_except_first_report | 첫 보고서 제외하고 닫기
closeall | 모두 닫기
closereport=인덱스 | 지정한 보고서 닫기(zero-based index) global.concatpage=true인 경우 인덱스와 상관없이 모든 보고서가 닫힘
comment_highlightpen_color | 주석 툴바의 형광펜 색 e-form에서만 지원됨
comment_highlightpen_thick | 주석 툴바의 형광펜 두께 e-form에서만 지원됨
comment_pen_color | 주석 툴바의 펜 색 e-form에서만 지원됨
comment_pen_thick | 주석 툴바의 펜 두께 e-form에서만 지원됨
commentbar_clear_all | 주석 모두 지우기 e-form에서만 지원됨
commentbar_drawborder_all | 주석 툴바의 테두리 그리기 선택 e-form에서만 지원됨
commentbar_eraser_all | 주석 툴바의 지우개 선택 e-form에서만 지원됨
commentbar_fillbackground_all | 주석 툴바의 바탕색 채우기 선택 e-form에서만 지원됨
commentbar_hand_all | 주석 툴바의 손 선택 e-form에서만 지원됨
commentbar_highlightpen_all | 주석 툴바의 형광펜 선택 e-form에서만 지원됨
commentbar_pen_all | 주석 툴바의 펜 선택 e-form에서만 지원됨
commentbar_update_all | 패러미터 값을 적용하여 주석 툴바를 업데이트 ScriptEx 함수에서 사용되는 명령어로, ScriptEx 함수의 두 번째 아규먼트에 설정된 뷰어 패러미터를 적용하여 주석 툴바를 업데이트함 e-form에서만 지원됨
continuous_all | 모든 보고서를 연속 보기
disable_input_all | 모든 보고서의 모든 입력 컴포넌트를 비활성화 상태로 변경 e-form에서만 지원됨
disable_paging_all | Android/iOS/WinRT 뷰어에서 멀티 보고서 간 가로 페이징 보기 취소 e-form에서만 지원됨
disable_zoombymouse_all | 모든 보고서의 마우스 확대/축소 기능을 비활성화
edittool | 편집 모드
enable_input_all | 모든 보고서의 모든 입력 컴포넌트를 활성화 상태로 변경 단, Enable 속성 값을 "아니오"로 설정한 컴포넌트는 적용되지 않음 e-form에서만 지원됨
enable_paging_all | Android/iOS/WinRT 뷰어에서 멀티 보고서 간 가로 페이징 보기 e-form에서만 지원됨
enable_zoombymouse_all | 모든 보고서의 마우스 확대/축소 기능을 활성화
end | 마지막 페이지로 이동
end_all | 모든 보고서를 마지막 페이지로 이동
end_report | 마지막 보고서로 이동
endedit | 입력 컴포넌트의 편집 상태 종료 변경된 내용이 있을 경우 컴포넌트에 값을 적용한 후 편집 상태를 종료하고 포커스를 반환함(OnValueChanged, OnKillFocus 이벤트가 호출됨) e-form 모바일에서만 지원됨
find | 찾기
find_silent | 찾기 다이얼로그를 실행하지 않고 바로 문자열 검색
handtool | 손 모드
hend | 수평 방향 마지막 페이지로 이동
hhome | 수평 방향 첫 페이지로 이동
hide_comment_at_inputmode_all | 주석 모드가 아닌 경우 주석을 숨김 e-form에서만 지원됨
hide_commentbar_all | Android/iOS/WinRT 뷰어에서는 편집 모드 아이콘 숨김 그 외 뷰어에서는 주석 툴바 숨김 e-form에서만 지원됨
hide_horizontalscroll_all | 모든 보고서의 가로 스크롤바를 숨김 가로 스크롤바를 숨길 경우 보고서 화면은 수평 방향 가운데로 정렬됨
hidereport=인덱스 | 지정한 보고서를 숨김 상태로 설정(zero-based index) 명령어 실행 시 페이지 번호, 트리 창, 페이지 축소판 창이 화면에 표시된 상태 기준으로 동기화됨 부모 보고서가 숨겨지는 경우 자식 보고서도 함께 숨겨짐 현재 화면에 표시된 보고서가 숨겨질 경우 다음 보고서가 화면에 표시됨. 단, 현재 화면에 표시된 보고서가 맨 마지막 보고서인 경우에는 이전 보고서가 화면에 표시됨
hnext | 수평 방향 한 페이지 다음으로 이동
home | 첫 페이지로 이동
home_all | 모든 보고서를 첫 페이지로 이동
home_report | 첫 보고서로 이동
hprev | 수평 방향 한 페이지 이전으로 이동
inputparam | 패러미터 입력
maxzoom=비율 | 확대 가능한 최대 비율 설정
maxzoom_all=비율 | 확대 가능한 최대 비율 설정(모든 보고서에 적용)
minzoom=비율 | 축소 가능한 최소 비율 설정
minzoom_all=비율 | 축소 가능한 최소 비율 설정(모든 보고서에 적용)
mode_comment_all | Android/iOS/WinRT 뷰어에서는 편집 모드로 변경 그 외 뷰어에서는 주석 모드로 변경 e-form에서만 지원됨
mode_input_all | Android/iOS/WinRT 뷰어에서는 입력 모드로 변경 그 외 뷰어에서는 주석 모드를 해제하고 이전 뷰어 모드로 변경 e-form에서만 지원됨
movepage=번호 | 지정된 페이지 번호로 이동
movereport=인덱스 | 보고서 인덱스로 이동(zero-based index)
multiscreen_mode_comment_all | 서브 모니터를 주석 모드로 변경 e-form에서만 지원됨
multiscreen_mode_input_all | 서브 모니터를 입력 모드로 변경 e-form에서만 지원됨
multiscreenguide | 안내 모드
navigator | Android/iOS/WinRT 뷰어에서는 페이지 네비게이터 표시 그 외 뷰어에서는 페이지 선택 창 표시
next | 한 페이지 다음으로 이동
next_report | 다음 보고서로 이동
open | 열기
pagesetup | 페이지 설정
paging_fittocontents | Android/iOS/WinRT 뷰어에서 가로 페이징 보기 시 보고서를 표시 내용에 맞추어 표시 e-form에서만 지원됨
paging_fittoframe | Android/iOS/WinRT 뷰어에서 가로 페이징 보기 시 보고서를 화면 크기에 맞추어 표시 e-form에서만 지원됨
paging_fittowidth | Android/iOS/WinRT 뷰어에서 가로 페이징 보기 시 보고서를 너비에 맞추어 표시 e-form에서만 지원됨
paging_nofit | Android/iOS/WinRT 뷰어에서 가로 페이징 보기 시 보기 모드를 변경하지 않음 e-form에서만 지원됨
paging_printsize | Android/iOS/WinRT 뷰어에서 가로 페이징 보기 시 보고서를 인쇄 크기로 표시 e-form에서만 지원됨
paging_zoom=비율 | Android/iOS/WinRT 뷰어에서 가로 페이징 보기 시 보고서의 줌 설정 e-form에서만 지원됨
prev | 한 페이지 이전으로 이동
prev_report | 이전 보고서로 이동
print | 인쇄
refresh | 보고서 새로 고침
resetzoom | 복원(100%)
save | 저장
save_memorystream | Memory Stream으로 저장. 저장된 결과는 OZExportMemoryStreamCallBack 이벤트에서 사용 가능 저장 후 바로 실행 기능은 동작되지 않음 출력 방향이 메일인 경우 첨부 파일 없이 메일 전송 프로그램이 실행됨
savecsv | CSV 저장
savedm | 데이터 저장
savedoc | DOC 저장
savegif | GIF 저장
savehan97 | HML 97 저장
savehtml | HTML 저장
savehwp | HWP 저장
savejpg | JPG 저장
savemht | MHT 저장
saveozd | OZD 저장
savepdf | PDF 저장
savepng | PNG 저장
saveppt | PPT 저장
savesvg | SVG 저장
savetiff | TIF 저장
savetxt | TXT 저장
savexls | XLS 저장
savexlsx | XLSX 저장
scroll_top | 스크롤을 맨 위로 이동시킴
show_comment_at_inputmode_all | 주석을 항상 표시 e-form에서만 지원됨
show_commentbar_all | Android/iOS/WinRT 뷰어에서는 편집 모드 아이콘 표시 그 외 뷰어에서는 주석 툴바 표시 e-form에서만 지원됨
show_horizontalscroll_all | 모든 보고서의 가로 스크롤바를 표시
showreport=인덱스 | 지정한 보고서의 숨김 상태를 해제(zero-based index) 명령어 실행 시 페이지 번호, 트리 창, 페이지 축소판 창이 화면에 표시된 상태 기준으로 동기화됨 지정한 보고서의 부모 보고서가 숨김 상태인 경우 다시 부모의 부모 보고서가 숨김 상태인지를 계속 추적하여 숨김 상태인 최상위 부모 보고서와 최상위 최상위 부모 보고서의 모든 자식 보고서의 숨김 상태를 해제함
showthumbnail | 페이지 축소판 보기
showtree | 보고서 트리보기
singlepage_all | 모든 보고서를 한 페이지씩 보기
singlepagecontinuous_all | 모든 보고서를 한 페이지씩 연속 보기
subscreen_active_at=보고서 인덱스 | 지정한 보고서를 서브 스크린 화면에 표시(zero-based index) e-form에서만 지원됨
subscreen_inactive_all | 서브 스크린의 모든 보고서를 비활성화 상태로 변경 e-form에서만 지원됨
textselecttool | 텍스트 선택 모드
vend | 수직 방향 마지막 페이지로 이동
vhome | 수직 방향 첫 페이지로 이동
viewfittocontents | 표시 내용에 맞추기
viewfittoframe | 화면 크기에 맞추기
viewfittowidth | 너비에 맞추기
viewnormal | 실제 크기
viewprintsize | 인쇄 크기
vnext | 수직 방향 한 페이지 다음으로 이동
vprev | 수직 방향 한 페이지 이전으로 이동
zoom=비율 | 줌 설정
zoom_all=비율 | 모든 보고서의 줌 설정
zoomin | 확대
zoomout | 축소


Example - ActiveX 뷰어

Script Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 오즈 뷰어의 툴바 아이콘을 제어하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시되고, [보고서 인쇄] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function Report_Save() {

      OZViewer.Script("save");

   }

   function Report_Print() {

      OZViewer.Script("print");

   }

</script>

</head>

<body>

<input type="button" value="보고서 저장" onclick="Report_Save()">

<input type="button" value="보고서 인쇄" onclick="Report_Print()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.Script의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Script("...

...

<object id="OZViewer"...


Example - Applet 뷰어

Script Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 오즈 뷰어의 툴바 아이콘을 제어하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시되고, [보고서 인쇄] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function Report_Save() {

      OZViewer.Script("save");

   }

   function Report_Print() {

      OZViewer.Script("print");

   }

</script>

</head>

<body>

<input type="button" value="보고서 저장" onclick="Report_Save()">

<input type="button" value="보고서 인쇄" onclick="Report_Print()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.Script의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Script("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

Script Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 오즈 뷰어의 툴바 아이콘을 제어하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시되고, [보고서 인쇄] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function Report_Save() {

      OZViewer.Script("save");

   }

   function Report_Print() {

      OZViewer.Script("print");

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="보고서 저장" onclick="Report_Save()">

<input type="button" value="보고서 인쇄" onclick="Report_Print()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.Script의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Script("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

Script Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 뷰어의 툴바 아이콘 중 저장 기능을 제어하는 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "보고서 저장";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

          OZViewer.Script("save");

       }

   }

}

Additional Information: OZViewer.Script의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Script("...


Example - HTML5 뷰어

Script Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 오즈 뷰어의 툴바 아이콘을 제어하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시되고, [보고서 인쇄] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function Report_Save(){

      OZViewer.Script("save");

   }

   function Report_Print(){

      OZViewer.Script("print");

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="보고서 저장" onclick="Report_Save()">

<input type="button" value="보고서 인쇄" onclick="Report_Print()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.Script의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Script("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

Script Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.Script("save");

...

}

...


Example - iOS 뷰어

Script Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onScript_save:(id)sender;

...

ViewController.m

...

-(IBAction)onScript_save:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   [self.viewer Script:@"save"];

}

...


Example - WinRT 뷰어

Script Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onScript_save()

{

   if (_viewer == null)  {

       return;

   }

  _viewer.Script("save");

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onScript_save();

MainPage.xaml.cpp

void OZWinRTViewerSample::onScript_save()

{

   if (_viewer == nullptr)  {

       return;

   }

  _viewer->Script("save");

}


ScriptEx

오즈 뷰어 툴바 아이콘의 기능을 제어합니다.

Arguments

command 오즈 뷰어 툴바 아이콘의 기능을 제어하는 명령어

param 오즈 뷰어 패러미터와 패러미터 값. "패러미터이름1=패러미터값1delimiter...delimiter패러미터이름n=패러미터값n" 형태로 설정

delimiter 패러미터이름=패러미터값을 구분하는 구분자. 생략 가능 (기본 값 : \n)

Reference

Script 함수가 명령어만 설정하는 것과 달리 이 함수는 명령어뿐만 아니라 패러미터와 패러미터 구분자도 설정할 수 있습니다.

오즈 뷰어 툴바 아이콘의 기능을 제어하는 명령어는 Script 함수를 참고하시기 바랍니다.

함수 실행 시 두 번째 아규먼트에 주석 패러미터를 설정하여 주석 툴바에 적용시키려면 함수의 첫 번째 아규먼트를 아래 명령어 중 하나로 설정하여야 합니다.

·commentbar_clear_all

·commentbar_highlightpen_all

·commentbar_pen_all

·commentbar_update_all

·hide_comment_at_inputmode_all

·hide_commentbar_all

·mode_comment_all

·mode_input_all

·show_comment_at_inputmode_all

·show_commentbar_all


Example - ActiveX 뷰어

ScriptEx Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 ScriptEx 함수를 사용하여 오즈 뷰어의 툴바 아이콘을 제어하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시되고, [보고서 인쇄] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function Report_Save() {

      OZViewer.ScriptEx("save", "export.applyformat=xls;excel.path=c:\\temp\;excel.filename=sample.xls", ";");

   }

   function Report_Print() {

      OZViewer.ScriptEx("print", "print.copies=2;print.pagerange=current;print.lockopt=true", ";");

   }

</script>

</head>

<body>

<input type="button" value="보고서 저장" onclick="Report_Save()">

<input type="button" value="보고서 인쇄" onclick="Report_Print()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.ScriptEx의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.ScriptEx("...

...

<object id="OZViewer"...


Example - Applet 뷰어

ScriptEx Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 ScriptEx 함수를 사용하여 오즈 뷰어의 툴바 아이콘을 제어하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시되고, [보고서 인쇄] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function Report_Save() {

      OZViewer.ScriptEx("save", "export.applyformat=xls;excel.path=c:\\temp\;excel.filename=sample.xls", ";");

   }

   function Report_Print() {

      OZViewer.ScriptEx("print", "print.copies=2;print.pagerange=current;print.lockopt=true", ";");

   }

</script>

</head>

<body>

<input type="button" value="보고서 저장" onclick="Report_Save()">

<input type="button" value="보고서 인쇄" onclick="Report_Print()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.ScriptEx의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.ScriptEx("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

ScriptEx Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 ScriptEx 함수를 사용하여 오즈 뷰어의 툴바 아이콘을 제어하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시되고, [보고서 인쇄] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function Report_Save() {

      OZViewer.ScriptEx("save", "export.applyformat=xls;excel.filename=sample.xls", ";");

   }

   function Report_Print() {

      OZViewer.ScriptEx("print", "print.copies=2;print.pagerange=current;print.lockopt=true", ";");

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="보고서 저장" onclick="Report_Save()">

<input type="button" value="보고서 인쇄" onclick="Report_Print()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.ScriptEx의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.ScriptEx("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

ScriptEx Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 ScriptEx 함수를 사용하여 뷰어의 툴바 아이콘 중 저장 기능을 제어하는 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "보고서 저장";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

          OZViewer.ScriptEx("save", "export.applyformat=xls;excel.path=c:\\temp\;excel.filename=sample.xls", ";");

       }

   }

}

Additional Information: OZViewer.ScriptEx의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.ScriptEx("...


Example - HTML5 뷰어

ScriptEx Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 ScriptEx 함수를 사용하여 오즈 뷰어의 툴바 아이콘을 제어하는 HTML 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [보고서 저장] 버튼을 클릭하면 저장 다이얼로그가 표시되고, [보고서 인쇄] 버튼을 클릭하면 인쇄 다이얼로그가 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function Report_Save() {

      OZViewer.ScriptEx("save", "export.applyformat=xls;excel.filename=sample.xls", ";");

   }

   function Report_Print() {

      OZViewer.ScriptEx("print", "print.copies=2;print.pagerange=current;print.lockopt=true", ";");

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="보고서 저장" onclick="Report_Save()">

<input type="button" value="보고서 인쇄" onclick="Report_Print()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.ScriptEx의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.ScriptEx("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

ScriptEx Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.ScriptEx("save", "export.applyformat=xls;excel.autofit=true", ";");

...

}

...


Example - iOS 뷰어

ScriptEx Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onScriptEx_save:(id)sender;

...

ViewController.m

...

-(IBAction)onScriptEx_save:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* str_param = @"export.applyformat=xls;excel.autofit=true";

   [self.viewer ScriptEx:@"save" param:str_param delimiter:@";"];

}

...


Example - WinRT 뷰어

ScriptEx Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onScriptEx_save()

{

   if (_viewer == null)  {

       return;

   }

   string str_param = "export.applyformat=xls;excel.autofit=true";

  _viewer.ScriptEx("save", str_param, ";");

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onScriptEx_save();

MainPage.xaml.cpp

void OZWinRTViewerSample::onScriptEx_save()

{

   if (_viewer == nullptr)  {

       return;

   }

   String^ str_param = "export.applyformat=xls;excel.autofit=true";

  _viewer->ScriptEx("save", str_param, ";");

}


SetChartStyle

차트 타입을 변경합니다.

Arguments

type 차트 타입

Reference

변경 가능한 차트 타입은 다음과 같습니다.

type | 차트 타입
Gauge | 게이지
HArea | 수평 범위
HArea_3D_Accumulative | 수평 범위 (3D, 누적)
HArea_3D_Percent | 수평 범위 (3D, 퍼센트 표시)
HArea_Accumulative | 수평 범위 (누적)
HArea_Percent | 수평 범위 (퍼센트 표시)
HBar_3D_Accumulative | 수평 막대 (3D, 누적)
HBar_3D_Bundle | 수평 막대 (3D, 묶음)
HBar_3D_Percent | 수평 막대 (3D, 퍼센트 표시)
HBar_Acumulative | 수평 막대 (누적)
HBar_Bundle | 수평 막대 (묶음)
HBar_Percent | 수평 막대 (퍼센트 표시)
HCone_3D_Accumulative | 수평 원뿔 (3D, 누적)
HCone_3D_Bundle | 수평 원뿔 (3D, 묶음)
HCone_3D_Percent | 수평 원뿔 (3D, 퍼센트 표시)
HCustom | 수평 사용자정의
HCustom_Accumulative | 수평 사용자정의 (누적)
HCustom_Percent | 수평 사용자정의 (퍼센트 표시)
HCylinder | 수평 원기둥
HCylinder_3D_Accumulative | 수평 원기둥 (3D, 누적)
HCylinder_3D_Bundle | 수평 원기둥 (3D, 묶음)
HCylinder_3D_Percent | 수평 원기둥 (3D, 퍼센트 표시)
HCylinder_Accumulative | 수평 원기둥 (누적)
HCylinder_Percent | 수평 원기둥 (퍼센트 표시)
HLine | 수평 라인
HLine_Accumulative | 수평 라인 (누적)
HLine_Accumulative_NoPoint | 수평 라인 (누적, 교점 표시 없음)
HLine_NoPoint | 수평 라인 (교점 표시 없음)
HLine_Percent | 수평 라인 (퍼센트 표시)
HLine_Percent_NoPoint | 수평 라인 (퍼센트 표시, 교점 표시 없음)
HPoint | 수평 포인트
HPoint_Accumulative | 수평 포인트 (누적)
HPoint_Percent | 수평 포인트 (퍼센트 표시)
HPyramid_3D_Accumulative | 수평 피라미드 (3D, 누적)
HPyramid_3D_Bundle | 수평 피라미드 (3D, 묶음)
HPyramid_3D_Percent | 수평 피라미드 (3D, 퍼센트표시)
HStep | 수평 계단형
Pie | 파이
Pie_3D | 파이 (3D)
Pie_Split | 파이 (분리)
Pie_Split_3D | 파이 (분리, 3D)
Radiant | 라디안 스타일
Radiant_Accumulative | 라디안 스타일 (누적)
Radiant_Accumulative_NoPoint | 라디안 스타일 (누적, 교점표시 없음)
Radiant_NoPoint | 라디안 스타일 (교점표시 없음)
Radiant_Percent | 라디안 (퍼센트 표시)
Radiant_Percent_NoPoint | 라디안 (퍼센트 표시, 교점표시 없음)
VArea | 수직 범위
VArea_3D | 수직 범위 (3D)
VArea_3D_Accumulative | 수직 범위 (3D, 누적)
VArea_3D_Percent | 수직 범위 (3D, 퍼센트 표시)
VArea_3D_Zwise | 수직 범위 (3D, 계열 및 항목 값 비교)
VArea_Accumulative | 수직 범위 (누적)
VArea_Percent | 수직 범위 (퍼센트 표시)
VArea_Rotational_3D | 수직 범위 (회전, 3D)
VArea_Rotational_3D_Zwise | 수직 범위 (회전, 3D, 계열 및 항목 값 비교)
VBar | 수직 막대
VBar_3D | 수직 막대 (3D)
VBar_3D_Accumulative | 수직 막대 (3D, 누적)
VBar_3D_Bundle | 수직 막대 (3D, 묶음)
VBar_3D_Percent | 수직 막대 (3D, 퍼센트 표시)
VBar_3D_Zwise | 수직 막대 (3D, 계열 및 항목 값 비교)
VBar_Accumulative | 수직 막대 (누적)
VBar_Percent | 수직 막대 (퍼센트 표시)
VBar_Rotational_3D | 수직 막대 (회전, 3D)
VBar_Rotational_3D_Zwise | 수직 막대 (회전, 3D, 계열 및 항목 값 비교)
VCone_3D | 수직 원뿔 (3D)
VCone_3D_Accumulative | 수직 원뿔 (3D, 누적)
VCone_3D_Bundle | 수직 원뿔 (3D, 묶음)
VCone_3D_Percent | 수직 원뿔 (3D, 퍼센트표시)
VCone_3D_Zwise | 수직 원뿔 (3D, 계열 및 항목 값 비교)
VCustom | 수직 사용자 정의
VCustom_Accumulative | 수직 사용자 정의 (누적)
VCustom_Percent | 수직 사용자 정의 (퍼센트 표시)
VCylinder | 수직 원 기둥
VCylinder_3D | 수직 원 기둥 (3D)
VCylinder_3D_Accumulative | 수직 원 기둥 (3D, 누적)
VCylinder_3D_Bundle | 수직 원 기둥 (3D, 묶음)
VCylinder_3D_Percent | 수직 원 기둥 (3D, 퍼센트 표시)
VCylinder_3D_Zwise | 수직 원 기둥 (3D, 계열 및 항목 값 비교)
VCylinder_Accumulative | 수직 원 기둥 (누적)
VCylinder_Percent | 수직 원 기둥 (퍼센트 표시)
VLine | 수직 라인
VLine_3D | 수직 라인 (3D)
VLine_3D_Zwise | 수직 라인 (3D, 계열 및 항목 값 비교)
VLine_Accumulative | 수직 라인 (누적)
VLine_Accumulative_NoPoint | 수직 라인 (누적, 교점 표시 없음)
VLine_NoPoint | 수직 라인 (교점 표시 없음)
VLine_Parcent | 수직 라인 (퍼센트 표시)
VLine_Parcent_NoPoint | 수직 라인 (퍼센트 표시, 교점 표시 없음)
VLine_Rotational_3D | 수직 라인 (회전, 3D)
VLine_Rotational_3D_Zwise | 수직 라인 (회전, 3D, 계열 및 항목 값 비교)
VPoint | 수직 포인트
VPoint_Accumulative | 수직 포인트 (누적)
VPoint_Percent | 수직 포인트 (퍼센트 표시)
VPyramid_3D | 수직 피라미드 (3D)
VPyramid_3D_Accumulative | 수직 피라미드 (3D, 누적)
VPyramid_3D_Bundle | 수직 피라미드 (3D, 묶음)
VPyramid_3D_Percent | 수직 피라미드 (3D, 퍼센트 표시)
VPyramid_3D_Zwise | 수직 피라미드 (3D, 계열 및 항목 값 비교)
VScatter | 분산형
VScatter_Line | 분산형 (꺽은선 연결)
VScatter_Line_NoPoint | 분산형 (꺽은선 연결, 교점 표시 없음)
VStep | 계단형


Example - ActiveX 뷰어

SetChartStyle Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 SetChartStyle 함수를 사용하여 보고서에 포함된 차트의 타입을 변경하는 HTML 스크립트로,

[차트 타입 변경] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 보고서의 차트가 묶은 가로 막대형 차트로 변경됩니다.

<html>

<head>

<script language="JavaScript">

   function SetChartStyle() {

      OZViewer.Document.SetChartStyle("HBar_Bundle");

       //_SetChartStyle도 가능함

       //OZViewer.Document_SetChartStyle("HBar_Bundle");

   }

</script>

</head>

<body>

<input type="button" value="차트 타입 변경" onclick="SetChartStyle()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.Document.SetChartStyle, OZViewer.Document_SetChartStyle의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.SetChartStyle("...

...

<object id="OZViewer"...


Example - Applet 뷰어

SetChartStyle Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 SetChartStyle 함수를 사용하여 보고서에 포함된 차트의 타입을 변경하는 HTML 스크립트로,

[차트 타입 변경] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 보고서의 차트가 묶은 가로 막대형 차트로 변경됩니다.

<html>

<head>

<script language="JavaScript">

   function SetChartStyle() {

      OZViewer.Document.SetChartStyle("HBar_Bundle");

       //_SetChartStyle도 가능함

       //OZViewer.Document_SetChartStyle("HBar_Bundle");

   }

</script>

</head>

<body>

<input type="button" value="차트 타입 변경" onclick="SetChartStyle()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.Document.SetChartStyle, OZViewer.Document_SetChartStyle의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.SetChartStyle("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

SetChartStyle Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 SetChartStyle 함수를 사용하여 보고서에 포함된 차트의 타입을 변경하는 HTML 스크립트로,

[차트 타입 변경] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 보고서의 차트가 묶은 가로 막대형 차트로 변경됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function SetChartStyle() {

      OZViewer.Document_SetChartStyle("HBar_Bundle");

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="차트 타입 변경" onclick="SetChartStyle()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.Document_SetChartStyle의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_SetChartStyle("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

SetChartStyle Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 SetChartStyle 함수를 사용하여 차트 타입을 변경하는 스크립트로,

뷰어에 sample.ozr 보고서가 표시된 상태에서 [차트 타입 변경] 버튼을 클릭하면 차트 타입이 묶은 가로 막대형으로 변경됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "차트 타입 변경";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

          OZViewer.Document.SetChartStyle("HBar_Bundle");

           //_SetChartStyle도 가능함

           //OZViewer.Document_SetChartStyle("HBar_Bundle");

       }

   }

}

Additional Information: OZViewer.Document.SetChartStyle, OZViewer.Document_SetChartStyle의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.SetChartStyle("...


Example - HTML5 뷰어

SetChartStyle Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 SetChartStyle 함수를 사용하여 보고서에 포함된 차트의 타입을 변경하는 HTML 스크립트로,

[차트 타입 변경] 버튼을 클릭하면 오즈 뷰어에 표시된 sample.ozr 보고서의 차트가 묶은 가로 막대형 차트로 변경됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function SetChartStyle() {

      OZViewer.Document_SetChartStyle("HBar_Bundle");

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="차트 타입 변경" onclick="SetChartStyle()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.Document_SetChartStyle "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_SetChartStyle("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

SetChartStyle Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.Document().SetChartStyle("HBar_Bundle");

   //Document_SetChartStyle도 가능함

   //viewer.Document_SetChartStyle("HBar_Bundle");

...

}

...


Example - iOS 뷰어

SetChartStyle Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onSetChartStyle:(id)sender;

...

ViewController.m

...

-(IBAction)onSetChartStyle:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* style = @"HBar_Bundle";

   [self.viewer.Document SetChartStyle:style];

   //Document_SetChartStyle도 가능함

   //[self.viewer Document_SetChartStyle:style];

}

...


Example - WinRT 뷰어

SetChartStyle Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onSetChartStyle()

{

   if (_viewer == null)  {

       return;

   }

   string style = "HBar_Bundle";

  _viewer.Document.SetChartStyle(style);

   //Document_SetChartStyle도 가능함

   //_viewer.Document_SetChartStyle(style);

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onSetChartStyle();

MainPage.xaml.cpp

void OZWinRTViewerSample::onSetChartStyle()

{

   if (_viewer == nullptr)  {

       return;

   }

   String^ style = "HBar_Bundle";

  _viewer->Document->SetChartStyle(style);

   //Document_SetChartStyle도 가능함

   //_viewer->Document_SetChartStyle(style);

}


SetGlobal

전역 변수 값을 설정합니다.

Arguments

key 전역 변수 Key

value 전역 변수 값

docIndex 보고서 인덱스. Zero-based index. 생략 가능 (기본 값 : 0)


Example - ActiveX 뷰어

SetGlobal Example - ActiveX 뷰어

아래 예제는 웹 페이지에 두 개의 버튼을 추가하고 버튼을 클릭하면 각각 SetGlobal/GetGlobal 함수를 사용하여 전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 HTML 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function SetGlobal() {

      OZViewer.Document.SetGlobal("company", "FORCS", 0);

       //_SetGlobal도 가능함

       //OZViewer.Document_SetGlobal("company", "FORCS", 0);

   }

   function GetGlobal() {

       var result=OZViewer.Document.GetGlobal("company", 0);

       //_GetGlobal도 가능함

       //var result=OZViewer.Document_GetGlobal("company", 0);

       alert("company : " + result);

   }

</script>

</head>

<body>

<input type="button" value="전역 변수 설정" onclick="SetGlobal()">

<input type="button" value="전역 변수 리턴" onclick="GetGlobal()">

<br>

<br>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZViewer.Document.SetGlobal, OZViewer.Document_SetGlobal의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.SetGlobal("...

...

<object id="OZViewer"...


Example - Applet 뷰어

SetGlobal Example - Applet 뷰어

아래 예제는 웹 페이지에 두 개의 버튼을 추가하고 버튼을 클릭하면 각각 SetGlobal/GetGlobal 함수를 사용하여 전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 HTML 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 팝업 창에 표시됩니다.

<html>

<head>

<script language="JavaScript">

   function SetGlobal() {

      OZViewer.Document.SetGlobal("company", "FORCS", 0);

       //_SetGlobal도 가능함

       //OZViewer.Document_SetGlobal("company", "FORCS", 0);

   }

   function GetGlobal() {

       var result=OZViewer.Document.GetGlobal("company", 0);

       //_GetGlobal도 가능함

       //var result=OZViewer.Document_GetGlobal("company", 0);

       alert("company : " + result);

   }

</script>

</head>

<body>

<input type="button" value="전역 변수 설정" onclick="SetGlobal()">

<input type="button" value="전역 변수 리턴" onclick="GetGlobal()">

<br>

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZViewer.Document.SetGlobal, OZViewer.Document_SetGlobal의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.SetGlobal("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

SetGlobal Example - Flash 뷰어

아래 예제는 웹 페이지에 두 개의 버튼을 추가하고 버튼을 클릭하면 각각 SetGlobal/GetGlobal 함수를 사용하여 전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 HTML 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 팝업 창에 표시됩니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function SetGlobal() {

      OZViewer.Document_SetGlobal("company", "FORCS", 0);

   }

   function GetGlobal() {

       var result;

       result=OZViewer.Document_GetGlobal("company", 0);

       alert("company : " + result);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="전역 변수 설정" onclick="SetGlobal()">

<input type="button" value="전역 변수 리턴" onclick="GetGlobal()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZViewer.Document_SetGlobal의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_SetGlobal("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

SetGlobal Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 SetGlobal/GetGlobal 함수를 사용하여전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 콘솔 창에 출력됩니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbeded

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> params = new Dictionary<string, string>();

           params.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           params.Add("connection.reportname", "sample.ozr");

           params.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events) =>

               {

                   Debug.WriteLine(events.ToString());

               };

               OZViewer = OZReportAPI.getOZReport(params);

               OZViewer.init(handler);

               Button button_set = new Button();

               Button button_get = new Button();

               button_set.Content = "전역 변수 설정";

               button_get.Content = "전역 변수 리턴";

               button_set.Click += new RoutedEventHandler(button_Click_set);

               button_get.Click += new RoutedEventHandler(button_Click_get);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button_set);

               stack.Children.Add(button_get);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

void button_Click_set(object sender, RoutedEventArgs e)

       {

          OZViewer.Document.SetGlobal("company", "FORCS", 0);

           //_SetGlobal도 가능함

           //OZViewer.Document_SetGlobal("company", "FORCS", 0);

       }

       void button_Click_get(object sender, RoutedEventArgs e)

       {

           var result;

           result=OZViewer.Document.GetGlobal("company", 0);

           //_GetGlobal도 가능함

           //result=OZViewer.Document_GetGlobal("company", 0);

           Debug.WriteLine("company : " + result);

       }

   }

}

Additional Information: OZViewer.Document.SetGlobal, OZViewer.Document_SetGlobal의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.SetGlobal("...


Example - HTML5 뷰어

SetGlobal Example - HTML5 뷰어

아래 예제는 웹 페이지에 두 개의 버튼을 추가하고 버튼을 클릭하면 각각 SetGlobal/GetGlobal 함수를 사용하여 전역 변수 값을 설정하고, 설정한 전역 변수의 값을 표시하도록 하는 HTML 스크립트로,

[전역 변수 설정] 버튼을 클릭하면 전역 변수를 설정하고, [전역 변수 리턴] 버튼을 클릭하면 설정된 전역 변수가 팝업 창에 표시됩니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function SetGlobal(){

      OZViewer.Document_SetGlobal("company", "FORCS", 0);

   }

   function GetGlobal(){

       var result;

       result=OZViewer.Document_GetGlobal("company", 0);

       alert("company : " + result);

   }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="전역 변수 설정" onclick="SetGlobal()">

<input type="button" value="전역 변수 리턴" onclick="GetGlobal()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZViewer.Document_SetGlobal의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_SetGlobal("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

SetGlobal Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

  viewer.Document().SetGlobal("company", "FORCS", 0);

   //Document_SetGlobal도 가능함

   //viewer.Document_SetGlobal("company", "FORCS", 0);

...

}

...


Example - iOS 뷰어

SetGlobal Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onSetGlobal:(id)sender;

...

ViewController.m

...

-(IBAction)onSetGlobal:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   [self.viewer.Document SetGlobal:@"company" value:@"FORCS" docIndex:0];

   //Document_SetGlobal도 가능함

   //[self.viewer Document_SetGlobal:@"company" value:@"FORCS" docIndex:0];

}

...


Example - WinRT 뷰어

SetGlobal Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onSetGlobal()

{

   if (_viewer == null)  {

       return;

   }

   var result = _viewer.Document.SetGlobal("company", "FORCS", 0);

   //Document_SetGlobal도 가능함

   //var result = _viewer.Document_SetGlobal("company", "FORCS", 0);

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onSetGlobal();

MainPage.xaml.cpp

void OZWinRTViewerSample::onSetGlobal()

{

   if (_viewer == nullptr)  {

       return;

   }

  _viewer->Document->SetGlobal("company", "FORCS", 0);

   //Document_SetGlobal도 가능함

   //_viewer->Document_SetGlobal("company", "FORCS", 0);

}


TriggerExternalEvent

현재 보고서의 OnExternalEvent 이벤트를 실행하고, OnExternalEvent 이벤트에서 전달한 값을 string 형태로 리턴받습니다.

Arguments

param1 OnExternalEvent로 전달할 첫 번째 값. 생략 가능 (기본 값 : "")

param2 OnExternalEvent로 전달할 두 번째 값. 생략 가능 (기본 값 : "")

param3 OnExternalEvent로 전달할 세 번째 값. 생략 가능 (기본 값 : "")

param4 OnExternalEvent로 전달할 네 번째 값. 생략 가능 (기본 값 : "")


Example - ActiveX 뷰어

TriggerExternalEvent Example - ActiveX 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEvent 함수를 사용하여 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

<html>

<head>

   <script language="JavaScript">

       function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname, mainscreen) {

           if(eventname == "OnValueChanged" && formid == "Married") {

              OZViewer.Document.TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

               //_TriggerExternalEvent도 가능함

               //OZViewer.Document_TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

           }

       }

   </script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

       <param name="eform.inputeventcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document.TriggerExternalEvent, OZViewer.Document_TriggerExternalEvent의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.TriggerExternalEvent("...

...

<object id="OZViewer"...


Example - Applet 뷰어

TriggerExternalEvent Example - Applet 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEvent 함수를 사용하여 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

<html>

<head>

<script language="JavaScript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname) {

       if(eventname == "OnValueChanged" && formid == "Married") {

          OZViewer.Document.TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

           //_TriggerExternalEvent도 가능함

           //OZViewer.Document_TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

       }

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false",

       "eform.inputeventcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document.TriggerExternalEvent, OZViewer.Document_TriggerExternalEvent의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.TriggerExternalEvent("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

TriggerExternalEvent Example - Flash 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEvent 함수를 사용하여 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname) {

       if(eventname == "OnValueChanged" && formid == "Married") {

          OZViewer.Document_TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

       }

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       oz.sendToActionScript("eform.inputeventcommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document_TriggerExternalEvent의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_TriggerExternalEvent("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

TriggerExternalEvent Example - WPF 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEvent 함수를 사용하여 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("eform.inputeventcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZEFormInputEventCommand".Equals(docindex, formid, eventname))

                   {

                       if(eventname == "OnValueChanged" && formid == "Married")

                       {

                          OZViewer.Document.TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

                           //_TriggerExternalEvent도 가능함

                 //OZViewer.Document_TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

                       }

                   }

                   break;

           }

       }

   }

}

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document.TriggerExternalEvent, OZViewer.Document_TriggerExternalEvent의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.TriggerExternalEvent("...


Example - HTML5 뷰어

TriggerExternalEvent Example - HTML5 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEvent 함수를 사용하여 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname) {

       if(eventname == "OnValueChanged" && formid == "Married") {

          OZViewer.Document_TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

       }

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("eform.inputeventcommand","true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document_TriggerExternalEvent의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_TriggerExternalEvent("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

TriggerExternalEvent Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "eform.inputeventcommand=true";

   FrameLayout flayout = new FrameLayout(this);

   //오즈 이벤트 listener 생성

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZEFormInputEventCommand(String docindex, String formid, String eventname)

       {

           if(eventname.equalsIgnoreCase("OnValueChanged") && formid.equalsIgnoreCase("Married")){

              viewer.Document().TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

               //Document_TriggerExternalEvent도 가능함

               //viewer.Document_TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

           }

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...


Example - iOS 뷰어

TriggerExternalEvent Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"eform.inputeventcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZEFormInputEventCommand: (NSString*)docindex :(NSString*)formid :(NSString*) eventname

{

   if([eventname isEqualToString:@"OnValueChanged"] && [formid isEqualToString:@"Married"]) {

       [self.viewer.Document TriggerExternalEvent:@"WeddingDay" param2:@"YYYY/MM/DD" param3:@"0, 0, 255" param4:@"true"];

       //Document_TriggerExternalEvent도 가능함

       //[self.viewer Document_TriggerExternalEvent:@"WeddingDay" param2:@"YYYY/MM/DD" param3:@"0, 0, 255" param4:@"true"];

   }

}

...

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...


Example - WinRT 뷰어

TriggerExternalEvent Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try  {

       if (_viewer != null)  {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\neform.inputeventcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZEFormInputEventCommand(string docindex, string formid, string eventname)

       {

           if(eventname == "OnValueChanged" && formid == "Married")

           {

              _viewer.Document.TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

               //Document_TriggerExternalEvent도 가능함

               //_viewer.Document_TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

           }

       }

   }

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onScriptEx_save();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try  {

       if (_viewer != nullptr)  {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\neform.inputeventcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

   }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZEFormInputEventCommand(String^ docindex, String^ formid, String^ eventname)

           {

               if(eventname == "OnValueChanged" && formid == "Married")

               {

                  _viewer->Document->TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

                   //Document_TriggerExternalEvent도 가능함

                   //_viewer->Document_TriggerExternalEvent("WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

               }

           }

   };

}

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...


TriggerExternalEventByDocIndex

지정한 보고서의 OnExternalEvent 이벤트를 실행하고, OnExternalEvent 이벤트에서 전달한 값을 string 형태로 리턴받습니다.

Arguments

docIndex 보고서 인덱스. Zero-based index

param1 OnExternalEvent로 전달할 첫 번째 값. 생략 가능 (기본 값 : "")

param2 OnExternalEvent로 전달할 두 번째 값. 생략 가능 (기본 값 : "")

param3 OnExternalEvent로 전달할 세 번째 값. 생략 가능 (기본 값 : "")

param4 OnExternalEvent로 전달할 네 번째 값. 생략 가능 (기본 값 : "")


Example - ActiveX 뷰어

TriggerExternalEventByDocIndex Example - ActiveX 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEventByDocIndex 함수를 사용하여 첫번째 보고서의 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

<html>

<head>

   <script language="JavaScript">

       function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname, mainscreen) {

           if(eventname == "OnValueChanged" && formid == "Married") {

              OZViewer.Document.TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

               //_TriggerExternalEventByDocIndex도 가능함

               //OZViewer.Document_TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

           }

       }

   </script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

      <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

       <param name="eform.inputeventcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document.TriggerExternalEventByDocIndex, OZViewer.Document_TriggerExternalEventByDocIndex의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.TriggerExternalEventByDocIndex("...

...

<object id="OZViewer"...


Example - Applet 뷰어

TriggerExternalEventByDocIndex Example - Applet 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEventByDocIndex 함수를 사용하여 첫번째 보고서의 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

<html>

<head>

<script language="JavaScript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname) {

       if(eventname == "OnValueChanged" && formid == "Married") {

          OZViewer.Document.TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

           //_TriggerExternalEventByDocIndex도 가능함

           //OZViewer.Document_TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

       }

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false",

       "eform.inputeventcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document.TriggerExternalEventByDocIndex, OZViewer.Document_TriggerExternalEventByDocIndex의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.TriggerExternalEventByDocIndex("...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

TriggerExternalEventByDocIndex Example - Flash 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEventByDocIndex 함수를 사용하여 첫번째 보고서의 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="http://127.0.0.1:8080/ozrviewer/AC_OETags.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozutil.js" language="javascript"></script>

<script src="http://127.0.0.1:8080/ozrviewer/ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname) {

       if(eventname == "OnValueChanged" && formid == "Married") {

          OZViewer.Document_TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

       }

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       oz.sendToActionScript("eform.inputeventcommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document_TriggerExternalEventByDocIndex의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_TriggerExternalEventByDocIndex("...

...

"name", "OZViewer",

...


Example - WPF 뷰어

TriggerExternalEventByDocIndex Example - WPF 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEventByDocIndex 함수를 사용하여 첫번째 보고서의 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("eform.inputeventcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZEFormInputEventCommand".Equals(docindex, formid, eventname))

                   {

                       if(eventname == "OnValueChanged" && formid == "Married")

                       {

                          OZViewer.Document.TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

                           //_TriggerExternalEventByDocIndex도 가능함

                           //OZViewer.Document_TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

                       }

                   }

                   break;

           }

       }

   }

}

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document.TriggerExternalEventByDocIndex, OZViewer.Document_TriggerExternalEventByDocIndex의 "OZViewer"는 OZReportViewer 객체에서 선언한 변수 이름과 같은 값으로 지정해야 합니다.

...

private OZReportViewer OZViewer = null;

...

OZViewer.Document.TriggerExternalEventByDocIndex("...


Example - HTML5 뷰어

TriggerExternalEventByDocIndex Example - HTML5 뷰어

아래 예제는 OZEFormInputEventCommand와 TriggerExternalEventByDocIndex 함수를 사용하여 첫번째 보고서의 FormID가 Married인 라디오 버튼을 클릭하면 결혼 기념일을 입력할 텍스트 박스의 FormID와 텍스트, 글꼴색, 표시 여부를 전달하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname) {

       if(eventname == "OnValueChanged" && formid == "Married") {

          OZViewer.Document_TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

       }

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript">

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("eform.inputeventcommand","true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...

Additional Information: OZViewer.Document_TriggerExternalEventByDocIndex의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document_TriggerExternalEventByDocIndex("...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

TriggerExternalEventByDocIndex Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "eform.inputeventcommand=true";

   FrameLayout flayout = new FrameLayout(this);

   //오즈 이벤트 listener 생성

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZEFormInputEventCommand(String docindex, String formid, String eventname)

       {

           if(eventname.equalsIgnoreCase("OnValueChanged") && formid.equalsIgnoreCase("Married")){

              viewer.Document().TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

               //Document_TriggerExternalEventByDocIndex도 가능함

               //viewer.Document_TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

           }

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...


Example - iOS 뷰어

TriggerExternalEventByDocIndex Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"eform.inputeventcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZEFormInputEventCommand: (NSString*)docindex :(NSString*)formid :(NSString*) eventname

{

   if([eventname isEqualToString:@"OnValueChanged"] && [formid isEqualToString:@"Married"]) {

       [self.viewer.Document TriggerExternalEventByDocIndex:0 param1:@"WeddingDay" param2:@"YYYY/MM/DD" param3:@"0, 0, 255" param4:@"true"];

       //Document_TriggerExternalEventByDocIndex도 가능함

       //[self.viewer Document_TriggerExternalEventByDocIndex:0 param1:@"WeddingDay" param2:@"YYYY/MM/DD" param3:@"0, 0, 255" param4:@"true"];

   }

}

...

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...


Example - WinRT 뷰어

TriggerExternalEventByDocIndex Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try  {

       if (_viewer != null)  {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\neform.inputeventcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZEFormInputEventCommand(string docindex, string formid, string eventname)

       {

           if(eventname == "OnValueChanged" && formid == "Married")

           {

              _viewer.Document.TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

               //Document_TriggerExternalEventByDocIndex도 가능함

               //_viewer.Document_TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

           }

       }

   }

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onScriptEx_save();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try  {

       if (_viewer != nullptr)  {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\neform.inputeventcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

   }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZEFormInputEventCommand(String^ docindex, String^ formid, String^ eventname)

           {

               if(eventname == "OnValueChanged" && formid == "Married")

               {

                  _viewer->Document->TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

                  //Document_TriggerExternalEventByDocIndex도 가능함

                  //_viewer->Document_TriggerExternalEventByDocIndex(0, "WeddingDay", "YYYY/MM/DD", "0, 0, 255", true);

               }

           }

   };

}

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnExternalEvent에 아래와 같이 스크립트를 추가하여야 합니다.

...

if(ozarg_1 == "WeddingDay"){

   ReportTemplate.GetInputComponent(ozarg_1).SetText(ozarg_2);

   ReportTemplate.GetInputComponent(ozarg_1).SetTextColor(ozarg_3);

   ReportTemplate.GetInputComponent(ozarg_1).SetVisible(ozarg_4);

}

...


TriggerLocationUpdated

현재 보고서의 OnLocationUpdated 이벤트를 실행하고, OnLocationUpdated 이벤트에서 전달한 값을 string 형태로 리턴받습니다.

Arguments

locationInfo OnLocationUpdated의 Location 객체에 전달할 위치 정보. {"key1":value1,"key2":value2, ... } 형식의 JSON 문자열로 설정

addressInfo OnLocationUpdated의 Address 객체에 전달할 주소 정보. {"key1":value1,"key2":value2, ... } 형식의 JSON 문자열로 설정

Reference

locationInfo는 아래와 같은 Key를 지원합니다.

Key Name | Data Type | Description
accuracy | double | 위치 추적 정확도
latitude | double | 위도
longitude | double | 경도
altitude | double | 고도
heading | double | 방위각, 방향
speed | double | 속도
timestamp | double | 위치 정보를 가져온 시간

addressInfo는 아래와 같은 Key를 지원합니다.

Key Name | Data Type | Description
fullAddress | string | 주소
country | string | 국가 이름
countryCode | string | 국가 코드
adminArea | string | 관리 지역
locality | string | 소재지
sublocality | string | 하위 소재지
street | string | 도로
streetNumber | string | 도로 번호 또는 번지


Example - ActiveX 뷰어

TriggerLocationUpdated Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 TriggerLocationUpdated 함수를 사용하여 보고서의 OnLocationUpdated 이벤트에서 전달한 값을 메시지 창에 표시하는 HTML 스크립트로,

[주소 설정] 버튼을 클릭하면 보고서의 OnLocationUpdated 이벤트에서 전달한 값이 메시지 창에 표시됩니다.

<html>

<head>

   <script language="JavaScript">

       function TriggerLocationUpdated() {

           var locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

           var addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

           var result = OZViewer.Document.TriggerLocationUpdated(locationInfo, addressInfo);

           //_TriggerLocationUpdated도 가능함

           //var result = OZViewer.Document_TriggerLocationUpdated(locationInfo, addressInfo);

           alert("Result : " + result);

       }

   </script>

</head>

<body>

<input type="button" value="주소 설정" onclick="TriggerLocationUpdated()">

<br>

<br>

<div id="RunOZViewer">

  <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnLocationUpdated에 아래와 같이 스크립트를 추가하여야 합니다.

...

return "OK";

...

Additional Information: OZViewer.Document.TriggerLocationUpdated, OZViewer.Document_TriggerLocationUpdated의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.TriggerLocationUpdated("...

...

<object id="OZViewer"...


Example - Android 뷰어

TriggerLocationUpdated Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

   String locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

   String addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

   String result = viewer.Document().TriggerLocationUpdated(locationInfo, addressInfo);

   //Document_TriggerLocationUpdated도 가능함

   //String result = viewer.Document_TriggerLocationUpdated(locationInfo, addressInfo);

...

}

...

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnLocationUpdated에 아래와 같이 스크립트를 추가하여야 합니다.

...

return "OK";

...


Example - iOS 뷰어

TriggerLocationUpdated Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onTriggerLocationUpdated:(id)sender;

...

ViewController.m

...

-(IBAction)onTriggerLocationUpdated:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   NSString* locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

   NSString* addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

   NSString* result = [self.viewer.Document TriggerLocationUpdated:locationInfo, addressInfo:addressInfo];

   //Document_TriggerLocationUpdated도 가능함

   //NSString* result = [self.viewer Document_TriggerLocationUpdated:locationInfo, addressInfo:addressInfo];

}

...

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnLocationUpdated에 아래와 같이 스크립트를 추가하여야 합니다.

...

return "OK";

...


Example - WinRT 뷰어

TriggerLocationUpdated Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onTriggerLocationUpdated()

{

   if (_viewer == null)  {

       return;

   }

   string locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

   string addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

   string result = _viewer.Document.TriggerLocationUpdated(locationInfo, addressInfo);

   //Document_TriggerLocationUpdated도 가능함

   //string result = _viewer.Document_TriggerLocationUpdated(locationInfo, addressInfo);

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onTriggerLocationUpdated();

MainPage.xaml.cpp

void OZWinRTViewerSample::onTriggerLocationUpdated()

{

   if (_viewer == nullptr)  {

       return;

   }

   String^ locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

   String^ addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

   String^ result = _viewer->Document->TriggerLocationUpdated(locationInfo, addressInfo);

   //Document_TriggerLocationUpdated도 가능함

   //String^ result = _viewer->Document_TriggerLocationUpdated(locationInfo, addressInfo);

}

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnLocationUpdated에 아래와 같이 스크립트를 추가하여야 합니다.

...

return "OK";

...


TriggerLocationUpdatedByDocIndex

지정한 보고서의 OnLocationUpdated 이벤트를 실행하고, OnLocationUpdated 이벤트에서 전달한 값을 string 형태로 리턴받습니다.

Arguments

docIndex 보고서 인덱스. Zero-based index

locationInfo OnLocationUpdated의 Location 객체에 전달할 위치 정보. {"key1":value1,"key2":value2, ... } 형식의 JSON 문자열로 설정

addressInfo OnLocationUpdated의 Address 객체에 전달할 주소 정보. {"key1":value1,"key2":value2, ... } 형식의 JSON 문자열로 설정

Reference

locationInfo는 아래와 같은 Key를 지원합니다.

Key Name | Data Type | Description
accuracy | double | 위치 추적 정확도
latitude | double | 위도
longitude | double | 경도
altitude | double | 고도
heading | double | 방위각, 방향
speed | double | 속도
timestamp | double | 위치 정보를 가져온 시간

addressInfo는 아래와 같은 Key를 지원합니다.

Key Name | Data Type | Description
fullAddress | string | 주소
country | string | 국가 이름
countryCode | string | 국가 코드
adminArea | string | 관리 지역
locality | string | 소재지
sublocality | string | 하위 소재지
street | string | 도로
streetNumber | string | 도로 번호 또는 번지


Example - ActiveX 뷰어

TriggerLocationUpdatedByDocIndex Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 TriggerLocationUpdatedByDocIndex 함수를 사용하여 보고서의 OnLocationUpdated 이벤트에서 전달한 값을 메시지 창에 표시하는 HTML 스크립트로,

[주소 설정] 버튼을 클릭하면 보고서의 OnLocationUpdated 이벤트에서 전달한 값이 메시지 창에 표시됩니다.

<html>

<head>

   <script language="JavaScript">

       function TriggerLocationUpdated() {

           var locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

           var addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

           var result = OZViewer.Document.TriggerLocationUpdatedByDocIndex(0, locationInfo, addressInfo);

           //_TriggerLocationUpdatedByDocIndex도 가능함

           //var result = OZViewer.Document_TriggerLocationUpdatedByDocIndex(0, locationInfo, addressInfo);

           alert("Result : " + result);

       }

   </script>

</head>

<body>

<input type="button" value="주소 설정" onclick="TriggerLocationUpdated()">

<br>

<br>

<div id="RunOZViewer">

  <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnLocationUpdated에 아래와 같이 스크립트를 추가하여야 합니다.

...

return "OK";

...

Additional Information: OZViewer.Document.TriggerLocationUpdatedByDocIndex, OZViewer.Document_TriggerLocationUpdatedByDocIndex의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

OZViewer.Document.TriggerLocationUpdatedByDocIndex("...

...

<object id="OZViewer"...


Example - Android 뷰어

TriggerLocationUpdatedByDocIndex Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

@Override

public void onCreate(Bundle savedInstanceState)

{

...

   String locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

   String addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

   String result = viewer.Document().TriggerLocationUpdatedByDocIndex(0, locationInfo, addressInfo);

   //Document_TriggerLocationUpdatedByDocIndex도 가능함

   //String result = viewer.Document_TriggerLocationUpdatedByDocIndex(0, locationInfo, addressInfo);

...

}

...

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnLocationUpdated에 아래와 같이 스크립트를 추가하여야 합니다.

...

return "OK";

...


Example - iOS 뷰어

TriggerLocationUpdated Example - iOS 뷰어

Xcode 프로젝트에 버튼을 추가하고, 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onTriggerLocationUpdatedByDocIndex:(id)sender;

...

ViewController.m

...

-(IBAction)onTriggerLocationUpdatedByDocIndex:(id)sender

{

   if(self.viewer == nil) {

       return;

   NSString* locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

   NSString* addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

   NSString* result = [self.viewer.Document TriggerLocationUpdatedByDocIndex:0, locationInfo:locationInfo, addressInfo:addressInfo];

   //Document_TriggerLocationUpdatedByDocIndex도 가능함

   //NSString* result = [self.viewer Document_TriggerLocationUpdatedByDocIndex:0, locationInfo:locationInfo, addressInfo:addressInfo];

}

...

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnLocationUpdated에 아래와 같이 스크립트를 추가하여야 합니다.

...

return "OK";

...


Example - WinRT 뷰어

TriggerLocationUpdated Example - WinRT 뷰어

C# 예제

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onTriggerLocationUpdatedByDocIndex()

{

   if (_viewer == null)  {

       return;

   }

   string locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

   string addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

   string result = _viewer.Document.TriggerLocationUpdatedByDocIndex(0, locationInfo, addressInfo);

   //Document_TriggerLocationUpdatedByDocIndex도 가능함

   //string result = _viewer.Document_TriggerLocationUpdatedByDocIndex(0, locationInfo, addressInfo);

}

C++/CX 예제

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer _viewer;

public :

   void onTriggerLocationUpdatedByDocIndex();

MainPage.xaml.cpp

void OZWinRTViewerSample::onTriggerLocationUpdatedByDocIndex()

{

   if (_viewer == nullptr)  {

       return;

   }

   String^ locationInfo = "{\"accuracy\":\"\", \"latitude\":\"\", \"longitude\":\"\", \"altitude\":\"\", \"heading\":\"\", \"speed\":\"\", \"timestamp\":\"\"}";

   String^ addressInfo = "{\"fullAddress\":\"\", \"country\":\"\", \"countryCode\":\"\", \"adminArea\":\"\", \"locality\":\"\", \"sublocality\":\"\", \"street\":\"\", \"streetNumber\":\"\"}";

   String^ result = _viewer->Document->TriggerLocationUpdatedByDocIndex(0, locationInfo, addressInfo);

   //Document_TriggerLocationUpdatedByDocIndex도 가능함

   //String^ result = _viewer->Document_TriggerLocationUpdatedByDocIndex(0, locationInfo, addressInfo);

}

Additional Information: 위와 같은 예제를 사용하려면 보고서의 ReportTemplate의 OnLocationUpdated에 아래와 같이 스크립트를 추가하여야 합니다.

...

return "OK";

...


뷰어 이벤트

본 장에서는 뷰어에서 지원하는 이벤트에 대해 설명합니다.

Available Viewers

Event | ActiveX | Applet | Flash | WPF | HTML5JS | HTML5SVG | Android | iOS | WinRT
OZBankBookPrintCommand | O | O | O | O | O | X | O | O | O
OZCommand | O | O | O | O | O | O | O | O | O
OZEFormInputEventCommand | O | O | O | O | O | X | O | O | O
OZErrorCommand | O | O | O | O | O | O | O | O | O
OZExitCommand | O | O | X | O | X | X | X | X | X
OZExportCommand | O | O | O | O | O | O | O | O | O
OZExportMemoryStreamCallBack | O | O | O | O | O | O | O | O | O
OZLinkCommand | O | O | O | O | O | X | O | O | O
OZMailCommand | O | O | X | O | X | X | O | O | O
OZPageBindCommand | O | O | O | O | O | O | O | O | O
OZPageChangeCommand | O | O | O | O | O | O | O | O | O
OZPostCommand | O | O | O | O | O | X | O | O | O
OZPrintCommand | O | O | O | O | O | O | O | O | O
OZProgressCommand | O | O | O | O | O | X | O | O | O
OZReportChangeCommand | O | O | O | O | O | O | O | O | O
OZUserActionCommand | O | O | O | O | O | O | O | O | O
OZUserEvent | O | O | O | O | O | X | O | O | O

O

Only e-Form


OZBankBookPrintCommand

통장 프린터 인쇄 아이콘이 클릭된 후 발생하는 이벤트입니다.

Arguments

datas 보고서의 라벨과 라인 정보를 가진 문자열

Reference

통장 프린터 인쇄 아이콘은 기본적으로 툴바에 표시되지 않습니다. 툴바에 통장 프린터 인쇄 아이콘을 표시하려면 toolbar.bankbookprint 패러미터 값을 true로 설정해야 합니다.

이벤트를 사용하려면 viewer.bankbookprintcommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZBankBookPrintCommand Example - ActiveX 뷰어

아래 예제는 보고서를 통장 프린터로 인쇄한 경우 OZBankBookPrintCommand 이벤트를 이용하여 라벨과 라인 정보를 가진 문자열을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZBankBookPrintCommand_OZViewer(datas) {

       alert("datas : " + datas);

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.bankbookprintcommand" value="true">

   <param name="toolbar.bankbookprint" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZBankBookPrintCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZBankBookPrintCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZBankBookPrintCommand Example - Applet 뷰어

아래 예제는 보고서를 통장 프린터로 인쇄한 경우 OZBankBookPrintCommand 이벤트를 이용하여 라벨과 라인 정보를 가진 문자열을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZBankBookPrintCommand_OZViewer(datas) {

       alert("datas : " + datas);

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.bankbookprintcommand=true",

       "toolbar.bankbookprint=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZBankBookPrintCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZBankBookPrintCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZBankBookPrintCommand Example - Flash 뷰어

아래 예제는 보고서를 통장 프린터로 인쇄한 경우 OZBankBookPrintCommand 이벤트를 이용하여 라벨과 라인 정보를 가진 문자열을 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZBankBookPrintCommand_OZViewer(datas) {

       alert("datas : " + datas);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.bankbookprintcommand", "true");

       oz.sendToActionScript("toolbar.bankbookprint", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZBankBookPrintCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZBankBookPrintCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZBankBookPrintCommand Example - WPF 뷰어

아래 예제는 보고서를 통장 프린터로 인쇄한 경우 OZBankBookPrintCommand 이벤트를 이용하여 라벨과 라인 정보를 가진 문자열을 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.bankbookprintcommand", "true");

           paramList.Add("toolbar.bankbookprint", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZBankBookPrintCommand".Equals(command))

                   {

                       //return values

                       //param[0] : datas

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZBankBookPrintCommand Example - HTML5 뷰어

아래 예제는 보고서를 통장 프린터로 인쇄한 경우 OZBankBookPrintCommand 이벤트를 이용하여 라벨과 라인 정보를 가진 문자열을 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZBankBookPrintCommand_OZViewer(datas) {

       alert("datas : " + datas);

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.bankbookprintcommand", "true");

       oz.sendToActionScript("toolbar.bankbookprint", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZBankBookPrintCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZBankBookPrintCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZBankBookPrintCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.bankbookprintcommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZBankBookPrintCommand(String datas)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZBankBookPrintCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.bankbookprintcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZBankBookPrintCommand: (NSString*)datas

{

   // Input Script

}

...


Example - WinRT 뷰어

OZBankBookPrintCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.bankbookprintcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZBankBookPrintCommand(string datas)

       {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.bankbookprintcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZBankBookPrintCommand(String^ datas)

           {

               // Input Script

          }

  };

}


OZCommand

오즈 뷰어 이벤트 실행 시 발생되는 이벤트입니다.

Arguments

code 이벤트 종류

args 실행된 이벤트의 모든 인자 값을 세미콜론(;)을 구분자로하여 나타낸 문자열

Reference

오즈 뷰어의 이벤트별로 리턴되는 code 값은 다음과 같습니다.

code | 이벤트 종류
ERROR | OZErrorCommand
EXIT | OZExitCommand
EXPORT | OZExportCommand
LINK | OZLinkCommand
MAIL | OZMailCommand
PAGEBIND | OZPageBindCommand
PAGECHANGE | OZPageChangeCommand
POST | OZPostCommand
PRINT | OZPrintCommand
PROGRESS | OZProgressCommand
REPORTCHANGE | OZReportChangeCommand

이벤트를 사용하여 이벤트의 인자 값을 가져오려면 해당 이벤트를 구동시키는 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZCommand Example - ActiveX 뷰어

아래 예제는 보고서가 저장된 경우 OZCommand 이벤트를 이용하여 OZExportCommand의 모든 인자 값을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZCommand_OZViewer(code, args) {

       if(code=="EXPORT") {

           alert(args);

       }

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.exportcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZCommand Example - Applet 뷰어

아래 예제는 보고서가 저장된 경우 OZCommand 이벤트를 이용하여 OZExportCommand의 모든 인자 값을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZCommand_OZViewer(code, args) {

       if(code=="EXPORT") {

           alert(args);

       }

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.exportcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZCommand Example - Flash 뷰어

아래 예제는 보고서가 저장된 경우 OZCommand 이벤트를 이용하여 OZExportCommand의 모든 인자 값을 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZCommand_OZViewer(code, args) {

       if(code=="EXPORT") {

           alert(args);

       }

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.exportcommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZCommand Example - WPF 뷰어

아래 예제는 보고서가 저장된 경우 OZCommand 이벤트를 이용하여 OZExportCommand의 모든 인자 값을 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.exportcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZCommand".Equals(command))

                   {

                       //return values

                       //param[0] : code

                       //param[1] : args

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZCommand Example - HTML5 뷰어

아래 예제는 보고서가 저장된 경우 OZCommand 이벤트를 이용하여 OZExportCommand의 모든 인자 값을 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZCommand_OZViewer(code, args) {

       if(code=="EXPORT") {

           alert(args);

       }

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.exportcommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.exportcommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZCommand(String code, String args)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.exportcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZCommand: (NSString*)code :(NSString*)args

{

   // Input Script

}

...


Example - WinRT 뷰어

OZCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.exportcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZCommand(string code, string args)

       {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.exportcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

   }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZCommand(String^ code, String^ args)

           {

               // Input Script

          }

  };

}


OZEFormInputEventCommand

사용자가 입력 컴포넌트를 클릭하거나 값을 변경하여 OnClick/OnFinish/OnFocus/OnKillFocus/OnPause/OnPlay/OnStop/OnValueChanged 이벤트가 실행된 경우 발생되는 이벤트입니다.

Arguments

docindex 보고서 인덱스(zero-based index)

formid OnClick/OnFinish/OnFocus/OnKillFocus/OnPause/OnPlay/OnStop/OnValueChanged 이벤트가 발생한 컴포넌트의 FormID. FormID가 설정되지 않은 경우 컴포넌트의 이름이 리턴됨

eventname 발생한 이벤트 이름(OnClick : 클릭됨, OnFinish : 동영상이 재생 완료됨, OnFocus : 포커스 얻음, OnKillFocus : 포커스 잃음, OnPause : 동영상이 일시 중지됨, OnPlay : 동영상이 재생됨, OnStop : 동영상이 중지됨, OnValueChanged : 값 변경됨)

mainscreen 입력 컴포넌트의 값이 입력된 스크린이 메인 스크린인지 여부(true : 메인 스크린, false : 서브 스크린)

Reference

멀티 스크린 환경을 지원하지 않는 뷰어의 경우 "mainscreen"은 항상 "true"로 리턴됩니다.

이벤트를 사용하려면 eform.inputeventcommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZEFormInputEventCommand Example - ActiveX 뷰어

아래 예제는 보고서에 추가된 입력 컴포넌트의 값을 변경한 경우 OZEFormInputEventCommand 이벤트를 이용하여 보고서 인덱스, FormID, 발생한 이벤트 이름을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname, mainscreen) {

       if(eventname == "OnValueChanged") {

           alert("보고서 인덱스 :" + docindex);

           alert("FormID : " + formid);

           alert("이벤트 이름 : " + eventname);

           alert("메인 스크린 여부 : " + mainscreen);

       }

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="eform.inputeventcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZEFormInputEventCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZEFormInputEventCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZEFormInputEventCommand Example - Applet 뷰어

아래 예제는 보고서에 추가된 입력 컴포넌트의 값을 변경한 경우 OZEFormInputEventCommand 이벤트를 이용하여 보고서 인덱스, FormID, 발생한 이벤트 이름을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname, mainscreen) {

       if(eventname == "OnValueChanged") {

           alert("보고서 인덱스 :" + docindex);

           alert("FormID : " + formid);

           alert("이벤트 이름 : " + eventname);

           alert("메인 스크린 여부 : " + mainscreen);

       }

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "eform.inputeventcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZEFormInputEventCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZEFormInputEventCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZEFormInputEventCommand Example - Flash 뷰어

아래 예제는 보고서에 추가된 입력 컴포넌트의 값을 변경한 경우 OZEFormInputEventCommand 이벤트를 이용하여 보고서 인덱스, FormID, 발생한 이벤트 이름을 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname, mainscreen) {

       if(eventname == "OnValueChanged") {

           alert("보고서 인덱스 :" + docindex);

           alert("FormID : " + formid);

           alert("이벤트 이름 : " + eventname);

           alert("메인 스크린 여부 : " + mainscreen);

       }

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("eform.inputeventcommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZEFormInputEventCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZEFormInputEventCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZEFormInputEventCommand Example - WPF 뷰어

아래 예제는 보고서에 추가된 입력 컴포넌트의 값을 변경한 경우 OZEFormInputEventCommand 이벤트를 이용하여 보고서 인덱스, FormID, 발생한 이벤트 이름을 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("eform.inputeventcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZEFormInputEventCommand".Equals(command))

                   {

                       if(eventname == "OnValueChanged")

                       {

                           //return values

                           //param[0] : docindex

                           //param[1] : formid

                           //param[2] : eventname

                           //param[3] : mainscreen

                       }

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZEFormInputEventCommand Example - HTML5 뷰어

아래 예제는 보고서에 추가된 입력 컴포넌트의 값을 변경한 경우 OZEFormInputEventCommand 이벤트를 이용하여 보고서 인덱스, FormID, 발생한 이벤트 이름을 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZEFormInputEventCommand_OZViewer(docindex, formid, eventname, mainscreen) {

       if(eventname == "OnValueChanged") {

           alert("보고서 인덱스 :" + docindex);

           alert("FormID : " + formid);

           alert("이벤트 이름 : " + eventname);

           alert("메인 스크린 여부 : " + mainscreen);

       }

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("eform.inputeventcommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZEFormInputEventCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZEFormInputEventCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZEFormInputEventCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "eform.inputeventcommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZEFormInputEventCommand(String docindex, String formid, String eventname, String mainscreen)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZEFormInputEventCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"eform.inputeventcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZEFormInputEventCommand: (NSString*)docindex :(NSString*)formid :(NSString*)eventname :(NSString*)mainscreen

{

   // Input Script

}

...


Example - WinRT 뷰어

OZEFormInputEventCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\neform.inputeventcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZEFormInputEventCommand(string docindex, string formid, string eventname, string mainscreen)

       {

           // Input Script

       }

   }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\neform.inputeventcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

   }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZEFormInputEventCommand(String^ docindex, String^ formid, String^ eventname, String^ mainscreen)

           {

               // Input Script

           }

   };

}


OZErrorCommand

에러 발생 시 발생하는 이벤트입니다.

Arguments

code 에러 메시지 코드

message 에러 기본 메시지

detailmessage 에러 상세 메시지

reportname 보고서 이름

Reference

이벤트를 사용하려면 viewer.errorcommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZErrorCommand Example - ActiveX 뷰어

아래 예제는 에러가 발생한 경우 OZErrorCommand 이벤트를 이용하여 에러 메시지 코드, 에러 기본 메시지, 에러 상세 메시지, 보고서 이름을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZErrorCommand_OZViewer(code, message, detailmessage, reportname) {

       alert("에러 메시지 코드 : " + code);

       alert("에러 기본 메시지 : " + message);

       alert("에러 상세 메시지 : " + detailmessage);

       alert("보고서 이름 : " + reportname);

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.errorcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZErrorCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZErrorCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZErrorCommand Example - Applet 뷰어

아래 예제는 에러가 발생한 경우 OZErrorCommand 이벤트를 이용하여 에러 메시지 코드, 에러 기본 메시지, 에러 상세 메시지, 보고서 이름을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZErrorCommand_OZViewer(code, message, detailmessage, reportname) {

       alert("에러 메시지 코드 : " + code);

       alert("에러 기본 메시지 : " + message);

       alert("에러 상세 메시지 : " + detailmessage);

       alert("보고서 이름 : " + reportname);

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.errorcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZErrorCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZErrorCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZErrorCommand Example - Flash 뷰어

아래 예제는 에러가 발생한 경우 OZErrorCommand 이벤트를 이용하여 에러 메시지 코드, 에러 기본 메시지, 에러 상세 메시지, 보고서 이름을 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZErrorCommand_OZViewer(code, message, detailmessage, reportname) {

       alert("에러 메시지 코드 : " + code);

       alert("에러 기본 메시지 : " + message);

       alert("에러 상세 메시지 : " + detailmessage);

       alert("보고서 이름 : " + reportname);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.errorcommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZErrorCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZErrorCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZErrorCommand Example - WPF 뷰어

아래 예제는 에러가 발생한 경우 OZErrorCommand 이벤트를 이용하여 에러 메시지 코드, 에러 기본 메시지, 에러 상세 메시지, 보고서 이름을 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.errorcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZErrorCommand".Equals(command))

                   {

                       //return values

                       //param[0] : code

                       //param[1] : message

                       //param[2] : detailmessage

                       //param[3] : reportname

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZErrorCommand Example - HTML5 뷰어

아래 예제는 에러가 발생한 경우 OZErrorCommand 이벤트를 이용하여 에러 메시지 코드, 에러 기본 메시지, 에러 상세 메시지, 보고서 이름을 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZErrorCommand_OZViewer(code, message, detailmessage, reportname) {

       alert("에러 메시지 코드 : " + code);

       alert("에러 기본 메시지 : " + message);

       alert("에러 상세 메시지 : " + detailmessage);

       alert("보고서 이름 : " + reportname);

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.errorcommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZErrorCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZErrorCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZErrorCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.errorcommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZErrorCommand(String code, String message, String detailmessage, String reportname)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZErrorCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.errorcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZErrorCommand: (NSString*)code :(NSString*)message :(NSString*)detailmessage :(NSString*)reportname

{

   // Input Script

}

...


Example - WinRT 뷰어

OZErrorCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.errorcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZErrorCommand(string code, string message, string detailmessage, string reportname)

       {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.errorcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

   }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZErrorCommand(String^ code, String^ message, String^ detailmessage, String^ reportname)

           {

               // Input Script

          }

  };

}


OZExitCommand

오즈 뷰어가 종료된 후 발생하는 이벤트입니다.

Reference

이벤트를 사용하려면 viewer.exitcommand 패러미터 값을 true로 설정해야 합니다.

또한 ActiveX, Applet, WPF 뷰어의 경우 viewer.isframe 패러미터 값을 true 또는 inprocess로 설정해야 합니다.


Example - ActiveX 뷰어

OZExitCommand Example - ActiveX 뷰어

아래 예제는 OZExitCommand 이벤트를 이용하여 오즈 뷰어가 종료될 때 메시지 창을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZExitCommand_OZViewer() {

       alert("오즈 뷰어가 종료되었습니다.");

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.isframe" value="true">

   <param name="viewer.exitcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZExitCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZExitCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZExitCommand Example - Applet 뷰어

아래 예제는 OZExitCommand 이벤트를 이용하여 오즈 뷰어가 종료될 때 메시지 창을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZExitCommand_OZViewer() {

       alert("오즈 뷰어가 종료되었습니다.");

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=true",

       "viewer.exitcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZExitCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZExitCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - WPF 뷰어

OZExitCommand Example - WPF 뷰어

아래 예제는 OZExitCommand 이벤트를 이용하여 오즈 뷰어가 종료될 때 종료 이벤트를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.isframe", "true");

           paramList.Add("viewer.exitcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZExitCommand".Equals(command))

                   {

                       //오즈 뷰어 종료 후 실행할 내용 입력

                   }

                   break;

           }

       }

   }

}


OZExportCommand

보고서 저장 시 발생하는 이벤트입니다.

Arguments

code 저장 성공 여부(0 : 실패, 1 : 성공)

path 파일 경로

filename 파일 이름

pagecount 저장된 페이지 수. 여러 페이지의 보고서를 한 페이지로 저장한 경우에는 1이 리턴됨

filepaths 뷰어가 실제 저장한 모든 파일의 경로와 이름. 파일이 여러 개일 경우 "|"를 구분자로 하여 리턴됨

Reference

예를 들어, 여러 페이지의 보고서를 jpg 파일로 저장할 때 파일 경로(path)가 "c:\report\"이고, 파일 이름(filename)이 "sample.jpg"인 경우 뷰어가 실제 저장한 파일(filepaths)은 "c:\report\sample.jpg|c:\report\sample_2_1.jpg|c:\report\sample_3_1.jpg|..." 형태의 여러 개 파일입니다.

Flash, HTML5, WinRT 뷰어의 경우 "path", "filename", "filepaths"는 항상 빈 값이 리턴됩니다.

이벤트를 사용하려면 viewer.exportcommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZExportCommand Example - ActiveX 뷰어

아래 예제는 보고서를 저장한 경우 OZExportCommand 이벤트를 이용하여 파일 경로, 파일 이름, 페이지 수, 실제 저장된 파일의 경로와 이름을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZExportCommand_OZViewer(code, path, filename, pagecount, filepaths) {

       if(code=="1") {

           alert("파일 경로 : " + path);

           alert("파일 이름 : " + filename);

           alert("페이지 수 : " + pagecount);

           var arr = filepaths.split('|');

           for(i=0; i<arr.length; i++) {

               alert("저장된 파일의 경로와 이름 - " + (i + 1) + "번째 파일 : " + arr[i]);

          }

       }

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.exportcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZExportCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZExportCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZExportCommand Example - Applet 뷰어

아래 예제는 보고서를 저장한 경우 OZExportCommand 이벤트를 이용하여 파일 경로, 파일 이름, 페이지 수, 절대 경로와 파일 이름을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZExportCommand_OZViewer(code, path, filename, pagecount, filepaths) {

       if(code=="1") {

           alert("파일 경로 : " + path);

           alert("파일 이름 : " + filename);

           alert("페이지 수 : " + pagecount);

           var arr = filepaths.split('|');

           for(i=0; i<arr.length; i++) {

               alert("저장된 파일의 경로와 이름 - " + (i + 1) + "번째 파일 : " + arr[i]);

          }

       }

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.exportcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZExportCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZExportCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZExportCommand Example - Flash 뷰어

아래 예제는 보고서를 저장한 경우 OZExportCommand 이벤트를 이용하여 페이지 수를 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZExportCommand_OZViewer(code, path, filename, pagecount, filepaths) {

       if(code=="1") {

           alert("페이지 수 : " + pagecount);

       }

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.exportcommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZExportCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZExportCommand_OZViewer(...

...

"name", "OZViewer",

...

Additional Information: Flash 뷰어의 경우 파일 경로와 파일 이름에 관련된 아규먼트 즉, "path", "filename", "filepaths"는 항상 빈 값이 리턴됩니다.


Example - WPF 뷰어

OZExportCommand Example - WPF 뷰어

아래 예제는 보고서를 저장한 경우 OZExportCommand 이벤트를 이용하여 저장 성공 여부, 파일 경로, 파일 이름, 페이지 수, 절대 경로와 파일 이름을 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.exportcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZExportCommand".Equals(command))

                   {

                       //return values

                       //param[0] : code

                       //param[1] : path

                       //param[2] : filename

                       //param[3] : pagecount

                       //param[4] : filepaths

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZExportCommand Example - HTML5 뷰어

아래 예제는 보고서를 저장한 경우 OZExportCommand 이벤트를 이용하여 페이지 수를 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZExportCommand_OZViewer(code, path, filename, pagecount, filepaths) {

       if(code=="1") {

           alert("페이지 수 : " + pagecount);

       }

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.exportcommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZExportCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZExportCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...

Additional Information: HTML5 뷰어의 경우 파일 경로와 파일 이름에 관련된 아규먼트 즉, "path", "filename", "filepaths"는 항상 빈 값이 리턴됩니다.


Example - Android 뷰어

OZExportCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.exportcommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZExportCommand(String code, String path, String filename, String pagecount, String filepaths)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZExportCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.exportcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZExportCommand: (NSString*)code :(NSString*)path :(NSString*)filename :(NSString*)pagecount :(NSString*)filepaths

{

   // Input Script

}

...


Example - WinRT 뷰어

OZExportCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.exportcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZExportCommand(string code, string path, string filename, string pagecount, string filepaths)

      {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.exportcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZExportCommand(String^ code, String^ path, String^ filename, String^ pagecount, String^ filepaths)

          {

               // Input Script

          }

  };

}


OZExportMemoryStreamCallBack

Script, ScriptEx 함수의 명령어를 "save_memorystream"로 설정하여 실행한 경우 발생하는 이벤트입니다.

Arguments

outputdata Memory Stream으로 저장된 결과

Reference

outputdata는 {"파일 전체 경로":"base64로 인코딩되어 저장된 파일의 Memory Stream"} 형식의 문자열로 리턴됩니다.

저장된 파일이 여러 개인 경우 콤마(,)를 구분자로하여 {"Path1":"Stream1","Path2":"Stream2",...,"Pathn":"Streamn"} 형식으로 리턴됩니다.

저장을 취소하거나 에러가 발생한 경우에는 {}로 리턴됩니다.

저장되는 파일이 여러 개인 경우 OZExportCommand 이벤트는 여러 번 호출되나 이 이벤트는 모든 저장이 완료된 후 한 번만 호출됩니다.


Example - ActiveX 뷰어

OZExportMemoryStreamCallBack Example - ActiveX 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 보고서를 Memory Stream으로 저장하고 OZExportMemoryStreamCallBack 이벤트를 이용하여 Memory Stream으로 저장된 결과를 표시하는 예입니다.

<html>

<head>

<script language="JavaScript">

   function Report_Save_MemoryStream() {

      OZViewer.Script("save_memorystream");

   }

   function OZExportMemoryStreamCallBack_OZViewer(outputdata) {

       if(outputdata == "{}") {

           alert("Fail");

        } else {

           alert(outputdata);

        }

   }

</script>

</head>

<body>

<input type="button" value="Memory Stream으로 저장" onclick="Report_Save_MemoryStream()">

<br>

<br>

<div id="RunOZViewer">

  <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

       <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

       <param name="connection.reportname" value="sample.ozr">

       <param name="viewer.isframe" value="false">

   </object>

</div>

</body>

</html>

Additional Information: OZExportMemoryStreamCallBack_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZExportMemoryStreamCallBack_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZExportMemoryStreamCallBack Example - Applet 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 보고서를 Memory Stream으로 저장하고 OZExportMemoryStreamCallBack 이벤트를 이용하여 Memory Stream으로 저장된 결과를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function Report_Save_MemoryStream() {

      OZViewer.Script("save_memorystream");

   }

   function OZExportMemoryStreamCallBack_OZViewer(outputdata) {

       if(outputdata == "{}") {

           alert("Fail");

       } else {

           alert(outputdata);

       }

   }

</script>

</head>

<body>

<input type="button" value="Memory Stream으로 저장" onclick="Report_Save_MemoryStream()">

<br>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZExportMemoryStreamCallBack_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZExportMemoryStreamCallBack_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZExportMemoryStreamCallBack Example - Flash 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 보고서를 Memory Stream으로 저장하고 OZExportMemoryStreamCallBack 이벤트를 이용하여 Memory Stream으로 저장된 결과를 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function Report_Save_MemoryStream() {

      OZViewer.Script("save_memorystream");

   }

   function OZExportMemoryStreamCallBack_OZViewer(outputdata) {

       if(outputdata == "{}") {

           alert("Fail");

       } else {

           alert(outputdata);

       }

    }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<body scroll="no">

<input type="button" value="Memory Stream으로 저장" onclick="Report_Save_MemoryStream()">

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.isframe", "false");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZExportMemoryStreamCallBack_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZExportMemoryStreamCallBack_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZExportMemoryStreamCallBack Example - WPF 뷰어

아래 예제는 WPF 뷰어가 임베디드된 .Net 프로그램에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 보고서를 Memory Stream으로 저장하고 OZExportMemoryStreamCallBack 이벤트를 이용하여 Memory Stream으로 저장된 결과를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

      private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.isframe", "false");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               Button button = new Button();

               button.Content = "Memory Stream으로 저장";

               button.Click += new RoutedEventHandler(button_Click);

               StackPanel stack = new StackPanel();

               stack.Children.Add(button);

               stack.Children.Add(OZViewer.getPanel());

               LayoutRoot.Children.Add(stack);

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZExportMemoryStreamCallBack".Equals(command))

                   {

                       //return values

                       //param[0] : outputdata

                   }

                   break;

           }

       }

       void button_Click(object sender, RoutedEventArgs e)

       {

          OZViewer.Script("save_memorystream");

       }

   }

}


Example - HTML5 뷰어

OZExportMemoryStreamCallBack Example - HTML5 뷰어

아래 예제는 웹 페이지에 버튼을 추가하고 버튼을 클릭하면 Script 함수를 사용하여 보고서를 Memory Stream으로 저장하고 OZExportMemoryStreamCallBack 이벤트를 이용하여 Memory Stream으로 저장된 결과를 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function Report_Save_MemoryStream() {

      OZViewer.Script("save_memorystream");

   }

   function OZExportMemoryStreamCallBack_OZViewer(outputdata) {

       if(outputdata == "{}") {

           alert("Fail");

       } else {

           alert(outputdata);

       }

    }

</script>

</head>

<body style="width:98%;height:98%">

<input type="button" value="Memory Stream으로 저장" onclick="Report_Save_MemoryStream()">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZExportMemoryStreamCallBack_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZExportMemoryStreamCallBack_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZExportMemoryStreamCallBack Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZExportMemoryStreamCallBack(String outputdata)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

   ...

  viewer.Script("save_memorystream");

   ...

}

...


Example - iOS 뷰어

OZExportMemoryStreamCallBack Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

@property (nonatomic, strong) OZReportViewer* viewer;

-(IBAction)onScript_save_memorystream:(id)sender;

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZExportMemoryStreamCallBack: (NSString*)outputdata

{

   // Input Script

}

-(IBAction)onScript_save_memorystream:(id)sender

{

   if(self.viewer == nil) {

       return;

   }

   [self.viewer Script:@"save_memorystream"];

}

...


Example - WinRT 뷰어

OZExportMemoryStreamCallBack Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

   }

   catch (Exception ex) {

       string s = ex.Message;

   }

}

public void onScript_save_memorystream()

{

   if (_viewer == null) {

       return;

   }

  _viewer.Script("save_memorystream");

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZExportMemoryStreamCallBack(string outputdata)

      {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

   void onScript_save_memorystream();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

void OZWinRTViewerSample::onScript_save_memorystream()

{

   if (_viewer == nullptr)  {

       return;

   }

  _viewer->Script("save_memorystream");

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZExportMemoryStreamCallBack(String^ outputdata)

          {

               // Input Script

          }

  };

}


OZLinkCommand

SetLinkEvent/setLinkEvent 함수가 실행된 후 발생하는 이벤트입니다.

Arguments

docindex 보고서 인덱스. 동일한 웹 브라우저에서 여러 개 보고서를 열었을 경우 각각의 보고서를 구별하기 위한 인덱스(zero-based index)

compname SetLinkEvent/setLinkEvent를 실행한 컴포넌트 이름

usertag 사용자 정의 태그

uservalue 사용자 정의 값

mousebutton 사용자가 클릭한 마우스 단추(Left : 왼쪽 단추, Right : 오른쪽 단추)

Reference

이벤트를 사용하려면 viewer.linkcommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZLinkCommand Example - ActiveX 뷰어

아래 예제는 SetLinkEvent/setLinkEvent 함수가 실행된 경우 OZLinkCommand 이벤트를 이용하여 보고서 인덱스, 컴포넌트 이름, 사용자 정의 태그와 사용자 정의 값을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZLinkCommand_OZViewer(docindex, compname, usertag, uservalue, mousebutton) {

       alert("보고서 인덱스 : " + docindex);

       alert("컴포넌트 이름 : " + compname);

       alert("사용자 정의 태그 : " + usertag);

       alert("사용자 정의 값 : " + uservalue);

       alert("사용자가 클릭한 마우스 단추 : " + mousebutton);

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.linkcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZLinkCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZLinkCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZLinkCommand Example - Applet 뷰어

아래 예제는 SetLinkEvent/setLinkEvent 함수가 실행된 경우 OZLinkCommand 이벤트를 이용하여 보고서 인덱스, 컴포넌트 이름, 사용자 정의 태그와 사용자 정의 값을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZLinkCommand_OZViewer(docindex, compname, usertag, uservalue, mousebutton) {

       alert("보고서 인덱스 : " + docindex);

       alert("컴포넌트 이름 : " + compname);

       alert("사용자 정의 태그 : " + usertag);

       alert("사용자 정의 값 : " + uservalue);

       alert("사용자가 클릭한 마우스 단추 : " + mousebutton);

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.linkcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZLinkCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZLinkCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZLinkCommand Example - Flash 뷰어

아래 예제는 SetLinkEvent/setLinkEvent 함수가 실행된 경우 OZLinkCommand 이벤트를 이용하여 보고서 인덱스, 컴포넌트 이름, 사용자 정의 태그와 사용자 정의 값을 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZLinkCommand_OZViewer(docindex, compname, usertag, uservalue, mousebutton) {

       alert("보고서 인덱스 : " + docindex);

       alert("컴포넌트 이름 : " + compname);

       alert("사용자 정의 태그 : " + usertag);

       alert("사용자 정의 값 : " + uservalue);

       alert("사용자가 클릭한 마우스 단추 : " + mousebutton);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.linkcommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZLinkCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZLinkCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZLinkCommand Example - WPF 뷰어

아래 예제는 SetLinkEvent/setLinkEvent 함수가 실행된 경우 OZLinkCommand 이벤트를 이용하여 보고서 인덱스, 컴포넌트 이름, 사용자 정의 태그와 사용자 정의 값을 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.linkcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZLinkCommand".Equals(command))

                   {

                       //return values

                       //param[0] : docindex

                       //param[1] : compname

                       //param[2] : usertag

                       //param[3] : uservalue

                       //param[4] : mousebutton

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZLinkCommand Example - HTML5 뷰어

아래 예제는 SetLinkEvent/setLinkEvent 함수가 실행된 경우 OZLinkCommand 이벤트를 이용하여 보고서 인덱스, 컴포넌트 이름, 사용자 정의 태그와 사용자 정의 값을 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZLinkCommand_OZViewer(docindex, compname, usertag, uservalue, mousebutton) {

       alert("보고서 인덱스 : " + docindex);

       alert("컴포넌트 이름 : " + compname);

       alert("사용자 정의 태그 : " + usertag);

       alert("사용자 정의 값 : " + uservalue);

       alert("사용자가 클릭한 마우스 단추 : " + mousebutton);

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.linkcommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZLinkCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZLinkCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZLinkCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.linkcommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZLinkCommand(String docindex, String compname, String usertag, String uservalue, String mousebutton)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZLinkCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.linkcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZLinkCommand: (NSString*)docindex :(NSString*)compname :(NSString*)usertag :(NSString*)uservalue :(NSString*)mousebutton

{

   // Input Script

}

...


Example - WinRT 뷰어

OZLinkCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.bankbookprintcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZLinkCommand(string docindex, string compname, string usertag, string uservalue, string mousebutton)

      {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.bankbookprintcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZLinkCommand(String^ docindex,String^ compname,String^ usertag,String^ uservalue,String^ mousebutton)

           {

               // Input Script

          }

  };

}


OZMailCommand

보고서를 오즈 메일로 전송 시 발생하는 이벤트입니다.

Arguments

code 오즈 메일 전송 성공 여부(0 : 실패, 1 : 성공)

Reference

이벤트를 사용하려면 viewer.mailcommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZMailCommand Example - ActiveX 뷰어

아래 예제는 보고서를 오즈 메일로 전송한 경우 OZMailCommand 이벤트를 이용하여 성공 여부를 메시지 창으로 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZMailCommand_OZViewer(code) {

       if(code=="1") {

           alert("메일을 전송하였습니다.");

       } else if(code=="0") {

           alert("메일을 전송하지 못했습니다.");

       }

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.mailcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZMailCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZMailCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZMailCommand Example - Applet 뷰어

아래 예제는 보고서를 오즈 메일로 전송한 경우 OZMailCommand 이벤트를 이용하여 성공 여부를 메시지 창으로 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZMailCommand_OZViewer(code) {

       if(code=="1") {

           alert("메일을 전송하였습니다.");

       } else if(code=="0") {

           alert("메일을 전송하지 못했습니다.");

       }

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.mailcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZMailCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZMailCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - WPF 뷰어

OZMailCommand Example - WPF 뷰어

아래 예제는 보고서를 오즈 메일로 전송한 경우 OZMailCommand 이벤트를 이용하여 성공 여부를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.mailcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZMailCommand".Equals(command))

                   {

                       //return values

                       //param[0] : code

                   }

                   break;

           }

       }

   }

}


Example - Android 뷰어

OZMailCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.mailcommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZMailCommand(String code)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZMailCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.mailcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZMailCommand: (NSString*)code

{

   // Input Script

}

...


Example - WinRT 뷰어

OZMailCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.bankbookprintcommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZMailCommand(string code)

       {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.mailcommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

  }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZMailCommand(String^ code)

           {

               // Input Script

          }

  };

}


OZPageBindCommand

viewer.pagebindcommandinterval 패러미터에서 설정한 주기별로 페이지가 바인딩된 후 발생하는 이벤트입니다.

Arguments

docindex 보고서 인덱스(zero-based index)

pagecount 바인딩된 페이지 번호

Reference

이 이벤트는 viewer.pagebindcommandinterval 패러미터에서 설정한 주기에 따라 발생하며 마지막 페이지에서의 주기와 상관없이 발생합니다.

예를 들어, 전체 25 페이지 보고서에서 viewer.pagebindcommandinterval 패러미터 값을 5로 설정한 경우 OZPageBindCommand 이벤트는 5, 10, 15, 20, 25, 25 페이지 순으로 발생합니다.(주기와 상관없이 마지막인 25 페이지에서 한 번 더 발생함)

크로스탭, 테이블, 간트 차트의 경우 자식 라벨을 모두 만든 후 한꺼번에 바인딩하므로 해당 컴포넌트가 있는 페이지의 경우 OZPageBindCommand 이벤트가 한꺼번에 발생할 수 있습니다.

OZPageBindCommand 이벤트가 가로 방향으로 바인딩된 페이지에서 실행될 시점인 경우 같은 행에 있는 마지막 페이지에서 실행됩니다.

예를 들어 페이지 구조가 아래와 같고, 이벤트 발생 주기가 5인 경우

5, 16, 16, 16 페이지 순으로 발생합니다.

5 주기가 5이므로 5 페이지에서 발생

16 다음 주기인 10 페이지에서는 가로 방향 페이지이므로 같은 행에 있는 마지막 페이지인 16 페이지에서 발생

16 다음 주기인 15 페이지에서도 10 페이지와 동일한 규칙으로 16 페이지에서 발생

16 주기와 상관없이 맨 마지막 페이지인 16 페이지에 한번 더 발생

이벤트를 사용하려면 viewer.pagebindcommandinterval 패러미터 값을 0보다 큰 값으로 설정해야 합니다.


Example - ActiveX 뷰어

OZPageBindCommand Example - ActiveX 뷰어

아래 예제는 OZPageBindCommand 이벤트를 이용하여 보고서 인덱스와 바인딩 중인 페이지 번호를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZPageBindCommand_OZViewer(docindex, pagecount) {

       alert("보고서 인덱스 : " + docindex);

       alert("바인딩 중인 페이지 번호 : " + pagecount);

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.pagebindcommandinterval" value="10">

   </object>

</div>

</body>

</html>

Additional Information: OZPageBindCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZPageBindCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZPageBindCommand Example - Applet 뷰어

아래 예제는 OZPageBindCommand 이벤트를 이용하여 보고서 인덱스와 바인딩 중인 페이지 번호를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZPageBindCommand_OZViewer(docindex, pagecount) {

       alert("보고서 인덱스 : " + docindex);

       alert("바인딩 중인 페이지 번호 : " + pagecount);

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.pagebindcommandinterval=10"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZPageBindCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZPageBindCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZPageBindCommand Example - Flash 뷰어

아래 예제는 OZPageBindCommand 이벤트를 이용하여 보고서 인덱스와 바인딩 중인 페이지 번호를 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZPageBindCommand_OZViewer(docindex, pagecount) {

       alert("보고서 인덱스 : " + docindex);

       alert("바인딩 중인 페이지 번호 : " + pagecount);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.pagebindcommandinterval", "10");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZPageBindCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZPageBindCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZPageBindCommand Example - WPF 뷰어

아래 예제는 OZPageBindCommand 이벤트를 이용하여 보고서 인덱스와 바인딩 중인 페이지 번호를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.pagebindcommandinterval", "10");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZPageBindCommand".Equals(command))

                   {

                       //return values

                       //param[0] : docindex

                       //param[1] : pagecount

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZPageBindCommand Example - HTML5 뷰어

아래 예제는 OZPageBindCommand 이벤트를 이용하여 보고서 인덱스와 바인딩 중인 페이지 번호를 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZPageBindCommand_OZViewer(docindex, pagecount) {

       alert("보고서 인덱스 : " + docindex);

       alert("바인딩 중인 페이지 번호 : " + pagecount);

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.pagebindcommandinterval", "10");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZPageBindCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZPageBindCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZPageBindCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.pagebindcommandinterval=10";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZPageBindCommand(String docindex, String pagecount)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZPageBindCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.pagebindcommandinterval=10";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZPageBindCommand: (NSString*)docindex :(NSString*)pagecount

{

   // Input Script

}

...


Example - WinRT 뷰어

OZPageBindCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.pagebindcommandinterval=10";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

   }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZPageBindCommand(string docindex, string pagecount)

       {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.pagebindcommandinterval=10";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

  }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZPageBindCommand(String^ docindex, String^ pagecount)

           {

               // Input Script

          }

  };

}


OZPageChangeCommand

화면에 표시되는 페이지가 변경된 후 발생하는 이벤트입니다.

Arguments

docindex 보고서 인덱스(zero-based index)

Reference

이벤트를 사용하려면 viewer.pagechangecommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZPageChangeCommand Example - ActiveX 뷰어

아래 예제는 OZPageChangeCommand 이벤트를 이용하여 보고서 인덱스를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZPageChangeCommand_OZViewer(docindex) {

       alert("보고서 인덱스 : " + docindex);

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.pagechangecommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZPageChangeCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZPageChangeCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZPageChangeCommand Example - Applet 뷰어

아래 예제는 OZPageChangeCommand 이벤트를 이용하여 보고서 인덱스를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZPageChangeCommand_OZViewer(docindex) {

       alert("보고서 인덱스 : " + docindex);

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.pagechangecommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZPageChangeCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZPageChangeCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZPageChangeCommand Example - Flash 뷰어

아래 예제는 OZPageChangeCommand 이벤트를 이용하여 보고서 인덱스를 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZPageChangeCommand_OZViewer(docindex) {

       alert("보고서 인덱스 : " + docindex);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.pagechangecommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZPageChangeCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZPageChangeCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZPageChangeCommand Example - WPF 뷰어

아래 예제는 OZPageChangeCommand 이벤트를 이용하여 보고서 인덱스를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.pagechangecommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZPageChangeCommand".Equals(command))

                   {

                       //return values

                       //param[0] : docindex

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZPageChangeCommand Example - HTML5 뷰어

아래 예제는 OZPageChangeCommand 이벤트를 이용하여 보고서 인덱스를 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZPageChangeCommand_OZViewer(docindex) {

       alert("보고서 인덱스 : " + docindex);

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.pagechangecommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZPageChangeCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZPageChangeCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZPageChangeCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.pagechangecommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZPageChangeCommand(String docindex)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZPageChangeCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.pagechangecommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZPageChangeCommand: (NSString*)docindex;

{

   // Input Script

}

...


Example - WinRT 뷰어

OZPageChangeCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.pagechangecommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZPageChangeCommand(string docindex)

      {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.pagechangecommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

   }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZPageChangeCommand(String^ docindex)

           {

               // Input Script

          }

  };

}


OZPostCommand

보고서를 뷰어 창에 미리보기한 후 또는 미리보기 없이 바로 저장하거나 인쇄한 후 발생하는 이벤트입니다.

보고서를 미리보기한 경우에는 오즈 뷰어에 보고서가 표시된 후 발생하고, 보고서를 미리보기 없이 바로 저장한 경우에는 파일 저장이 완료된 후에 발생하고, 보고서를 미리보기 없이 바로 인쇄한 경우에는 보고서를 프린터 스풀에 넘긴 후 발생합니다.

Arguments

cmd 뷰어 패러미터에서 설정한 명령어

msg 뷰어 패러미터에서 설정한 메시지

Reference

이벤트를 사용하려면 viewer.postcommand 패러미터 값에 명령어와 메시지를 세미콜론(;)을 구분자로 하여 설정해야 합니다.


Example - ActiveX 뷰어

OZPostCommand Example - ActiveX 뷰어

아래 예제는 OZPostCommand 이벤트를 이용하여 뷰어 패러미터에서 설정한 명령어와 메시지를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZPostCommand_OZViewer(cmd, msg) {

       alert("명령어 : " + cmd);

       alert("메시지 : " + msg);

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.postcommand" value="command;messages">

   </object>

</div>

</body>

</html>

Additional Information: OZPostCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZPostCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZPostCommand Example - Applet 뷰어

아래 예제는 OZPostCommand 이벤트를 이용하여 뷰어 패러미터에서 설정한 명령어와 메시지를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZPostCommand_OZViewer(cmd, msg) {

       alert("명령어 : " + cmd);

       alert("메시지 : " + msg);

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.postcommand=command;messages"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZPostCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZPostCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZPostCommand Example - Flash 뷰어

아래 예제는 OZPostCommand 이벤트를 이용하여 뷰어 패러미터에서 설정한 명령어와 메시지를 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZPostCommand_OZViewer(cmd, msg) {

       alert("명령어 : " + cmd);

       alert("메시지 : " + msg);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.postcommand", "command;messages");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZPostCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZPostCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZPostCommand Example - WPF 뷰어

아래 예제는 OZPostCommand 이벤트를 이용하여 뷰어 패러미터에서 설정한 명령어와 메시지를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.postcommand", "command;messages");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZPostCommand".Equals(command))

                   {

                       //return values

                       //param[0] : cmd

                       //param[1] : msg

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZPostCommand Example - HTML5 뷰어

아래 예제는 OZPostCommand 이벤트를 이용하여 뷰어 패러미터에서 설정한 명령어와 메시지를 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZPostCommand_OZViewer(cmd, msg) {

       alert("명령어 : " + cmd);

       alert("메시지 : " + msg);

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.postcommand", "command;messages");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZPostCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZPostCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZPostCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.postcommand=command;messages";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZPostCommand(String cmd, String msg)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZPostCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.postcommand=command;messages";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZPostCommand: (NSString*)cmd :(NSString*)msg

{

   // Input Script

}

...


Example - WinRT 뷰어

OZPostCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.postcommand=command;messages";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZPostCommand(string cmd, string msg)

      {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.postcommand=command;messages";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

  }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZPostCommand(String^ cmd, String^ msg)

           {

               // Input Script

          }

  };

}


OZPrintCommand

보고서 인쇄 또는 인쇄 취소 시 발생하는 이벤트입니다.

Arguments

msg 프린트 결과 메시지

code 프린트 성공 여부(0 : 성공, 1 : 실패)

reportname 보고서 이름

printername 프린터 이름

printcopy 인쇄 매수

printpages 인쇄된 용지 매수

printrange 인쇄 범위(all : 모두, current : 현재 페이지, selected : 선택된 페이지, range : 페이지 지정, selectedreport : 리포트 지정)

username 사용자 이름

printerdrivername 프린터 드라이버 이름

printpagesrange 인쇄된 페이지 범위

Reference

printpagesrange의 경우 인쇄 다이얼로그에서 설정한 인쇄 범위를 "-"와 ","를 이용하여 리턴합니다. 예를 들어, 전체 10 페이지인 보고서를 인쇄할 때 인쇄 범위를 모두로 선택한 경우에는 "1-10"으로, 현재 페이지로 선택한 경우에는 페이지 번호를, 그 외 경우에는 "1-3" 또는 "5,7" 또는 "1-3,5,7" 등의 형태로 리턴됩니다.

뷰어 타입별로 오즈 뷰어 인쇄 다이얼로그에서 지원하지 않는 옵션은 기본 값으로 리턴됩니다.

이벤트를 사용하려면 viewer.printcommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZPrintCommand Example - ActiveX 뷰어

아래 예제는 보고서를 인쇄한 경우 OZPrintCommand 이벤트를 이용하여 프린트 결과 메시지, 보고서 이름, 프린터 이름, 인쇄 매수, 인쇄된 용지 매수, 인쇄 범위, 사용자 이름, 프린터 드라이버 이름, 인쇄된 페이지 범위를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZPrintCommand_OZViewer(msg, code, reportname, printername, printcopy, printpages, printrange, username, printerdrivername, printpagesrange) {

       if(code==0) {

           alert("프린트 결과 메시지 : " + msg);

           alert("보고서 이름 : " + reportname);

           alert("프린터 이름 : " + printername);

           alert("인쇄 매수 : " + printcopy);

           alert("인쇄된 용지 매수 : " + printpages);

           alert("인쇄 범위 : " + printrange);

           alert("사용자 이름 : " + username);

           alert("프린터 드라이버 이름 : " + printerdrivername);

           alert("인쇄된 페이지 범위 : " + printpagesrange);

       }

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.printcommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZPrintCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZPrintCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZPrintCommand Example - Applet 뷰어

아래 예제는 보고서를 인쇄한 경우 OZPrintCommand 이벤트를 이용하여 프린트 결과 메시지, 보고서 이름, 프린터 이름, 인쇄 매수, 인쇄된 용지 매수, 인쇄 범위, 사용자 이름, 프린터 드라이버 이름, 인쇄된 페이지 범위를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZPrintCommand_OZViewer(msg, code, reportname, printername, printcopy, printpages, printrange, username, printerdrivername, printpagesrange) {

       if(code==0) {

           alert("프린트 결과 메시지 : " + msg);

           alert("보고서 이름 : " + reportname);

           alert("프린터 이름 : " + printername);

           alert("인쇄 매수 : " + printcopy);

           alert("인쇄된 용지 매수 : " + printpages);

           alert("인쇄 범위 : " + printrange);

           alert("사용자 이름 : " + username);

           alert("프린터 드라이버 이름 : " + printerdrivername);

           alert("인쇄된 페이지 범위 : " + printpagesrange);

       }

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.printcommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZPrintCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZPrintCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZPrintCommand Example - Flash 뷰어

아래 예제는 보고서를 인쇄한 경우 OZPrintCommand 이벤트를 이용하여 프린트 결과 메시지, 보고서 이름, 인쇄 매수, 인쇄된 용지 매수, 인쇄 범위, 사용자 이름, 인쇄된 페이지 범위를 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZPrintCommand_OZViewer(msg, code, reportname, printername, printcopy, printpages, printrange, username, printerdrivername, printpagesrange) {

       if(code==0) {

           alert("프린트 결과 메시지 : " + msg);

           alert("보고서 이름 : " + reportname);

           alert("인쇄 매수 : " + printcopy);

           alert("인쇄된 용지 매수 : " + printpages);

           alert("인쇄 범위 : " + printrange);

           alert("사용자 이름 : " + username);

           alert("인쇄된 페이지 범위 : " + printpagesrange);

       }

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.printcommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZPrintCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZPrintCommand_OZViewer(...

...

"name", "OZViewer",

...

Additional Information: Flash 뷰어의 경우 프린터 관련된 아규먼트 즉, "printername", "printerdrivername"은 항상 빈 값이 리턴됩니다.


Example - WPF 뷰어

OZPrintCommand Example - WPF 뷰어

아래 예제는 보고서를 인쇄한 경우 OZPrintCommand 이벤트를 이용하여 프린트 결과 메시지, 보고서 이름, 프린터 이름, 인쇄 매수, 인쇄된 용지 매수, 인쇄 범위, 사용자 이름, 프린터 드라이버 이름, 인쇄된 페이지 범위를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.printcommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZPrintCommand".Equals(command))

                  {

                       //return values

                       //param[0] : msg

                       //param[1] : code

                       //param[2] : reportname

                       //param[3] : printername

                       //param[4] : printcopy

                       //param[5] : printpages

                       //param[6] : printrange

                       //param[7] : username

                       //param[8] : printerdrivername

                       //param[9] : printpagesrange

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZPrintCommand Example - HTML5 뷰어

아래 예제는 보고서를 인쇄한 경우 OZPrintCommand 이벤트를 이용하여 프린트 결과 메시지, 보고서 이름, 인쇄 매수, 인쇄된 용지 매수, 인쇄 범위, 사용자 이름, 인쇄된 페이지 범위를 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZPrintCommand_OZViewer(msg, code, reportname, printername, printcopy, printpages, printrange, username, printerdrivername, printpagesrange) {

       if(code==0) {

           alert("프린트 결과 메시지 : " + msg);

           alert("보고서 이름 : " + reportname);

           alert("인쇄 매수 : " + printcopy);

           alert("인쇄된 용지 매수 : " + printpages);

           alert("인쇄 범위 : " + printrange);

           alert("사용자 이름 : " + username);

           alert("인쇄된 페이지 범위 : " + printpagesrange);

       }

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.printcommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZPrintCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZPrintCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...

Additional Information: HTML5 뷰어의 경우 프린터 관련된 아규먼트 즉, "printername", "printerdrivername"은 항상 빈 값이 리턴됩니다.


Example - Android 뷰어

OZPrintCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.printcommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZPrintCommand(String msg, String code, String reportname, String printername, String printcopy, String printpages, String printrange, String username, String printerdrivername, String printpagesrange)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZPrintCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.printcommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZPrintCommand: (NSString*)msg :(NSString*)code :(NSString*)reportname :(NSString*)printername :(NSString*)printcopy :(NSString*)printpages :(NSString*)printrange :(NSString*)username :(NSString*)printerdrivername :(NSString*)printpagesrange

{

   // Input Script

}

...


Example - WinRT 뷰어

OZPrintCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.printcommand=command";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZPrintCommand(string msg, string code, string reportname, string printername, string printcopy, string printpages, string printrange, string username, string printerdrivername, string printpagesrange)

      {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.printcommand=command";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

  }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZPrintCommand(String^ msg, String^ code, String^ reportname, String^ printername, String^ printcopy, String^ printpages, String^ printrange, String^ username, String^ printerdrivername, String^ printpagesrange)

          {

               // Input Script

          }

  };

}


OZProgressCommand

보고서 생성 단계별로 발생하는 이벤트입니다.

Arguments

step 보고서 생성 단계(0 : 뷰어 실행 옵션 설정, 1 : 보고서 파일 다운로드, 2 : 보고서 템플릿 생성, 3 : 데이터 다운로드, 4 : 보고서 바인딩)

state 보고서 생성 상태(1 : 시작, 2 : 완료)

reportname 보고서 이름

Reference

이벤트를 사용하려면 viewer.progresscommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZProgressCommand Example - ActiveX 뷰어

아래 예제는 보고서 생성 진행 시 OZProgressCommand 이벤트를 이용하여 보고서 생성 단계, 생성 상태, 보고서 이름을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZProgressCommand_OZViewer(step, state, reportname) {

       alert("보고서 생성 단계 : " + step);

       alert("보고서 생성 상태 : " + state);

       alert("보고서 이름 : " + reportname);

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.progresscommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZProgressCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZProgressCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZProgressCommand Example - Applet 뷰어

아래 예제는 보고서 생성 진행 시 OZProgressCommand 이벤트를 이용하여 보고서 생성 단계, 생성 상태, 보고서 이름을 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZProgressCommand_OZViewer(step, state, reportname) {

       alert("보고서 생성 단계 : " + step);

       alert("보고서 생성 상태 : " + state);

       alert("보고서 이름 : " + reportname);

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.progresscommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZProgressCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZProgressCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZProgressCommand Example - Flash 뷰어

아래 예제는 보고서 생성 진행 시 OZProgressCommand 이벤트를 이용하여 보고서 생성 단계, 생성 상태, 보고서 이름을 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZProgressCommand_OZViewer(step, state, reportname) {

       alert("보고서 생성 단계 : " + step);

       alert("보고서 생성 상태 : " + state);

       alert("보고서 이름 : " + reportname);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.progresscommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZProgressCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZProgressCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZProgressCommand Example - WPF 뷰어

아래 예제는 보고서 생성 진행 시 OZProgressCommand 이벤트를 이용하여 보고서 생성 단계, 생성 상태, 보고서 이름을 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.progresscommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZProgressCommand".Equals(command))

                  {

                       //return values

                       //param[0] : step

                       //param[1] : state

                       //param[2] : reportname

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZProgressCommand Example - HTML5 뷰어

아래 예제는 보고서 생성 진행 시 OZProgressCommand 이벤트를 이용하여 보고서 생성 단계, 생성 상태, 보고서 이름을 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZProgressCommand_OZViewer(step, state, reportname) {

       alert("보고서 생성 단계 : " + step);

       alert("보고서 생성 상태 : " + state);

       alert("보고서 이름 : " + reportname);

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.progresscommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZProgressCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZProgressCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZProgressCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.progresscommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZProgressCommand(String step, String state, String reportname)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZProgressCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.progresscommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZProgressCommand: (NSString*)step :(NSString*)state :(NSString*)reportname

{

   // Input Script

}

...


Example - WinRT 뷰어

OZProgressCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.progresscommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZProgressCommand(string step, string state, string reportname)

       {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.progresscommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

  }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZProgressCommand(String^ step, String^ state, String^ reportname)

           {

               // Input Script

          }

  };

}


OZReportChangeCommand

화면에 표시되는 보고서가 변경된 후 발생하는 이벤트입니다.

Arguments

docindex 보고서 인덱스(zero-based index)

Reference

보고서가 처음 바인딩될 때에도 OZReportChangeCommand 이벤트가 발생하고, 해당 보고서의 인덱스가 리턴됩니다.

단, global.concatpage=true로 설정한 경우 child로 설정한 보고서가 맨 처음 바인딩될 때에는 OZReportChangeCommand 이벤트는 보고서 개수만큼 발생하지만 docindex는 무조건 0으로 리턴됩니다. 바인딩된 후 보고서 트리에서 보고서를 클릭하거나 페이지 이동 등으로 보고서가 변경될 때에는 해당 보고서의 인덱스로 리턴됩니다.

이벤트를 사용하려면 viewer.reportchangecommand 패러미터 값을 true로 설정해야 합니다.


Example - ActiveX 뷰어

OZReportChangeCommand Example - ActiveX 뷰어

아래 예제는 OZReportChangeCommand 이벤트를 이용하여 보고서 인덱스를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZReportChangeCommand_OZViewer(docindex) {

       alert("보고서 인덱스 : " + docindex);

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.reportchangecommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZReportChangeCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZReportChangeCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZReportChangeCommand Example - Applet 뷰어

아래 예제는 OZReportChangeCommand 이벤트를 이용하여 보고서 인덱스를 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZReportChangeCommand_OZViewer(docindex) {

       alert("보고서 인덱스 : " + docindex);

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.reportchangecommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZReportChangeCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZReportChangeCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZReportChangeCommand Example - Flash 뷰어

아래 예제는 OZReportChangeCommand 이벤트를 이용하여 보고서 인덱스를 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZReportChangeCommand_OZViewer(docindex) {

       alert("보고서 인덱스 : " + docindex);

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.reportchangecommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZReportChangeCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZReportChangeCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZReportChangeCommand Example - WPF 뷰어

아래 예제는 OZReportChangeCommand 이벤트를 이용하여 보고서 인덱스를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.reportchangecommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZReportChangeCommand".Equals(command))

                   {

                       //return values

                       //param[0] : docindex

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZReportChangeCommand Example - HTML5 뷰어

아래 예제는 OZReportChangeCommand 이벤트를 이용하여 보고서 인덱스를 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZReportChangeCommand_OZViewer(docindex) {

       alert("보고서 인덱스 : " + docindex);

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.reportchangecommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZReportChangeCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZReportChangeCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZReportChangeCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.reportchangecommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZReportChangeCommand(String docindex)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZReportChangeCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.reportchangecommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZReportChangeCommand: (NSString*)docindex;

{

   // Input Script

}

...


Example - WinRT 뷰어

OZReportChangeCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.reportchangecommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZReportChangeCommand(string docindex)

      {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.reportchangecommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

  }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZReportChangeCommand(String^ docindex)

           {

               // Input Script

          }

  };

}


OZUserActionCommand

인쇄, 저장, 컴포넌트 속성 변경 등 사용자가 뷰어의 기능을 실행할 때 발생하는 이벤트입니다.

Arguments

type 기능 타입

attr 실행 정보

Reference

이벤트를 사용하려면 viewer.useractioncommand 패러미터 값을 true로 설정해야 합니다.


기능 타입과 실행 정보

OZUserActionCommand의 기능 타입과 실행 정보

OZUserActionCommand 이벤트는 AddMemo, BankbookPrint, ChangeComp 등 여러 가지 기능 타입을 지원하며, 각 타입별로 보고서 이름, 파일 이름, 바탕색 등의 실행 정보를 통해 오즈 뷰어 및 사용자가 어떤 기능을 어떻게 실행했는지 개발자가 알 수 있도록 다양한 기능 타입과 실행 정보를 제공합니다.


AddArrow

OZUserActionCommand > AddArrow

OZUserActionCommand의 type 중 AddArrow는 보고서에 화살표를 추가할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
height | 화살표의 높이(float)
reportname | 보고서 이름(string)
width | 화살표의 너비(float)
xpos | 화살표의 X 좌표(float)
ypos | 화살표의 Y 좌표(float)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "AddArrow") {

       alert(MyObj.height);

       ...

   }

}

...


AddCircle

OZUserActionCommand > AddCircle

OZUserActionCommand의 type 중 AddCircle는 보고서에 원을 추가할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
height | 원의 높이(float)
reportname | 보고서 이름(string)
width | 원의 너비(float)
xpos | 원의 X 좌표(float)
ypos | 원의 Y 좌표(float)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "AddCircle") {

       alert(MyObj.height);

       ...

   }

}

...


AddImage

OZUserActionCommand > AddImage

OZUserActionCommand의 type 중 AddImage는 보고서에 이미지를 추가할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
height | 이미지 라벨의 높이(float)
reportname | 보고서 이름(string)
width | 이미지 라벨의 너비(float)
xpos | 이미지 라벨의 X 좌표(float)
ypos | 이미지 라벨의 Y 좌표(float)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "AddImage") {

       alert(MyObj.height);

       ...

   }

}

...


AddLine

OZUserActionCommand > AddLine

OZUserActionCommand의 type 중 AddLine는 보고서에 선을 추가할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
height | 선의 높이(float)
reportname | 보고서 이름(string)
width | 선의 너비(float)
xpos | 선의 X 좌표(float)
ypos | 선의 Y 좌표(float)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "AddLine") {

       alert(MyObj.height);

       ...

   }

}

...


AddMemo

OZUserActionCommand > AddMemo

OZUserActionCommand의 type 중 AddMemo는 보고서에 메모 라벨을 추가할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
height | 메모 라벨의 높이(float)
reportname | 보고서 이름(string)
width | 메모 라벨의 너비(float)
xpos | 메모 라벨의 X 좌표(float)
ypos | 메모 라벨의 Y 좌표(float)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "AddMemo") {

       alert(MyObj.height);

       ...

   }

}

...


AddRectangle

OZUserActionCommand > AddRectangle

OZUserActionCommand의 type 중 AddRectangle는 보고서에 사각형을 추가할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
height | 사각형의 높이(float)
reportname | 보고서 이름(string)
width | 사각형의 너비(float)
xpos | 사각형의 X 좌표(float)
ypos | 사각형의 Y 좌표(float)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "AddRectangle") {

       alert(MyObj.height);

       ...

   }

}

...


BankbookPrint

OZUserActionCommand > BankbookPrint

OZUserActionCommand의 type 중 BankbookPrint는 통장 프린터로 인쇄할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
pagecount | 인쇄한 페이지 수(int)
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "BankbookPrint") {

       alert(MyObj.pagecount);

       ...

   }

}

...


Binding

OZUserActionCommand > Binding

OZUserActionCommand의 type 중 Binding은 오즈 뷰어가 보고서를 바인딩할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(string)
state | 바인딩 상태(string) 바인딩 시작 직전에 "false", 바인딩이 완료된 후 "true"로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Binding") {

       alert(MyObj.reportname);

       ...

   }

}

...


ChangeComp

OZUserActionCommand > ChangeComp

OZUserActionCommand의 type 중 ChangeComp는 컴포넌트의 속성을 변경할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
backcolor | 바탕 색(string) RGB 값으로 "Red, Green, Blue" 형태로 리턴됨
barcodeerroroption | 바코드의 에러 표시 옵션(string) 에러 데이터 표시인 경우 "ShowErrorData", 바코드 크기 오류 표시인 경우 "ShowErrorSize", 빈 값 표시인 경우 "ShowEmptyData"로 리턴됨, 여러 값이 한꺼번에 선택된 경우 콤마(,)를 구분자로 하여 리턴됨
bottomframethickness | 아래쪽 선 두께(string)
charspace | 자간(string)
charttype | 차트 타입(string) 뷰어 함수 중 SetChartStyle 함수의 차트 타입 표 참고
clip | 클립핑(string) 클립핑을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
compname | 컴포넌트 이름(string) 메모는 공백으로 리턴됨
comptype | 그리기 형태(string) 라벨인 경우 "LABEL", 이미지인 경우 "IMAGE", 바코드인 경우 "BARCODE", PDF417 바코드인 경우 "PDF417", QR 바코드인 경우 "QRBARCODE", DataMatrix 바코드인 경우 "DATAMATRIXBARCODE", HTML인 경우 "HTML"로 리턴됨 메모는 공백으로 리턴됨
datagap | 바코드 데이터 간격(string)
datamatrixencoding | DataMatrix 바코드 인코딩(string) ANSI인 경우 "ANSI", UTF-8인 경우 "UTF-8"로 리턴됨
datamatrixmargin | DataMatrix 바코드 여백(string)
dataposition | 바코드 데이터 위치(string) 없음인 경우 "None", 위쪽인 경우 "Top", 아래쪽인 경우 "Botton"으로 리턴됨
effect | 글꼴 효과(string) Basic인 경우 "Basic", Outline인 경우 "Outline", 3D인 경우 "3D", Engrave인 경우 "Engrave", Segments인 경우 "Segments", Hollow인 경우 "Hollow", Shadow인 경우 "Shadow"로 리턴됨
fontname | 글꼴 이름(string) 모바일에서 실행된 경우 빈 값으로 리턴됨
fontsize | 글꼴 크기(int)
fontstretch | 장평(string)
fontstyle | 글꼴 스타일(string) 보통인 경우 "PLAIN", 굵게인 경우 "BOLD", 기울임꼴인 경우 "ITALIC", 굵은 기울임꼴인 경우 "BOLD_ITALIC"으로 리턴됨
gradientcolor | 그라데이션 색(string) RGB 값으로 "Red, Green, Blue" 형태로 리턴됨
gradienttype | 그라데이션 타입(string) 위 아래는 연하고 가운데는 진하게 표시인 경우 "Bottom_Center_Top", 아래에서 위로 갈수록 연하게 표시인 경우 "Bottom_Top", 우측 하단과 좌측 상단이 연하고 가운데는 진하게 표시인 경우 "BottomRight_Center_LeftTop", 우측 하단에서 좌측 상단으로 갈수록 연하게 표시인 경우 "BottomRight_LeftTop", 양 옆이 진하고 가운데는 연하게 표시인 경우 "Left_Center_Right", 좌측에서 우측으로 갈수록 연하게 표시인 경우 "Left_Right", 좌측 하단과 우측 상단이 진하고 가운데는 연하게 표시인 경우 "LeftBottom_Center_RightTop", 좌측 하단에서 우측 상단으로 갈수록 연하게 표시인 경우 "LeftBottom_RightTop", 좌측 상단에서 우측 하단으로 갈수록 연하게 표시인 경우 "LeftTop_BottomRight", 좌측 상단과 우측 하단이 진하고 가운데는 연하게 표시인 경우 "LeftTop_Center_BottomRight", 양 옆이 연하고 가운데는 진하게 표시인 경우 "Right_Center_Left", 우측에서 좌측으로 갈수록 연하게 표시인 경우 "Right_Left", 우측 상단과 좌측 하단이 연하고 가운데는 진하게 표시인 경우 "RightTop_Center_LeftBottom", 우측 상단에서 좌측 하단으로 갈수록 연하게 표시인 경우 "RightTop_LeftBottom", 위에서 아래로 갈수록 연하게 표시인 경우 "Top_Bottom", 위 아래가 진하고 가운데는 연하게 표시인 경우 "Top_Center_Bottom"로 리턴됨
halign | 텍스트 수평 정렬(string) 왼쪽인 경우 "Left", 가운데인 경우 "Center", 오른쪽인 경우 "Right", 균등 분할인 경우 "Distributed", 양쪽 맞춤인 경우 "Justify"로 리턴됨
horizontalalignment | 바코드 수평 정렬(string) 왼쪽인 경우 "Left", 가운데인 경우 "Center", 오른쪽인 경우 "Right"로 리턴됨
imagestyle | 이미지 스타일(string) 일반인 경우 "TopLeft", 중앙인 경우 "MiddleCenter", 고정인 경우 "Fit", 타일인 경우 "Tile", 가로고정인 경우 "FitByWidth", 가로고정,중앙으로인 경우 "FitByWidth_Center", 세로고정인 경우 "FitByHeight", 세로고정,중앙으로인 경우 "FitByHeight_Center", 동일비율인 경우 "Isotropic", 동일비율,중앙으로인 경우 "Isotropic_Center", 위,중앙으로인 경우 "TopCenter", 위,오른쪽으로인 경우 "TopRight", 중간,왼쪽으로인 경우 "MiddleLeft", 중간,오른쪽으로인 경우 "MiddleRight", 아래,왼쪽으로인 경우 "BottomLeft", 아래,중앙으로인 경우 "BottomCenter", 아래,오른쪽으로인 경우 "BottomRight"로 리턴됨
leftframethickness | 왼쪽 선 두께(string)
linecolor | 테두리 색(string) RGB 값으로 "Red, Green, Blue" 형태로 리턴됨
linespace | 줄 간격(string)
linetype | 선 종류(string) 수평인 경우 "Horizontal", 수직인 경우 "Vertical", 슬래쉬인 경우 "Slash", 역슬래쉬인 경우 "BackSlash"로 리턴됨
margin | 바코드 여백(string)
pdf417colnum | PDF417 바코드 열 수(string)
pdf417ecc | PDF417 바코드 에러 교정(string)
pdf417rownum | PDF417 바코드 행 수(string)
pdf417xscale | PDF417 바코드 X 크기(string)
pdf417yscale | PDF417 바코드 Y 크기(string)
penthickness | 선 두께(string)
printscale | 바코드 프린트 크기(string)
qrecc | QR 바코드 에러 교정(string) H인 경우 "H", L인 경우 "L", M인 경우 "M", Q인 경우 "Q"로 리턴됨
qrencoding | QR 바코드 인코딩(string) ANSI인 경우 "ANSI", UTF-8인 경우 "UTF-8"로 리턴됨
qrmargin | QR 바코드 여백(string)
ratio | 바코드 비율(string)
reportname | 보고서 이름(string)
rightframethickness | 오른쪽 선 두께(string)
scale | 바코드 크기(string)
showdata | 차트 데이터 보기(string) 데이터 보기를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
textcolor | 글꼴 색(string) RGB 값으로 "Red, Green, Blue" 형태로 리턴됨
textgap | 바코드 제목 간격(string)
textindent | 들여쓰기(string)
textposition | 바코드 제목 위치(string) 없음인 경우 "None", 위쪽인 경우 "Top", 아래쪽인 경우 "Bottom"으로 리턴됨
textstretch | 텍스트 방향(string) HORIZONTAL인 경우 "Horizontal", COUNTERCLOCKWISE인 경우 "CountClockWise", VERTICAL_2BYTE인 경우 "Vertical2", VERTICAL인 경우 "Vertical", CLOCKWISE인 경우 "ClockWise", HORIZONTAL_2BYTE인 경우 "Horizontal2"로 리턴됨
tooltiptext | 툴팁 텍스트(string)
topframethickness | 위쪽 선 두께(string)
transparent | 채우기 없음(string) 채우기 없음을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
type | 바코드 타입(string) 바코드 타입을 설정하는 콤보박스에 선택된 텍스트로 리턴됨
usegradient | 그라데이션 사용(string) 그라데이션 사용을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
valign | 텍스트 수직 정렬(string) 위쪽인 경우 "Top", 중앙인 경우 "Middle", 아래쪽인 경우 "Bottom", 균등 분할인 경우 "Distributed", 양쪽 맞춤인 경우 "Justify"로 리턴됨
wordwrap | 자동 줄바꾸기(string) 자동 줄바꾸기를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
wordwraptype | 자동 줄바꾸기 타입(string) 공백 무시를 체크한 경우 "IgnoreSpace", 단어 잘림 방지를 체크한 경우 "NonAsciiWord"로, 모두 체크한 경우 "IgnoreSpace,NonAsciiWord"로, 아무것도 체크하지 않은 경우 "Default"로 리턴됨

Reference

ChangeComp는 속성 값을 변경하므로 리턴되는 attr은 변경되기 전 값을 나타내는 oldvalue와 변경된 후 값을 나타내는 newvalue로 구성됩니다. (단, "compname", "reportname"은 제외)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "ChangeComp") {

       alert("Old Value : " + MyObj.oldvalue.backcolor + "  New Value : " + MyObj.newvalue.backcolor);

       ...

   }

}

...


ChartEditMode

OZUserActionCommand > ChartEditMode

OZUserActionCommand의 type 중 ChartEditMode는 차트의 회전 가능 상태를 변경할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(string)
state | 차트 회전 가능 상태(string) 회전 가능인 경우 "true", 회전 가능이 아닌 경우 "false"로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "ChartEditMode") {

       alert(MyObj.reportname);

       ...

   }

}

...


Close

OZUserActionCommand > Close

OZUserActionCommand의 type 중 Close는 보고서를 닫을 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
index | 보고서 인덱스(int). Zero-Based Index
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Close") {

       alert(MyObj.index);

       ...

   }

}

...


CloseAll

OZUserActionCommand > CloseAll

OZUserActionCommand의 type 중 CloseAll은 모든 보고서를 닫을 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(Array)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "CloseAll") {

       for(i = 0; i < MyObj.reportname.length; i++) {

           alert(MyObj.reportname[i]);

      }

   }

}

...


CloseByThumbnailSection

OZUserActionCommand > CloseByThumbnailSection

OZUserActionCommand의 type 중 CloseByThumbnailSection는 페이지 축소판의 섹션바에 표시된 보고서 닫기 아이콘을 클릭한 경우 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
index | 보고서 인덱스(int). Zero-Based Index
reportname | 보고서 이름(string)
close | 보고서 닫힘 여부(string) 보고서가 닫힌 경우 "true", 닫히지 않은 경우 "false"로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "CloseByThumbnailSection") {

       alert(MyObj.index);

       ...

   }

}

...


CopyInputData

OZUserActionCommand > CopyInputData

OZUserActionCommand의 type 중 CopyInputData는 [입력 데이터 복사 (json)], [입력 데이터 복사 (xml)] 메뉴를 클릭할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
clipboardtext | 복사된 텍스트(string)
reportname | 보고서 이름(string)
type | 입력 데이터 타입(string) JSON 형식인 경우 "json", XML 형식인 경우 "xml"으로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "CopyInputData") {

       alert(MyObj.clipboardtext);

       ...

   }

}

...


CopySelectedText

OZUserActionCommand > CopySelectedText

OZUserActionCommand의 type 중 CopySelectedText는 라벨, 메모의 텍스트를 선택할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
clipboardtext | 복사된 텍스트(string)
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "CopySelectedText") {

       alert(MyObj.clipboardtext);

       ...

   }

}

...


EditComp

OZUserActionCommand > EditComp

OZUserActionCommand의 type 중 EditComp는 라벨, 메모의 텍스트를 변경할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
caption | 텍스트(string)
compname | 컴포넌트 이름(string) 메모는 공백으로 리턴됨
comptype | 컴포넌트 타입(string) 속성 창의 타입에 표시된 컴포넌트 타입이 라벨인 경우 "label", 차트인 경우 "chart", 사각형인 경우 "rect", 원인 경우 "circle", 선인 경우 "line", 화살표인 경우 "arrow"로 리턴됨 메모는 공백으로 리턴됨
reportname | 보고서 이름(string)

Reference

EditComp는 속성 값을 변경하므로 리턴되는 attr 중 caption은 변경되기 전 값을 나타내는 oldvalue와 변경된 후 값을 나타내는 newvalue로 구성됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "EditComp") {

       alert("Old Value : " + MyObj.oldvalue.caption + ",  New Value : " + MyObj.newvalue.caption);

       alert("Component Name : " + MyObj.compname);

       alert("Component Type : " + MyObj.comptype);

       alert("Report Name : " + MyObj.reportname);

   }

}

...


Error

OZUserActionCommand > Error

OZUserActionCommand의 type 중 Error는 에러가 발생할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
description | 상세 에러 메시지(string)
errorcode | 에러 코드(string)
errormessage | 에러 메시지(string)
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Error") {

       alert(MyObj.description);

       ...

   }

}

...


Export

OZUserActionCommand > Export

OZUserActionCommand의 type 중 Export는 보고서를 저장할 때 발생하며, 파일 형식에 따라 리턴되는 attr이 다릅니다.

attr | 설명
code | 전송 코드(string) 성공한 경우 "true", 실패한 경우 "false"로 리턴됨
executefile | 저장 후 바로 실행(string) 저장 후 바로 실행을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
exportbypage | 페이지별로 저장(string) 페이지별로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
filename | 파일 이름(string)
format | 파일 형식(string)
largebundle | 한 페이지로 저장(string) 한 페이지로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
pagemode | 저장 영역(string) 전체 페이지인 경우 "All", 현재 페이지인 경우 "Current", 선택된 페이지인 경우 "Selected", 지정인 경우 "Range"로 리턴됨
pagerange | 저장 영역이 페이지 지정일 때 페이지 범위(string) 페이지 범위가 "시작 페이지-끝 페이지,페이지 번호,시작 페이지-끝 페이지" 형태로 리턴됨(ex. "1-3,5,7-9") 저장 영역이 페이지 지정일 때에만 리턴됨
path | 저장 경로(string)
reportname | 보고서 이름(Array)
savearrow | 화살표 저장(string) 화살표를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savebarcode | 바코드 저장(string) 바코드를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savechart | 차트 저장(string) 차트를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savecircle | 원 저장(string) 원를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savedatamatrixbarcode | DataMatrix 바코드 저장(string) DataMatrix 바코드를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savehtml | HTML 저장(string) HTML을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
saveimage | 이미지 저장(string) 이미지를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savelabel | 라벨 저장(string) 라벨를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
saveline | 라인 저장(string) 라인을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savelinktoc | 모든 문서 저장(string) 모든 문서 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savelinkurl | URL 링크(string) URL 링크를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savemultidoc | 모든 문서 저장(string) 모든 문서 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
saveonefile | 한 파일로 저장(string) 한 파일로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savepdf417 | PDF417 저장(string) PDF417을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
saveqrbarcode | QR 바코드 저장(string) QR 바코드를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
saverect | 사각형 저장(string) 사각형을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
silentexecute | 임시 파일 생성 후 바로 실행(string) 임시 파일 생성 후 바로 실행인 경우 "true", 저장 다이얼로그 실행인 경우 "false"로 리턴됨
target | 출력 방향(string) Disk File인 경우 "disk", 메일인 경우 "email", 오즈 메일인 경우 "ozmail", 공유인 경우 "share"로 리턴됨
zip | 압축 저장(string) 압축을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
zipfilename | 압축 파일 이름(string)
zippassword | 압축 암호 설정(string) 암호를 설정한 경우 "true", 설정하지 않은 경우 "false"로 리턴됨
zippath | 압축 저장 경로(string)


CSV

OZUserActionCommand > Export > CSV

OZUserActionCommand의 type 중 Export에서 CSV 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
addseparator | 자릿수 구분기호 추가(string) 자릿수 구분기호 추가를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
charset | 인코딩(string) ANSI인 경우 "ansi", 유니코드인 경우 "unicode"로 리턴됨
exceptfirstpage | 첫 페이지 제외(string) 첫 페이지 제외를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
pageline | 페이지 간격 줄 수(int)
pagestyle | 페이지 구분 형태(string) 구분 형태를 설정하는 콤보 박스에 선택된 값이 리턴됨
pagetitle | 페이지 구분 형태 중 <PAGE>(string) <PAGE>를 설정하는 텍스트 박스에 입력된 값이 리턴됨
removerange | 라인 제거 범위(string) "첫 페이지 번호-마지막 페이지 번호" 형태로 리턴됨
saveastable | 테이블 형식으로 저장(string) 테이블 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
separator | 구분자(string) tab인 경우 "\t", space인 경우 " ", |인 경우 "|", /인 경우 "/", ~인 경우 "~", comma인 경우 "," empty인 경우 "", Other인 경우 사용자 정의 텍스트 박스에 입력한 값이 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "csv") {

           alert(MyObj.addseparator);

           ...

       }

   }

}

...


DOC

OZUserActionCommand > Export > DOC

OZUserActionCommand의 type 중 Export에서 DOC 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
saveastable | 테이블 형식으로 저장(string) 테이블 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
saveasxml | XML 형식으로 저장(string) XML 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savetoheaderfooter | 페이지 헤더/풋터 밴드를 머리글/바닥글에 저장(string) 페이지 헤더/풋터 밴드를 머리글/바닥글에 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "doc") {

           alert(MyObj.code);

           ...

       }

   }

}

...


GIF

OZUserActionCommand > Export > GIF

OZUserActionCommand의 type 중 Export에서 GIF 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
zoom | 확대/축소 비율(int)

Reference

Flash, HTML5 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "gif") {

           alert(MyObj.code);

           ...

       }

   }

}

...


GUL

OZUserActionCommand > Export > GUL

OZUserActionCommand의 type 중 Export에서 GUL 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
saveastable | 테이블 형식으로 저장(string) 테이블 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Reference

GUL 형식은 ActiveX 뷰어에서만 지원합니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "gul") {

           alert(MyObj.code);

           ...

       }

   }

}

...


HML

OZUserActionCommand > Export > HML

OZUserActionCommand의 type 중 Export에서 HML 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
saveastable | 테이블 형식으로 저장(string) 테이블 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "han97") {

           alert(MyObj.code);

           ...

       }

   }

}

...


HTML

OZUserActionCommand > Export > HTML

OZUserActionCommand의 type 중 Export에서 HTML 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
charset | 인코딩(string) ANSI인 경우 "ansi", 유니코드인 경우 "unicode", UTF-8인 경우 "utf-8"로 리턴됨
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
fontsize | 글꼴 크기(int)
horizontal | 페이지 간격 중 수평 라인 수(int)
imagepath | 이미지 경로(string)
offsetx | 오프셋 중 X축(int)
offsety | 오프셋 중 Y축(int)
pagetitle | 제목(string)
savebypage | 페이지별 저장(string) 페이지별 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
usefontsize | 글꼴 크기 설정(string) 글꼴 크기 설정을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
version | HTML 버전(string) 버전이 없을 경우 "none", 4.01 버전인 경우 "4.01"로 리턴됨
vertical | 페이지 간격 중 수직 라인 수(int)

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "html") {

           alert(MyObj.charset);

           ...

       }

   }

}

...


HWP

OZUserActionCommand > Export > HWP

OZUserActionCommand의 type 중 Export에서 HWP 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
keeplabelsize | 라벨 크기 고정(string) 라벨 크기 고정을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
saveastable | 테이블 형식으로 저장(string) 테이블 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savetobackground | 백그라운드 밴드를 바탕쪽에 저장(string) 백그라운드 밴드를 바탕쪽에 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savetoheaderfooter | 페이지 헤더/풋터 밴드를 머리말/꼬리말에 저장(string) 페이지 헤더/풋터 밴드를 머리말/꼬리말에 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
verttoparagraph | 세로를 문단으로 설정(string) 세로를 문단으로 설정을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "hwp") {

           alert(MyObj.code);

           ...

       }

   }

}

...


JPG

OZUserActionCommand > Export > JPG

OZUserActionCommand의 type 중 Export에서 JPG 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
quality | JPG 파일 압축 품질(int)
zoom | 확대/축소 비율(int)

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "jpg") {

           alert(MyObj.code);

           ...

       }

   }

}

...


MHT

OZUserActionCommand > Export > MHT

OZUserActionCommand의 type 중 Export에서 MHT 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
savefont | 글꼴(string)
savefontsize | 글꼴 크기(int)

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "mht") {

           alert(MyObj.savefont);

           ...

       }

   }

}

...


OZD

OZUserActionCommand > Export > OZD

OZUserActionCommand의 type 중 Export에서 OZD 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
includeedits | 편집 내용 포함(string) 편집 내용 포함을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
includeimage | 이미지 포함(string) 이미지 포함을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
password | 암호 설정(string) 암호를 설정한 경우 "true", 설정하지 않은 경우 "false"로 리턴됨
saveall | 모든 보고서 저장(string) 모든 보고서 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "ozd") {

           alert(MyObj.code);

           ...

       }

   }

}

...


PDF

OZUserActionCommand > Export > PDF

OZUserActionCommand의 type 중 Export에서 PDF 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
author | 작성자(string)
changeable | 변경 허용(string) 없음인 경우 "none", 주석 달기, 양식 필드 채우기 및 서명인 경우 "commenting_filling_in_formfields_and_signing", 페이지 레이아웃, 양식 필드 채우기 및 서명인 경우 "pagelayout_filling_in_formfields_and_signing", 페이지 추출을 제외한 모두인 경우 "any_except_extracting_of_pages"로 리턴됨
contentscopy | 내용 복사(string) 내용 복사를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
fontembedding | 폰트 포함(string) 폰트 포함을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
keyword | 키워드(string)
masterpassword | 마스터 암호 설정(string) 마스터 암호를 설정한 경우 "true", 설정하지 않은 경우 "false"로 리턴됨
printable | 인쇄 허용(string) 인쇄 허용을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
producer | 응용 프로그램(string)
savecharttoimage | 차트를 이미지로 저장(string) 차트를 이미지로로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
subject | 주제(string)
title | 제목(string)
userpassword | 사용자 암호 설정(string) 사용자 암호를 설정한 경우 "true", 설정하지 않은 경우 "false"로 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "pdf") {

           alert(MyObj.author);

           ...

       }

   }

}

...


PNG

OZUserActionCommand > Export > PNG

OZUserActionCommand의 type 중 Export에서 PNG 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
zoom | 확대/축소 비율(int)

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "png") {

           alert(MyObj.code);

           ...

       }

   }

}

...


PPT

OZUserActionCommand > Export > PPT

OZUserActionCommand의 type 중 Export에서 PPT 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
saveastable | 테이블 형식으로 저장(string) 테이블 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "ppt") {

           alert(MyObj.code);

           ...

       }

   }

}

...


SVG

OZUserActionCommand > Export > SVG

OZUserActionCommand의 type 중 Export에서 SVG 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
savemultipage | 한 파일에 저장(string) 한 파일에 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "svg") {

           alert(MyObj.code);

           ...

       }

   }

}

...


TEXT

OZUserActionCommand > Export > TEXT

OZUserActionCommand의 type 중 Export에서 TEXT 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
addseparator | 자릿수 구분기호 추가(string) 자릿수 구분기호 추가를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
charset | 인코딩(string) ANSI인 경우 "ansi", 유니코드인 경우 "unicode"로 리턴됨
exceptfirstpage | 첫 페이지 제외(string) 첫 페이지 제외를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
pageline | 페이지 간격 줄 수(int)
pagestyle | 페이지 구분 형태(string) 구분 형태를 설정하는 콤보 박스에 선택된 값이 리턴됨
pagetitle | 페이지 구분 형태 중 <PAGE>(string) <PAGE>를 설정하는 텍스트 박스에 입력된 값이 리턴됨
removerange | 라인 제거 범위(string) "첫 페이지 번호-마지막 페이지 번호" 형태로 리턴됨
saveastable | 테이블 형식으로 저장(string) 테이블 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
separator | 구분자(string) tab인 경우 "\t", space인 경우 " ", |인 경우 "|", /인 경우 "/", ~인 경우 "~", comma인 경우 "," empty인 경우 "", Other인 경우 사용자 정의 텍스트 박스에 입력한 값이 리턴됨

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "txt") {

           alert(MyObj.addseparator);

           ...

       }

   }

}

...


TIF

OZUserActionCommand > Export > TIF

OZUserActionCommand의 type 중 Export에서 TIF 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
dpi | 해상도(int)
encode | 인코딩 방식(string) G3인 경우 "G3", G4인 경우 "G4", JPG인 경우 "JPG"로 리턴됨
height | 높이(int)
savemultipage | 한 파일에 저장(string) 한 파일에 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
sizemode | 크기 모드(string) 비율을 체크한 경우 "zoom", 크기를 체크한 경우 "size", 해상도에 따라 크기 결정을 체크한 경우 "dpi"로 리턴됨
width | 너비(int)
zoom | 확대/축소 비율(int)

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "tif") {

           alert(MyObj.dpi);

           ...

       }

   }

}

...


XLS

OZUserActionCommand > Export > XLS

OZUserActionCommand의 type 중 Export에서 XLS 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
autofit | 자동 맞춤(string) 자동 맞춤을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
autofitheight | 자동 맞춤 높이(int)
autofitwidth | 자동 맞춤 너비(int)
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
freezepanes_column | 틀 고정할 열 이름(string)
freezepanes_row | 틀 고정할 행 번호(int)
matchsubmode | 페이지별 시트 저장 시 우선 순위(string) Column 우선인 경우 "columnfirst", Row 우선인 경우 "rowfirst"로 리턴됨
minimumcellheight | 셀 최소 높이(int)
minimumcellwidth | 셀 최소 너비(int)
removeblank | 페이지 사이 공백 제거(string) 페이지 사이 공백 제거를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
removeoption | 라인 제거 옵션(string) 첫 페이지 제외인 경우 "firstpageexcept", 첫 페이지만인 경우 "firstpageonly", 모든 페이지인 경우 "allpage"로 리턴됨
removerange | 라인 제거 범위(string) 라인 제거 범위를 설정하는 텍스트 박스에 입력된 값이 리턴됨
savebyhtml | mht 형식으로 저장(string) mht 형식으로 저장을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savefont | 글꼴(string)
savefontsize | 글꼴 크기(int)
savemode | 저장 방식(string) 폼 형태, 속성 유지인 경우 "keepform", 색상, 외곽라인, 셀합치기 무시인 경우 "ignoreblank"로, 색상, 외곽라인, 셀합치기 무시이면서 분할 후 주변 셀 제거인 경우 "ignoreprops"로 리턴됨
savenumberformat | 숫자 포맷(string) 숫자 포맷을 설정하는 텍스트 박스에 입력된 값이 리턴됨
savenumbertype | 표시 형식이 숫자인 라벨만 적용(string) 표시 형식이 숫자인 라벨만 적용을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savetogeneral | 일반으로 변환(string) 일반으로 변환을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savetointeger | 숫자형 텍스트를 숫자로 변환(string) 숫자형 텍스트를 숫자로 변환을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
showgridlines | 눈금선(string) 눈금선을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
shrinktofit | 셀에 맞춤(string) 셀에 맞춤을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
usesavefont | 글꼴 설정(string) 글꼴을 설정한 경우 "true", 설정하지 않은 경우 "false"로 리턴됨
zoom | 확대/축소 비율(int)

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "xls") {

           alert(MyObj.autofit);

           ...

       }

   }

}

...


XLSX

OZUserActionCommand > Export > XLSX

OZUserActionCommand의 type 중 Export에서 XLSX 파일로 저장 시 리턴되는 attr은 다음과 같습니다.

attr | 설명
autofit | 자동 맞춤(string) 자동 맞춤을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
autofitheight | 자동 맞춤 높이(int)
autofitwidth | 자동 맞춤 너비(int)
convertedimagedpi | 이미지로 익스포트 되는 컴포넌트의 해상도(int)
freezepanes_column | 틀 고정할 열 이름(string)
freezepanes_row | 틀 고정할 행 번호(int)
matchsubmode | 페이지별 시트 저장 시 우선 순위(string) Column 우선인 경우 "columnfirst", Row 우선인 경우 "rowfirst"로 리턴됨
minimumcellheight | 셀 최소 높이(int)
minimumcellwidth | 셀 최소 너비(int)
removeblank | 페이지 사이 공백 제거(string) 페이지 사이 공백 제거를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
removeoption | 라인 제거 옵션(string) 첫 페이지 제외인 경우 "firstpageexcept", 첫 페이지만인 경우 "firstpageonly", 모든 페이지인 경우 "allpage"로 리턴됨
removerange | 라인 제거 범위(string) 라인 제거 범위를 설정하는 텍스트 박스에 입력된 값이 리턴됨
savefont | 글꼴(string)
savefontsize | 글꼴 크기(int)
savemode | 저장 방식(string) 폼 형태, 속성 유지인 경우 "keepform", 색상, 외곽라인, 셀합치기 무시인 경우 "ignoreblank"로, 색상, 외곽라인, 셀합치기 무시이면서 분할 후 주변 셀 제거인 경우 "ignoreprops"로 리턴됨
savenumberformat | 숫자 포맷(string) 숫자 포맷을 설정하는 텍스트 박스에 입력된 값이 리턴됨
savenumbertype | 표시 형식이 숫자인 라벨만 적용(string) 표시 형식이 숫자인 라벨만 적용을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savetogeneral | 일반으로 변환(string) 일반으로 변환을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
savetointeger | 숫자형 텍스트를 숫자로 변환(string) 숫자형 텍스트를 숫자로 변환을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
showgridlines | 눈금선(string) 눈금선을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
shrinktofit | 셀에 맞춤(string) 셀에 맞춤을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
usesavefont | 글꼴 설정(string) 글꼴을 설정한 경우 "true", 설정하지 않은 경우 "false"로 리턴됨
zoom | 확대/축소 비율(int)

Reference

Flash, HTML5 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Export") {

       if(MyObj.format == "xlsx") {

           alert(MyObj.autofit);

           ...

       }

   }

}

...


Find

OZUserActionCommand > Find

OZUserActionCommand의 type 중 Find는 보고서를 검색할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
checkmatchcase | 대/소문자 구분(string) 대/소문자 구분을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
checkword | 단어 단위로(string) 단어 단위로를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
direction | 방향(string) 위로인 경우 "up", 아래로인 경우 "down"으로 리턴
reportname | 보고서 이름(string)
str | 찾을 내용(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Find") {

       alert(MyObj.checkmatchcase);

       ...

   }

}

...


HideReport

OZUserActionCommand > HideReport

OZUserActionCommand의 type 중 HideReport는 보고서를 숨길 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
index | 보고서 인덱스(int). Zero-Based Index
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "HideReport") {

       alert(MyObj.index);

       ...

   }

}

...


InversePaper

OZUserActionCommand > InversePaper

OZUserActionCommand의 type 중 InversePaper는 용지 방향을 변경할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
orientation | 용지 방향(string) 가로로 변경한 경우 "horizontal", 세로로 변경한 경우 "vertical"로 리턴됨
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "InversePaper") {

       alert(MyObj.orientation);

       ...

   }

}

...


Link

OZUserActionCommand > Link

OZUserActionCommand의 type 중 Link는 링크 스크립트를 실행한 경우 발생하며, 실행된 함수에 따라 리턴되는 attr은 다음과 같습니다.

·SetLinkEvent/setLinkEvent

attr | 설명
linktype | 링크 스크립트 타입(string) SetLinkEvent/setLinkEvent 함수인 경우 "setlinkevent"로 리턴됨
reportname | 보고서 이름(string)
tag | SetLinkEvent/setLinkEvent 함수의 UserTag 인자 값(string)
value | SetLinkEvent/setLinkEvent 함수의 UserValue 인자 값(string)

·SetLinkExecute/setLinkExecute

attr | 설명
cmd | SetLinkExecute/setLinkExecute 함수의 Command 인자 값(string)
linktype | 링크 스크립트 타입(string) SetLinkExecute/setLinkExecute 함수인 경우 "setlinkexecute"로 리턴됨
parameter | SetLinkExecute/setLinkExecute 함수의 Parameter 인자 값(string)
reportname | 보고서 이름(string)

·SetLinkPostURL/setLinkPostURL

attr | 설명
linktype | 링크 스크립트 타입(string) SetLinkPostURL/setLinkPostURL 함수인 경우 "setlinkposturl"로 리턴됨
postparam | SetLinkPostURL/setLinkPostURL 함수의 PostParameter 인자 값(string)
reportname | 보고서 이름(string)
target | SetLinkPostURL/setLinkPostURL 함수의 Target 인자 값(string)
url | SetLinkPostURL/setLinkPostURL 함수의 URL 인자 값(string)

·SetLinkRepository/setLinkRepository

attr | 설명
linktype | 링크 스크립트 타입(string) SetLinkRepository/setLinkRepository 함수인 경우 "setlinkrepository"로 리턴됨
mode | SetLinkRepository/setLinkRepository 함수의 FileExecuteMode 인자 값(string)
reportname | 보고서 이름(string)
url | SetLinkRepository/setLinkRepository 함수의 RepositoryFileURL 인자 값(string)

·SetLinkServer/setLinkServer

attr | 설명
linktype | 링크 스크립트 타입(string) SetLinkServer/setLinkServer 함수인 경우 "setlinkserver"로 리턴됨
reportname | 보고서 이름(string)
server | SetLinkServer/setLinkServer 함수의 ServerIP 인자 값(string)
port | SetLinkServer/setLinkServer 함수의 인자 PortNumber 값(int)

·SetLinkServlet/setLinkServlet

attr | 설명
linktype | 링크 스크립트 타입(string) SetLinkServlet/setLinkServlet 함수인 경우 "setlinkservlet"로 리턴됨
reportname | 보고서 이름(string)
url | SetLinkServlet/setLinkServlet 함수의 ServletURL 인자 값(string)

·SetLinkToc/setLinkToc

attr | 설명
linktype | 링크 스크립트 타입(string) SetLinkToc/setLinkToc 함수인 경우 "setlinktoc"로 리턴됨
reportname | 보고서 이름(string)
tag | SetLinkToc/setLinkToc 함수의 TocPath 인자 값(string)

·SetLinkURL/setLinkURL

attr | 설명
linktype | 링크 스크립트 타입(string) SetLinkURL/setLinkURL 함수인 경우 "setlinkurl"로 리턴됨
reportname | 보고서 이름(string)
target | SetLinkURL/setLinkURL 함수의 Target 인자 값(string)
url | SetLinkURL/setLinkURL 함수의 URL 인자 값(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Link") {

       alert(MyObj.linktype);

       ...

   }

}

...


Mail

OZUserActionCommand > Mail

OZUserActionCommand의 type 중 Mail은 오즈 메일을 전송할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
bcc | 숨은 참조(string)
cc | 참조(string)
code | 전송 코드(string) 성공한 경우 "true", 실패한 경우 "false"로 리턴됨
contents | 내용(string)
filename | 보고서 이름(string)
from | 보내는 사람(string)
sendto | 받는 사람(string)
title | 제목(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Mail") {

       alert(MyObj.bcc);

       ...

   }

}

...


MakeTemplate

OZUserActionCommand > MakeTemplate

OZUserActionCommand의 type 중 MakeTemplate는 뷰어가 리포트 템플릿을 생성할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(string)
state | 생성 상태(string) 생성 시작 직전에 "false", 생성이 완료된 후 "true"로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "MakeTemplate") {

       alert(MyObj.reportname);

       ...

   }

}

...


MoveComp

OZUserActionCommand > MoveComp

OZUserActionCommand의 type 중 MoveComp는 컴포넌트의 크기와 위치를 변경할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
compname | 컴포넌트 이름(string) 메모는 공백으로 리턴됨
comptype | 컴포넌트 타입(string) 속성 창의 타입에 표시된 컴포넌트 타입이 라벨인 경우 "label", 차트인 경우 "chart", 사각형인 경우 "rect", 원인 경우 "circle", 선인 경우 "line", 화살표인 경우 "arrow"로 리턴됨 메모는 공백으로 리턴됨
height | 높이(float)
reportname | 보고서 이름(string)
width | 너비(float)
xpos | X 좌표(float)
ypos | Y 좌표(float)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "MoveComp") {

       alert(MyObj.compname);

       ...

   }

}

...


MovePage

OZUserActionCommand > MovePage

OZUserActionCommand의 type 중 MovePage는 페이지를 이동할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
direction | 이동 방향(string) 수직 방향에서 수직 방향으로 이동한 경우 "vertical", 수평 방향에서 수평 방향으로 이동한 경우 "horizontal", 수직 방향에서 수평 방향으로 또는 수평 방향에서 수직 방향으로 이동한 경우 "both"로 리턴됨
index | 이동된 페이지 번호(int)
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "MovePage") {

       alert(MyObj.direction);

       ...

   }

}

...


MoveReport

OZUserActionCommand > MoveReport

OZUserActionCommand의 type 중 MoveReport는 보고서를 이동할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
index | 보고서 인덱스(int). Zero-Based Index
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "MoveReport") {

       alert(MyObj.index);

       ...

   }

}

...


MultiPrint

OZUserActionCommand > MultiPrint

OZUserActionCommand의 type 중 MultiPrint는 여러 보고서를 인쇄할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
adjust | 용지에 맞춰 인쇄(string) 용지에 맞춰 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
code | 인쇄 코드(string) 성공한 경우 "true", 실패한 경우 "false"로 리턴됨
collate | 한 부씩 인쇄(string) 한 부씩 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
copies | 인쇄 매수(int)
dividepage | 용지에 맞춰서 분할 인쇄(string) 용지에 맞춰서 분할 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
drivername | 프린터 드라이버 이름(string)
duplex | 양면 인쇄(string) 없음인 경우 "none", 긴 쪽으로 넘김인 경우 "duplexvertical", 짧은 쪽으로 넘김인 경우 "duplexhorizontal"로 리턴됨
gray | 흑백 인쇄(string) 흑백 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
handout | 모아찍기(string) 모아찍기를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
handoutorder | 모아찍기 중 인쇄 순서(string) 수평인 경우 "horizontal", 수직인 경우 "vertical"로 리턴됨
handoutorientation | 모아찍기 중 인쇄 방향(string) 세로인 경우 "vertical", 가로인 경우 "horizontal"로 리턴됨
handoutpage | 모아찍기 중 한 페이지에 인쇄할 페이지 수(int)
orientation | 용지 방향(string) 세로인 경우 "portrait", 가로인 경우 "landscape"로 리턴됨
pageindex | 페이지 인덱스(int) Zero-Based Index이며, 인쇄 범위가 현재 페이지일 때에만 리턴됨
papersize | 인쇄할 용지(string)
printername | 프린터 이름(string)
printinfo | 인쇄된 보고서 정보 가진 배열(Array)
printrange | 인쇄 범위(string) 모두인 경우 "all", 현재 페이지인 경우 "current", 선택된 페이지인 경우 "selected", 페이지 지정인 경우 "range", 리포트 지정인 경우 "selectedreport"로 리턴됨
printtofile | 파일로 인쇄(string) 파일로 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
reportname | 보고서 이름(string)
trayname | 용지 공급(string) 용지 공급 콤보 박스에 선택된 값이 리턴됨. 단, 자동 선택인 경우 공백으로 리턴됨
usespooleachcopy | 한 부씩 스풀 사용(string) 한 부씩 스풀 사용을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
zoom | 확대/축소 비율(int)

Reference

뷰어 타입별로 오즈 뷰어 인쇄 다이얼로그에서 지원하지 않는 옵션은 기본 값으로 리턴됩니다.

여러 보고서를 인쇄할 때 발생하는 MultiPrint의 attr은 인쇄된 보고서 정보를 가진 배열인 printinfo을 이용하여 가져옵니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "MultiPrint") {

       alert(MyObj.printinfo[0].adjust);

       ...

   }

}

...


Open

OZUserActionCommand > Open

OZUserActionCommand의 type 중 Open은 OZD 파일을 열 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
code | 열기 코드(string) 성공한 경우 "true", 실패한 경우 "false"로 리턴됨
filename | OZD 파일 이름(string)
path | OZD 파일 경로(string)

Reference

Flash, HTML5 뷰어의 경우 "path"는 공백으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Open") {

       alert(MyObj.code);

       ...

   }

}

...


PageSetup

OZUserActionCommand > PageSetup

OZUserActionCommand의 type 중 PageSetup은 페이지 설정을 변경할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
autoadjustmargin | 자동 조정(string) 자동 조정을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
bottommargin | 아래쪽 여백(string)
leftmargin | 왼쪽 여백(string)
pagesetup_unit | 사용 단위계의 단위(string)
reportname | 보고서 이름(string)
rightmargin | 오른쪽 여백(string)
topmargin | 위쪽 여백(string)
usedefaultmargin | 기본 여백 사용(string) 기본 여백 사용을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Reference

bottommargin, leftmargin, rightmargin, topmargin의 리턴 값은 페이지 설정 다이얼로그에서 설정한 단위와 상관없이 무조건 pt 단위로 환산되어 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "PageSetup") {

       alert(MyObj.autoadjustmargin);

       ...

   }

}

...


Parameter

OZUserActionCommand > Parameter

OZUserActionCommand의 type 중 Parameter는 패러미터 값을 입력하여 보고서와 데이터를 새로 고침할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
parameter | 변경된 패러미터 내용(Array)
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Parameter") {

       alert(MyObj.parameter[0]);

       ...

   }

}

...


Print

OZUserActionCommand > Print

OZUserActionCommand의 type 중 Print는 보고서를 인쇄할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
adjust | 용지에 맞춰 인쇄(string) 용지에 맞춰 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
code | 인쇄 코드(string) 성공한 경우 "true", 실패한 경우 "false"로 리턴됨
collate | 한 부씩 인쇄(string) 한 부씩 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
copies | 인쇄 매수(int)
dividepage | 용지에 맞춰서 분할 인쇄(string) 용지에 맞춰서 분할 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
drivername | 프린터 드라이버 이름(string)
duplex | 양면 인쇄(string) 없음인 경우 "none", 긴 쪽으로 넘김인 경우 "duplexvertical", 짧은 쪽으로 넘김인 경우 "duplexhorizontal"로 리턴됨
gray | 흑백 인쇄(string) 흑백 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
handout | 모아찍기(string) 모아찍기를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
handoutorder | 모아찍기 중 인쇄 순서(string) 수평인 경우 "horizontal", 수직인 경우 "vertical"로 리턴됨
handoutorientation | 모아찍기 중 인쇄 방향(string) 세로인 경우 "vertical", 가로인 경우 "horizontal"로 리턴됨
handoutpage | 모아찍기 중 한 페이지에 인쇄할 페이지 수(int)
orientation | 용지 방향(string) 세로인 경우 "portrait", 가로인 경우 "landscape"로 리턴됨
pageindex | 페이지 인덱스(int) Zero-Based Index이며, 인쇄 범위가 현재 페이지일 때에만 리턴됨
pagersize | 인쇄할 용지(string)
printername | 프린터 이름(string)
printrange | 인쇄 범위(string) 모두인 경우 "all", 현재 페이지인 경우 "current", 선택된 페이지인 경우 "selected", 페이지 지정인 경우 "range", 리포트 지정인 경우 "selectedreport"로 리턴됨
printtofile | 파일로 인쇄(string) 파일로 인쇄를 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
reportname | 보고서 이름(string)
trayname | 용지 공급(string) 용지 공급 콤보 박스에 선택된 값이 리턴됨. 단, 자동 선택인 경우 공백으로 리턴됨
usespooleachcopy | 한 부씩 스풀 사용(string) 한 부씩 스풀 사용을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨
zoom | 확대/축소 비율(int)

Reference

뷰어 타입별로 오즈 뷰어 인쇄 다이얼로그에서 지원하지 않는 옵션은 기본 값으로 리턴됩니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Print") {

       alert(MyObj.adjust);

       ...

   }

}

...


PrintableComp

OZUserActionCommand > PrintableComp

OZUserActionCommand의 type 중 PrintableComp는 컴포넌트의 인쇄 불가 여부를 변경할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
comptype | 컴포넌트 타입(string) 속성 창의 타입에 표시된 컴포넌트 타입이 라벨인 경우 "label", 차트인 경우 "chart", 사각형인 경우 "rect", 원인 경우 "circle", 선인 경우 "line", 화살표인 경우 "arrow"로 리턴됨
reportname | 보고서 이름(string)
state | 인쇄하지 않음(string) 인쇄하지 않음을 체크한 경우 "true", 체크하지 않은 경우 "false"로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "PrintableComp") {

       alert(MyObj.comptype);

       ...

   }

}

...


Refresh

OZUserActionCommand > Refresh

OZUserActionCommand의 type 중 Refresh는 주기를 설정하여 보고서를 새로 고침할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
hhmmss | 주기(string) 새로 고침 타입이 "start"일 경우에는 "시:분:초" 형태로, 그외 경우에는 공백으로 리턴됨
reportname | 보고서 이름(string)
type | 새로 고침 타입(string) [새로 고침] 버튼을 클릭한 경우 "refresh", [시작] 버튼을 클릭한 경우 "start", [정지] 버튼을 클릭한 경우 "stop"으로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Refresh") {

       alert(MyObj.hhmmss);

       ...

   }

}

...


RequestData

OZUserActionCommand > RequestData

OZUserActionCommand의 type 중 RequestData는 뷰어에서 데이터를 요청할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(string)
state | 요청 상태(string) 요청 시작 직전에 "false", 요청이 완료된 후 "true"로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "RequestData") {

       alert(MyObj.reportname);

       ...

   }

}

...


RequestForm

OZUserActionCommand > RequestForm

OZUserActionCommand의 type 중 RequestForm은 뷰어가 폼 파일을 요청할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(string)
state | 요청 상태(string) 요청 시작 직전에 "false", 요청이 완료된 후 "true"로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "RequestForm") {

       alert(MyObj.reportname);

       ...

   }

}

...


SaveAsImage

OZUserActionCommand > SaveAsImage

OZUserActionCommand의 type 중 SaveAsImage는 보고서에 표시된 이미지, 바코드, PDF417 바코드, QR 바코드, DataMatrix 바코드, 차트, ImagePicker를 이미지 파일로 저장할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
compname | 컴포넌트 이름(string)
filename | 파일 이름(string)
path | 저장 경로(string)
reportname | 보고서 이름(string)

Reference

Flash, HTML5, WinRT 뷰어의 경우 "filename", "path"는 빈 값으로 리턴됩니다.

컴포넌트 종류에 따라 이미지 저장 다이얼로그에 설정되는 파일 형식 규칙은 아래와 같습니다.

종류 | 파일 형식
이미지(라벨/노트), ImagePicker | 설정된 이미지 파일 형식으로 설정됨 DB 데이터 등 확장자가 지정되지 않은 경우에는 *.*로 설정됨
바코드, 사용자 컴포넌트(라벨/노트), 차트 | *.jpg로 설정됨
PDF417 바코드, QR 바코드, DataMatrix 바코드 | *.bmp로 설정됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "SaveAsImage") {

       alert(MyObj.compname);

       ...

   }

}

...


ScreenTool

OZUserActionCommand > ScreenTool

OZUserActionCommand의 type 중 ScreenTool은 뷰어 모드를 변경할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(string)
screentool | 뷰어 모드(string) 손 모드인 경우 "hand", 편집 모드인 경우 "edit", 텍스트 선택 모드인 경우 "textselect", 주석 모드인 경우 "comment", 안내 모드인 경우 "multiscreenguide"로 리턴됨

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "ScreenTool") {

       alert(MyObj.reportname);

       ...

   }

}

...


ScrollReport

OZUserActionCommand > ScrollReport

OZUserActionCommand의 type 중 ScrollReport는 스크롤 상태가 변경될 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
horizontalscroll_status | 가로 스크롤 상태(string) 가로 스크롤이 표시되지 않은 경우 "none", 가장 왼쪽에 위치한 경우 "left", 가장 오른쪽에 위치한 경우 "right", 그 외 경우 "center"로 리턴됨
reportname | 보고서 이름(string)
verticalscroll_status | 세로 스크롤 상태(string) 세로 스크롤이 표시되지 않은 경우 "none", 가장 위쪽에 위치한 경우 "top", 가장 아래쪽에 위치한 경우 "bottom", 그 외 경우 "middle"로 리턴됨

Reference

ScrollReport는 사용자가 스크롤을 직접 변경시킬 때 뿐만 아니라 페이지 이동, 보기 모드 변경, 모바일 단말기 회전, 모바일 단말기의 키패드/키보드 활성화 등 스크롤 상태가 변경되는 모든 상황에 대해 발생합니다. 단, 스크롤 상태가 이전과 다를 경우에만 발생합니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "ScrollReport") {

       alert(MyObj.horizontalscroll_status);

       ...

   }

}

...


SearchParameter

OZUserActionCommand > SearchParameter

OZUserActionCommand의 type 중 SearchParameter는 조회 툴바를 이용해 보고서와 데이터를 새로 고침할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
action | 조회 타입(string) 데이터와 보고서를 새로고침인 경우 "Action_Refresh", 보고서만 새로고침인 경우 "Action_ReBinding", 라벨의 텍스트만 새로고침인 경우 "Action_SetText"로 리턴됨
fieldname | 필드 이름(string)
odiname | ODI 이름(string)
reportname | 보고서 이름(string)
value | 필드 값(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "SearchParameter") {

       alert(MyObj.action);

       ...

   }

}

...


SelectComp

OZUserActionCommand > SelectComp

OZUserActionCommand의 type 중 SelectComp는 마우스 클릭 또는 드래그 & 드롭 동작으로 컴포넌트를 직접 선택한 경우에만 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
changeable | 속성 변환 가능 여부(string) 속성 변환 가능한 경우 "true", 속성 변환 가능하지 않은 경우 "false"로 리턴됨
compname | 컴포넌트 이름(string) 메모는 공백으로 리턴됨
comptype | 컴포넌트 타입(string) "label", "chart", "rect", "circle", "line", "arrow", "button", "radiobutton", "checkbox", "textbox", "combobox", "signpad", "voicerecorder", "datetimepicker", "numericupdown", "imagepicker" 중 하나의 값으로 리턴됨 메모는 공백으로 리턴됨
editable | 편집 가능 여부(string) 편집 가능한 경우 "true", 편집 가능하지 않은 경우 "false"로 리턴됨
height | 높이(float)
movable | 이동 가능 여부(string) 이동 가능한 경우 "true", 이동 가능하지 않은 경우 "false"로 리턴됨
reportname | 보고서 이름(string)
selecttype | 선택 타입(string) 왼쪽 마우스로 클릭하여 선택한 경우 "LButtonDown", 오른쪽 마우스로 클릭하여 선택한 경우 "RButtonDown", 드래그 & 드롭으로 선택한 경우 "Drag"로 리턴됨 모바일에서 실행된 경우 항상 "LButtonDown"으로 리턴됨
width | 너비(float)
xpos | X 좌표(float)
ypos | Y 좌표(float)

Reference

찾기 또는 목차 선택 등으로 컴포넌트가 선택된 경우에는 SelectComp가 발생하지 않습니다.

드래그 & 드롭 동작으로 여러 컴포넌트가 한꺼번에 선택된 경우에는 컴포넌트가 페이지에 추가된 순서 기준으로 OZUserActionCommand가 한꺼번에 발생합니다.

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "SelectComp") {

       alert(MyObj.changeable);

       ...

   }

}

...


ShowReport

OZUserActionCommand > ShowReport

OZUserActionCommand의 type 중 ShowReport는 숨긴 보고서를 다시 표시할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
index | 보고서 인덱스(int). Zero-Based Index
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "ShowReport") {

       alert(MyObj.index);

       ...

   }

}

...


Toc

OZUserActionCommand > Toc

OZUserActionCommand의 type 중 Toc는 보고서 트리에서 목차를 선택할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(string)
toclevel | 목차 레벨(int)
tocname | 목차 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Toc") {

       alert(MyObj.reportname);

       ...

   }

}

...


Tree

OZUserActionCommand > Tree

OZUserActionCommand의 type 중 Tree는 보고서 트리에서 보고서를 선택할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
reportname | 보고서 이름(string)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Tree") {

       alert(MyObj.reportname);

   }

}

...


Zoom

OZUserActionCommand > Zoom

OZUserActionCommand의 type 중 Zoom은 보고서를 확대, 축소, 복원할 때 발생하며, 리턴되는 attr은 다음과 같습니다.

attr | 설명
pagedisplay | 페이지 표시(string) 한 페이지씩 보기인 경우 "singlepage", 한 페이지씩 연속 보기인 경우 "singlepagecontinuous", 연속 보기인 경우 "continuous"로 리턴됨
reportname | 보고서 이름(string)
viewmode | 보기 모드(string) 실제 크기인 경우 "normal", 화면 크기에 맞추기인 경우 "fittoframe", 너비에 맞추기인 경우 "fittowidth", 표시 내용에 맞추기인 경우 "fittocontents", 인쇄 크기인 경우 "printsize"로 리턴됨
zoom | 확대, 축소, 복원(string) 확대한 경우 "zoomin", 축소한 경우 "zoomout", 복원한 경우 "reset"으로 리턴됨
zoomvalue | 보고서의 확대, 축소 비율(int)

Example

...

function OZUserActionCommand_OZViewer(type, attr) {

   var MyObj = eval('(' + attr + ')');

   if(type == "Zoom") {

       alert(MyObj.pagedisplay);

       ...

   }

}

...


Example - ActiveX 뷰어

OZUserActionCommand Example - ActiveX 뷰어

아래 예제는 UserActionCommand 이벤트를 이용하여 사용자가 보고서를 저장한 경우 파일 형식, 저장 영역을 표시하는 예입니다.

<html>

<head>

<script language="JavaScript">

   function OZUserActionCommand_OZViewer(type, attr) {

       var MyObj = eval('(' + attr + ')');

       if(type == "Export") {

           if(MyObj.code == "true") {

               alert("파일 형식 : " + MyObj.format);

               alert("저장 영역 : " + MyObj.pagemode);

           }

       }

   }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

   <param name="viewer.isframe" value="false">

   <param name="viewer.useractioncommand" value="true">

   </object>

</div>

</body>

</html>

Additional Information: OZUserActionCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZUserActionCommand_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZUserActionCommand Example - Applet 뷰어

아래 예제는 UserActionCommand 이벤트를 이용하여 사용자가 보고서를 저장한 경우 파일 형식, 저장 영역을 표시하는 예입니다.

<html>

<head>

<script language="JavaScript">

   function OZUserActionCommand_OZViewer(type, attr) {

       var MyObj = eval('(' + attr + ')');

       if(type == "Export") {

           if(MyObj.code == "true") {

               alert("파일 형식 : " + MyObj.format);

               alert("저장 영역 : " + MyObj.pagemode);

           }

       }

   }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

       "viewer.isframe=false",

       "viewer.useractioncommand=true"

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZUserActionCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZUserActionCommand_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZUserActionCommand Example - Flash 뷰어

아래 예제는 UserActionCommand 이벤트를 이용하여 사용자가 보고서를 저장한 경우 파일 형식, 저장 영역을 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZUserActionCommand_OZViewer(type, attr) {

       var MyObj = eval('(' + attr + ')');

       if(type == "Export") {

           if(MyObj.code == "true") {

               alert("파일 형식 : " + MyObj.format);

               alert("저장 영역 : " + MyObj.pagemode);

           }

       }

   }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       oz.sendToActionScript("viewer.useractioncommand", "true");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZUserActionCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZUserActionCommand_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZUserActionCommand Example - WPF 뷰어

아래 예제는 UserActionCommand 이벤트를 이용하여 사용자가 뷰어의 기능을 실행할 때 기능 타입과 실행 정보를 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           paramList.Add("viewer.isframe", "false");

           paramList.Add("viewer.useractioncommand", "true");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZUserActionCommand".Equals(command))

                  {

                       //return values

                       //param[0] : type

                       //param[1] : attr

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZUserActionCommand Example - HTML5 뷰어

아래 예제는 UserActionCommand 이벤트를 이용하여 사용자가 보고서를 저장한 경우 파일 형식, 저장 영역을 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZUserActionCommand_OZViewer(type, attr) {

       var MyObj = eval('(' + attr + ')');

       if(type == "Export") {

           if(MyObj.code == "true") {

               alert("파일 형식 : " + MyObj.format);

               alert("저장 영역 : " + MyObj.pagemode);

           }

       }

   }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       oz.sendToActionScript("viewer.useractioncommand", "true");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZUserActionCommand_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZUserActionCommand_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZUserActionCommand Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   String params = "connection.servlet=http://127.0.0.1:8080/oz/server";

   params += "\n" + "connection.reportname=sample.ozr";

   params += "\n" + "viewer.useractioncommand=true";

   FrameLayout flayout = new FrameLayout(this);

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public void OZUserActionCommand(String type, String attr)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZUserActionCommand Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (void) createViewer

{

...

   NSString* strParam = @"connection.servlet=http://127.0.0.1:8080/oz/server\n"

                         @"connection.reportname=sample.ozr\n"

                         @"viewer.useractioncommand=true";

   OZReportViewer* reportViewer = [OZReportAPI createViewer:self view:_reportView param:strParam];

   self.viewer = reportViewer;

   [reportViewer release];

...

}

- (void) OZUserActionCommand: (NSString*)type :(NSString*)attr

{

   // Input Script

}

...


Example - WinRT 뷰어

OZUserActionCommand Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.useractioncommand=true";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public void OZUserActionCommand(string type, string attr)

       {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\nviewer.useractioncommand=true";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

  }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual void OZUserActionCommand(String^ type, String^ attr)

           {

               // Input Script

          }

  };

}


OZUserEvent

_TriggerOCXUserEvent 함수 실행 시 발생하는 이벤트입니다.

Arguments

param1 _TriggerOCXUserEvent 함수에서 전달한 첫 번째 값

param2 _TriggerOCXUserEvent 함수에서 전달한 두 번째 값

param3 _TriggerOCXUserEvent 함수에서 전달한 세 번째 값


Example - ActiveX 뷰어

OZUserEvent Example - ActiveX 뷰어

아래 예제는 _TriggerOCXUserEvent 함수에서 전달한 패러미터 값을 OZUserEvent 이벤트를 이용하여 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZUserEvent_OZViewer(param1, param2, param3) {

       alert("Parameter1 : " + param1);

       alert("Parameter2 : " + param2);

       alert("Parameter3 : " + param3);

  }

</script>

</head>

<body>

<div id="RunOZViewer">

   <object id="OZViewer" classid="clsid:0DEF32F8-170F-46f8-B1FF-4BF7443F5F25" width="100%" height="100%">

   <param name="connection.servlet" value="http://127.0.0.1:8080/oz/server">

   <param name="connection.reportname" value="sample.ozr">

</object>

</div>

</body>

</html>

Additional Information: OZUserEvent_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "object id"에서 설정한 값으로 지정해야 합니다.

...

function OZUserEvent_OZViewer(...

...

<object id="OZViewer" ...


Example - Applet 뷰어

OZUserEvent Example - Applet 뷰어

아래 예제는 _TriggerOCXUserEvent 함수에서 전달한 패러미터 값을 OZUserEvent 이벤트를 이용하여 표시하는 예입니다.

<html>

<head>

<script language="Javascript">

   function OZUserEvent_OZViewer(param1, param2, param3) {

       alert("Parameter1 : " + param1);

       alert("Parameter2 : " + param2);

       alert("Parameter3 : " + param3);

  }

</script>

</head>

<body>

<script src="http://java.com/js/deployJava.js"></script>

<script src="deployOZ.js"></script>

<script language="JavaScript">

  var viewerName = "OZViewer";

   var javaVersion = '1.6.0';

   var appletParameter = new Array (

       "id="+ viewerName,

       "width=100%",

       "height=100%",

       "codebase=oz/",

       "ozversion=70.2015.0529.100"

   );

   var viewerParameter = new Array (

       "connection.servlet=http://127.0.0.1:8080/oz/server",

       "connection.reportname=sample.ozr",

   );

   OZAppletViewerStart(appletParameter, viewerParameter, javaVersion);

</script>

</body>

</html>

Additional Information: OZUserEvent_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "viewerName"에서 설정한 값으로 지정해야 합니다.

...

function OZUserEvent_OZViewer(...

...

var viewerName = "OZViewer";

...


Example - Flash 뷰어

OZUserEvent Example - Flash 뷰어

아래 예제는 _TriggerOCXUserEvent 함수에서 전달한 패러미터 값을 OZUserEvent 이벤트를 이용하여 표시하는 예입니다.

<html>

<!--

Smart developers always View Source.

This application was built using Adobe Flex, an open source framework for building rich Internet applications that get delivered via the Flash Player or to desktops via Adobe AIR.

Learn more about Flex at http://flex.org//

-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=euc-kr">

<script src="AC_OETags.js" language="javascript"></script>

<script src="ozutil.js" language="javascript"></script>

<script src="ozjscript.js" language="javascript"></script>

<script language="JavaScript">

   function OZUserEvent_OZViewer(param1, param2, param3) {

       alert("Parameter1 : " + param1);

       alert("Parameter2 : " + param2);

       alert("Parameter3 : " + param3);

  }

</script>

<style>

body {margin: 0px; overflow:hidden}

</style>

<script language="JavaScript" type="text/javascript">

<!--

// Globals

// Major version of Flash required

var requiredMajorVersion = 10;

// Minor version of Flash required

var requiredMinorVersion = 0;

// Minor version of Flash required

var requiredRevision = 0;

// -->

</script>

</head>

<script language="JavaScript" type="text/javascript">

<!--

// Version check for the Flash Player that has the ability to start Player Product Install (6.0r65)

var hasProductInstall = DetectFlashVer(6, 0, 65);

// Version check based upon the values defined in globals

var hasRequestedVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);

if(hasProductInstall && !hasRequestedVersion) {

   // DO NOT MODIFY THE FOLLOWING FOUR LINES

   // Location visited after installation is complete if installation is required

   var MMPlayerType = (isIE == true) ? "ActiveX" : "PlugIn";

   var MMredirectURL = window.location;

   document.title = document.title.slice(0, 47) + " - Flash Player Installation";

   var MMdoctitle = document.title;

   AC_FL_RunContent(

       "src", "playerProductInstall",

       "FlashVars", "MMredirectURL="+MMredirectURL+'&MMplayerType='+MMPlayerType+'&MMdoctitle='+MMdoctitle+"",

       "width", "100%",

       "height", "100%",

       "id", "playerProductInstall",

       "quality", "high",

       "bgcolor", "#ffffff",

       "name", "playerProductInstall",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer"

   );

} else if(hasRequestedVersion) {

   // if we've detected an acceptable version

   // embed the Flash Content SWF when all tests are passed

   function SetOZParamters_OZViewer() {

       var oz;

       if(navigator.appName.indexOf("Microsoft") != -1){

           oz = window["OZViewer"];

       } else{

           oz = document["OZViewer"];

       }

       oz.sendToActionScript("connection.servlet", "http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname", "sample.ozr");

       return true;

   }

   AC_FL_RunContent(

       "src", "OZViewer10",

       "width", "100%",

       "height", "100%",

       "id", "OZViewer",

       "quality", "high",

       "bgcolor", "#ffffff",

      "name", "OZViewer",

       "allowScriptAccess", "sameDomain",

       "type", "application/x-shockwave-flash",

       "pluginspage", "http://www.adobe.com/go/getflashplayer",

       "flashVars", "flash.objectid=OZViewer"

   );

} else {// flash is too old or we can't detect the plugin

   var alternateContent = 'Alternate HTML content should be placed here. ' + 'This content requires the Adobe Flash Player. ' + '<a href=http://www.adobe.com/go/getflash/>Get Flash</a>';

   document.write(alternateContent);  // insert non-flash content

}

// -->

</script>

</body>

</html>

Additional Information: OZUserEvent_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 "name"에서 설정한 값으로 지정해야 합니다.

...

function OZUserEvent_OZViewer(...

...

"name", "OZViewer",

...


Example - WPF 뷰어

OZUserEvent Example - WPF 뷰어

아래 예제는 _TriggerOCXUserEvent 함수에서 전달한 패러미터 값을 OZUserEvent 이벤트를 이용하여 가져오는 예입니다.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Windows;

using System.Windows.Controls;

using System.Windows.Data;

using System.Windows.Documents;

using System.Windows.Input;

using System.Windows.Media;

using System.Windows.Media.Imaging;

using System.Windows.Navigation;

using System.Windows.Shapes;

using oz.api;

using System.Diagnostics;

namespace OZ_WPFEmbededSample

{

   /// <summary>

   /// Interaction logic for MainWindow.xaml

   /// </summary>

   public partial class MainWindow : Window

   {

       private OZReportViewer OZViewer = null;

       public MainWindow()

       {

           InitializeComponent();

           IDictionary<string, string> paramList = new Dictionary<string, string>();

           paramList.Add("connection.servlet", "http://127.0.0.1:8080/oz/server");

           paramList.Add("connection.reportname", "sample.ozr");

           try

           {

               EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

               OZViewer = OZReportAPI.getOZReport(paramList);

               OZViewer.init(handler);

               LayoutRoot.Children.Add(OZViewer.getPanel());

           }

           catch(Exception e)

           {

               Debug.WriteLine(e.Message);

           }

       }

       EventHandler<OZEmbededEvent> handler = (object sender2, OZEmbededEvent events)

       {

           Object[] param = events.getParams();

           switch (events.getEventType())

           {

               case OZEmbededEvent.OZEVENT_COMMAND:

                   String command = events.getCommand();

                   if("OZUserEvent".Equals(command))

                   {

                       //return values

                       //param[0] : param1

                       //param[1] : param2

                       //param[2] : param3

                   }

                   break;

           }

       }

   }

}


Example - HTML5 뷰어

OZUserEvent Example - HTML5 뷰어

아래 예제는 _TriggerOCXUserEvent 함수에서 전달한 패러미터 값을 OZUserEvent 이벤트를 이용하여 표시하는 예입니다.

<!DOCTYPE html>

<html style="height:100%">

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

<script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

<link rel="stylesheet" href="http://code.jquery.com/ui/1.9.2/themes/base/jquery-ui.css" type="text/css"/>

<script src="http://code.jquery.com/ui/1.9.2/jquery-ui.min.js"></script>

<link rel="stylesheet" href="http://127.0.0.1:8080/ozrviewer/ui.dynatree.css" type="text/css"/>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/jquery.dynatree.js" charset="utf-8"></script>

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSViewer.js" charset="utf-8"></script>

<!-- If you want to run the HTML5SVG viewer please change the OZJSViewer.js to OZJSSVGViewer.js.

<script type="text/javascript" src="http://127.0.0.1:8080/ozrviewer/OZJSSVGViewer.js" charset="utf-8"></script>

-->

<script language="JavaScript">

   function OZUserEvent_OZViewer(param1, param2, param3) {

       alert("Parameter1 : " + param1);

       alert("Parameter2 : " + param2);

       alert("Parameter3 : " + param3);

  }

</script>

</head>

<body style="width:98%;height:98%">

<div id="OZViewer" style="width:98%;height:98%"></div>

<script type="text/javascript" >

   function SetOZParamters_OZViewer(){

       var oz;

       oz = document.getElementById("OZViewer");

       oz.sendToActionScript("connection.servlet","http://127.0.0.1:8080/oz/server");

       oz.sendToActionScript("connection.reportname","sample.ozr");

       return true;

   }

   start_ozjs("OZViewer","http://127.0.0.1:8080/ozrviewer/");

</script>

</body>

</html>

Additional Information: OZUserEvent_OZViewer의 "OZViewer"는 오즈 뷰어 객체로 뷰어를 호출하는 HTML의 getElementById 함수에서 설정한 값으로 지정해야 합니다.

...

function OZUserEvent_OZViewer(...

...

oz = document.getElementById("OZViewer");

...


Example - Android 뷰어

OZUserEvent Example - Android 뷰어

Eclipse 프로젝트에 아래 스크립트를 입력합니다.

...

import oz.api.OZReportCommandListener;

...

@Override

public void onCreate(Bundle savedInstanceState)

{

   super.onCreate(savedInstanceState);

   ...

  OZReportCommandListener listener = new OZReportCommandListener()

   {

       ...

       @Override

       public String OZUserEvent(String param1, String param2, String param3)

       {

           // Input Script

       }

       ...

   };

  viewer = OZReportAPI.createViewer(flayout, listener, params);

}

...


Example - iOS 뷰어

OZUserEvent Example - iOS 뷰어

Xcode 프로젝트에 아래 스크립트를 입력합니다.

ViewController.h

#import <UIKit/UIKit.h>

#import "OZReportAPI.h"

@interface ViewController : UIViewController <OZReportCommandListener>

{

   IBOutlet UIView* _reportView;

}

...

ViewController.m

...

- (NSString*)OZUserEvent: (NSString*)param1 :(NSString*)param2 :(NSString*)param3

{

   // Input Script

}

...


Example - WinRT 뷰어

OZUserEvent Example - WinRT 뷰어

스크립트 입력 - C#

C# 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.cs

public void onCreateReport()

{

   try {

       if (_viewer != null) {

           _viewer.Dispose();

       }

       string param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\n";

      OZListener listener = new OZListener();

      _viewer = OZReportAPI.CreateViewer(Border, listener, param);

  }

   catch (Exception ex) {

       string s = ex.Message;

  }

}

C# 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.cs

using oz.api;

using Windows.UI.Xaml;

using Windows.UI.Xaml.Controls;

namespace OZSample

{

   public class OZListener : OZReportCommandListener

   {

       // Override

       public string OZUserEvent(string param1, string param2, string param3)

       {

           // Input Script

      }

  }

}

스크립트 입력 - C++/CX

C++/CX 프로젝트에 아래 스크립트를 입력합니다.

MainPage.xaml.h

private :

   OZReportViewer^ _viewer;

public :

   void onCreateReport();

MainPage.xaml.cpp

void OZWinRTViewerSample::onCreateReport()

{

   try {

       if (_viewer != nullptr) {

           _viewer = nullptr;

       }

       String^ param = "connection.servlet=http://127.0.0.1:8080/oz/server\nconnection.reportname=sample.ozr\n";

      OZListener^ listener = ref new OZListener();

      _viewer = OZReportAPI::CreateViewer(Border, listener, param);

  }

   catch (Exception^ ex) {

       String^ s = ex->Message;

  }

}

C++/CX 프로젝트에 아래 클래스를 추가하여 스크립트를 입력합니다.

OZListener.h

using namespace oz::api;

using namespace Windows::UI::Xaml;

using namespace Windows::UI::Xaml::Controls;

namespace OZWinRTViewerSample

{

   public ref class OZListener sealed: public OZReportCommandListener

   {

       // Override

       public :

           virtual String^ OZUserEvent(String^ param1, String^ param2, String^ param3)

           {

               // Input Script

          }

  };

}


뷰어 다이얼로그

본 장에서는 뷰어에서 제공하는 다이얼로그에 대해 설명합니다.


데이터 저장 다이얼로그

저장 형태 | 구분자를 설정합니다. 구분자 : 컬럼 구분자를 설정합니다. tab : tab space : space | : | / : / ~ : ~ comma : comma Other : 그 외 값 사용자 정의 : 기본적으로 제공하는 문자 외에 다른 문자를 구분자로 설정합니다. 들여쓰기 기능 사용 : 저장할 데이터 모듈이 마스터-디테일 관계로 설정된 경우 마스터 데이터와 디테일 데이터를 구분하기 위해 디테일 데이터를 들여쓰기하여 저장합니다.
저장 경로 | 저장 경로를 설정합니다. 저장 경로를 직접 입력하거나 [찾기] 버튼을 클릭하여 나타나는 다이얼로그를 이용하여 설정할 수 있습니다.
저장 방식 | 저장 방식을 설정합니다. 인코딩 : 인코딩 타입을 설정합니다. ANSI : ANSI 유니코드 : 유니코드

Additional Information: 데이터 저장 기능은 바인딩된 보고서의 데이터 트리에 추가된 모든 데이터를 텍스트 형식으로 저장하는 기능입니다. 만일, 미리보기 화면에 표시된 데이터와 데이터 트리에 추가된 데이터가 일치하지 않을 경우 화면에는 표시되지 않은 데이터가 저장될 수 있습니다. 데이터 저장 기능을 사용하도록 설정한 경우 데이터 트리에 ODI, CSV 등의 데이터 추가 시 해당 사항을 고려하여 보고서를 디자인하시기 바랍니다.


메일 전송 다이얼로그

받는 사람 | 받는 사람의 이메일 주소를 설정합니다.
제목 | 메일 제목을 설정합니다. 다이얼로그 실행 시 보고서 트리에 표시된 이름이 표시됩니다.
첨부 | 메일에 첨부할 첨부 파일의 위치가 표시됩니다. 첨부 파일은 저장 다이얼로그에서 파일 형식에 설정한 포맷으로 사용자 PC의 임시 폴더에 저당된 후 뷰어가 종료되면 자동으로 삭제됩니다.
내용 | 메일의 본문 내용을 입력합니다.


메일 설정 다이얼로그

SMTP 서버 정보 | SMTP 서버 정보를 설정합니다. 서버 주소 : 서버 주소를 설정합니다. 서버 포트번호 : 서버 포트 번호를 설정합니다.
보내는 사람 | 보내는 사람의 이메일 주소를 설정합니다.
보내는 메일 서버(SMTP) 인증 필요 | 보내는 메일 서버(SMTP)를 인증합니다. 사용자 이름 : 사용자 이름을 설정합니다. 암호 : 암호를 설정합니다.


보고서 새로 고침 다이얼로그

주기 | 보고서 새로 고침 주기를 설정합니다.
새로 고침 | 보고서를 바로 새로 고침합니다.
시작 | 보고서를 주기적으로 새로 고침합니다.
정지 | 보고서 새로 고침을 정지합니다.


인쇄 다이얼로그

프린터 | 프린터를 설정합니다. 이름 : 인쇄할 프린터 이름을 설정합니다. 파일로 인쇄 : 프린터로 인쇄하지 않고 파일로 인쇄합니다. 저장된 파일의 값을 프린터로 다음과 같이 보내면 동일한 인쇄 결과를 얻을 수 있습니다. ex) copy /b 파일명 LPT1:
용지 방향 | 용지 방향을 설정합니다. 세로 : 세로로 설정합니다. 가로 : 가로로 설정합니다.
다중 문서 | 다중 문서를 설정합니다. 모든 문서 인쇄 : 다중 보고서로 바인딩된 경우 현재 화면에 표시된 보고서뿐만 아니라 모든 보고서를 인쇄합니다.
인쇄 매수 | 인쇄 매수를 설정합니다. 매수 : 인쇄 매수를 설정합니다. 한 부씩 인쇄 : 여러 페이지의 보고서를 한 부씩 인쇄합니다. 즉, 지정한 인쇄 매수만큼 첫 페이지부터 끝 페이지까지 한부를 다 인쇄한 후 다시 처음부터 인쇄할 것인지, 한 페이지씩 인쇄할 것인지를 설정합니다. 한 부씩 스풀 사용 : 한 부씩 스풀을 사용합니다.
인쇄 범위 | 인쇄 범위를 설정합니다. 모두 : 모든 페이지를 인쇄합니다. 현재 페이지 : 현재 화면에 표시된 페이지만 인쇄합니다. 선택된 페이지 : 페이지 선택 창에서 선택된 페이지만 인쇄합니다. 페이지 지정 : 페이지 범위를 지정하여 인쇄합니다.
용지 설정 | 용지를 설정합니다. 디자인 용지 : 보고서 디자인 시 설정한 용지 크기를 표시합니다. 인쇄할 용지 : 인쇄할 용지를 설정합니다. [용지정보] 버튼을 클릭하여 선택한 용지의 정보를 확인할 수 있습니다. 다중 보고서를 하나의 보고서처럼 바인딩한 경우에는 By Report(보고서1용지크기,보고서2용지크기,...보고서n용지크기) 형식으로 표시되며, 용지 방향 옵션이 비활성화됩니다. ex) By Report(A4,A3) 용지에 맞춰 인쇄 : 용지에 맞춰 인쇄합니다. 인쇄할 용지와 디자인 용지를 다르게 설정했을 때 수직 또는 수평의 여백이 남을 경우 용지의 중앙에 맞추어 인쇄됩니다. 인쇄할 용지가 디자인 용지보다 작은 경우 축소하여 인쇄하지 않고 디자인된 크기 그대로 인쇄하려면 용지에 맞춰 인쇄를 체크 해지한 후 옵션 다이얼로그의 용지에 맞춰서 분할 인쇄를 체크하시기 바랍니다.


인쇄 옵션 다이얼로그

인쇄 방법 | 인쇄 방법을 설정합니다. 흑백 인쇄 : 흑백으로 인쇄합니다.
페이지 별 인쇄 | 여러 페이지가 한 페이지로 바인딩된 보고서를 각각의 페이지로 인쇄합니다.
양면 인쇄 | 양면 인쇄를 설정합니다. 값을 설정하지 않을 경우 프린터에 설정된 양면 인쇄 옵션 값을 따릅니다. 없음 : 양면 인쇄하지 않습니다. 긴 쪽으로 넘김 : 양면 인쇄하고 긴 쪽으로 넘겨 인쇄합니다. 짧은 쪽으로 넘김 : 양면 인쇄하고 짧은 쪽으로 넘겨 인쇄합니다.
출력 배율 | 출력 배율을 설정합니다. 확대/축소 비율 : 확대/축소 비율을 설정합니다.
스풀링 페이지 | 스풀링할 페이지 수를 설정합니다.
용지 선택 | 용지 선택을 설정합니다. 용지 공급 : 용지함을 설정합니다.
분할 인쇄 | 분할 인쇄를 설정합니다. 용지에 맞춰서 분할 인쇄 : 용지에 맞춰서 분할 인쇄합니다. 용지에 맞춰서 분할 인쇄는 인쇄 다이얼로그의 용지에 맞춰 인쇄가 체크 해지된 경우에만 사용할 수 있습니다.
모아찍기 | 모아찍기를 설정합니다. 한 페이지에 인쇄할 페이지 수 : 한 페이지에 인쇄할 페이지 수를 설정합니다. 인쇄 순서 : 한 페이지에 4페이지를 모아찍기할 경우 인쇄 순서를 설정합니다. 수평 : 수평으로 설정합니다. 수직 : 수직으로 설정합니다. 인쇄 방향 : 한 페이지에 2페이지 이상 모아찍기할 경우 인쇄 방향을 설정합니다. 세로 : 세로로 설정합니다. 가로 : 가로로 설정합니다.


저장 다이얼로그

파일 형식 | 파일 형식을 설정합니다. OZ Report Data File(*.ozd), Adobe PDF File(*.pdf), Microsoft Excel 97-2003 File(*.xls), Microsoft Excel File(*.xlsx), Microsoft Word Document(*.doc), Microsoft Presentation(*.ppt), Web Page(*.html), Comma Separated Values File(*.csv), Tab Separated(*.txt), JPEG Image(*.jpg), PNG Image(*.png), GIF Image(*.gif), TIFF Image(*.tif), Scalable Vector Graphics(*.svg), Hangul File(*.hwp), Hangul97 File(*.hml), Haansoft Nexel File(*.nxl), Web Page Save File(*.mht), Jungum Global File(*.gul)의 파일 형식을 지원합니다. gul 형식은 ActiveX 뷰어에서만 지원하며, nxl 포맷은 export.applyformat 패러미터 값에 nxl이 추가된 경우에만 표시됩니다.
출력 방향 | 출력 방향을 설정합니다. Disk File : 사용자 PC에 파일을 저장합니다. 메일 : 사용자 PC에 설치된 메일 프로그램으로 파일을 전송합니다. 오즈 메일 : 오즈 메일로 파일을 전송합니다.
저장 경로 | 저장 경로를 설정합니다. 저장 경로를 직접 입력하거나 [찾기] 버튼을 클릭하여 나타나는 다이얼로그를 이용하여 설정할 수 있습니다.
옵션 | 파일 형식별로 옵션을 설정합니다.


저장 기본 옵션 다이얼로그

저장 방식 | 보고서 저장 방식을 설정합니다. 한페이지로 저장 : 여러 페이지의 보고서를 한 페이지로 바인딩하여 저장합니다. 페이지별로 저장 : 여러 페이지의 보고서가 한 페이지로 바인딩된 경우 페이지별로 다시 바인딩하여 저장합니다.
실행 | 바로 실행 여부를 설정합니다. 저장 후 바로 실행 : 익스포트한 결과 파일을 연결된 프로그램으로 바로 실행합니다. 익스포트한 결과 파일과 연결할 프로그램이 없을 경우 에러 메시지가 발생합니다.
다중 문서 | 다중 문서 저장 옵션을 설정합니다. 한파일로 저장 : 여러 개의 보고서를 하나의 파일로 저장합니다. 한 파일로 저장 시 파일 형식별로 용지가 다르게 설정됩니다. "한 파일로 저장 시 파일 형식별 용지 설정 규칙"을 참고하시기 바랍니다. 모든 문서 저장 : 여러 개의 보고서를 각각의 파일로 저장합니다.
저장 영역 | 저장할 페이지 영역을 설정합니다. 전체 페이지 : 보고서의 모든 페이지를 저장합니다. 현재 페이지 : 현재 화면에 표시된 페이지만 저장합니다. 선택된 페이지 : 페이지 선택 창의 보고서 구조보기에서 선택한 페이지만 저장합니s다. 페이지 지정 : 페이지 범위를 지정하여 저장합니다.
컴포넌트 | 저장할 컴포넌트를 설정합니다. 차트와 바코드는 이미지로 저장됩니다.
링크정보 저장 | 링크 정보 저장 옵션을 설정합니다. 링크 정보 저장 옵션은 기본 옵션의 다른 옵션과 다르게 파일 형식별로 다른 값으로 설정할 수 있습니다. URL 링크 : URL 링크 정보를 포함하여 저장합니다. 목차 링크 : 목차 라벨 정보를 포함하여 저장합니다.
압축 저장 | 압축 저장 여부를 설정합니다. 암호를 입력하여 압축 파일을 암호로 보호할 수 있습니다.

Additional Information: 한 파일로 저장 시 파일 형식별 용지 설정 규칙은 아래와 같습니다.

·PDF : 각 페이지에 설정된 용지 그대로 적용됨

·XLS : mht 형식이 아닌 경우에는 첫 번째 시트에 맨 처음 저장된 페이지의 용지가 모든 시트에 적용되고, mht 형식인 경우에는 각각의 시트에 맨 처음 저장된 페이지의 용지가 각각의 시트에 적용됨

·XLSX : 첫 번째 페이지의 용지가 모든 페이지에 적용됨

·DOC : xml 형식이 아닌 경우에는 첫 번째 페이지의 용지가 모든 페이지에 적용되고, xml 형식인 경우에는 각 페이지에 설정된 용지 그대로 적용됨

·PPT, HWP, HML : 첫 번째 페이지의 용지가 모든 페이지에 적용됨

·그 외 형식 : 파일 특성 상 용지 정보가 없는 형식이므로 용지 설정 규칙과 무관함


정음 Global 저장 옵션 다이얼로그

테이블 저장 방식

테이블 저장 방식을 설정합니다.

테이블 형식으로 저장 : 테이블, 크로스탭, 고정 테이블을 정음 Global의 표로 저장합니다.


한글 저장 옵션 다이얼로그

테이블 저장 방식

테이블 저장 방식을 설정합니다.

테이블 형식으로 저장 : 테이블, 크로스탭, 고정 테이블을 한글의 표로 저장합니다.

라벨 저장 방식

라벨 저장 방식을 설정합니다.

라벨 크기 고정 : 한글로 저장된 라벨의 크기를 고정합니다. 라벨 크기 고정을 체크한 경우 한글의 [개체속성] > [기본] 탭의 크기 고정 옵션이 체크됩니다.

위치 저장 방식

위치 저장 방식을 설정합니다.

세로를 문단으로 설정 : 라벨이나 표의 위치 저장 방식을 세로를 문단으로 설정합니다. 세로를 문단으로 설정을 체크한 경우 한글의 [개체속성] > [기본] 탭의 위치 옵션 중 세로가 문단으로 설정됩니다. 세로를 문단으로 설정 옵션을 체크하면 표를 하나의 문단으로 인식합니다. 익스포트된 한글 파일을 열어 문단 부호를 표시한 후 <엔터>키를 입력하여 문단을 추가하면 표를 하나의 문단으로 인식하는 것을 확인할 수 있습니다.

밴드 저장 방식

밴드 저장 방식을 설정합니다.

백그라운드 밴드를 바탕쪽에 저장 : 백그라운드 밴드에 표시된 내용을 한글의 바탕쪽에 저장합니다. 페이지별로 백그라운드 밴드가 다르게 설정된 보고서를 저장할 경우 한글 바탕쪽의 기능 상 첫 번째 페이지에 설정한 백그라운드 밴드가 다음 페이지에도 반복되어 표시됩니다.

페이지 헤더/풋터 밴드를 머리말/꼬리말에 저장 : 보고서의 페이지 헤더/풋터 밴드를 한글의 머리말/꼬리말에 저장합니다. 페이지 번호를 표시하는 라벨이 페이지 헤더/풋터 밴드에 있는 보고서를 페이지 헤더/풋터 밴드를 머리말/꼬리말에 저장을 체크하고 특정 페이지만 저장할 경우 현재 페이지 번호는 무조건 1부터 설정되고, 전체 페이지 번호는 보고서의 전체 페이지 번호를 기준으로 설정됩니다.

보고서에서 페이지 헤더 또는 풋터 밴드를 생략하거나 스크립트로 특정 페이지의 페이지 번호를 생략할 경우 "페이지 헤더/풋터 밴드를 머리말/꼬리말에 저장" 옵션을 적용하여 한글 파일로 저장하면 한글의 기능 상 페이지 번호가 모든 페이지에 표시됩니다.

ex) 보고서에서 "2, 4, 5" 페이지의 페이지 번호가 표시되었을 경우 한글 파일로 저장하면 "1, 2, 3, 4, 5"로 모든 페이지에 쪽 번호가 표시됩니다.

"Page_Of_Total" 시스템 라벨을 한글의 쪽 번호로 저장될 경우 현재 페이지는 정상적으로 적용되나 전체 페이지 수는 보고서에 바인딩된 전체 페이지 수와 동일하게 표시됩니다.

ex) "3/3" 페이지의 한글 파일을 편집하여 페이지 수가 증가하였을 경우 "4/3"으로 전체 페이지는보고서와 동일하게 "3"으로 표시됩니다.


한글97 저장 옵션 다이얼로그

테이블 저장 방식

테이블 저장 방식을 설정합니다.

테이블 형식으로 저장 : 테이블, 크로스탭, 고정 테이블을 한글97의 표로 저장합니다.


CSV/Text 저장 옵션 다이얼로그

구분 | 구분자를 설정합니다. 구분자 : 컬럼 구분자를 설정합니다. tab : tab space : space | : | / : / ~ : ~ comma : comma empty : empty Other : 그 외 값 사용자 정의 : 기본적으로 제공하는 문자 외에 다른 문자를 구분자로 설정합니다. 구분자 옵션을 Other로 설정하여야 사용자 정의 옵션이 활성화됩니다.
페이지 구분 | 페이지 구분을 설정합니다. 구분형태 : 페이지 구분을 나타내는 텍스트를 설정합니다.(n : 페이지 번호) None : 페이지 구분자 없이 저장 n <PAGE> : n <PAGE> n <PAGE> --- : n <PAGE> --- --- n <PAGE> : --- n <PAGE> <PAGE> n : <PAGE> n <PAGE> n --- : <PAGE> n --- --- <PAGE> n : --- <PAGE> n <PAGE> : 페이지 구분형태에서 <PAGE>를 대체할 텍스트를 설정합니다.
페이지 간격 | 페이지 간격을 나타낼 줄 수를 설정합니다. 페이지 구분형태와 페이지 간격 줄 수를 모두 설정한 경우 페이지 구분형태를 먼저 표시하고 그 다음 줄에 지정한 줄 수 만큼의 빈 줄이 표시됩니다.
라인 제거 | 라인 제거를 설정합니다. 라인 제거 : 특정 라인을 제거하여 CSV로 저장하고, 제거할 라인 범위를 설정합니다. 첫 페이지 제외 : 보고서의 첫 페이지만 제외하고 라인을 제거합니다.
숫자문자 | 숫자문자를 설정합니다. 자릿수 구분기호 추가 : 숫자형 텍스트의 경우 1000 단위 구분 기호(,)를 추가합니다. 자릿수 구분기호 제거 : 숫자형 텍스트의 경우 1000 단위 구분 기호(,)를 제거합니다.
저장 방식 | 저장 방식을 설정합니다. 테이블 형식으로 저장 : 테이블, 크로스탭, 고정 테이블의 자식 라벨 중 병합된 라벨이 있을 경우 라벨을 분할하여 저장합니다. 분할된 라벨 중 맨 왼쪽 위에 있는 라벨에만 텍스트를 적용하여 저장하고, 나머지 라벨은 공백 문자로 저장됩니다. 인코딩 : 인코딩 타입을 설정합니다. ANSI : ANSI 유니코드 : 유니코드


Excel 저장 옵션 다이얼로그

자동 맞춤

자동 맞춤을 설정합니다.

자동 맞춤 : 페이지 배율을 자동 맞춤으로 설정합니다. 엑셀의 [페이지 설정] > [페이지] 탭의 "자동 맞춤"의 용지 너비와 높이 값 설정과 동일합니다. 엑셀에서 이 속성은 설정한 페이지 수에 맞게 문서 전체를 확대 또는 축소하여 출력하는 기능입니다.

너비 : 너비를 설정합니다.

높이 : 높이를 설정합니다.

창 옵션

창 옵션을 설정합니다.

눈금선 : 엑셀의 눈금선 표시 여부를 설정합니다.

텍스트 조정

텍스트 조정 옵션을 설정합니다.

셀에 맞춤 : 엑셀의 셀 서식 중 셀에 맞춤 여부를 설정합니다.

배율

배율을 설정합니다.

확대/축소 비율 : 엑셀 파일을 열 때 확대/축소 배율을 설정합니다.

틀 고정

틀 고정을 설정합니다.

행 : 틀 고정할 행 번호를 설정합니다.

열 : 틀 고정할 열 이름을 설정합니다.

저장 방식

저장 방식을 설정합니다.

폼 형태, 속성 유지 : 보고서 형태와 속성을 최대한 유지하면서 저장합니다.

색상, 외곽라인, 셀합치기 무시 : 라벨의 색, 테두리, 병합 상태 등을 무시하고, 단순 리스트 형태로 라벨의 텍스트만 저장합니다. 이때 페이지 사이 공백은 자동으로 제거되며, 병합된 크로스탭 피봇 또는 라벨이 모두 셀 분할되어 저장되므로 사용 시 주의바랍니다.

분할 후 주변 셀 제거 : 병합된 라벨을 분할한 후 주변 셀을 제거합니다. 예를 들어, 보고서에서는 하나의 라벨이 엑셀에서는 네 개의 셀로 분할된 경우 셀 위치를 기준으로 맨 왼쪽 위에 있는 한 개의 셀만 남기고 나머지 셀을 제거합니다. 셀이 제거된 후에는 제거된 셀의 오른쪽에 있는 텍스트가 제거된 셀 위치로 이동됩니다.

저장 형태

저장 형태를 설정합니다.

페이지 열별 시트 저장 : 같은 열에 있는 페이지를 같은 시트에 저장합니다.

페이지별 시트 저장 : 페이지별로 시트를 구분하여 저장합니다.

Column 우선 : 열 방향 우선으로 시트를 생성합니다.

Row 우선 : 행 방향 우선으로 시트를 생성합니다.

페이지

페이지를 설정합니다.

페이지 사이 공백 제거 : 페이지 사이의 공백을 제거합니다.

글꼴

글꼴과 글꼴 크기를 설정합니다.

글꼴 : 라벨의 글꼴을 일괄적으로 변경합니다. 글꼴을 설정한 경우 각 라벨에 설정된 글꼴을 무시하고, 콤보 박스에서 설정한 글꼴이 모든 라벨에 적용됩니다.

크기 : 라벨의 글꼴 크기를 일괄적으로 변경합니다. 글꼴 크기를 설정한 경우 각 라벨에 설정된 글꼴 크기를 무시하고, 콤보 박스에서 설정한 글꼴 크기가 모든 라벨에 적용됩니다.

라인

라인을 설정합니다.

라인 제거 : 특정 라인을 제거하여 엑셀로 저장하고, 제거할 라인 범위를 설정합니다. 제거할 라인 범위보다 적은 라인 수를 가진 페이지가 있을 경우 무한루프 현상이 발생할 수 있으니 옵션 설정시 주의하시기 바랍니다.

첫 페이지 제외 : 보고서의 첫 페이지만 제외하고 라인을 제거합니다.

첫 페이지만 : 보고서의 첫 페이지만 라인을 제거합니다.

모든 페이지 : 보고서의 모든 페이지 라인을 제거합니다.

서식

셀 서식을 설정합니다.

숫자형 텍스트를 숫자로 변환 : 숫자형 텍스트를 숫자로 변환하고, 변환되는 셀의 표시 형식을 설정합니다. 텍스트 박스에 입력한 표시 형식은 엑셀의 셀 표시 형식에 적용됩니다. 이때 셀 서식 중 범주는 엑셀 파일을 열기한 엑셀 프로그램이 인식하는 범주로 자동 선택됩니다. 예를 들어, #,###.00으로 설정한 경우 범주가 사용자 지정으로 선택될 수도 있고, 통화로도 선택될 수 있습니다. 숫자형 텍스트를 숫자로 변환을 체크하지 않고 저장한 엑셀을 열면 숫자 텍스트가 입력된 셀은 오류 검사 아이콘( [image] )이 표시됩니다.

표시 형식이 숫자인 라벨만 적용 : 보고서를 디자인할 때 설정한 라벨의 표시 형식이 숫자인 라벨만 숫자로 변환합니다. 보고서에 표시된 모든 숫자형 텍스트를 숫자로 변환하려면 표시 형식이 숫자인 라벨만 적용을 체크 해지하시기 바랍니다.

일반(셀표시 형식)으로 변환 : 셀 표시 형식을 일반으로 변환합니다.

셀 최소 크기

셀 최소 크기를 설정합니다.

너비 : 셀 최소 너비를 설정합니다. 엑셀로 저장된 셀의 너비가 설정한 값보다 작을 경우 오른쪽 셀에 병합됩니다. 저장 방식이 "폼 형태, 속성 유지"일 경우에만 적용되며 기본 값(1)보다 작은 값으로 설정할 경우 기본 값으로 적용됩니다.

높이 : 셀 최소 높이를 설정합니다. 엑셀로 저장된 셀의 높이가 설정한 값보다 작을 경우 아래쪽 셀에 병합됩니다. 저장 방식이 "폼 형태, 속성 유지"일 경우에만 적용되며 기본 값(1)보다 작은 값으로 설정할 경우 기본 값으로 적용됩니다.

저장 형식

저장 형식을 설정합니다. (해당 옵션은 파일 형식이 Microsoft Excel 97-2003 File(*.xls)일 때만 지원합니다.)

mht 형식으로 저장 : mht 형식의 엑셀로 저장합니다. mht 형식의 엑셀로 저장할 경우 저장된 파일을 Excel 2007 이상에서 열면 "파일 형식이 파일 이름 확장명에서 지정한 형식과 다르다"는 경고 메시지가 나타납니다. 이 경고 메시지는 Excel 2007에 추가된 사용자 알림 기능으로, 자세한 내용은 Microsoft 고객지원 홈 페이지(http://support.microsoft.com/kb/948615/ko)를 참고하시기 바랍니다.


GIF 저장 옵션 다이얼로그

저장 배율

저장 배율을 설정합니다.

확대/축소 비율 : GIF 이미지의 확대/축소 비율을 설정합니다.


HTML 저장 옵션 다이얼로그

글꼴 크기 설정 | 라벨의 글꼴 크기를 일괄적으로 설정합니다. 글꼴 크기 설정을 체크한 경우 각 라벨에 설정된 글꼴 크기를 무시하고, 콤보 박스에서 설정한 글꼴 크기가 모든 라벨에 적용됩니다.
이미지 경로 | 이미지 파일의 저장 위치를 설정합니다. 경로를 직접 입력하거나 [찾기] 버튼을 클릭하여 나타나는 다이얼로그를 이용하여 설정할 수 있습니다.
페이지 간격 | 페이지 간격을 설정합니다. 라인수 / 수평 : 하나의 파일로 저장될 때 각 페이지 사이의 수평 라인수를 설정합니다. 라인수 / 수직 : 하나의 파일로 저장될 때 각 페이지 사이의 수직 라인수를 설정합니다.
오프셋 | 오프셋을 설정합니다. 오프셋 / X축 : HTML 문서가 시작되는 X축 좌표를 설정합니다. 오프셋 / Y축 : HTML 문서가 시작되는 Y축 좌표를 설정합니다.
저장 방식 | 저장 방식을 설정합니다. 페이지별 저장 : 페이지별로 별도의 파일로 저장합니다. 페이지별 저장을 체크하지 않은 경우에는 하나의 파일로 저장합니다. 인코딩 : 인코딩 타입을 설정합니다. ANSI : ANSI 유니코드 : 유니코드 UTF-8 : UTF-8
페이지 | 페이지를 설정합니다. 제목 : 페이지 제목을 설정합니다.
버전 | 버전을 설정합니다. HTML 버전 : HTML의 버전을 설정합니다. 없음 : HTML 버전을 설정하지 않습니다. 버전을 설정하지 않을 경우 보고서가 왼쪽으로 정렬됩니다. 4.01 : HTML 버전을 4.01로 설정합니다. 4.01로 설정할 경우 보고서가 가운데로 정렬됩니다.
보호 | HTML 파일을 열 때 입력받을 암호를 입력합니다. 암호가 설정된 HTML 파일을 열면 암호를 입력받는 웹 페이지가 실행되고 암호가 일치한 경우에만 보고서가 표시됩니다. 단, HTML 파일 외에 이미지로 생성되는 파일은 암호화되지 않습니다. 암호를 입력받는 웹 페이지를 고객 환경에 맞게 변경하려면 고객용 템플릿 페이지를 디자인한 후 html.templatepath 패러미터 값에 템플릿 페이지 경로를 설정하시기 바랍니다.


JPG 저장 옵션 다이얼로그

저장 배율 | 저장 배율을 설정합니다. 확대/축소 비율 : JPG 이미지의 확대/축소 비율을 설정합니다.
압축 | 압축 품질을 설정합니다. 품질 : JPG 이미지의 압축 품질을 설정합니다. 큰 값으로 설정할수록 압축 품질이 높아지고 파일 크기가 커집니다.


MHT 저장 옵션 다이얼로그

글꼴 | 글꼴과 글꼴 크기를 설정합니다. 글꼴 : 라벨의 글꼴을 일괄적으로 변경합니다. 글꼴을 설정한 경우 각 라벨에 설정된 글꼴을 무시하고, 콤보 박스에서 설정한 글꼴이 모든 라벨에 적용됩니다. 크기 : 라벨의 글꼴 크기를 일괄적으로 변경합니다. 글꼴 크기를 설정한 경우 각 라벨에 설정된 글꼴 크기를 무시하고, 콤보 박스에서 설정한 글꼴 크기가 모든 라벨에 적용됩니다.
보호 | MHT 파일을 열 때 입력받을 암호를 입력합니다. 암호가 설정된 MHT 파일을 열면 암호를 입력받는 웹 페이지가 실행되고 암호가 일치한 경우에만 보고서가 표시됩니다. 단, MHT 파일에 저장된 보고서의 텍스트만 암호화되고, 이미지 데이터는 암호화되지 않습니다. 암호를 입력받는 웹 페이지를 고객 환경에 맞게 변경하려면 고객용 템플릿 페이지를 디자인한 후 mht.templatepath 패러미터 값에 템플릿 페이지 경로를 설정하시기 바랍니다.


OZD 저장 옵션 다이얼로그

암호 | OZD 파일의 암호를 설정합니다.
확인 | OZD 파일의 암호를 한번 더 확인합니다.
편집 내용 포함 | 미리보기 화면에서 추가한 메모, 주석, 콜아웃 도형(선, 화살표, 사각형, 원), 텍스트 편집 내용, 입력 컴포넌트 설정 값을 OZD 파일에 포함하여 저장합니다. 미리보기 화면에서 텍스트를 변경한 OZD를 오즈 뷰어에서 열기할 때 OnEndBind 이벤트가 실행되기 직전에 실행되는 모든 이벤트에서는 변경 전 텍스트가 라벨 및 노트에 적용되고, OnEndBind 이벤트부터 그 이후에 발생하는 모든 이벤트에서는 변경 후 텍스트가 라벨 및 노트에 적용됩니다. 그러므로, 텍스트를 이용하여 어떤 동작을 실행하도록 스크립트를 작성한 경우에는 주의하시기 바랍니다. 또한, OnEndBind 이벤트에서 SetText() 함수로 텍스트를 변경한 경우 미리보기 화면에서 변경한 텍스트가 아니라 SetText() 함수에서 설정한 텍스트로 적용됩니다.
모든 보고서 저장 | 현재 열린 모든 보고서를 하나의 OZD 파일로 저장합니다. 옵션을 체크하지 않으면 현재 보고서 창에 표시된 보고서만 저장됩니다.
이미지 포함 | 이미지 경로가 URL 형태(http://, ozp://, file://)로 설정된 경우 해당 이미지를 OZD 파일에 포함하여 저장합니다. 이미지 포함 옵션은 이미지뿐만 아니라 텍스트를 특정 URL(http://, ozp://, file://)을 통해 가져오도록 설정한 노트에도 적용됩니다.


PDF 저장 옵션 다이얼로그

문서정보

문서의 정보를 설정합니다.

제목 : 문서 제목을 설정합니다.

작성자 : 문서 작성자를 설정합니다.

주제 : 문서 주제를 설정합니다.

키워드 : 키워드를 설정합니다.

응용프로그램 : 응용 프로그램을 설정합니다.

열기 보호

파일을 열 때 사용할 비밀번호를 설정합니다.

편집 보호

파일의 권한 및 암호를 변경할 때 사용할 비밀번호를 설정합니다.

사용자 접근 권한

사용자 접근 권한을 설정합니다.

인쇄 허용 : 인쇄할 수 있도록 설정합니다. 인쇄 허용을 체크하지 않고 저장한 PDF 파일을 PDF Reader에서 열면 PDF 파일을 인쇄할 수 없도록 [인쇄] 메뉴와 아이콘이 비활성화됩니다.

내용 복사 : 내용을 복사할 수 있도록 설정합니다. 내용 복사를 체크하지 않고 저장한 PDF 파일을 PDF Reader에서 열면 PDF 파일의 내용을 복사할 수 없도록 [복사] 메뉴와 아이콘이 비활성화됩니다.

변경 허용 : 변경 허용 옵션을 설정합니다. 설정한 변경 허용 옵션은 PDF Reader의 문서 속성 다이얼로그 > 보안 옵션에서 확인할 수 있습니다.

차트를 이미지로 저장

차트를 이미지로 변환하여 저장합니다.

차트를 이미지로 변환하여 저장할 경우 PDF 파일 크기가 커지고, 차트에 표시된 텍스트가 차트 영역을 벗어나서 그려질 경우 차트 영역 외의 텍스트는 잘려서 익스포트됩니다.

차트를 이미지로 저장 옵션은 차트에 표시된 텍스트의 글꼴이나 방향이 뷰어에서 표시된 것과 다르게 익스포트될 경우에만 사용하시기를 권장합니다.

폰트 포함

보고서에 사용된 폰트를 포함하여 저장합니다.

TrueType 폰트이면서 폰트 파일 재작성에 대한 저작권 문제가 없는 폰트만 포함할 수 있습니다. 단, Android, iOS, WinRT 뷰어에서는 포함할 폰트를 모바일 앱에 함께 배포시켜야 폰트를 포함할 수 있습니다.

폰트 포함 시 PDF 파일 크기가 커질 수 있으므로, 보고서 개발 시 폰트 설정에 주의하시기 바랍니다.

PDF 파일에 포함된 폰트는 PDF Reader의 문서 속성 다이얼로그 > 글꼴 옵션에서 확인할 수 있으며 "OZ-영문폰트이름 (포함)" 형태로 표시됩니다. 예를 들어, 굴림의 경우 "OZ-Gulim (포함)"으로 표시됩니다.


PNG 저장 옵션 다이얼로그

저장 배율

저장 배율을 설정합니다.

확대/축소 비율 : PNG 이미지의 확대/축소 비율을 설정합니다.


PowerPoint 저장 옵션 다이얼로그

테이블 저장 방식

테이블 저장 방식을 설정합니다.

테이블 형식으로 저장 : 테이블, 크로스탭, 고정 테이블을 PowerPoint의 표로 저장합니다.


SVG 저장 옵션 다이얼로그

저장 방식

저장 방식을 설정합니다.

한 파일에 저장 : 보고서를 하나의 파일로 저장합니다. 한 파일에 저장을 체크하지 않으면 페이지별로 별도의 파일로 저장됩니다. 한 파일에 저장 옵션 체크 시 페이지를 구분할 수 있게 페이지별로 테두리를 표시하고, 위/아래 페이지 사이에 일정 간격이 추가됩니다. 또한, 가로 방향으로 확장되는 구조의 보고서를 한 파일에 저장할 경우 가로 방향은 무시되고, 세로 방향으로 나열되어 저장됩니다.


TIFF 저장 옵션 다이얼로그

인코딩 방식 | 인코딩 방식을 설정합니다. G3 : G3 방식으로 인코딩합니다. G4 : G4 방식으로 인코딩합니다. JPG : JPG 방식으로 인코딩합니다.
저장 방식 | 저장 방식을 설정합니다. 한 파일에 저장 : 보고서를 하나의 파일로 저장합니다. 한 파일에 저장을 체크하지 않으면 페이지별로 별도의 파일로 저장됩니다.
비율 | TIF 파일의 크기를 비율로 설정합니다. 확대/축소 비율 : TIF 파일의 확대/축소 비율을 설정합니다.
크기 | TIF 파일의 크기를 직접 설정합니다. 너비 : TIF 파일의 너비를 설정합니다. 높이 : TIF 파일의 높이를 설정합니다.
해상도에 따라 크기 결정 | TIF 파일의 크기를 해상도에 따라 결정합니다. 해상도 : 해상도를 설정합니다.


Word 저장 옵션 다이얼로그

Word 저장 방식 | Word 저장 방식을 설정합니다. XML 형식으로 저장 : XML 형식의 워드 문서로 저장합니다. 워드가 설치되지 않은 PC에서는 XML 형식으로 저장을 체크하여 워드 문서로 저장하시기 바랍니다.
테이블 저장 방식 | 테이블 저장 방식을 설정합니다. 테이블 형식으로 저장 : 테이블, 크로스탭, 고정 테이블을 워드의 표로 저장합니다. 테이블 형태로 저장하기 위해서는 "XML 형식으로 저장" 옵션을 체크하여야 하며, 테이블 형태로 저장할 경우 테이블, 크로스탭에 표시된 이미지는 저장되지 않습니다.
밴드 저장 방식 | 밴드 저장 방식을 설정합니다. 페이지 헤더/풋터 밴드를 머리글/바닥글에 저장 : 페이지 헤더/풋터 밴드에 표시된 내용을 워드의 머리글/바닥글로 저장합니다. 워드의 특성 상 페이지별로 머리글/바닥글을 다르게 설정할 수 없으므로, 익스포트되는 첫 번째 페이지의 페이지 헤더/풋터 밴드가 모든 페이지의 머리글/바닥글로 적용되어 익스포트됩니다. 즉, 익스포트되는 첫 페이지에 페이지 헤더/풋터 밴드가 없는 경우 다른 페이지에 페이지 헤더/풋터 밴드가 있어도 모든 페이지가 머리글/바닥글 없이 익스포트되며, 첫 페이지의 페이지 헤더/풋터 밴드와 다른 페이지의 페이지 헤더/풋터 밴드가 다를 경우 무조건 첫 번째 페이지의 헤더/풋터 밴드로 머리글/바닥글이 설정됩니다.


찾기 다이얼로그

찾을 내용 | 찾을 내용을 입력합니다.
단어 단위로 | 단어 단위로 검색합니다.
대/소문자 구분 | 대/소문자를 구분하여 검색합니다.
방향 | 검색할 방향을 설정합니다. 위로 : 위로 검색합니다. 아래로 : 아래로 검색합니다.


페이지 설정 다이얼로그

여백 | 여백을 설정합니다. 오른쪽, 아래쪽 여백을 설정하려면 자동 조정을 체크하시기 바랍니다.
사용 단위계 | 사용 단위계를 설정합니다. 단위 : 페이지 여백 설정 시 사용할 단위를 설정합니다. pt : 포인트 inch : 인치 cm : 센티미터
여백 옵션 | 여백 옵션을 설정합니다. 기본 여백 사용 : 보고서의 여백을 기본 값 즉, 보고서 디자인 시 설정한 값으로 여백을 변경합니다. 자동 조정 : 보고서의 여백을 자동으로 조정합니다. 자동 조정을 체크하고 여백을 변경하면 다른 방향의 여백이 자동으로 조절되고, 보고서가 자동으로 확대 또는 축소됩니다.


Reference

본 장에서는 뷰어 제약 사항, 뷰어 설치 및 실행 시 사용되는 언어 코드와 국가 코드, TimeZone 코드 등에 대해 설명합니다.


제약 사항

보고서 바인딩 및 인쇄, 익스포트 시 아래와 같은 제약 사항이 있습니다.

아래 제약 사항은 ActiveX, Applet, Flash, WPF, HTML5JS, HTML5SVG, Android, iOS, WinRT 뷰어에 대한 공통 제약 사항이며, 각 뷰어 타입별 제약 사항은 각각의 제약 사항을 참고하시기 바랍니다.

아래 명시된 내용 외에 제약 사항은 뷰어 패러미터 설명 부분의 Available Viewers를 참고하시기 바랍니다.

글꼴 제약 사항

·글꼴이 미리보기와 다르게 익스포트될 수 있습니다.

·ClearType이 지원되는 폰트일 경우 디스플레이 등록 정보의 옵션 값과 상관없이 무조건 ClearType으로 표시됩니다.

익스포트 포맷별 제약 사항

[PDF 포맷]

·표 바탕색이 미리보기와 다르게 익스포트될 수 있습니다.

[XLS 포맷]

·단락의 들여쓰기는 무조건 0으로 적용됩니다.

·텍스트의 장평은 무조건 100으로 적용됩니다.

·밑줄, 취소선, 이중 취소선은 익스포트되지 않습니다.

·HTML 라벨의 첨자는 일반 텍스트로 익스포트됩니다.

·둥근 테두리는 직선 테두리로 익스포트됩니다.

·둥근 점선은 XLS 형식에서 지원하는 둥근 점선으로 익스포트됩니다.

·미리보기된 것과 달리 줄 바뀜 현상이 발생할 수 있습니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

·글꼴색과 셀 바탕색이 미리보기된 것과 약간 다르게 익스포트될 수 있습니다. 엑셀은 글꼴색과 셀 바탕색을 40가지 기본색만 사용할 수 있는데 리포트 뷰어에서 RGB값을 이용하여 설정한 색이 엑셀의 40가지 색에 없을 경우 수치상 가장 근사한 색으로 설정되기 때문입니다. 따라서 색상이 100% 일치하지 않을 수 있으며 엑셀 자체의 사용 가능 색상 수에 대한 제약이 있음을 인지하여 보고서 디자인 시 사용할 색상을 미리 선정하시기 바랍니다.

[XLSX 포맷]

·단락의 들여쓰기는 무조건 0으로 적용됩니다.

·텍스트의 장평은 무조건 100으로 적용됩니다.

·밑줄, 취소선, 이중 취소선은 익스포트되지 않습니다.

·HTML 라벨의 첨자는 일반 텍스트로 익스포트됩니다.

·둥근 테두리는 직선 테두리로 익스포트됩니다.

·둥근 점선은 XLSX 형식에서 지원하는 둥근 점선으로 익스포트됩니다.

·미리보기된 것과 달리 줄 바뀜 현상이 발생할 수 있습니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

[DOC 포맷]

·ActiveX 외의 뷰어는 XML 형식 DOC로 익스포트됩니다.

·일반 방식 DOC인 경우 단락의 들여쓰기는 무조건 0으로 적용됩니다.

·보고서의 라벨이 워드 글 상자로 익스포트됩니다.

·밑줄, 취소선, 이중 취소선은 XML 형식으로 저장한 경우에만 지원되며, 선 색은 글꼴 색으로 익스포트됩니다.(일반 방식 DOC는 밑줄만 지원됩니다.)

·둥근 테두리는 직선 테두리로 익스포트됩니다.

·둥근 점선은 DOC 형식에서 지원하는 둥근 점선으로 익스포트됩니다.

·미리보기된 것과 달리 줄 바뀜 현상이 발생할 수 있습니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

·라벨의 투명도 속성은 지원되지 않습니다.

·가로 쓰기이면서 수평 정렬이 양쪽 맞춤인 경우와 세로 쓰기이면서 수직 정렬이 양쪽 맞춤인 경우에만 양쪽 맞춤이 적용됩니다. 그 외 경우에는 쓰기 방향에 따라 정렬 방식이 결정됩니다. 즉, 쓰기 방향이 오른쪽인 경우 왼쪽 정렬, 왼쪽인 경우 오른쪽 정렬, 위쪽인 경우 아래쪽 정렬, 아래쪽인 경우 위쪽 정렬로 바뀌어 익스포트됩니다.

·테이블 형식으로 저장할 때에는 저장된 DOC 파일의 페이지 위/아래로 최소 2라인의 빈 줄이 확보되어야 테이블 레이아웃이 유지됩니다.

[PPT 포맷]

·단락의 들여쓰기는 무조건 0으로 적용됩니다.

·텍스트의 장평은 무조건 100으로 적용됩니다.

·밑줄의 선 색은 글꼴 색으로 익스포트되고, 취소선, 이중 취소선은 익스포트되지 않습니다.

·둥근 테두리는 직선 테두리로 익스포트됩니다.

·둥근 점선은 PPT 형식에서 지원하는 둥근 점선으로 익스포트됩니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

·간트 차트의 Bar 아래 있는 라벨의 크기가 미리보기된 것보다 작게 익스포트됩니다.

·이미지 라벨 또는 차트 등 이미지로 저장되는 컴포넌트의 "투명" 속성 값이 "예"인 경우 바탕색과 동일한 색을 투명하게 설정하여 투명한 이미지로 저장되므로 바탕색 설정 시 주의하시기 바랍니다.

·가로 쓰기이면서 수평 정렬이 양쪽 맞춤인 경우와 세로 쓰기이면서 수직 정렬이 양쪽 맞춤인 경우에만 양쪽 맞춤이 적용됩니다. 그 외 경우에는 쓰기 방향에 따라 정렬 방식이 결정됩니다. 즉, 쓰기 방향이 오른쪽인 경우 왼쪽 정렬, 왼쪽인 경우 오른쪽 정렬, 위쪽인 경우 아래쪽 정렬, 아래쪽인 경우 위쪽 정렬로 바뀌어 익스포트됩니다.

[HTML 포맷]

·단락의 들여쓰기는 텍스트 방향이 HORIZONTAL, HORIZONTAL_2BYTE인 경우에만 적용되고, 그 외 경우에는 0으로 적용됩니다.

·텍스트의 장평은 무조건 100으로 적용됩니다.

·밑줄, 취소선, 이중 취소선은 익스포트되지 않습니다.

·동일한 위치의 둥근 테두리 값이 서로 다를 경우 작은 값으로 둥근 테두리가 적용되어 익스포트됩니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

·화살표는 조금 잘린 형태로 익스포트됩니다.

·텍스트의 수평/수직 정렬이 양쪽 맞춤으로 설정된 경우 쓰기 방향에 따라 정렬 방식이 결정됩니다. 즉, 쓰기 방향이 오른쪽인 경우 왼쪽 정렬, 왼쪽인 경우 오른쪽 정렬, 위쪽인 경우 아래쪽 정렬, 아래쪽인 경우 위쪽 정렬로 익스포트됩니다.

[HWP 포맷]

·밑줄의 선 색은 검정 색으로 익스포트되고, 취소선, 이중 취소선은 익스포트되지 않습니다.

·둥근 점선은 HWP 형식에서 지원하는 둥근 점선으로 익스포트됩니다.

·둥근 테두리는 직선 테두리로 익스포트됩니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

·텍스트의 장평은 50부터 200 사이의 값만 적용되며, 50보다 작은 값은 50으로 200보다 큰 값은 200으로 적용됩니다.

·가로 쓰기이면서 수평 정렬이 양쪽 맞춤인 경우와 세로 쓰기이면서 수직 정렬이 양쪽 맞춤인 경우에만 양쪽 맞춤이 적용됩니다. 그 외 경우에는 쓰기 방향에 따라 정렬 방식이 결정됩니다. 즉, 쓰기 방향이 오른쪽인 경우 왼쪽 정렬, 왼쪽인 경우 오른쪽 정렬, 위쪽인 경우 아래쪽 정렬, 아래쪽인 경우 위쪽 정렬로 바뀌어 익스포트됩니다.

[HML 포맷]

·단락의 들여쓰기는 무조건 0으로 적용됩니다.

·밑줄의 선 색은 검정 색으로 익스포트되고, 취소선, 이중 취소선은 익스포트되지 않습니다.

·둥근 테두리는 직선 테두리로 익스포트됩니다.

·둥근 점선은 무시되고, HML에서 표현할 수 있는 사각 점선으로 익스포트됩니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

·텍스트의 장평은 50부터 200 사이의 값만 적용되며, 50보다 작은 값은 50으로 200보다 큰 값은 200으로 적용됩니다.

[MHT 포맷]

·단락의 들여쓰기는 텍스트 방향이 HORIZONTAL, HORIZONTAL_2BYTE인 경우에만 적용되고, 그 외 경우에는 0으로 적용됩니다.

·텍스트의 장평은 무조건 100으로 적용됩니다.

·밑줄, 취소선, 이중 취소선은 익스포트되지 않습니다.

·둥근 테두리는 직선 테두리로 익스포트됩니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

·텍스트의 수평/수직 정렬이 양쪽 맞춤으로 설정된 경우 쓰기 방향에 따라 정렬 방식이 결정됩니다. 즉, 쓰기 방향이 오른쪽인 경우 왼쪽 정렬, 왼쪽인 경우 오른쪽 정렬, 위쪽인 경우 아래쪽 정렬, 아래쪽인 경우 위쪽 정렬로 익스포트됩니다.

[GUL 포맷]

·단락의 들여쓰기는 무조건 0으로 적용됩니다.

·HTML 라벨의 첨자는 일반 텍스트로 익스포트됩니다.

·밑줄, 취소선, 이중 취소선의 선 색은 글꼴 색으로 익스포트됩니다.

·둥근 테두리는 직선 테두리로 익스포트됩니다.

·둥근 점선은 무시되고, GUL에서 표현할 수 있는 사각 점선으로 익스포트됩니다.

·텍스트 회전을 지원하지 않습니다.

·텍스트 방향 중 HORIZONTAL을 제외한 방향은 미리보기와 다르게 익스포트될 수 있습니다.

·텍스트의 장평은 25부터 250 사이의 값만 적용되며, 25보다 작은 값은 25로 250보다 큰 값은 250으로 적용됩니다.

·라벨의 수직 정렬 속성 중 균등 분할, 양쪽 맞춤은 중간으로 설정되며, 투명도 속성은 지원되지 않습니다.

·라벨의 오른쪽, 위쪽, 아래쪽 테두리는 왼쪽 테두리에서 설정한 값으로 익스포트됩니다.

·화살표의 화살표 크기는 기본 크기로 익스포트되며, 화살표 모양 중 마름모, 반원, 열린 삼각형은 삼각형으로 익스포트됩니다.

·테이블 형식으로 저장 옵션을 체크한 경우 크로스탭, 테이블, 고정 테이블의 자식 라벨이 미리보기와 다르게 익스포트됩니다.

1.자식 라벨 중 HTML 라벨은 텍스트만 익스포트됩니다.

2.자식 라벨 속성은 가로 정렬, 세로 정렬, 글꼴, 글꼴 색, hollow 효과, shadow 효과, 줄 간격, 테두리 없음, 왼쪽/위쪽/오른쪽/아래쪽 선 두께와 테두리 색만 유지됩니다.

3.자식 라벨의 왼쪽과 오른쪽 내부 여백은 1.1mm로, 위쪽과 아래쪽 내부 여백은 0으로 설정됩니다.

4.자식 라벨의 테두리는 다음과 같이 익스포트됩니다.

§이중선으로 설정되는 테두리 두께 값은 "1 1 1", "1 1 2", "1 1 3", "2 1 1", "3 1 1"입니다. 단, 점선은 무시되고 실선 형태의 이중선으로 익스포트됩니다.

§삼중선으로 설정되는 테두리 두께 값은 "1 1 1 1 1", "1 1 2 1 1"입니다. 단, 점선은 무시되고 실선 형태의 삼중선으로 익스포트됩니다.

§점선으로 익스포트하려면 테두리를 단일선으로 설정하고, 점선 값을 "1 1", "2 1", "2 2", "3 1", "4 1 2 1", "4 2 1 2 1 2", "4 1 1 1 1 1" 중 하나로 설정하여야 합니다.

§그 외에는 무조건 실선 형태의 단일선으로 저장됩니다.

5.위/아래/왼쪽/오른쪽 라벨의 테두리가 겹칠 경우 오른쪽과 아래쪽 라벨의 테두리 설정 값으로 변경됩니다.

입력 컴포넌트 제약 사항

·텍스트 박스의 텍스트 수평 정렬 방식 중 균등 분할은 미리보기 시에는 적용되지 않습니다.

·사용자가 수정한 입력 컴포넌트 값은 OZD 파일로 익스포트 시 적용되지 않습니다.

·입력 컴포넌트로 마우스 커서를 위치시키거나 클릭한 경우 해당 뷰어에서 지원하는 입력 컴포넌트 모양으로 표시합니다. 그러므로, 입력 컴포넌트 모양 및 조작 방법이 뷰어마다 다릅니다.

·입력 컴포넌트의 Enable 속성 값이 "아니오"인 경우 미리보기 창에서만 비활성화 상태로 표시되고, 페이지 축소판 창 및 Android, iOS, WinRT 뷰어의 멀티 보고서 가로 페이징 보기 창(enable_paging_all)에서는 활성화 상태로 표시됩니다. 또한 인쇄 및 익스포트 시에도 활성화 상태의 모양으로 인쇄 및 익스포트됩니다.

·고정 테이블 입력 컴포넌트를 테이블 형식의 DOC, PPT, HWP, HML, GUL 포맷으로 익스포트 시 다음과 같은 규칙으로 익스포트됩니다.

1.고정 테이블 텍스트 박스, 고정 테이블 녹음, 고정 테이블 버튼 : 표의 셀로 추가됩니다.

2.고정 테이블 체크 박스, 고정 테이블 라디오 버튼 : 텍스트 상자(글 상자) 형태로 표 위에 추가됩니다.

3.고정 테이블 콤보 박스, 고정 테이블 NumericUpDown, 고정 테이블 DateTimePicker : eform.functionbutton_display_type이 alwaysshow인 경우 텍스트 상자(글 상자) 형태로 표 위에 추가되고, 그 외 경우 표의 셀로 추가됩니다.

4.고정 테이블 ImagePicker : 이미지를 선택하지 않은 경우 표의 셀로 추가됩니다. 이미지를 선택한 경우 DOC, PPT, HML, GUL 포맷은 이미지 형태로 표 위에 추가되고, HWP 포맷은 표의 셀로 추가됩니다.

5.고정 테이블 서명 : 서명을 하지 않은 경우 표의 셀로 추가됩니다. 서명한 경우 DOC, PPT, HML, GUL 포맷은 이미지 형태로 표 위에 추가되고, HWP 포맷은 표의 셀로 추가됩니다.


ActiveX 뷰어

제약 사항 - ActiveX 뷰어

Additional Information: 아래 제약 사항은 ActiveX 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다.

익스포트 포맷별 제약 사항

[DOC 포맷]

·"XML 형식으로 저장" 옵션을 체크하지 않은 경우 사용자 PC에 설치된 Microsoft Word와 연동하여 저장하므로, 다른 포맷에 비해 저장 속도가 느립니다.


Applet 뷰어

제약 사항 - Applet 뷰어

Additional Information: 아래 제약 사항은 Applet 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다.

환경 제약 사항

·JRE 1.6 이상에서 Applet 뷰어를 웹 브라우저에 임베디드된 형태로 실행한 경우 메모리를 100M 이상 사용할 수 없습니다.


Flash 뷰어

제약 사항 - Flash 뷰어

Additional Information: 아래 제약 사항은 Flash 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다. 또한, Flash 뷰어는 Adobe Flash Player에 종속되어 실행되므로, 아래 나열된 제약 사항 외에 Adobe Flash Player의 제약으로 인한 제약 사항이 더 있을 수 있습니다.

기능 제약 사항

·Adobe Flash Player에 종속되어 실행됩니다.

·웹 브라우저와 별도의 창으로 실행되는 독립 구동형 뷰어는 지원하지 않습니다.

·서블릿 형태의 오즈 서버만 연동됩니다.

·메일 전송 기능과 다이렉트 저장/인쇄 기능을 지원하지 않습니다.

·Flash 뷰어에서 실행된 다이얼로그는 뷰어 영역 내에서만 표시됩니다.

·바인딩/저장 시간이 60초 이상 소요되는 보고서는 바인딩/저장할 수 없습니다.

·보고서의 모든 페이지가 바인딩된 후 한꺼번에 화면에 표시됩니다.

·저장/인쇄할 경우 Flash 뷰어의 저장/인쇄 다이얼로그가 실행된 후 Adobe Flash Player에서 제공하는 별도의 저장/인쇄 다이얼로그가 실행됩니다.

·페이지마다 별도의 파일로 익스포트되는 이미지 포맷(JPG, PNG, GIF 등)으로 저장한 경우 ZIP 파일로 압축하여 저장됩니다.

·HTML 라벨 편집 시 HTML 라벨 편집기가 실행되지 않고, 텍스트 편집기가 실행됩니다.

·링크 함수 중 SetLinkExecute/setLinkExecute 함수는 동작하지 않습니다.

·"file://" 경로로 설정한 이미지, 텍스트 등을 표시할 수 없습니다.

·이미지, 텍스트 등의 경로를 "ozp://" 형태로 설정하여 사용하려면 오즈 서버의 repository.properties 파일의 REPOSITORY_ACCESS_BY_HTTP_GET 속성 값을 true로 설정하여야 합니다.

환경 제약 사항

·Flash 뷰어는 크로스 도메인을 지원하지 않습니다.

·웹 브라우저가 설치된 운영 체제 종류에 따라 글꼴이 다르게 표시됩니다.

·이미지는 PNG, GIF, JPG 형식만 지원합니다.

·이미지 형태로 익스포트되는 컴포넌트가 있는 보고서를 HTML 형식으로 저장할 때 뷰어를 실행한 웹 브라우저가 Internet Explorer인 경우 HTML 파일과 이미지 파일이 하나의 ZIP 파일로 압축하여 저장되고, 그 외 웹 브라우저에서는 이미지가 포함된 하나의 HTML 파일로 저장됩니다.


WPF 뷰어

제약 사항 - WPF 뷰어

Additional Information: 아래 제약 사항은 WPF 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다.

기능 제약 사항

·웹 브라우저와 연동되지 않습니다.

·웹 브라우저와 연동하는 모든 기능(이벤트 호출, 링크 기능 등)을 지원하지 않습니다.

·HTML 라벨 편집 시 HTML 라벨 편집기가 실행되지 않고, 텍스트 편집기가 실행됩니다.


HTML5JS 뷰어

제약 사항 - HTML5JS 뷰어

Additional Information: 아래 제약 사항은 HTML5JS 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다. 또한, HTML5JS 뷰어는 HTML5 포맷에 종속되어 실행되므로, 아래 나열된 제약 사항 외에 HTML5 포맷의 제약으로 인한 제약 사항이 더 있을 수 있습니다.

기능 제약 사항

·웹 브라우저와 별도의 창으로 실행되는 독립 구동형 뷰어는 지원하지 않습니다.

·서블릿 형태의 오즈 서버만 연동됩니다.

·메일 전송 기능과 다이렉트 저장/인쇄 기능을 지원하지 않습니다.

·HTML5JS 뷰어는 사용자 조작(바인딩/저장/클릭 등)에 대한 반응 속도가 다른 뷰어보다 느립니다.

·보고서의 모든 페이지가 바인딩된 후 한꺼번에 화면에 표시됩니다.

·페이지마다 별도의 파일로 익스포트되는 이미지 포맷(JPG, PNG, GIF 등)으로 저장한 경우 ZIP 파일로 압축하여 저장됩니다.

·HTML 라벨 편집 시 HTML 라벨 편집기가 실행되지 않고, 텍스트 편집기가 실행됩니다.

·링크 함수 중 SetLinkExecute/setLinkExecute 함수는 동작하지 않습니다.

·"file://" 경로로 설정한 이미지, 텍스트 등을 표시할 수 없습니다.

·이미지, 텍스트 등의 경로를 "ozp://" 형태로 설정하여 사용하려면 오즈 서버의 repository.properties 파일의 REPOSITORY_ACCESS_BY_HTTP_GET 속성 값을 true로 설정하여야 합니다.

환경 제약 사항

·HTML5JS 뷰어는 크로스 도메인을 지원하지 않습니다.

·웹 브라우저가 설치된 운영 체제 종류에 따라 글꼴이 다르게 표시됩니다.

·이미지는 HTML5JS 뷰어를 실행한 웹 브라우저에서 지원하는 형식만 지원합니다.

·손 모드일 때 뷰어를 실행한 웹 브라우저가 Internet Explorer인 경우 마우스 포인터가 십자 화살표 모양으로 표시됩니다.

·HTML5JS 뷰어를 실행한 웹 브라우저에서 인쇄 모듈을 로딩할 수 없을 경우 PDF 파일로 익스포트되어 인쇄됩니다. 단, PDF 파일 인쇄 방식은 HTML5JS 뷰어를 실행한 웹 브라우저에 따라 다를 수 있습니다.


HTML5SVG 뷰어

제약 사항 - HTML5SVG 뷰어

Additional Information: 아래 제약 사항은 HTML5SVG 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다.

기능 제약 사항

·HTML5SVG 뷰어는 e-Form 기능을 지원하지 않습니다.

·웹 브라우저와 별도의 창으로 실행되는 독립 구동형 뷰어는 지원하지 않습니다.

·서블릿 형태의 오즈 서버만 연동됩니다.

·보고서 열기/닫기, 메모 추가, 찾기, 새로고침, 메일 전송, 다이렉트 저장/인쇄, 링크 기능을 지원하지 않습니다.

·OnPreDraw, OnPostDraw, OnPostChartBuild 이벤트를 지원하지 않습니다.

·페이지마다 별도의 파일로 익스포트되는 이미지 포맷(JPG, PNG, GIF 등)으로 저장한 경우 ZIP 파일로 압축하여 저장됩니다.

환경 제약 사항

·HTML5SVG 뷰어와 연동된 스케줄러가 구동 중인 운영 체제 종류에 따라 글꼴이 다르게 표시됩니다.

·보고서를 인쇄할 경우 PDF 파일로 익스포트된 후 인쇄됩니다. 단, PDF 파일 인쇄 방식은 HTML5SVG 뷰어를 실행한 웹 브라우저에 따라 다를 수 있습니다.


Android 뷰어

제약 사항 - Android 뷰어

Additional Information: 아래 제약 사항은 Android 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다.

기능 제약 사항

·별도의 창으로 실행되는 독립 구동형 뷰어는 지원하지 않습니다.

·Android 웹 브라우저에서 실행한 경우에는 뷰어 함수와 뷰어 이벤트를 지원하지 않습니다.

·폰트가 다르게 저장될 수 있습니다. 윈도우 환경에서 보고서를 디자인할 때에는 여러 가지의 폰트를 사용할 수 있으나 Android 장비마다 지원하는 폰트가 다르므로, 미리보기된 것과 다른 폰트로 저장될 수 있습니다.(폰트 포함 기능을 사용하거나 Android 장비에서 지원하는 폰트로 보고서를 디자인하시기 바랍니다.)


iOS 뷰어

제약 사항 - iOS 뷰어

Additional Information: 아래 제약 사항은 iOS 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다.

기능 제약 사항

·별도의 창으로 실행되는 독립 구동형 뷰어는 지원하지 않습니다.

·iOS 웹 브라우저에서 실행한 경우에는 뷰어 함수와 뷰어 이벤트를 지원하지 않습니다.

·폰트가 다르게 저장될 수 있습니다. 윈도우 환경에서 보고서를 디자인할 때에는 여러 가지의 폰트를 사용할 수 있으나 iOS 장비마다 지원하는 폰트가 다르므로, 미리보기된 것과 다른 폰트로 저장될 수 있습니다.(폰트 포함 기능을 사용하거나 iOS 장비에서 지원하는 폰트로 보고서를 디자인하시기 바랍니다.)

익스포트 포맷별 제약 사항

[PDF 포맷]

·iOS에 내장된 PDF Reader로 PDF 파일을 읽을 경우 영어 글꼴로 설정된 일부 텍스트가 다른 텍스트로 표시될 수 있습니다. Adobe사의 Reader를 사용하도록 가이드 바랍니다


WinRT 뷰어

제약 사항 - WinRT 뷰어

Additional Information: 아래 제약 사항은 WinRT 뷰어에만 해당되는 제약 사항이며, 그 외 제약 사항은 공통 제약 사항과 패러미터, 함수, 이벤트의 Available Viewers를 참고하시기 바랍니다.

기능 제약 사항

·별도의 창으로 실행되는 독립 구동형 뷰어는 지원하지 않습니다.

·인쇄 기능을 지원하지 않습니다.

·WinRT 웹 브라우저에서 실행한 경우에는 뷰어 함수와 뷰어 이벤트를 지원하지 않습니다.

·저장 다이얼로그의 파일 경로를 사용자가 임의로 입력할 수 없습니다. 찾기로 사용자가 직접 저장할 경로를 지정하여야 합니다.

·폰트가 다르게 저장될 수 있습니다. 윈도우 환경에서 보고서를 디자인할 때에는 여러 가지의 폰트를 사용할 수 있으나 WinRT 장비마다 지원하는 폰트가 다르므로, 미리보기된 것과 다른 폰트로 저장될 수 있습니다.(폰트 포함 기능을 사용하거나 WinRT 장비에서 지원하는 폰트로 보고서를 디자인하시기 바랍니다.)


언어 코드와 국가 코드

오즈 뷰어 설치 또는 실행 시에 발생하는 에러 메시지를 작성해 놓은 파일명에 사용되는 언어 코드와 국가 코드는 아래 표와 같습니다.

언어 코드와 국가 코드는 ISO 표준 규격을 따릅니다.

언어 코드_국가 코드 | Display Name | ISO 639x Value
af_AZ | Afrikaans - South Africa | AFK
sq_AL | Albanian - Albania | SQI
ar_DZ | Arabic - Algeria | ARG
ar_BH | Arabic - Bahrain | ARH
ar_EG | Arabic - Egypt | ARE
ar_IQ | Arabic - Iraq | ARI
ar_JO | Arabic - Jordan | ARJ
ar_KW | Arabic - Kuwait | ARK
ar_LB | Arabic - Lebanon | ARB
ar_LY | Arabic - Libya | ARL
ar_MA | Arabic - Morocco | ARM
ar_OM | Arabic - Oman | ARO
ar_QA | Arabic - Qatar | ARQ
ar_SA | Arabic - Saudi Arabia | ARA
ar_SY | Arabic - Syria | ARS
ar_TN | Arabic - Tunisia | ART
ar_AE | Arabic - United Arab Emirates | ARU
ar_YE | Arabic - Yemen | ARY
hy_AM | Armenian - Armenia |
eu_ES | Basque - Basque | EUQ
be_BY | Belarusian - Belarus | BEL
bg_BG | Bulgarian - Bulgaria | BGR
ca_ES | Catalan - Catalan | CAT
zh_CN | Chinese - China | CHS
zh_HK | Chinese - Hong Kong SAR | ZHH
zh_MO | Chinese - Macau SAR |
zh_SG | Chinese - Singapore | ZHI
zh_TW | Chinese - Taiwan | CHT
zh_CHS | Chinese (Simplified) |
zh_CHT | Chinese (Traditional) |
hr_HR | Croatian - Croatia | HRV
cs_CZ | Czech - Czech Republic | CSY
da_DK | Danish - Denmark | DAN
div_MV | Dhivehi - Maldives |
nl_BE | Dutch - Belgium | NLB
nl_NL | Dutch - The Netherlands |
en_AU | English - Australia | ENA
en_BZ | English - Belize | ENL
en_CA | English - Canada | ENC
en_CB | English - Caribbean |
en_IE | English - Ireland | ENI
en_JM | English - Jamaica | ENJ
en_NZ | English - New Zealand | ENZ
en_PH | English - Philippines |
en_ZA | English - South Africa | ENS
en_TT | English - Trinidad and Tobago | ENT
en_GB | English - United Kingdom | ENG
en_US | English - United States | ENU
en_ZW | English - Zimbabwe |
et_EE | Estonian - Estonia | ETI
fo_FO | Faroese - Faroe Islands | FOS
fa_IR | Farsi - Iran | FAR
fi_FI | Finnish - Finland | FIN
fr_BE | French - Belgium | FRB
fr_CA | French - Canada | FRC
fr_FR | French - France |
fr_LU | French - Luxembourg | FRL
fr_MC | French - Monaco |
fr_CH | French - Switzerland | FRS
gl_ES | Galician - Galician |
ka_GE | Georgian - Georgia |
de_AT | German - Austria | DEA
de_DE | German - Germany |
de_LI | German - Liechtenstein | DEC
de_LU | German - Luxembourg | DEL
de_CH | German - Switzerland | DES
el_GR | Greek - Greece | ELL
gu_IN | Gujarati - India |
he_IL | Hebrew - Israel | HEB
hi_IN | Hindi - India | HIN
hu_HU | Hungarian - Hungary | HUN
is_IS | Icelandic - Iceland | ISL
id_ID | Indonesian - Indonesia |
it_IT | Italian - Italy |
it_CH | Italian - Switzerland | ITS
ja_JP | Japanese - Japan | JPN
kn_IN | Kannada - India |
kk_KZ | Kazakh - Kazakhstan |
kok_IN | Konkani - India |
ko_KR | Korean - Korea | KOR
ky_KZ | Kyrgyz - Kazakhstan |
lv_LV | Latvian - Latvia | LVI
lt_LT | Lithuanian - Lithuania | LTH
mk_MK | Macedonian (FYROM) | MKD
ms_BN | Malay - Brunei |
ms_MY | Malay - Malaysia |
mr_IN | Marathi - India |
mn_MN | Mongolian - Mongolia |
nb_NO | Norwegian (BokmA¡Íl) - Norway |
nn_NO | Norwegian (Nynorsk) - Norway |
pl_PL | Polish - Poland | PLK
pt_BR | Portuguese - Brazil | PTB
pt_PT | Portuguese - Portugal |
pa_IN | Punjabi - India |
ro_RO | Romanian - Romania | ROM
ru_RU | Russian - Russia | RUS
sa_IN | Sanskrit - India |
sk_SK | Slovak - Slovakia | SKY
sl_SI | Slovenian - Slovenia | SLV
es_AR | Spanish - Argentina | ESS
es_BO | Spanish - Bolivia | ESB
es_CL | Spanish - Chile | ESL
es_CO | Spanish - Colombia | ESO
es_CR | Spanish - Costa Rica | ESC
es_DO | Spanish - Dominican Republic | ESD
es_EC | Spanish - Ecuador | ESF
es_SV | Spanish - El Salvador | ESE
es_GT | Spanish - Guatemala | ESG
es_HN | Spanish - Honduras | ESH
es_MX | Spanish - Mexico | ESM
es_NI | Spanish - Nicaragua | ESI
es_PA | Spanish - Panama | ESA
es_PY | Spanish - Paraguay | ESZ
es_PE | Spanish - Peru | ESR
es_PR | Spanish - Puerto Rico | ES
es_ES | Spanish - Spain |
es_UY | Spanish - Uruguay | ESY
es_VE | Spanish - Venezuela | ESV
sw_KE | Swahili - Kenya |
sv_FI | Swedish - Finland | SVF
sv_SE | Swedish - Sweden |
syr_SY | Syriac - Syria |
ta_IN | Tamil - India |
tt_RU | Tatar - Russia |
te_IN | Telugu - India |
th_TH | Thai - Thailand | THA
tr_TR | Turkish - Turkey | TRK
uk_UA | Ukrainian - Ukraine | UKR
ur_PK | Urdu - Pakistan | URD
vi_VN | Vietnamese - Vietnam | VIT


TimeZone 코드

표준 시간대를 설정하는 TimeZone 코드는 아래 표와 같습니다.

ACT | Antarctica/DumontDUrville
 | Asia/Vladivostok
 | Australia/Adelaide
 | Australia/Broken_Hill
 | Australia/Brisbane
 | Australia/Hobart
 | Australia/Sydney
 | Pacific/Truk
 | Pacific/Guam
 | Pacific/Saipan
 | Pacific/Port_Moresby
AET | Australia/Lord_Howe
 | Pacific/Efate
 | Pacific/Guadalcanal
 | Pacific/Ponape
AGT | America/Godthab
 | America/Miquelon
 | America/Sao_Paulo
ART | Asia/Amman
 | Asia/Beirut
 | Asia/Damascus
 | Asia/Jerusalem
 | Europe/Athens
 | Europe/Chisinau
 | Europe/Helsinki
 | Europe/Vilnius
 | Europe/Riga
 | Europe/Bucharest
 | Europe/Kaliningrad
 | Europe/Kiev
 | Europe/Istanbul
AST | America/Vancouver
 | America/Tijuana
 | America/Los_Angeles
 | Pacific/Pitcairn
BET | America/Noronha
 | America/Scoresbysund
 | Africa/Ouagadougou
 | Africa/Abidjan
 | Africa/Accra
 | Africa/Banjul
 | Africa/Bissau
 | Africa/Conakry
 | Africa/Monrovia
 | Africa/Casablanca
 | Africa/Timbuktu
 | Africa/Nouakchott
 | Africa/Freetown
 | Africa/Dakar
 | Africa/Sao_Tome
 | Africa/Lome
 | Atlantic/South_Georgia
 | Atlantic/Jan_Mayen
 | Atlantic/Cape_Verde
 | Atlantic/Azores
 | Atlantic/Reykjavik
 | Atlantic/St_Helena
BST | Asia/Almaty
 | Asia/Novosibirsk
 | Asia/Rangoon
 | Asia/Jakarta
 | Asia/Phnom_Penh
 | Asia/Vientiane
 | Asia/Saigon
 | Indian/Christmas
 | Indian/Cocos
CAT | Africa/Cairo
 | Africa/Johannesburg
 | Asia/Nicosia
 | Europe/Minsk
 | Europe/Sofia
 | Europe/Tallinn
CNT | America/Fortaleza
 | America/Cayenne
 | America/Paramaribo
 | America/Montevideo
 | America/Buenos_Aires
CST | America/Porto_Acre
 | America/Bogota
 | America/Guayaquil
 | America/Jamaica
 | America/Cayman
 | America/Managua
 | America/Panama
 | America/Lima
 | America/Indianapolis
CTT | Asia/Irkutsk
 | Asia/Jayapura
 | Asia/Pyongyang
 | Asia/Seoul
 | Asia/Tokyo
 | Asia/Ulan_Bator
 | Pacific/Palau
EAT | Africa/Dar_es_Salaam
 | Africa/Mogadishu
 | Africa/Nairobi
 | Africa/Kampala
 | Asia/Aden
 | Asia/Baghdad
 | Asia/Kuwait
 | Asia/Qatar
 | Asia/Riyadh
 | Asia/Tehran
 | Europe/Simferopol
 | Europe/Moscow
 | Indian/Antananarivo
 | Indian/Comoro
 | Indian/Mayotte
ECT | Africa/Bujumbura
 | Africa/Gaborone
 | Africa/Lubumbashi
 | Africa/Maseru
 | Africa/Blantyre
 | Africa/Maputo
 | Africa/Kigali
 | Africa/Khartoum
 | Africa/Mbabane
 | Africa/Lusaka
 | Africa/Harare
EET | Asia/Bahrain
 | Africa/Addis_Ababa
 | Africa/Asmera
 | Africa/Djibouti
EST | America/Antigua
 | America/Anguilla
 | America/Aruba
 | America/Barbados
 | America/Curacao
 | America/La_Paz
 | America/Manaus
 | America/Dominica
 | America/Santo_Domingo
 | America/Grenada
 | America/Guadeloupe
 | America/Guyana
 | America/St_Kitts
 | America/St_Lucia
 | America/Martinique
 | America/Montserrat
 | America/Puerto_Rico
GMT | GMT
HST | America/Adak
 | America/Anchorage
 | Pacific/Rarotonga
 | Pacific/Marquesas
 | Pacific/Gambier
IET | America/Nassau
 | America/Montreal
 | America/Havana
 | America/Port-au-Prince
 | America/Grand_Turk
 | America/New_York
IST | Antarctica/Mawson
 | Asia/Katmandu
 | Asia/Thimbu
 | Asia/Colombo
 | Asia/Dacca
JST | Asia/Yakutsk
 | Australia/Darwin
MET | Asia/Dubai
 | Asia/Muscat
 | Asia/Yerevan
 | Indian/Mahe
 | Indian/Mauritius
 | Indian/Reunion
MIT | Pacific/Pago_Pago
 | Pacific/Tahiti
 | Pacific/Fakaofo
 | Pacific/Honolulu
MST | America/Belize
 | America/Regina
 | America/Guatemala
 | America/Tegucigalpa
 | America/El_Salvador
 | America/Costa_Rica
 | America/Winnipeg
 | America/Mexico_City
 | America/Chicago
 | Pacific/Galapagos
 | Pacific/Easter
NET | Asia/Ashkhabad
 | Asia/Aqtau
 | Asia/Baku
 | Asia/Dushanbe
 | Asia/Kabul
 | Asia/Tbilisi
 | Asia/Tashkent
 | Asia/Karachi
 | Europe/Samara
 | Indian/Chagos
 | Indian/Kerguelen
 | Indian/Maldives
NST | Asia/Anadyr
 | Pacific/Chatham
 | Pacific/Enderbury
 | Pacific/Kiritimati
 | Pacific/Tongatapu
NUT | Pacific/Niue
PLT | Asia/Aqtobe
 | Asia/Bishkek
 | Asia/Calcutta
 | Asia/Yekaterinburg
PNT | America/Edmonton
 | America/Mazatlan
 | America/Denver
PRT | America/Asuncion
 | Atlantic/Bermuda
 | America/Caracas
 | America/Cuiaba
 | America/Halifax
 | America/Port_of_Spain
 | Antarctica/Palmer
 | Atlantic/Stanley
 | America/Santiago
 | America/St_Johns
 | America/St_Thomas
 | America/St_Vincent
 | America/Thule
 | America/Tortola
PST | America/Dawson_Creek
 | America/Phoenix
SST | Antarctica/McMurdo
 | Asia/Kamchatka
 | Asia/Magadan
 | Pacific/Auckland
 | Pacific/Noumea
 | Pacific/Norfolk
 | Pacific/Kosrae
 | Pacific/Tarawa
 | Pacific/Majuro
 | Pacific/Nauru
 | Pacific/Funafuti
 | Pacific/Wake
 | Pacific/Wallis
 | Pacific/Fiji
 | Pacific/Auckland
VST | Antarctica/Casey
 | Asia/Bangkok
 | Asia/Krasnoyarsk
 | Asia/Brunei
 | Asia/Hong_Kong
 | Asia/Ujung_Pandang
 | Asia/Macao
 | Asia/Kuala_Lumpur
 | Asia/Manila
 | Asia/Singapore
 | Asia/Taipei
 | Asia/Shanghai
 | Australia/Perth
UTC | Africa/Luanda
 | Africa/Porto-Novo
 | Africa/Bangui
 | Africa/Kinshasa
 | Africa/Douala
 | Africa/Libreville
 | Africa/Malabo
 | Africa/Niamey
 | Africa/Lagos
 | Africa/Ndjamena
 | Africa/Tunis
 | Africa/Algiers
 | Africa/Tripoli
 | Africa/Windhoek
 | Atlantic/Faeroe
 | Atlantic/Canary
 | Europe/Dublin
 | Europe/Lisbon
 | Europe/London
 | Europe/Andorra
 | Europe/Tirane
 | Europe/Vienna
 | Europe/Brussels
 | Europe/Zurich
 | Europe/Berlin
 | Europe/Copenhagen
 | Europe/Madrid
 | Europe/Prague
 | Europe/Gibraltar
 | Europe/Budapest
 | Europe/Rome
 | Europe/Vaduz
 | Europe/Luxembourg
 | Europe/Monaco
 | Europe/Malta
 | Europe/Amsterdam
 | Europe/Oslo
 | Europe/Warsaw
 | Europe/Stockholm
 | Europe/Belgrade
 | Europe/Paris
WST | Pacific/Apia